Subject: RE: IPv6 w.g. Last Call on "IPv6 for Some Second and Third Genera tion Cellular Hosts"

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 22 May 2002 14:19:12 +0200

> 	no, it doesn't make sense to me.  even for hardcoded 
  > addresses, there
  > 	should be an MLD join packet issued from the listener.

=> Well, the MLD spec doesn't say that though! We can change
the MLD spec if enough people agree, but as far as this 
draft is concerned,we have to follow existing specs.

  > 
  > 	what i don't understand is why you are wanting to omit it.  

=> I didn't omit anything, I said it was not mandatory. 
If it is then there would have been statement in the 
RFC to indicate that.

for
  > 	example, if 3G mobile node in the following diagram 
  > transmits MLD join
  > 	uptream router could suppress packet to the expensive 
  > wireless link for
  > 	packet to ff02::blah.  i believe MLD support has benefit to the
  > 	situation.

=> But do you assume that the default router on a p2p link
will forward mcast packets to multiple links even though 
hosts on those links didn't join this group?
                       incoming packet to ff02::blah
                         |        
               H2--------R------- H1

If only H2 joined, doyou assume that the router will
send it to H1 as well? Why?
Note H1 and H2 do not share the same link.

Hesham

  > 
  > itojun
  > 
  > 
  > 	router
  > 	  |
  > 	  |
  > 	3G mobile node
  > --------------------------------------------------------------------
  > IETF IPng Working Group Mailing List
  > IPng Home Page:                      http://playground.sun.com/ipng
  > FTP archive:                      ftp://playground.sun.com/pub/ipng
  > Direct all administrative requests to [email-masked]
  > --------------------------------------------------------------------
  > 
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: [email-masked]
Date: Wed, 22 May 2002 21:25:54 +0900

sorry, i was wrong about ff02::1.

>Note H1 and H2 do not share the same link.

	i was trying to think about packets originated from R.  not the
	forwarding case.

itojun

---

From: Brian Haberman <[email-masked]>
Date: Wed, 22 May 2002 08:27:27 -0400

Hesham,

> Note H1 and H2 do not share the same link.

Maybe I missed something here.  R will send the packet addressed to
ff02::blah to whatever host it received the MLD Report message from
for ff02::blah.  So, H2 would have to transmit an MLD Report to
R in order to receive the multicast packet.  In traditional wired
p2p networks, MLD/IGMP are still used, why would they not be used
in a 3G p2p network?

Brian

---

From: Brian Haberman <[email-masked]>
Date: Wed, 22 May 2002 08:32:55 -0400

Let me clarify my comment.  ff02::blah is a bad example for what I
am asking.  Will the 3G network support applications utilizing mcast?
Will a host be able to join ff05::abcd and receive data on that group
address?  If that is supported, then MLD is needed.

Brian