Subject: 1RE: Proposed IPv6 DNS Discovery Requirements

From: "Bound, Jim" <[email-masked]>
Date: Wed, 1 May 2002 17:33:58 -0400

I want to second what Itojun says below.  We cannot assume multicast for immediate deployment beyond the link.  DHCPv6 relays will have to be deployed with hard config as they are in DHCPv4 today.  My hope is we do really do Multicast beyond the link with IPv6 but it has not materialized yet even at the bake-offs.

So saying use MLD is a non-starter from the base premise I support us doing this quickly if we can and that is Mobile Ipv6 Terminals are being deployed like very soon.  As Itojun stated in other mail vendors will be forced to just provide hardcoded addresses or some other such mechanism.

The projections for roll-out for IPv6 handheld devices in real production in Europe and Asia is as early as Q1 CY 2003.  This is not test bed stuff folks but parts you will be able to buy.

If we can't meet this deadline (and I don't think we can based on the strong positions on each side) then the vendors will have to develop a solution pretty soon that at least those who care can agree upon to ship IPv6.

More on this anycast issue later.  Thats a problem too.

/jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, May 01, 2002 12:00 AM
> To: Steve Deering
> Cc: [email-masked]
> Subject: Re: Proposed IPv6 DNS Discovery Requirements 
> 
> 
> >(Now that I mention it, perhaps DHCP relays ought also to be replaced
> >by the use of a well-known, site-local anycast address.)
> 
> 	question i have is, can we really depend on 
> availability of multicast
> 	routing infrastructure in a site.  there are lots of 
> proposals that
> 	assume it, however, implementation status is, i have to 
> say, rather
> 	poor.
> 
> itoun
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 1 May 2002 17:44:32 -0400

I meant to say Mobile Terminals that Support IPv6.  Not Mobile IPv6.....
Just to make that clear.  Two different things. 
/jim

> From: Bound, Jim 
> Sent: Wednesday, May 01, 2002 5:34 PM
> To: [email-masked]; Steve Deering
> Subject: 1RE: Proposed IPv6 DNS Discovery Requirements 
> 
> 
> I want to second what Itojun says below.  We cannot assume 
> multicast for immediate deployment beyond the link.  DHCPv6 
> relays will have to be deployed with hard config as they are 
> in DHCPv4 today.  My hope is we do really do Multicast beyond 
> the link with IPv6 but it has not materialized yet even at 
> the bake-offs.
> 
> So saying use MLD is a non-starter from the base premise I 
> support us doing this quickly if we can and that is Mobile 
> Ipv6 Terminals are being deployed like very soon.  As Itojun 
> stated in other mail vendors will be forced to just provide 
> hardcoded addresses or some other such mechanism.
> 
> The projections for roll-out for IPv6 handheld devices in 
> real production in Europe and Asia is as early as Q1 CY 2003. 
>  This is not test bed stuff folks but parts you will be able to buy.
> 
> If we can't meet this deadline (and I don't think we can 
> based on the strong positions on each side) then the vendors 
> will have to develop a solution pretty soon that at least 
> those who care can agree upon to ship IPv6.
>