Subject: RE: IPv6 w.g. Last Call on "IPv6 for Some Second and Third Genera tion Cellular Hosts"

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 22 May 2002 14:00:33 +0200

Brian

  > 
  > Take a look at the very last paragraph of section 5 of 2710.  It
  > states:
  > 
  >      MLD messages ARE sent for multicast addresses whose scope is 2
  >     (link-local), including Solicited-Node multicast 
  > addresses [ADDR-
  >     ARCH], except for the link-scope, all-nodes address (FF02::1).
  > 
  > That means that a host MUST send an MLD Report for all multicast
  > groups it joins except all-nodes.

=> The solicited nodemcast address cannot be hard coded
of course, so that's understandable. My question 
was why it needs to do it for the ALL Nodes mcast 
address, and you have explained that MLD is not 
needed for that. I agree ! 

We can make it clearer that the statement applies
to the ALL Nodes mcast address, this was the intention
anyway. 

Hesham

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 22 May 2002 14:43:04 +0200

Brian, 

That's exactly what the draft says. 

Hesham

  > Let me clarify my comment.  ff02::blah is a bad example for what I
  > am asking.  Will the 3G network support applications 
  > utilizing mcast?
  > Will a host be able to join ff05::abcd and receive data on 
  > that group
  > address?  If that is supported, then MLD is needed.
  > 
  > Brian
  > 
  > Brian Haberman wrote:
  > > 
  > > Hesham,
  > > 
  > > "Hesham Soliman (ERA)" wrote:
  > > >
  > > >                        incoming packet to ff02::blah
  > > >                          |
  > > >                H2--------R------- H1
  > > >
  > > > If only H2 joined, doyou assume that the router will
  > > > send it to H1 as well? Why?
  > > > Note H1 and H2 do not share the same link.
  > > 
  > > Maybe I missed something here.  R will send the packet 
  > addressed to
  > > ff02::blah to whatever host it received the MLD Report 
  > message from
  > > for ff02::blah.  So, H2 would have to transmit an MLD Report to
  > > R in order to receive the multicast packet.  In traditional wired
  > > p2p networks, MLD/IGMP are still used, why would they not be used
  > > in a 3G p2p network?
  > > 
  > > Brian
  >

---

From: "Dave Thaler" <[email-masked]>
Date: Wed, 22 May 2002 11:22:32 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> 
> >=> Do you mean that MLD is used for the ALL Nodes mcast
> >address ofr example?
> 
> 	yes.
> 
> itojun

No.

RFC 2710 end of section 5:
   The link-scope all-nodes address (FF02::1) is handled as a special
   case.  The node starts in Idle Listener state for that address on
   every interface, never transitions to another state, and never sends
   a Report or Done for that address.

   MLD messages are never sent for multicast addresses whose scope is 0
   (reserved) or 1 (node-local).

   MLD messages ARE sent for multicast addresses whose scope is 2
   (link-local), including Solicited-Node multicast addresses [ADDR-
   ARCH], except for the link-scope, all-nodes address (FF02::1).

-Dave

---

From: "Dave Thaler" <[email-masked]>
Date: Wed, 22 May 2002 11:33:07 -0700

> Sent: Wednesday, May 22, 2002 4:30 AM
> To: [email-masked]
> Subject: Re: IPv6 w.g. Last Call on "IPv6 for Some Second and Third
Genera
> tion Cellular Hosts"
> 
> >=> I've never seen that in any spec.
> >I guess you are saying that it's needed for L2
> >switches that snoop MLD messages to decide
> >on mcast forwarding of mcast ethernet frames?
> >
> >If so, then we don't have this situation in
> >cellular networks. What we're dealing with is
> >a p2p link with no multicast capability.
> 
> 	even under the above situation, there's no such clause that
permits
> 	omission of MLD in RFC2710 (MLD).  if you have any reference
please
> 	let me know, i'm interested in knowing the rationale for the
claim.
> itojun

The relevant paragraph in RFC 2710 for what itojun is referring to is:
   MLD messages ARE sent for multicast addresses whose scope is 2
   (link-local), including Solicited-Node multicast addresses [ADDR-
   ARCH], except for the link-scope, all-nodes address (FF02::1).

I believe this was indeed for supporting snooping switches.
However, sending reports for link-scoped groups is also required 
if you want to support source notification of interest 
(draft-ietf-idmr-msnip-01.txt) for link-scoped groups.

The scenario here would be if the router ever needed to be informed,
to know whether to start sending data to that group or not.

-Dave