Subject: RE: MLD comments on cellular host drafts - seeking feedback

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Mon, 27 May 2002 11:51:55 +0200

> I do not think we can ignore the rest of the network. The 
  > SGSN needs a 
  > mechanism to populate its forwarding table with mcast addresses - 
  > that is where MLD snooping comes in. 

=> I don't know if my earlier message failed to convey
the picture but please ignore the SGSN, it is irrelevant
to this discussion. All traffic MUST go to the GGSN
and get routed there. 

  > 
  > Is the following a good representation of a cellular network ?
  > 
  > 
  >         IPL1               IPR1
  > Mobile 1--------(SGSN)------\
  >                             (GGSN)-->
  > Mobile 2--------(SGSN)------/
  >         IPL2               IPR2
  > 
  > I am saying IPR1 = IPR2 , hence IPL1, IPL2, IPR1 all are on the same
  > link as SGSN are L2 devices. So if Mobile 1 subscribes to a 
  > link-local 
  > group and so does Mobile 2, then we need mcast forwarding between 
  > them. 

=> No. See my comment above. No routing before the GGSN.
and Mobile 1 _cannot_ communicate to Mobile 2 using link-local
addresses.

Hesham
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Dr. Subrata Goswami" <[email-masked]>
Date: Mon, 27 May 2002 08:44:30 -0700

That was exactly the point  was making , till GGSN everything is on L2 -
hence on the same link.

Again, I am saying the same thing, GGSN (and SGSN) needs to know who are
subscribing to the mcast group.