Subject: Re:

From: [email-masked]
Date: Mon, 27 May 2002 13:17:57 +0300

> Is there support in this WG for making route optimization a MUST in all IPv6 hosts ? The ball is really in this WG's court. This is really a "do you really want ubiquitous end to end functionality or not?" question

I'm not sure if that rule could be enforced. If a node keeps on sending to home address, it's a problem for the home network, but not for the sender.

Is there a business reason for honouring an optimization? Why would a "free" ad-driven service (e.g. sports news) care about the well being of someone else's network? Why should it put effort in the authentication computations, if there is no benefit for itself?

-- Lassi

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 27 May 2002 09:52:04 -0700

Hello Lassi,

You have expressed exactly the reason for mandating "route optimization".
It's because a node that does not handle the Binding Update causes remote
nodes to do extra work with no noticeable local effects.  It's for the
overall health of the IPv6 Internet that nodes should be required to
implement Binding Update and along with it the lightweight Return
Routability tests.

Regards,
Charlie P.