Subject: RE: IPv6 w.g. Last Call on "IPv6 for Some Second and Third Gener ation Cellular Hosts"

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 22 May 2002 13:48:37 +0200

> > 
  > > => The IID part for link-local addresses is essentially
  > > a random number. 
  > 
  > Ok, this is what I really was after.  Whether it could be 
  > generated from 
  > some contract number, or whatever.
  > 
  > >There is nothing in 3GPP that specifies
  > > how it should be generated.In fact, depending on how you 
  > > implement the GGSN, you could use the same IID for 
  > > all decives because each link is p2p and each device
  > > has a separate prefix. 
  > 
  > Do the nodes also adapt that IID (unless they use RFC3041) for the 
  > global/site-local address?

=> It is up to the nodes. Since a /64 is assigned, default
routers only look at that /64 to identify a node.

  > 
  > >So, maybe we can add something
  > > to say that hosts are encouraged to use 3041. 
  > 
  > 3041 isn't really all that beneficial if IID part is 
  > already quite random 
  > (and is changing from time to time, e.g. in the scope of a 
  > day or week).

=> Agreed, but unfortunately it is left up to implementations,
so hosts can't really rely on the GGSN to do that. 
So RFC 3041 might come handy after all. Actually, as a side
node, I think 2462 should be deprecated and replaced by 
3041....please don't shoot!

  > >But 
  > > there is no globally unique token in the IID that will make
  > > a 'device or user' trackable.
  > 
  > What about draft-dupont-ipv6-imei-00.txt?  (The beef of the 
  > draft seems to 
  > be the "universal" part, but I'm curious about IMEI here.)

=> I guess my statement above would tell you that 
I'm not a fan of globally unique iids :)
So a way of generating an iid on each link layer
is unnecessary IMHO. I hope the u bit will go away
soon too. 

Hesham

  > 
  > -- 
  > Pekka Savola                 "Tell me of difficulties surmounted,
  > Netcore Oy                   not those you stumble over and fall"
  > Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords
  > 
  > 
  > 
  > 
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Pekka Savola <[email-masked]>
Date: Wed, 22 May 2002 15:08:39 +0300 (EEST)

On Wed, 22 May 2002, Hesham Soliman (ERA) wrote:
> So RFC 3041 might come handy after all. 

If nothing can be assumed, then yes, I think it probably should be 
implemented.  Turned on..?  A different thing..

>Actually, as a side

Where did I put my M16..... ;-)

In the meantime, you might want to check out 
draft-dupont-ipv6-rfc3041harmful-00.txt .. there's an omission or two, but 
should be recommended reading for RFC3041 advocates :-)