Subject: RE: MLD comments on cellular host drafts - seeking feedback

From: [email-masked]
Date: Fri, 24 May 2002 18:35:43 +0300

Hesham,

this was a good summary. So how about going for alternative 3?

Cheers,
	-Juha W.-

-----Original Message-----
From: ext Hesham Soliman (ERA) [mailto:[email-masked]]
Sent: 23 May, 2002 18:34

I've tried to summarise the current situation
with MLD and see how we can move forward with
the next revisions of the draft. 
Jari will send another emails for the rest of 
the issues discussed. 

First let me summarise the comments:

- MLD must be used for all multicast addresses
except the all nodes multicast address. This 
is what RFC2710 says. 

My understanding (please correct me if I'm wrong)
was that the need for using MLD for link-scope
addresses was to allow for the cases where L2
switches snoop MLD reports. 

As far as the cellular host is concerned, we 
are dealing with p2p links where the neighbour 
is a default router. So for link local traffic
in general the notion of multicast does not 
exist (even if, for example an RS is sent to the 
all routers multicast address, it is going to
one router). And there are no switches that will
need to snoop MLD traffic.

Sending MLD reports for link local addresses, 
will not only increase the use of BW on the 
links but is unnecessary for this p2p link. 
However, MLD will be necessary for multicast 
addresses with scopes larger than the link
scope. 

So based on the dicussion above, we have
a number of choices for the next update:

1. Suggest that MLD must be used even for link
local addresses in p2p links within cellular
networks (3GPP). 

pros: We follow RFC 2710.
cons: Waste of expensive BW unnecessarily

2. We suggest that for these p2p links, with
no switches snooping MLD traffic, MLD should 
only be used for multicast addresses with scopes
larger than link-local.

pros: We save expensive BW
cons: We don't follow RFC2710, but then again
      RFC2710 does not make a clear distinction 
      between these p2p links and other multicast links.

3. We suggest that this exception (of not using MLD for 
link-local multicast traffic) can be made, until
RFC2710 is updated to explain why the mandate 
was placed and whether there should be any exceptions
to that mandate. 

pros: We also minimise the scope of the exception 
      to 3GPP only.

cons: We still don't follow this particular part 
      of RFC2710  

I look forward to your choices from the above
selection :) or even new suggestions. 

Hesham
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Dr. Subrata Goswami" <[email-masked]>
Date: Fri, 24 May 2002 09:02:16 -0700

The L2 p2p link ends at the BTS (?) , but the L3 subnet ends at GGSN (?)
which is a router. BTS supports multiple p2p links, any of them can have a
mcast listener. So the BTS needs a way to figure out to which L2 p2p link a
mcast packet needs to be forwarded. Without MLD support, how does the L2
switch know there is a mcast listener in the link so it can copy  a packet
to that link ?  The only other way would be to manually configure the L2
switch - not scalable.

Subrata

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Friday, May 24, 2002 8:36 AM
To: [email-masked]; [email-masked]
Subject: RE: MLD comments on cellular host drafts - seeking feedback

Hesham,

Cheers,
	-Juha W.-

-----Original Message-----
From: ext Hesham Soliman (ERA) [mailto:[email-masked]]
Sent: 23 May, 2002 18:34

Hesham