Subject: RE: Mandating Route Optimization

From: [email-masked]
Date: Thu, 30 May 2002 16:45:01 +0300

Charlie,

sorry to trip a player in the same team, but there is a certain satisfaction not unlike playing chess against a Grand Master and not losing on the first move...

> -----Original Message-----
> From: Perkins Charles (IPRG) 
<...>
> Here are some facts:
> 
> A. A mobile device transmitting data to a correspondent node will
>    require forward and reverse tunneling through the home network
>    unless it can establish a binding cache entry at the correspondent
>    node.
> 
> B. This can increase the total capacity requirement for the
>    communications by an arbitrary amount, depending on the
>    layout with respect to the home network.  That could easily
>    mean a factor of "thousands".
> 
> Opinion:
> 
> A typical multiplier for (B) will be about 2.  The actual
> number depends on the relative placement of the nodes, and
> the multiplier will be higher whenever a mobile device needs to
> communicate with a local correspondent.

Suppose the mobile end subscribes to local services using the CoA in stead of the Home Address. The local service doesn't have to know about the home address at all. While having your beer in the pub (for privacy reasons you actually don't even *want* to use the HA route!) you can check the latest results of Swamp Soccer World Championships (http://www.swampsoccer.net/) using the optimal route. Multiplier 1.

But of course you'll lose the connection, if you happen to do a handover out of the pub WLAN, so better sit down and order more beer. Or be prepared to click 'reload' at the new address.

> Thus, the scenario where people would expect the most
> responsive communications will offer counterintuitive
> behavior.

Now we're getting to percentages of traffic. How many services need to follow you while moving? How many are used while being static for the duration of the service session? Most of us don't browse the web while walking or driving!

> Solutions for this problem include:
> - restricted mobility
> - transient IP addresses
>   = subcase: EIDs to replace IP addresses as identifiers
> - reengineering human intuition
> - proxy agents
> 
> These are good for more startups and full employment (like
> NATs are), but most of them are bad for the Internet.

Thus far the Internet services have all been start-ups. IMHO, they still will be for a long time. They are still looking for the best feel, which leads back to my previous comment. And the kids are learning fast to "reengineer human intuition" to what is available. The text messaging tornado was driven by kids, not business users.

As a system architect I respect your arguments, but the wicked service providers seem to have triumphed over them all...

<...>
> Making it a SHOULD means you cannot fault any vendor for making
> devices that continually cause extra work for numerous remote
> Internet nodes.

Making it a MUST wouldn't change anything. There is no Internet Police that could enforce a MUST. We can't even claim that they will lose business, if they don't comply, because there is no MIPv6 business to lose.

Out of the three known tools of statesmanship, Threats and Blackmail are powerless. The only one left is Bribing. Therefore I was asking, if there is a business reason for the fixed, free-for-all, financed-by-ads services to support MIP. What will they win, if they do it?

-- Lassi

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 30 May 2002 10:03:06 -0700

Hello Lassi,

[email-masked] wrote:

> Suppose the mobile end subscribes to local services using the CoA in stead of
> the Home Address. The local service doesn't have to know about the home address
> at all. While having your beer in the pub (for privacy reasons you actually
> don't even *want* to use the HA route!) you can check the latest results of
> Swamp Soccer World Championships (http://www.swampsoccer.net/) using the
> optimal route. Multiplier 1.

You are describing the well-known case where Mobile IP is not used at all.
It does not necessarily relate to discussion about Mobile IP specifications.

> But of course you'll lose the connection, if you happen to do a handover
> out of the pub WLAN, so better sit down and order more beer. Or be prepared
> to click 'reload' at the new address.

I call this URP -- the "User-controlled Retransmission Protocol".
The name is quite appropriate.

> Now we're getting to percentages of traffic. How many services need to follow
> you while moving? How many are used while being static for the duration of the
> service session? Most of us don't browse the web while walking or driving!

It is possible that a majority of the future Internet will be embedded
devices.  It is possible that voice applications will continue while
people are moving.  It is possible that video displays will be of interest
to us even while we move.

Don't get stuck in the mode of living with what's been forced on us by
lack of functional network-wide mobility management in today's laptops
and PDAs.

> Thus far the Internet services have all been start-ups. IMHO, they still
> will be for a long time. They are still looking for the best feel, which
> leads back to my previous comment. And the kids are learning fast to
> "reengineer human intuition" to what is available. The text messaging
> tornado was driven by kids, not business users.

None of this supports your contention related to the topic at hand.
In fact, service providers across the Internet would be a lot happier
if their clients did not have to URP all the time.

> As a system architect I respect your arguments, but the wicked service
> providers seem to have triumphed over them all...

Nowhere in my text will you find the characterization that service
providers are wicked.  In fact, they tend to deploy the standardized
protocols that help them make the most money.

It's our job to get those standardized protocols available to them
in a way that does not burn all of us in the future.

> Making it a MUST wouldn't change anything. There is no Internet Police
> that could enforce a MUST.

Exactly.  We can't make anyone implement IPv6.  We can't make anyone
implement Mobile IPv6.  We can't make anyone implement these protocols,
no matter which protocol features we MANDATE or RECOMMEND.  But we can
foster the expectation that we make good engineering judgements about
what needs to be done, if vendors implement the protocols at all.

Promulgating systems that are certain to break will not help us to
foster this expectation.

> We can't even claim that they will lose business, if they don't comply,
> because there is no MIPv6 business to lose.

So, how is it going to help us make the business if we promote
false expectations about the need for various features?

> Out of the three known tools of statesmanship, Threats and Blackmail
> are powerless. The only one left is Bribing. Therefore I was asking,
> if there is a business reason for the fixed, free-for-all, financed-by-ads
> services to support MIP. What will they win, if they do it?

Even in these dark days of worldwide loss of human lives, property,
and civil liberties attributable to the intentional and/or misguided
actions of certain of the world's leaders, I am not yet this cynical
about the characterization of statesmanship.

So I suggest that we continue along with the business of engineering
useful protocols.  Others in our company, and in other companies,
will take up the task of creating systems using these protocols,
and they may be able to continue trust in our results if we don't
ourselves forget the purpose(s) of the work.

I view good IETF work as enlarging the Internet pie, so that we can
all get bigger slices.

I reckon the service providers will make tons of money from IPv6.
Why not?  Why not help them, by enabling users to avoid URPing?

Regards,
Charlie P.