Subject: RE: Anycast Addresses being used for Nodes not just Routers; anycast as Source IP address

From: "Bound, Jim" <[email-masked]>
Date: Thu, 2 May 2002 15:09:41 -0400

Charlie,

Not sure if we have disconnect.  What I am supporting with Pekka is removing the MUST per Pekka's mail below.  I want anycast dst addresses to be more than just routers.

I do not support using anycast address as IP src address at all at this time.

Just be clear.

regards,
/jim

> -----Original Message-----
> From: Charles E. Perkins [mailto:[email-masked]]
> Sent: Thursday, May 02, 2002 12:33 PM
> To: IPng Working Group
> Subject: Re: Anycast Addresses being used for Nodes not just Routers;
> anycast as Source IP address
> 
> 
> 
> Hello folks,
> 
> I think this is a great idea.
> 
> Furthermore, on the topic of letting packets have Source IP
> address be the address of an anycast group, I think that it's
> the responsibility of the particular anycast group to handle
> all the ramifications.  It would be nice to have an Internet
> Draft that lays out all of the canonical ramifications.
> 
> In the case where there is only one element of an anycast group,
> and it has one of the "well-known" anycast numbers on its subnet,
> this seems to be very natural and beneficial.  There would not
> be a need to make the restriction for short session lifetimes.
> 
> If the anycast group can have several members, but still is
> addressable at one of the "well-known" anycast numbers, then
> we can require a standard specification for the operation
> of the anycast group, including any such features as use of
> the anycast address as a Source IP value.
> 
> Similar considerations hold for security, and even mobility
> of the anycast group.  In fact, with enough calculation, we
> might even be able to find some CGA-able anycast groups within
> some lucky subnets!
> 
> Regards,
> Charlie P.
> 
> 
> "Bound, Jim" wrote:
> > 
> > I agree.  Lets begin to work on getting a SHOULD that would 
> fix it completely.
> > 
> > I will follow your lead in the WG so lets do it ............
> > 
> > /jim
> > 
> > > -----Original Message-----
> > > From: Pekka Savola [mailto:[email-masked]]
> > > Sent: Thursday, May 02, 2002 2:28 AM
> > > To: Bound, Jim
> > > Cc: [email-masked]
> > > Subject: Re: Anycast Addresses being used for Nodes not 
> just Routers
> > >
> > >
> > > On Wed, 1 May 2002, Bound, Jim wrote:
> > > > What do we think we need to do to get the requirement that
> > > only Routers
> > > > can have anycast addresses changed to "nodes".
> > > >
> > > > IETF Work draft-yanjun-lbam-ipv6-00.txt is a good example
> > > of the use of
> > > > anycast for non-router systems that are very important for
> > > the Internet
> > > > and IPv6.
> > >
> > > I've been trying to push the changing of this:
> > >
> > >       o An anycast address must not be assigned to an 
> IPv6 host, that
> > >         is, it may be assigned to an IPv6 router only.
> > >
> > > in addr-arch-v3-07 to change 'must' to a 'should' for some
> > > time now, with
> > > not much progress.
> > >
> > > I think this is one item that should be changed before
> > > addr-arch is done
> > > with in the IESG and locked for a few years.
> > >
> > > --
> > > Pekka Savola                 "Tell me of difficulties surmounted,
> > > Netcore Oy                   not those you stumble over and fall"
> > > Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords
> > >
> > >
> > 
> > --------------------------------------------------------------------
> > IETF IPng Working Group Mailing List
> > IPng Home Page:                      http://playground.sun.com/ipng
> > FTP archive:                      ftp://playground.sun.com/pub/ipng
> > Direct all administrative requests to [email-masked]
> > --------------------------------------------------------------------
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Claude Castelluccia" <[email-masked]>
Date: Mon, 6 May 2002 09:36:08 +0200

Hello,

BTW we have a draft (submitted to the GSEC WG) that actually tackles
this problem and proposes a solution based on CGA (crypto. generated 
addresses)...
The draft can be dowloaded at:
http://www.inrialpes.fr/planete/people/ccastel/draft-irtf-gsec-sgmv6-00.txt

regards,
Claude.

-----Message d'origine-----
>     2. Security: at a minimum some form of authentication to allow
>        routers to determine if hosts are allowed to join an anycast
>        group
>