Subject: RE: MLD comments on cellular host drafts - seeking feedback

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 28 May 2002 13:44:18 +0200

> > Sorry, that isn't the correct model.
  > 
  > Then it is the correct model, if you read my email it was 
  > mentioned that
  > SGSN is an L2 device. Also as one SGSN supports multiple 
  > mobiles - it needs
  > to know somehow which mobiles are part of an mcast group 
  > and that can be
  > done by MLD.

=> No. The model is not correct as we tried to 
explain. The SGSN does not 'see' the mobile's
traffic and does not do any 'L2 switching'. 
So your conclusion is not correct.

For more information, please refer to 3GPP
specs: TS 23.060 (any revision will explain
this issue clearly).

Hesham

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Dr. Subrata Goswami" <[email-masked]>
Date: Tue, 28 May 2002 10:18:54 -0700

Hesham, SGSN "sees" the mobile's traffic - as it passes through it.
SGSN being an L2 device for IP, it is capable of doing L2 switching (if
the 3gpp spec does not prohibit and the vendor innovates).  The
following is the protocol stack for the SGSN (user plane, from the TS
23.060 you referred, btw the 3GPP web-site needs better navigation). 

-------------              ---------------
|SNDCP GTP-U|              |GTP-U   GTP-U |
|LLC   UDP  |              |UDP/IP  UDP/IP|
|BSSGP IP   |              |AAL5    L2    |
|FR    L2   |              |ATM     L1    |
|L1    L1   |              ---------------
------------
GPRS-SGSN                  UMTS-SGSN

From the above, it is possible to make GPRS-SGSN to mcast as it
detunnels the IP packets.

In case of UMTS, the same functionality can be in the UTRAN.

Subrata

-----Original Message-----
From: Hesham Soliman (ERA) [mailto:[email-masked]] 
Sent: Tuesday, May 28, 2002 4:44 AM
To: 'Dr. Subrata Goswami'; [email-masked];
[email-masked]
Subject: RE: MLD comments on cellular host drafts - seeking feedback

Hesham