Subject: Re: RE: MIPv6 and ND value changes

From: Richard Nelson <[email-masked]>
Date: Tue, 19 Nov 2002 10:37:33 -0800

I agree with Hesham.  I think there is a lot of difference between RA interval 
changes that have been in the MIPv6 draft a long time and Fast RAs that has 
known failure modes that need to be experimented with to determine their 
significance.

I'd add the minor points that section 11.5.2 contains a basic version of optimistic 
DAD (its been there since draft 12) and that there AP cached RAs are an 
alternative to fast RAs in yet another separate draft.

Richard.

----- Original Message -----
From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Tuesday, November 19, 2002 8:52 am
Subject: RE: MIPv6 and ND value changes

> I'm getting very confused when reading this 
> discussion. Some people are focusing on the 
> RA intervals, others about DAD (2462) and 
> others talk generally about ND. 
> 
> Please divide the issues...
> AFAIK we have the following (independent) issues:
> 
> - RA intervals were reduced by MIPv6 (changing 2461)
> - When DAD fails we configure a new address and try again (2462)
> - Elimination of DAD delays (optimistic DAD)
> - Eliminsation of the random delay before sending an RA (fast RA)
> 
> The last two bullets are addressed in separate drafts. 
> The first 2 bullets are in the MIPv6 spec, and the 
> second bullet has nothing to do with 2461.
> 
> There are different value for each point, they're all
> important, but let's not lump them all in one discussion.
> 
> Hesham
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Nick 'Sharkey' Moore" <[email-masked]>
Date: Wed, 20 Nov 2002 10:46:24 +1100

On Tue, Nov 19, 2002 at 10:37:33AM -0800, Richard Nelson wrote:
> DAD (its been there since draft 12) [...]

Basic? ... Very Basic!

	"Furthermore, the mobile node MAY continue using the
	address without performing Duplicate Address Detection, although
	it SHOULD in most cases.  begin Duplicate Address Detection
	asynchronously when it begins use of the address."

By the way, an updated version of my Optimistic DAD draft
is now available:

<http://www.ctie.monash.edu.au/ipv6/draft-moore-ipv6-optimistic-dad-01.txt>

Which addresses many of the technical concerns raised in the
discussion on this list.  I didn't get it submitted in time for 
this IETF, but I figure those of you stranded in the terminal
room might enjoy some light reading ... also, there's a Linux
implementation well under way.

-----Nick