Subject: RE: globally unique site local addresses

From: "Michel Py" <[email-masked]>
Date: Mon, 25 Nov 2002 09:13:07 -0800

Charlie,

> Charlie Perkins wrote:
> Whatever the freebie allocation algorithm is, it
> has to be simple enough to be free. If it costs
> even $0.01, then that means paperwork for the
> consumer probably including even an invoice and
> managerial approval.

Agreed.

> My proposal is that we allocated them linearly --
> starting at 1,000,000 or so and incrementing by one
> after each allocation. That's easy and effective.

I would support any scheme that makes site-locals unique as long as the
non-reachability is enforced, but keep reading.

> If you want something more structured,then that's
> solving a different problem and should be considered
> separately. One problem at a time, please!

This makes sense, but the other side of this coin is that it might be a
good idea to kill two birds with one stone if it does not require aiming
for two years. 

In any case, the "one problem at a time" also applies to not trying to
solve the problem of global PI with unique site-locals.....

Michel.

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 25 Nov 2002 09:24:33 -0800

Hello Michel,

Agreed on all points.  I take your point about
discussion time to mean that we should not get into
a situation where a simple solution would be blocked
while a solution with more features is devised.
The feature set should be simple enough to be
proposed and agreed upon right away.

Regards,
Charlie P.