Subject: RE: Default site-local behavior for routers

From: "Bound, Jim" <[email-masked]>
Date: Sat, 2 Nov 2002 00:37:42 -0500

There will always be us and them forever its natural. The objective is
to manage it and stop killing each other.  Ipv6 will at least permit
that communications so more are involved with the discussion so its
possible.  But many of us will not be tolerant of those that are not
cool any more than we can turn the other cheek when its been slapped.
And I believe no one should ever slap without just cause or turn the
other cheek if slapped.  The word just is far more complex to parse than
SLs.

Now we just need to manage SLs in that context.  I suggest Brian
Haberman produce that draft just on doing that.  I don't mean manage
with MIBs just in case et al.  Maybe that will turn our discussion to a
technical solution so we don't have to just trust those routing packets.

/jim
[In matters of style, swim with the currents...in matters of principle,
stand like a rock.  - Thomas Jefferson]

> -----Original Message-----
> From: Margaret Wasserman [mailto:[email-masked]] 
> Sent: Thursday, October 31, 2002 9:59 AM
> To: Mark Smith
> Cc: Keith Moore; [email-masked]
> Subject: Re: Default site-local behavior for routers
> 
> 
> 
> 
> >As Vint Cerf wrote in a RFC recently, The Internet is for Everyone. 
> >Once everyone has it (I'd say one of the fundamental 
> inherent goals of 
> >IPv6), hopefully the world can become a more tolerant place through 
> >communication, allowing better understanding of different 
> peoples view 
> >points and beliefs. Hopefully the world will become small 
> enough that 
> >there will eventually be no "us and them".
> 
> And, hopefully, that's while we're all here -- trying to 
> build an Internet that can deliver on this vision.
> 
> Mark, thanks for reminding us that we're all really on the same side.
> 
> Margaret
> 
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Bound, Jim" <[email-masked]>
Date: Sat, 2 Nov 2002 00:53:47 -0500

> 
> 	i still think it necessary to:
> 	- limit nodes from joining more than (including) 2 
> sites at the same
> 	  time.
> 	- document site-border router's behavior in full

Does anyone on this list object to Itojuns request?

I think it's a good idea and healthy for IPv6.

/jim

---

From: "Bound, Jim" <[email-masked]>
Date: Sat, 2 Nov 2002 00:55:54 -0500

Tony,

That's the first thing you said I fully agree with on this thread.  I am
willing to support this for sure.  I don't agree with lots of other
things but that's ok.

/jim

> From: Tony Hain [mailto:[email-masked]] 
> Sent: Thursday, October 31, 2002 3:26 PM
> To: 'Ralph Droms'; [email-masked]
> Subject: RE: Default site-local behavior for routers 
> 
> 
> Ralph Droms wrote:
> > ...
> > Adjacent nets that both use SLs is an interesting (potentially
> > problematic?) architecture - I would be interested in finding 
> > out about 
> > deployment experience with that case.
> 
> This is exactly the case that Keith is concerned about. There 
> is no magic here, in this situation the address space needs 
> to be coordinated, or a nat is required. Since we are all 
> trying to avoid nat, the hammer approach is to simply ban SL. 
> My argument is that it is more pragmatic to simply document 
> the failure modes. If we can just do that, we will be able to 
> put the effort into developing a PI approach with better 
> support for the multi-party app.
> 
> Tony
> 
> 
> 
>

---

From: Ignatios Souvatzis <[email-masked]>
Date: Sun, 3 Nov 2002 12:11:50 +0100

Hi,

On Fri, Nov 01, 2002 at 07:06:21AM +0900, Jun-ichiro itojun Hagino wrote:
> 	if you get a default route from three sites you are joined to, what
> 	are you going to do?  or what if you get 2001:240::/32 from both sides,
> 	what are you going to do?

Same as when you have two intra-site routers on your network. Thats a global
address; which router you use is a matter of policy, cost, load sharing, 
but surely not whether the exit point is in site* A or site* B (where site*
is what the routing boundaries of site-local addresses define). What problem
am I missing?

Regards,
	-is