Subject: RE: MIPv6 and ND value changes

From: [email-masked]
Date: Tue, 19 Nov 2002 15:40:46 +0200

Hi James,

> The primary issue is whether the ND spec itself should benefit.

I agree.  I think it should.  My suggestion is that MIPv6 discusses
what is needed for MIPv6 (maybe even moved into an appendix) and 
this data is taken as a starting point for updating 2461.
 
> The behavior of DAD failure is an example. RFC 2461 currently has a built-in DoS
> hole in that it specifies the host should shut down the interface if there is a
> DAD failure. This is a perfect opportunity for propagating a successful DoS
> attack, and is not restricted to MIP.

I agree.

> By burying the solution for this into the MIP spec, it 
> removes the possibility that wider IPv6 nodes can benefit.

I don't think we should bury it in the MIP spec, but first
address it in the MIPv6 spec then take that & move it into a
2461-bis draft.

> However, there are other proposed ND optimizations that are purely mobile
> specific. Some of these are in the MIP spec, some aren't. I think it makes some
> sense to group these into a seperate spec in the MIP group.

Why can't it be in MIPv6 & then moved in the 2461-bis?

John

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Pekka Savola <[email-masked]>
Date: Tue, 19 Nov 2002 17:08:12 +0200 (EET)

> address it in the MIPv6 spec then take that & move it into a

I don't think waiting for 2461-bis is the right approach, rather a draft 
pushed through in mobileip wg.

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords