Subject: RE: assignment of GUPI [RE: Taking two steps back (Was: Re: onequestion...)]

From: "Michel Py" <[email-masked]>
Date: Tue, 26 Nov 2002 15:20:39 -0800

Pekka,

> Pekka Savola wrote:
> That's because those addresses are meant to be unique
> _only_ within a scope.  Addresses leak, yes, but that
> doesn't hurt when the probably of collision then is
> suitably low (e.g. below 0.1%).

Go tell that to the network administrator that "wins". Only two ways
out: renumber or NAT. Both a pain. Network administrators don't take
chances with a 1 in 1000 odd.

> If the addresses are _unnecessarily_ unique, they will be
> used for wrong purposes, no matter what.

Your proposal is good enough for people to use them from wrong purposes
too. What you are talking about is the very principle of ambiguity:
ambiguity (vs. unique) guarantees that the addresses will not be routed
globally.

> IMO we will not want to have site-locals be too attractive:
> we don't want to have (too big) competition to global-scope
> addresses.  IMO we want _IPv6_ users to use _globals_, and
> (some) site-locals only when they more or less have to.

Agreed.

> Globally unique PI addresses are a step in entirely wrong
> direction.

If they are not aggregatable.

> As you see, these are not really all that "technical"
> reasons, but I don't want to see the world where people
> are using IPv6 with similar walled-gardens as NAT's
> create today.

Agreed.

> (and besides, with "nearly unique" there's no need for
> any infrastructure to support them.)

A server to implement a counter is not "infrastructure", which is why
Charlie offered to provide the service for free.

> Note: I'm not disputing the (possible) usefulness of
> globally unique PI for e.g.  multihoming etc. purposes,
> but those are _global scope_ addresses, and that's not
> the point here.

Agreed.

Here's the deal: any mechanism that makes site-locals less ambiguous is
a danger to bad usage. Mechanisms that are ambiguous enough not to be a
danger are worthless as they don't solve the ambiguity issue. Mechanisms
that are good enough to solve the ambiguity issue (including yours) are
a danger no matter what the risk of collision is.

If you increase the collision risk to the point that people would not be
tempted to route globally, at the same time you miss the goal which is
to resolve ambiguity.

The goal is to eliminate ambiguity. Focus on what to do in order to
reduce the risk of bad use, no try to knob the level of ambiguity.

Michel.

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Michel Py" <[email-masked]>
Date: Wed, 27 Nov 2002 08:11:28 -0800

Pekka,

> Pekka Savola wrote:
> I'm _only_ _specifically_ thinking of "how do we fix
> site-locals to make them usable".  I do _not_ want this
> w.g. to try to bang its head against the wood, trying to
> get workable globally scoped unique PI, possibly
> routable, addresses to work (in all layers from L1 to
> L10).  Seems like a total waste of energy to me, as most
> efforts are _not_ in the layers we can really control.

I very much agree with this.

> You seem to be thinking "how do we provide alternative
> globally unique, possibly routable, PI addresses so that
> site-locals would not be needed".

My reading also.

Richard Carlson just brought an interesting point about the scope of
these GUSL addresses. I think that it is whatever the scope of
site-locals is.

Michel.

---

From: "Michel Py" <[email-masked]>
Date: Wed, 27 Nov 2002 08:23:08 -0800

> Pekka Savola wrote:
> - if we specify global-scope GUPI's they will also be used
> when regular global-scope addresses would be better
> (and we should encourage PA addresses, because they
> actually _work_); ie. they will cause trouble and may
> eventually result in prefix/address translation
> NAT-like) problems.

Agreed.

> - if we instead specify site-local, near-unique addresses,
> folks still treat them as site-locals; they are used less
> than GUPI's would be, in site-local contexts only.
> Near-uniqueness removes the problems with ambiguity of
> site-locals.

Agreed.

> - I think it's better to deal with reality (provider
> assigned addresses) than try to escape it (provider
> independent addresses), even though how enticing it
> could be...

Agreed. That being said, I think you miss the target by thinking that
"near unique" will be less enticing than "truly unique". If the risk of
collision is very low, people will try to use it as global PI.

> Following my thinking, site-locals could of course be used
> as an aid for e.g. renumbering or intermittently connected
> sites, but that should be better than having delusions that
> using global-scope addresses there would somehow make such
> addresses "global" or "globally usable".

Agreed, but we also need to think about the scope of GUSL used to create
a VPN between organizations.

Michel.