Subject: RE: assignment of GUPI [RE: Taking two steps back (Was: Re: onequestion...)]

From: "Michel Py" <[email-masked]>
Date: Wed, 27 Nov 2002 08:29:37 -0800

> Keith Moore wrote:
> yes, some people will probably try to use GUPIs where PA
> globals would be a better choice.  eventually, they'll
> learn.  they'll have to renumber to fix that problem, but
> it won't be more difficult than any other kind of IPv6
> renumbering, and we have to solve that problem anyway.

The trouble is that they might elect to use NAT instead of renumbering.
I have seen this many times with IPv4. What you propose is taking one
problem away (site-locals) and replacing with one even worse (NAT).

> I do think that an addressing architecture that
> simplifies decision-making would minimize the potential
> for delusions. From that perspective, a simple table is
> quite attractive:
> network not connected to the    | PI global addresses
> public internet, but            |
> connected to other IP networks  |
> via private arrangements        |

PI global addresses do NOT exist.

Michel.

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Keith Moore <[email-masked]>
Date: Wed, 27 Nov 2002 11:33:55 -0500

> The trouble is that they might elect to use NAT instead of renumbering.

perhaps.  but that potential exists for IPv6 in general.  GUPIs don't
make that any worse.

> problem away (site-locals) and replacing with one even worse (NAT).

no, that's simply not true.

> PI global addresses do NOT exist.

we've been talking about various proposals for creating them since
long before Atlanta.  where have you been? 

Keith