Subject: RE: Proposal for site-local clean-up

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 13 Nov 2002 18:13:46 +0100

> Keith;
  > 
  > At 09:27 PM 11/12/02 -0500, Keith Moore wrote:
  > >[snip snip snip]
  > >No.  Scopes reduce the ablity of the network to support apps.
  > >They make it harder to produce an app that works independently
  > >of network location, and they don't add a single extra capability
  > >that wasn't present already.
  > 
  > You keep saying that some apps will fail with scoped 
  > addresses.  My poor 
  > brain can't grasp why this is so.  Can you give me a 
  > detailed example of 
  > how an app will fail if it has multiple scoped addresses to 
  > choice from? 

=> I think he did to some extent, but the point 
is Brian Z. and Rich already showed how this can be
done. Sure there is additional complexity, but 
didn't we know this 3 years ago ? I think we did.

Harald's email is a good example of the complexities
introduced in the DNS, but it is solveable, that's 
why I think a BCP will be much more convincing than
changing a couple of lines in the existing RFC.

Hesham

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Keith Moore <[email-masked]>
Date: Wed, 13 Nov 2002 13:55:43 -0500

> didn't we know this 3 years ago ? I think we did.

It is simply not acceptable to expect apps to absorb all of this
complexity for the sake of the dubious and marginal amount of 
additional functionality that SLs provide.

And the fact that serious mistakes were made in the past is not
an excuse for propagating them -- particuarly not when staying with
the status quo is far more disruptive than reducing use of SLs.

Keith