Subject: RE: MIPv6 and site local addresses

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Mon, 11 Nov 2002 20:43:25 +0100

> > One more apparent headache: a mobile node running mobile 
  > IP for IPv6
  > > (MIPv6) will often be in 2 different domains simultaneously. 
  > > It's home domain (where it continues to have a Home Address 
  > > and the domain that it is currently visiting). How does one 
  > > handle site-locals in this case?
  > 
  > The mobile node is effectively multi-sited in this 
  > situation. Here's one
  > way to implement this. Some (most?) 

=> All the ones I know of do that (virtual interface).

MIPv6 implementations assign the
  > home address to a virtual interface. Then the virtual 
  > interface belongs
  > to the home site, and the physical interface (which has the care-of
  > address) belongs to the foreign site.

=> I'm not sure this solves the problem though. It all
depends on where the SL address came from. Is it in the 
visited site or the home site? 
src address selection should by default provide the HoA
to the app, but if the SL is in the visited site, it won't
work. So do we need some coupling between src address selection
and the resolver? 

If the CoA is given to the app, then MIPv6 won't work
unless you use something link HMIPv6 which provides a 
local HA. But this will only provide session continuity
while the MN is moving within the MAP domain. 

Have I missed something?

Hesham

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Richard Draves" <[email-masked]>
Date: Mon, 11 Nov 2002 14:14:47 -0800

> I take it that the implication here is that all MNs need to 
> be multi-sited and support the site scoping document (or 
> equivalent). In other words, it will need to be widely 
> supported in practice.
> 
> Is this really the implication? There is a hope/expectation 
> that very many nodes will implement MIPv6. It would be nice 
> of MNs wouldn't be required to implement the scoping document 
> in order to make things work.

If a mobile node wants to have a site-local home address in addition to
a global home address, then it needs to be multi-sited with all that
entails. If it just wants to support global home addresses, then that's
not necessary.

Let me mention scoped care-of addresses. At least in our implementation,
care-of address selection is governed by the normal address selection
rules for choosing a source address for the correspondent (destination)
address. The home agent's address should be global. So you should choose
a global care-of address to register with the home agent.

> visited site or the home site? 

I don't think I understand the problem to which you are referring.

I think the best way to conceptualize this is, the MIPv6 virtual
interface (which has the home address) is just like a VPN back to the
home site. So the multi-site issues are the same as for any multi-sited
host.

Rich

---

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Mon, 11 Nov 2002 23:51:32 +0100

> home site. So the multi-site issues are the same as for any 

=> I agree with this. My comment was essentially that the 
applications will need to indicate which site they should
communicate to. Therefore, they would need to know if the 
SL address belong to the "home" site or the visited site. 
Nothing new is needed though as you mention above, I inconveniently 
didn't consider the API extensions for scoped addresses :( 

Hesham