Subject: Re:

From: "aridaman kaushik" <[email-masked]>
Date: 23 Dec 2002 07:35:40 -0000

Hi all,
     I have a doubt regarding FIB implementation.

We are using one alogorithm which is consuming too much memory
for memtainace of routing tabel. Is there any efficient 
algorithm
fast(look up) and takes less memory for storing Ipv6 routes.

regards
ari.

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Margaret Wasserman <[email-masked]>
Date: Mon, 23 Dec 2002 07:10:16 -0500

Hi Ari,

The IETF does not, typically, specify algorithms.

There has been quite a bit of research done in efficient
FIB storage algorithms in other fora, such as the ACM,
though.  Last time I looked into this topic (a couple
of years ago), trie-based algorithms were very popular,
and the Luleå algorithm, developed at Luleå University of
Technology in Sweden was considered among the best for
building memory efficient, high performance forwarding
tables.

You may want to look for more recent work, though, before
committing to a particular algorithm.

Good luck!

Margaret

At 07:35 AM 12/23/2002 +0000, aridaman  kaushik wrote:
>for memtainace of routing tabel. Is there any efficient algorithm