Subject: RE: IPv6 router requirements

From: [email-masked]
Date: Fri, 28 Feb 2003 07:04:06 +0200

Hi Steph,

Of of the top of my head, I do not know.  Does anyone
have an opinion?

br,
John

> -----Original Message-----
> From: ext Stephen Bailey [mailto:[email-masked]]
> Sent: 27 February, 2003 22:45
> To: Loughney John (NRC/Helsinki)
> Cc: [email-masked]
> Subject: IPv6 router requirements
> 
> 
> Hi John,
> 
> Do you have a suggestion of somebody who could tell me if an 
> IPv6 router
> is required to perform host discovery for host routes?
> 
> Thanks,
>   Steph
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Margaret Wasserman <[email-masked]>
Date: Fri, 28 Feb 2003 13:51:47 -0500

> > is required to perform host discovery for host routes?

I'm sorry, but I don't completely understand the question...

If a router has a host route in its routing table, it doesn't
need to do any "checking" on that validity of that host router
(i.e. neighbor discovery(ND), neighbor unreachability detection,
etc.).

However, if a router wants to send a packet to a host on a
local link, it will use ND to determine if the host is
reachable and get link-layer address information, if needed.

Do either of those statement answer your question?

Margaret