Subject: Testing tool for out IPv6 stack.

From: "sasson, shuki" <[email-masked]>
Date: Wed, 12 Feb 2003 09:35:38 -0500

Hi all, we are developing an IPv6 stack for our products. I wander if you
can recommend us for a good testing tool for the IPv6 stack.

Thanks,

Shuki Sasson
Principal Engineer, Network Storage Group
	EMC²  		
where information lives

Phone: 508 305 8515
FaxNo: 508 435 8901
Pager: 877 919 0794
Email:  [email-masked]

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 12 Feb 2003 11:16:09 -0500

The standard benchmarks suites (e.g. Webstone, FPA, NFSstone, etc) have not been ported to this date to my knowledge.  What we had to do is get our QA folks to port the stress tests to IPv6. I will assume you are integrating IPv6 into IPv4 stack? If so, then it is important for the following:

1. Should not break IPv4 applications
2. IPv4 should not perform less because IPv6 added to the stack.
3. Applications should be able to use either Ipv4 or IPv6 and testing this tells you a lot about your stack.
4. Can you make IPv6 perform better is the key.

For base conformance you can get tests done by TAHI in Japan, University of New Hampshire in U.S. and ETSI in Europe.  Also SPIRENT does good conformance tests.  

For interoperability testing which is completely different than running a test suite you have to get your machine in the above labs and let them beat on it and attend events for testing from the above places and go to places like Connectathon sponsored by Sun Microsystems in San Jose and there is one in a few weeks if your ready.

For an IPv6 ONLY stack.  Things get more complicated because some of the test "assumptions" change and some new ones we don't have now need to be created.

Bottom line take the IPv4 stress and QA tools you have now and port them to use IPv6 is required to do a thorough job to state an IPv6 product can be deployed in a production network with all the liabilities such as statement implies for IPv4 today to your customers.

Regards,
/jim

>-----Original Message-----
>From: sasson, shuki [mailto:[email-masked]] 
>Sent: Wednesday, February 12, 2003 9:36 AM
>To: [email-masked]
>Subject: Testing tool for out IPv6 stack.
>
>
>Hi all, we are developing an IPv6 stack for our products. I 
>wander if you can recommend us for a good testing tool for the 
>IPv6 stack.
>
>Thanks,
>
>Shuki Sasson