Subject: RFID in V6?

From: George Michaelson <[email-masked]>
Date: Thu, 1 May 2003 09:19:08 +1000

[ posted to multi6 17 March 2003. Nobody replied, but I really am interested in
  this question, and it was suggested I try here. -ggm]

Will RFID map into V6 in a sensible manner?

If there was even a restricted subset mapping, what kinds of things could we
do with it?

-George

-- 
George Michaelson       |  APNIC
Email: [email-masked]    |  PO Box 2131 Milton QLD 4064
Phone: +61 7 3367 0490  |  Australia
  Fax: +61 7 3367 0482  |  http://www.apnic.net
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Subrata Goswami" <[email-masked]>
Date: Wed, 30 Apr 2003 18:15:25 -0700

The Electronic Product Code (EPC) from MIT's Auto-ID center is 96 bits -
should fit into the original 128 bit IPv6 address with a unique 32 bit
prefix. Although Auto-ID center is reserving the right to define longer
EPC's. A 96 bit EPC has the following components.

Header:  8 bits contains version, length etc.
Manager: 28 bits - manufacturer
Object:  24 bits - the Stock Keeping Unit (SKU) #
Serial #: 36 bits

Subrata 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of George Michaelson
> Sent: Wednesday, April 30, 2003 4:19 PM
> To: [email-masked]
> Subject: RFID in V6?
> 
> 
> 
> If there was even a restricted subset mapping, what kinds of 
> things could we do with it?
> 
> -George
> 
> --

---

From: Soohong Daniel Park <[email-masked]>
Date: Mon, 31 Mar 2003 11:01:21 +0900

Hello Subrata

Basically I am wondering below formation of Auto-ID is a standard or
not.
If we want to use an IPv6 address with Auto-ID (96bit), there is no
extra space to make an address.
We only have to use 32bit prefix length.

What I want to say is that if we want to reduce Auto-ID, is it possible
or not ?

	Daniel

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Subrata Goswami
Sent: Thursday, May 01, 2003 10:15 AM
To: [email-masked]
Subject: RE: RFID in V6?

Subrata

---

From: "Subrata Goswami" <[email-masked]>
Date: Wed, 30 Apr 2003 19:54:07 -0700

Hi Daniel, the Auto-ID center also has an EPC of 64 bits. It is always
possible to reduce a longer range of number to a smaller one - hashing,
selectively picking some bits (i.e. SKU and SN), etc. The issue is what
makes sense and where. I am not sure enough known about usages of  RFTAG
ID's with IPv6/v4 addresses.

Subrata

> From: Soohong Daniel Park [mailto:[email-masked]]
> Sent: Sunday, March 30, 2003 6:01 PM
> To: 'Subrata Goswami'; [email-masked]
> Subject: RE: RFID in V6?
> 
> 
> Hello Subrata
> 
> Basically I am wondering below formation of Auto-ID is a
> standard or not. If we want to use an IPv6 address with 
> Auto-ID (96bit), there is no extra space to make an address. 
> What I want to say is that if we want to reduce Auto-ID, is
> it possible or not ?
> 
> 	Daniel
> 
> 
> 
> The Electronic Product Code (EPC) from MIT's Auto-ID center
> is 96 bits - should fit into the original 128 bit IPv6 
> address with a unique 32 bit prefix. Although Auto-ID center 
> is reserving the right to define longer EPC's. A 96 bit EPC 
> has the following components.
> 
> > If there was even a restricted subset mapping, what kinds of things 
> > could we do with it?
> > 
> > -George
> > 
> > --