Subject: RE: My Thoughts on Site-Locals

From: [email-masked]
Date: Fri, 4 Apr 2003 06:54:20 +0300

Michael,

> Second, by your own account we do need to prepare documents about what
> to do next. Call it deprecation if you want what I call it is that we
> have more work to do on site-locals and on the scoped architecture.
> 
> 
> > and it isn't clear how we can ever finalize the scoped
> > addressing architecture without some type of decision
> > on this issue.  Perhaps we can break out the
> > non-contentious parts and advance those parts?
> 
> I believe we can progress on three topics:
> - Ambiguity
> - Convexity / defining the site borders.
> - Tuning the compromise.

I support this as a way forward.

John

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: [email-masked]
Date: Fri, 4 Apr 2003 09:52:00 +0300

Margaret,

> The primary differences between IPv6 unicast site-local addresses (FECO::/10),
> as defined today, and PI addresses are:
> 
>          1. Site-local addresses are intentionally ambiguous.
>          2. Sites may not overlap or be nested.
>          3. Sites need to be convex, constraining their boundaries
>                  to routing area or AS boundaries.
> 
> Most of the implementation complexity comes from #1 and, IMO, we would be
> much better off with an unambiguous form of local addressing. There are
> a few proposals for MAC-address based versions or unique IPv4-address
> based versions.  We could also ask registries to provide globally unique
> provider-independent addresses for this purpose.  Perhaps there are other
> choices.  I am not actually a proponent of the "random 
> choice" model, BTW.

I think that the disambiguating site-locals to a certain extent may
be advisable (if we do keep them).  However, I actually think that
one of the attaction of NATs for users is that NATs provide ambiguous
addresses.  Even if we disambigated site-locals (or GUPIs or whatever)
I don't that would kill the interest for ambigious addressing.  

What I would hope would be for some better controls on ambiguous 
addresses. Can we provide clear rules on their use and applicability?

In addition, I also agree with you the "random choice" model 
- I think that such a solution would cause more harm than good.

br,
John

---

From: Margaret Wasserman <[email-masked]>
Date: Fri, 04 Apr 2003 09:27:51 -0500

Hi Michel,

At 04:39 PM 4/3/2003 -0800, Michel Py wrote:
>Unfortunately this requires people that are for IPv6 and not against and
>that are willing to compromise. I regret to report that at this point I
>count only three: Bob Hinden, you and me.

I find this statement highly offensive, and I completely
disagree with your assessment of the IPv6 WG.

There are scores, probably hundreds, of people who care about
IPv6 and want it to succeed.  We have spent years working on
difficult issues, sometimes disagreeing, but always finding
a way forward.  We may currently have some disagreement
regarding the value of site-local unicast addressing, but we
_will_ find a way to work through this issue.

It should be possible for us to disagree on a technical issue
without questioning each other's integrity, competence or
commitment to IPv6.

The classic decision making process goes:

         Disagree -> Decide -> Commit -> Execute

We are currently in the "disagree" stage for site-locals, so
it is good that people are voicing their own opinions and
stating technical reasons to support those positions.  We
are trying to drive towards a decision.  And, once we do
make a decision about how to proceed, I believe that it will
be followed (as difficult decisions in IPv6 always have been)
by a high degree of commitment and execution.

Margaret