Subject: Re: CONSENSUS CALL: Deprecating Site-Local Addressing

From: "Tom Petch" <[email-masked]>
Date: Fri, 4 Apr 2003 18:20:55 +0100

NO -- Do not deprecate site-local unicast addressing.

They are needed for access control in enterprise (as opposed to
home/private use) networks

Tom Petch
[email-masked]

-----Original Message-----
From: Margaret Wasserman <[email-masked]>
To: [email-masked] <[email-masked]>
Date: 01 April 2003 21:03
Subject: CONSENSUS CALL: Deprecating Site-Local Addressing

>
>Hi All,
>
>At the IPv6 WG meetings in SF, we reached consensus on several
>points, all of which will be confirmed on the IPv6 mailing list.
>One point in particular seems to be the source of discussion
>on our list and elsewhere, so we will check this consensus on the
>mailing list now.  Specifically, we would like to check the consensus
>of the IPv6 WG regarding the deprecation of site-local addresses.
>
>This email asks those that were NOT present at the Thursday IPv6
>meeting in SF to express their opinions on a question that was
>asked of the room.   If you expressed an opinion on this issue in
>SF you can skip this message; in any case you MUST NOT respond to
>this query.
>
>By now, all of you have heard about the IPv6 meeting held on
>Thursday, March 20th, where we discussed what to do about
>IPv6 site-local addressing.
>
>At the meeting, the chairs (Bob Hinden and Margaret Wasserman)
>changed the agenda to include a joint presentation by the
>chairs on various options for site-local usage.  There were
>no objections to the agenda change.
>
>The chairs' joint presentation can be found at:
>
>http://www.psg.com/~mrw/IPv6_Site_Local_Mar03.ppt
>
>After the chairs' joint presentation, there was over an hour of
>lively discussion that covered many aspects of site-local
>addressing.  Draft minutes of the discussion can be found at:
>
>http://www.psg.com/~mrw/ipv6-wg-minutes-mar2003.txt
>
>These minutes are a summary of the discussion, and they did
>not capture every detail of the discussion.
>
>During the discussion, it became clear that the "exclusive" model
>proposed by the chairs had some fundamental flaws and was not
>a viable option.  The WG was unwilling to choose between the three
>options presented for site-local usage ("limited", "exclusive" or
>"moderate"), believing that all three models represented a poor
>cost vs. benefit trade-off.  And, as the discussion developed, it
>became clear that there was growing support for deprecating
>site-local addressing.
>
>After the usual discussion regarding the phrasing and meaning
>of the question (not all of which was captured in the minutes),
>the chairs asked a yes/no question:  "Should we deprecate IPv6
>site-local unicast addressing?"  There was clear consensus in the
>room to deprecate site-local addressing.  So, now it is time to
>check that consensus on the mailing list.
>
>In order to get a good read for consensus on this point, PLEASE
>adhere to the following rules:
>
>NOTE:  DO NOT reply if you already expressed an opinion during
>the IPv6 WG meeting in SF!
>
> - Make your response very clear (YES or NO).
>        - Respond by Monday, April 7th, 2003 at 5pm EST.
>        - Do NOT respond if you were physically present
> in SF and participated in the consensus
> call at that time (We are trusting you!).
>        - Respond to this thread with the subject intact.
>        - Respond only once.
> - Clearly identify yourself (in the From: line or
> inside your message).
> - Include the IPv6 WG mailing list in your response
> ([email-masked]).
>        - PLEASE do NOT start any discussion in this thread
>                (Discussions are encouraged in other threads).
>
>Any responses that do not adhere to these rules may not be counted.
>
>The question is:
>
>         Should we deprecate IPv6 site-local unicast addressing?
>
>Valid responses are:
>
> "YES -- Deprecate site-local unicast addressing".
> "NO -- Do not deprecate site-local unicast addressing".
>
>If you express an opinion not to deprecate site-local addressing, it
>would be helpful if you would provide a reason.  Providing a reason
>is completely optional, but it may help us to determine how to move
>forward if the consensus to deprecate site-locals does not hold.
>Possible reasons include:
>
> - Site-locals should be retained for disconnected sites.
> - Site-locals should be retained for intermittently
> connected sites.
> - Site-locals should be retained for their access control
> benefits.
> - Site-locals should be retained as a means for internal
> connections to survive global prefix renumbering.
> - Other (please specify).
>
>Please, make your response _very_ clear (either YES or NO), or it
will
>not be counted.
>
>Please Note:  DO NOT respond if you already participated in the
>consensus call at the meeting in SF.  At the meeting, there were
>102 people who raised their hands for YES (deprecate site-locals)
>and 20 people who raised their hands for NO (do not deprecate
>site-locals).  We will add the responses received on the mailing
>list to the hands counted at the meeting, and use that information
>to determine full WG consensus on this issue.
>
>If you feel an urgent need to reply to something that someone sends
>in response to this message, please do it in a SEPARATE THREAD with
>a different subject line.  No discussion in this thread!
>
>Please voice your opinion on this important issue.
>
>Bob Hinden & Margaret Wasserman
>IPv6 WG Chairs
>
>
>
>
>
>
>--------------------------------------------------------------------
>IETF IPng Working Group Mailing List
>IPng Home Page:                      http://playground.sun.com/ipng
>FTP archive:                      ftp://playground.sun.com/pub/ipng
>Direct all administrative requests to [email-masked]
>--------------------------------------------------------------------

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Randy Bush <[email-masked]>
Date: Sat, 5 Apr 2003 03:55:21 -0800

> home/private use) networks

i.e. let's solve a routing problem with an address model hack.
pfui!