Subject: Site Locals - a silly suggestion

From: "EricLKlein" <[email-masked]>
Date: Wed, 16 Apr 2003 09:11:04 +0300

This may seem strange, but why are we killing ourselves to add site locals to IPv6? (No need to in-line an answer it is rhetorical - read on)

Mostly because people want to keep the RFC 1918 addresses in their networks for whatever reasons that they feel that they are needed (real or imagined).

As the addresses ::10:x:x:x (and the rest of the RFC 1918 addresses) will have to keep their existing "local only: special status, lets just make this official (i.e. not add another IPv6 /10 space) and write it into the specification.

This way we don't add work and we don't kill what is installed in so many companies already. These are the companies  (or people) that will insist on using an 4 to 6 "NAT" on their router based on a Global IPv6 address that will be provided by their ISP and their own (existing or new) RFC 1918 addresses inside their private network.

After all we still need to account for the RFC 1918 addresses in what ever we propose as the standard, and this way we meet what Mike Saywell said in "Re: IETF spec complexity and site locals [Re: C000]"

> It seems to me that most of the people who want to keep site-locals
> only require the address space and not any special handling of scope.
> Whilst the people that want to get rid of them are mainly concerned
> about the problems scoping implies.

---

From: Margaret Wasserman <[email-masked]>
Date: Wed, 16 Apr 2003 07:58:21 -0400

Hi Eric,

At 09:11 AM 4/16/2003 +0300, EricLKlein wrote:
>As the addresses ::10:x:x:x (and the rest of the RFC 1918 addresses) will 
>have to keep their existing "local only: special status, lets just make 
>this official (i.e. not add another IPv6 /10 space) and write it into the 
>specification.
>
>This way we don't add work and we don't kill what is installed in so many 
>companies already. These are the companies  (or people) that will insist 
>on using an 4 to 6 "NAT" on their router based on a Global IPv6 address 
>that will be provided by their ISP and their own (existing or new) RFC 
>1918 addresses inside their private network.

This is an interesting suggestion.  It fits well with the suggestion
that others have made that people who have stable PI address space
in IPv4 could use the IPv6 addresses that map to their IPv4 addresses.

This might be one way of, quite literally, making sure that IPv6
doesn't take away anything that people can already do in IPv4.

Margaret

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Quality Quorum <[email-masked]>
Date: Wed, 16 Apr 2003 09:24:05 -0400

> doesn't take away anything that people can already do in IPv4.

IMHO, it is not going to work, because there is no IID field here and
hence a lot of stuff would simply be broken.

> Margaret

Thanks,

Aleksey