Subject: RE: Charge for traffic, not IP addresses (Was: RE: CONSENSUS CALL: Deprecating Site-Local Addressing)

From: Dan Lanciani <[email-masked]>
Date: Thu, 3 Apr 2003 16:01:44 -0500 (EST)

"Jeroen Massar" <[email-masked]> wrote:

|Dan Lanciani wrote:
|
|> "Jeroen Massar" <[email-masked]> wrote:
|> 
|> [email-masked] wrote:
|> |
|> |> NO - Do NOT Deprecate Site-Local Addressing.
|> |> 
|> |> There are reason to use site-locals, and reason NOT to use 
|> them. But
|> |> "FORBIDDING" people will only alienate them and lead them to 
|> |> find ways to do it anyway.
|> |> 
|> |> Perfect example, when (or should I say IF) my home ISP goes 
|> |> to IPv6, they charge per IP. Always have, and always will.
|> |> Sure, they will gladly give me a range of IPs, as well as
|> |> gladly charge me as if each were a PC. Also,
|> |> when I get tired of putting up with the abuse from this 
|> |> particular ISP and decide to choose another ISP to abuse me,
|> |> I will still have the same issue.
|> |
|> |Very good example that you don't get it at all.
|> |ISP's should be charging for traffic, not for IP's.
|> 
|> So why don't you make the ISPs work the way you think they should?
|> Then NAT would go away and you wouldn't have to try to ban it.  NAT
|> is the effect, not the cause.
|
|That's the IPv4 world. The ISP's will have to get inside
|their heads that IP space is not 'scarce' anymore.

I'm sorry, but you simply do not understand the business model used by the
vast majority of ISPs in (at least) the US.  ISPs do not charge for IP addresses
because of their (largely artificial) scarcity.  ISPs use the number of
addresses as a surrogate measure of bandwidth.  ISPs use the stability of
addresses to control what they perceive as higher-use (= higher cost) activity
such as running a server.  Many ISPs also charge for addresses simply because
they can.

|Fortunatly most RIR's will tell them that when they
|request an allocation and I even suspect that when an ISP
|get 'caught' for not passing out the correct bits down
|to their clients that they can be requested to return
|their allocation as they are not using it anyways.

Now I really have to wonder if you are joking...

|The IPv4 mentality should go. IPv6 != IPv4 fortunatly ;)

Charging for addresses has nothing to do with an IPv4 mentality.  It
has to do with a business model.  There is absolutely nothing in IPv6
that would cause this business model to change.

				Dan Lanciani
				ddl@danlan.*com
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Tony Hain" <[email-masked]>
Date: Thu, 3 Apr 2003 15:05:40 -0800

Dan Lanciani wrote:
> ...
> Charging for addresses has nothing to do with an IPv4 
> mentality.  It has to do with a business model.  There is 
> absolutely nothing in IPv6 that would cause this business 
> model to change.

Customers insisting that their privacy is important, so the ISP must
support RFC3041 usage by the customer. This will prevent the per/address
charges. It will not prevent charging per /64.

Tony