Subject: Re: Charge for traffic, not IP addresses (Was: RE: CONSENSUS CALL: Deprecating Site-Local Addressing)

From: Dan Lanciani <[email-masked]>
Date: Wed, 2 Apr 2003 14:44:43 -0500 (EST)

"Jeroen Massar" <[email-masked]> wrote:

[email-masked] wrote:
|
|> NO - Do NOT Deprecate Site-Local Addressing.
|> 
|> There are reason to use site-locals, and reason NOT to use them. But
|> "FORBIDDING" people will only alienate them and lead them to 
|> find ways to do it anyway.
|> 
|> Perfect example, when (or should I say IF) my home ISP goes 
|> to IPv6, they charge per IP. Always have, and always will.
|> Sure, they will gladly give me a range of IPs, as well as
|> gladly charge me as if each were a PC. Also,
|> when I get tired of putting up with the abuse from this 
|> particular ISP and decide to choose another ISP to abuse me,
|> I will still have the same issue.
|
|Very good example that you don't get it at all.
|ISP's should be charging for traffic, not for IP's.

So why don't you make the ISPs work the way you think they should?
Then NAT would go away and you wouldn't have to try to ban it.  NAT
is the effect, not the cause.

				Dan Lanciani
				ddl@danlan.*com
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Jim Fleming" <[email-masked]>
Date: Thu, 3 Apr 2003 06:06:23 -0600

From: "Jeroen Massar" <[email-masked]>
"IP space is not 'scarce' anymore..."?

=====

If you flip the AM/FM bit to 1, you double the address space but not in both directions.

When you add the 4 bits in both directions for TOS Routing, you get a 16x expansion.

When you add the 7 bits in both directions for RIFRAF Routing, you get another 128x expansion.

Numerous /8s are now exposed as available, that used to be hoaded prior to liberation from the Postel regime.
http://www.iana.org/assignments/ipv4-address-space

Each /8 becomes 2,047 more /8s and the AM/FM doubles that...and that is just for the DMZ Cloud connecting the GKs and PKs...the PKs
have their own transport and addressing...

Jim Fleming

http://www.IPv8.info

----- Original Message -----
From: "Jeroen Massar" <[email-masked]>
To: "'Dan Lanciani'" <[email-masked]>; <[email-masked]>
Sent: Thursday, April 03, 2003 5:55 AM
Subject: RE: Charge for traffic, not IP addresses (Was: RE: CONSENSUS CALL: Deprecating Site-Local Addressing)

> Dan Lanciani wrote:
> That's the IPv4 world. The ISP's will have to get inside
> their heads that IP space is not 'scarce' anymore.
> Fortunatly most RIR's will tell them that when they
> request an allocation and I even suspect that when an ISP
> get 'caught' for not passing out the correct bits down
> to their clients that they can be requested to return
> their allocation as they are not using it anyways.
>
> The IPv4 mentality should go. IPv6 != IPv4 fortunatly ;)
>
> Btw most ISP's I know charge for traffic, though basically
> they say 'this is the "fair use limit"', whenever you pass
> it you have to pay up, hard. Extra IPv4 IP's can usually
> be requested for an additional fee, but that's mostly
> an administration hurdle.
>
> Greets,
>  Jeroen
>
>
>
>

---

From: "Jeroen Massar" <[email-masked]>
Date: Thu, 3 Apr 2003 13:55:46 +0200

Greets,
 Jeroen