Subject: Re: Patrick Faltstrom message: Why SiteLocal is not what solves the problems people want to solve

From: Dan Lanciani <[email-masked]>
Date: Sun, 6 Apr 2003 19:24:45 -0400 (EDT)

Eliot Lear <[email-masked]> wrote:

|Dan Lanciani wrote:
|> However poor, site-locals are the _only_ currently defined local address.
|
|Nope.  You can use IPv4.  And one might as well.

That's true, of course, but it's a pretty depressing reality.  How will
it affect deployment if we have to tell users that switching to v6 means
giving up functionality that they have come to depend on?

|What is the benefit of 
|IPv6 if we don't solve this problem?

Are you talking about solving the problem of site-locals by getting rid
of them or solving the underlying problems (renumbering, routing, etc.) that
drive people to need local address space in the first place?

|Clearly site-locals have been used as a crutch because the hard problems 
|haven't been solved.

I agree that site-locals have been offered as a substitute for more direct
solutions to some difficult problems; however, I do not believe that the
existence of site-locals has had even epsilon effect on the efforts to solve
those difficult problems directly.  Attempts to discuss alternate routing and
portable identifier schemes usually meet with extremely vocal objections that
we do not and can not even know how to begin thinking about the solutions.  I'm
not sure why we aren't hearing more of those objections now.

|Through my vote I am saying that we should go 
|solve the hard problems.

If that is indeed your goal (and I truly think a direct vote to solve
the hard problems would be far more helpful than this indirect approach)
I urge you to make your intent very clear.  Others with whom you are voting
have already expressed the opinion that the hard problems in question are
unimportant/uninteresting and that solving them would not justify further
changes in the architecture.  Given a yes/no vote on a rather nebulous
question, your vote may well be taken as agreement with these sentiments.

|We have a working network for now.

Yes, and it is going to be around for years to come.  This is one reason
I don't understand the huge rush to vote out site-locals.  Why couldn't
we take some time first to at least outline the alternate solutions we will
offer to the underlying difficult problems?

				Dan Lanciani
				ddl@danlan.*com
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Michael Thomas <[email-masked]>
Date: Mon, 7 Apr 2003 10:33:57 -0700 (PDT)

> drive people to need local address space in the first place?

I don't know about Eliot, but that sure has my
vote.  There's certainly more than enough
ignorance floating around about private address
space, but there are also problems like address
stability which are not so easy to dismiss. 

IMO, this giant reset is good since we can sort
through the actual problems. The current presence
of s*t*-l*c*ls is making it near impossible to
have that discussion since it's a supposed -- but
flawed -- solution to a somewhat ill defined set
of problems. For example, it's fairly clear to me
that a BCP should be written which clearly
enumerates why you don't need private address
space to achieve the same security goals, and how
to go about doing that with IPv6's plentiful
address space. And we clearly need a frank
discussion about why current ipv6 renumbering is
viewed as "not good enough for the real world",
and what we can realistically do about it (cf
address stability).

		Mike