Subject: RE: 6to4 and 2002:PRIV:ATE [RE: A use for site local addresses?]

From: "Brian Zill" <[email-masked]>
Date: Tue, 1 Apr 2003 20:09:47 -0800

In the case you list below, host1 and host2 will both have two
addresses.  One set of those addresses share a subnet and by virtue of
longest prefix match will be the pair picked by the source/destination
address selection rules.  So host1 and host2 will happily communicate
without needing to traverse a router.

In other words: it is quite all right for nodes to have a 6to4
pseudo-interface enabled even if another link to which they are
connected has a native prefix including those within 2002::/16.  The RFC
is fine as is.

--Brian

> -----Original Message-----
> From: Michel Py [mailto:[email-masked]] 
> Sent: Thursday, 27 March, 2003 12:14
> To: Ole Troan
> Cc: Brian Carpenter; [email-masked]
> Subject: RE: 6to4 and 2002:PRIV:ATE [RE: A use for site local 
> addresses?]
> 
> 
> > Ole Troan wrote:
> > a host connected to a native link should not
> > automatically enable a 6to4 pseudo interface.
> 
> Agree, and especially not if this native link RAses a prefix 
> within 2002::/16.
> 
> 
> > Brian Carpenter wrote:
> > Some hosts can support such a pseudo-interface, but having
> > it on by default is a problem IMHO.
> > RFC 3056 mainly talks about routers and strongly implies
> > what Michel says, but that MUST NOT is not in any RFC.
> 
> It should be, but is implied anyway because that's the only 
> way it can work.
> 
> Example: My IPv4 prefix is x.y.z.0/24
> I have four subnets:
> - x.y.z.0/26
> - x.y.z.64/26
> - x.y.z.128/26
> - x.y.z.192/26
> 
> My router is x.y.z.1 and x.y.z.65 and x.y.z.129 and x.y.z.193 
> host1 is x.y.z.66 host2 is x.y.z.67
> 
> I migrate to IPv6 using 6to4. I decide that my IPv6 prefix is 
> 2002:xxyy:zz01::/48. Makes sense as the router is going to be 
> the 6to4 gateway for the site.
> 
> I will dual-stack. My subnets now are:
> 
>                  Routing prefix|Site|IID
>                                |topo|
> - x.y.z.0/26     2002:xxyy:zz01:0000::/64
> - x.y.z.64/26    2002:xxyy:zz01:0001::/64
> - x.y.z.128/26   2002:xxyy:zz01:0002::/64
> - x.y.z.192/26   2002:xxyy:zz01:0003::/64
>                                |    |
> 
> 
> My hosts IPv6 addresses should be:
> 
>        Routing prefix|Site|IID
>                      |topo|
> host1: 2002:xxyy:zz01:0001:HST1:I:I:D/64
> host2: 2002:xxyy:zz01:0001:HST2:I:I:D/64
>                      |    |
> 
> 
> However, if there is a 6to4 interface enabled on the hosts, 
> it breaks thinks as the hosts might decide to use:
> 
>        Routing prefix|Site|IID
>                      |topo|
> host1: 2002:xxyy:zz66:????:HST1:I:I:D/64
> host2: 2002:xxyy:zz67:????:HST2:I:I:D/64
>                    ^^|    |
>                    ||
>                    ??
> 
> Not only this is not what I want but it does break things as 
> these two hosts are not even in the same IPv6 logical subnet 
> with the 6to4 address they pick. If these two hosts need to 
> talk together they need to transit by the router, no good.
> 
> In other words: the fact that the RFC does not mention that 
> hosts must not have a 6to4 pseudo-interface enabled if the 
> link has a native prefix including those within 2002::/16 
> does not change the reality that 6to4 interfaces on hosts 
> break things so using them is not an option unless there is 
> only one host per site.
> 
> Michel.
> 
> 
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
> 

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Pekka Savola <[email-masked]>
Date: Wed, 2 Apr 2003 10:12:18 +0300 (EEST)

On Tue, 1 Apr 2003, Brian Zill wrote:
> connected has a native prefix including those within 2002::/16.  

True.

But you assume that such links are either very simple (one link, no links
behind that) or you run a routing protocol which distributes those 
prefixes.

(There are, I think, also some implementations that might not handle this 
properly but I haven't verified.)

> The RFC

Depends on what you want.  The use of 2002:PRIV:ATE is *not* fine for a 
substitute of site-local addressing.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings