Subject: Re: A simple question

From: Bill Manning <[email-masked]>
Date: Sat, 19 Apr 2003 17:24:39 -0700 (PDT)

% >>> So, unless there's some routing revolution, you're just going to have
% >>> to learn to deal with multiple addresses, and unless LL addresses go
% >>> away, you're also going to have to deal with scoped addresses.
% >>
% >> LL use can and should be reserved for bootstrapping and diagnostics.
% >
% > LL is used in applications already. e.g LL addresses are commonly used
% > to address BGP endpoints on exchanges.
% 
% What exchanges do that?
% 
% 
% Joe

	Akira Kato and I had a draft out on how this could be done
	and had working, inter-operable implementations (zebra, cisco)
	in two locations, NSPIXP3 and LAIIX.  The IDR wg chose another
	method and so this technique is not likely to be widely 
	endorsed as an IETF approved method. It is still supported in
	the code and some folks still use it.

--bill
Opinions expressed may not even be mine by the time you read them, and
certainly don't reflect those of any other entity (legal or otherwise).
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Bill Manning <[email-masked]>
Date: Sat, 19 Apr 2003 21:25:59 -0700 (PDT)

% Sat, Apr 19, 2003 at 05:24:39PM -0700, Bill Manning:
% > % >>> So, unless there's some routing revolution, you're just going to have
% > % >>> to learn to deal with multiple addresses, and unless LL addresses go
% > % >>> away, you're also going to have to deal with scoped addresses.
% > % >>
% > % >> LL use can and should be reserved for bootstrapping and diagnostics.
% > % >
% > % > LL is used in applications already. e.g LL addresses are commonly used
% > % > to address BGP endpoints on exchanges.
% > % 
% > % What exchanges do that?
% > % 
% > % 
% > % Joe
% > 
% > 
% > 	Akira Kato and I had a draft out on how this could be done
% > 	and had working, inter-operable implementations (zebra, cisco)
% > 	in two locations, NSPIXP3 and LAIIX.
% 
% but, why?

	why not?  back in the day, the pier wg identified several 
	apps that did not take to renumbering well.  BGP was one.
	couple that with the oddities of small bits of address 
	space that are needed at exchanges (and do not play well 
	w/ the (non)compelling arguements for aggregation) and it 
	seemed reasonable that, if massive aggregation was an 
	inevitable feature of IPv6, that moving exchange point 
	communications to linklocal addresses would make many 
	things simpler. No "special-use" ranges in v6 land
	for exchanges.  But it was not to be.  Check the IDR
	archives for details.

	we now have special blocks of IPv6 space that are not
	supposed to be aggregated for things like exchanges.
	massive aggregation is expected, except for these "special
	prefixes".  One more administrative thing to track. :(

--bill

---

From: "Stephen Sprunk" <[email-masked]>
Date: Sun, 20 Apr 2003 14:44:21 -0500

Thus spake "Keith Moore" <[email-masked]>
> > Also, I'm wondering how the SL/1918 address-scoping debate
> > plays in the context of firewalls.  Don't firewalls provide an even
> > more random form of address scoping that apps must cope with?
> > Or not?
>
> ...
> Scoped addresses muddy this picture, because experience indicates
> that apps will be expected to cope with a mixture of scoped and
> global addresses.  Once scoped addresses are introduced, the app
> has to perform functions traditionally performed by the network. If
> host A cannot reach host B, it might be due to policy or a network
> failure, or it might be that the address that A has for B is not valid in
> the scope that A is using.

So you're not arguing against scoped addresses per se, you're arguing
against having both scoped and global addresses on the same host?  I see the
same problem occuring if a host has two global addresses which are treated
differently by the firewall(s), so it's not truly a problem with SL.

The only SL-specific problem is when naughty applications pass network-layer
addresses across site boundaries; such applications must be "address aware"
anyways, so understanding SL isn't much of an incremental burden.

S

Stephen Sprunk         "God does not play dice."  --Albert Einstein
CCIE #3723         "God is an inveterate gambler, and He throws the
K5SSS        dice at every possible opportunity." --Stephen Hawking

---

From: Keith Moore <[email-masked]>
Date: Sun, 20 Apr 2003 16:00:15 -0400

> against having both scoped and global addresses on the same host?

it turns out that this doesn't solve the problem.  the addresses will still
leak.  apps will still be expected to cope with the mixture of ambiguous and
unambiguous addresses.

> I see the
> differently by the firewall(s),

I see that as a different problem - in particular, in that case there's no
need for apps to cope with ambiguous IP addresses.  as a result it's much
clearer that it's unreasonable to expect apps to talk to the nodes whose
traffic is being filtered.

> addresses across site boundaries

which is a perfectly healthy and reasonable thing for apps to do.
(not that they can tell where those site boundaries are anyway)

> ; such applications must be "address aware"

using an address as an opaque identifier doesn't require address awareness.

Keith

---

From: Pekka Savola <[email-masked]>
Date: Tue, 22 Apr 2003 13:50:45 +0300 (EEST)

On Sat, 19 Apr 2003, Bill Manning wrote:
[...]
> 	prefixes".  One more administrative thing to track. :(

Please stop this.  There is nothing of the kind.  The prefixes are not 
special.  They are not expected to be routable, so there are no additional 
administrative things to track.

Addressing for exchanges killed the need to using LL's with BGP, as simple 
as that.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Bill Manning <[email-masked]>
Date: Tue, 22 Apr 2003 09:57:47 -0700 (PDT)

% On Sat, 19 Apr 2003, Bill Manning wrote:
% [...]
% > 	we now have special blocks of IPv6 space that are not
% > 	supposed to be aggregated for things like exchanges.
% > 	massive aggregation is expected, except for these "special
% > 	prefixes".  One more administrative thing to track. :(
% 
% Please stop this.  There is nothing of the kind.  The prefixes are not 
% special.  They are not expected to be routable, so there are no additional 
% administrative things to track.

	stop what?  telling people that RIRs have created special use
	prefixes for things link exchanges that for every technical 
	purpose are global unicast addresses which have to be administratively
	dealt with so that they are not routed?

% Addressing for exchanges killed the need to using LL's with BGP, as simple 
% as that.

	When it would have been so much easier to just use LLs.
	Its a perfect fit for LLs.   

% Pekka Savola                 "You each name yourselves king, yet the
% Netcore Oy                    kingdom bleeds."
% Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

--bill