Subject: Re: I-D ACTION:draft-ietf-ipv6-flow-label-06.txt

From: Pekka Savola <[email-masked]>
Date: Fri, 4 Apr 2003 00:27:02 +0300 (EEST)

A diversion from the site-local debacle.. :-)

On Tue, 25 Mar 2003 [email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the IP Version 6 Working Group Working Group of the IETF.
> 
> 	Title		: IPv6 Flow Label Specification
> 	Author(s)	: J. Rajahalme, A. Conta, B. Carpenter, S. Deering
> 	Filename	: draft-ietf-ipv6-flow-label-06.txt
> 	Pages		: 9
> 	Date		: 2003-3-24
> 	
> This document specifies the IPv6 Flow Label field, the requirements
> for IPv6 source nodes labeling flows, the requirements for IPv6 nodes
> forwarding labeled packets, and the requirements for flow state
> establishment methods.
> The usage of the Flow Label field enables efficient IPv6 flow
> classification based only on IPv6 main header fields in fixed
> positions.

This satisfies my concerns for security considerations.

I still disagree on the issue on API, but that's acceptable.  Let's see
what the community thinks about it.

The two editorial/semi-editorial nits against the last version are still 
valid; however, they weren't critical and can be corrected in future 
revisions if appropriate.

I think sending this off to the IESG would be appropriate.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Shannon -jj Behrens <[email-masked]>
Date: Thu, 3 Apr 2003 14:10:29 -0800

> what the community thinks about it.

I think it's perfectly acceptible to say that an API MUST be present without
specifying the API.  API documents are by their very nature informational and
not standards track.  Afterall, just because an OS isn't written in C/C++
doesn't mean it shouldn't conform to IETF standards if it wants to talk to the
Internet.  Such an OS is subject to RFC's concerning bits on the wire, but is
surely not subject to RFC's concerning API's.

Nonetheless, I think we should forward this document and then get to work 
on an informational API document.  The flow label is something that definitely
deserves a standardized C API.

Best Regards,
-jj

-- 
Hacker is to software engineer as 
Climbing Mt. Everest is to building a Denny's there.
--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 04 Apr 2003 13:45:09 +0200

Thanks Pekka. We did get a few private comments on the revised
security considerations from Ran Atkinson, and we forgot to
acknowledge your comments, so a quick -07 revision is needed,
and then we can ask the chairs whether they are ready to
declare consensus.

   Brian