Subject: RE: Globally Unique Private Addresses and Scoped Architecture

From: "Michel Py" <[email-masked]>
Date: Wed, 9 Apr 2003 08:01:24 -0700

Harald,

>> Michel Py wrote:
>> Example that works (WRT to being un-routable on the public
>> Internet that is): RFC1918. Although we occasionally see
>> these on the public Internet, it's due to misconfiguration.
>> No customer is going to see their upstream and offer them
>> money to leak or route RFC1918 addresses, because it
>> achieves nothing (because RFC1918 addresses are ambiguous).
>> No demand, no routing. Since what we are talking about here
>> is to remove ambiguity, we must provide a replacement for
>> what ambiguity provides in terms of enforcing the non
>> -public-routability.

> Harald Tveit Alvestrand wrote:
> when IPv4 customers come to their ISP and offer them money
> in order to route RFC 1918 addresses to places the customer
> is not directly connected to, we usually call the result a
> provider provisioned VPN.
> Demand seems widespread.
> So if we roll out globally unique non-routable addresses,
> we should not be at all surprised to see that ISPs will
> actually route them if offered enough money; it's simpler
> (and therefore cheaper) for them than configuring a VPN.

Agree. What would be a surprise is if they would not try.

> (of course this only works in v4 if the two ends have
> coordinated their RFC 1918 deplyment plans. There are
> a lot of cases when they do.)

Which is why we need to reduce the odds of what you described two
paragraphs ago happening in v6 as much as we possibly can.

Michel.

--------------------------------------------------------------------
IETF IPng Working Group Mailing List
IPng Home Page:                      http://playground.sun.com/ipng
FTP archive:                      ftp://playground.sun.com/pub/ipng
Direct all administrative requests to [email-masked]
--------------------------------------------------------------------

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 09 Apr 2003 08:54:26 -0700

> Agree. What would be a surprise is if they would not try.

O.K.  The agreement seems to be that some providers
would try to route provider-independent addresses,
if offered enough money.  Is that correct?

> paragraphs ago happening in v6 as much as we possibly can.

Do you mean, that we should discourage providers from
routing provider-independent addresses?

Do you still believe this if such addresses are forbidden
from inclusion in the default-free zone?

It seems to me that we "should" be able to enforce
this directly, if it's specified as an important part
of IPv6 scalability.  Mistakes might happen, but they
could be corrected within hours, and typically that
amount of deviation from "goodness" wouldn't upset the
overall scalability of the aggregated route advertisements.
It just has to be that most of the DFZ community does
effectively exclude and nullify advertisement of provider-
independent (i.e., non-aggregable) addresses.

Regards,
Charlie P.