Subject: Re: comments on draft-ietf-ipv6-addr-arch-v4-00.txt

From: Erik Nordmark <[email-masked]>
Date: Wed, 17 Dec 2003 08:02:38 -0800 (PST)

> IPv4 mapped address
> 	if I remember correctly draft-itojun-v6ops-v4mapped-harmful-02.txt
> 	(IPv4 mapped address on-wire is harmful) got enough consensus.  please
> 	document that IPv4 mapped address is not permitted on wire, in 2.5.5.

That would seem inconsistent with the SIIT RFC which is a proposed standard.
Thus *if* we should ban IPv4 mapped addresses on the wire,
the correct order would be to deprecated the SIIT RFC first and
then update the addressing architecture.

And it seems like v6ops WG is on the path to clarify the applicability
of NAT-PT and SIIT and not downright deprecating them.

> IPv4 compatible address
> 	2.5.5 states that "The IPv6 transition mechanisms [TRAN] include..."
> 	for IPv4 compatible address.  however, [TRAN] (RFC2893) no longer
> 	includes automatic tunnel.

Incorrect. Is it not until the update to RFC 2893 (currently an
internet-draft)  that automatic tunnels and compatible addresses have been
removed.
 
Given that this draft will hopefully be finished by v6ops I actually think it
is ok to remove the IPv4 compatible addresses from addr-arch at this
point in time.

   Erik

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Bound, Jim" <[email-masked]>
Date: Sat, 20 Dec 2003 12:10:21 -0500

Don't remove deering just the contact information.
Thanks
/jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Jun-ichiro itojun Hagino
> Sent: Monday, December 15, 2003 2:30 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: comments on draft-ietf-ipv6-addr-arch-v4-00.txt
> 
> 
> > 	as an IAB i was asked to comment on 
> draft-ietf-ipv6-addr-arch-v4-00.txt,
> > 	so here it is.  happy holidays.
> 
> 	one more ;-)
> 
> itojun
> 
> 
> MINOR
> =====
> 	[email-masked] is no longer valid, so you may want 
> to remove it
> 	from the draft.
>