Subject: RFC2461: be more clearer about TLL option in NA

From: Yukiyo Akisada <[email-masked]>
Date: Mon, 16 Feb 2004 13:02:19 +0900

Hi, all.

RFC2461 says TLL option SHOULD be requires in NA while responding to unicast NS.

    4.4.  Neighbor Advertisement Message Format
    ----------------------------------------------------------------
       1351    Possible options:
       1352
       1353       Target link-layer address
       1354                      The link-layer address for the target, i.e., the
       1355                      sender of the advertisement.  This option MUST be
       1356                      included on link layers that have addresses when
       1357                      responding to multicast solicitations.  When
       1358                      responding to a unicast Neighbor Solicitation this
       1359                      option SHOULD be included.

but RFC2461 also says 'MAY' be omitted.

    7.2.4.  Sending Solicited Neighbor Advertisements
    ----------------------------------------------------------------
       3387                          If the solicitation's IP Destination Address is
       3388    not a multicast address, the Target Link-Layer Address option MAY be
       3389    omitted; the neighboring node's cached value must already be current
       3390    in order for the solicitation to have been received.

It isn't contradiction, but it is unclear.

The former seems that it disallows omission of TLL option,
and the latter seems that it allows omission.

I think 2461bis can be more clear about this option.

Regards.

----
Yukiyo Akisada <[email-masked]>

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Soliman Hesham <[email-masked]>
Date: Mon, 16 Feb 2004 07:29:24 -0500

Thanks, unfortunately I already submitted the draft but I'll
create a new issue for it. 

Hesham

 > -----Original Message-----
 > From: [email-masked] [mailto:[email-masked]]On Behalf Of
 > Yukiyo Akisada
 > Sent: Sunday, February 15, 2004 11:02 PM
 > To: [email-masked]
 > Subject: RFC2461: be more clearer about TLL option in NA
 > 
 > 
 > Hi, all.
 >