Subject: RE: [psg.com #246] [2461bisissue 246] Preferred lifetime > valid lifetime

From: Soliman Hesham <[email-masked]>
Date: Fri, 13 Feb 2004 10:55:37 -0500

> > What is the handling for the case where a prefix's 
 > preferred lifetime
 > > exceeds the valid lifetime?
 > 
 > > Suggestion: Specify that a router MUST NOT send a prefix option
 > > containing preferred lifetime > valid lifetime
 > 
 > > Current text in Preferred Lifetime description (sec 4.2):
 > 
 > > Preferred Lifetime
 > >                   32-bit unsigned integer.  The length of time in
 > >                   seconds (relative to the time the packet is sent)
 > >                   that addresses generated from the prefix via
 > >                   stateless address autoconfiguration remain
 > >                   preferred [ADDRCONF].  A value of all one bits
 > >                   (0xffffffff) represents infinity.  See 
 > [ADDRCONF].
 > >                   Note that the value of this field MUST 
 > NOT exceed 
 > >                   the Valid Lifetime field to avoid preferring 
 > >                   addresses that are no longer valid.
 > 
 > Let me check: is this your suggested text in rfc2461bis?

=> yes

 > 
 > (BTW: I guess you meant "sec 4.6.2", not "sec 4.2")

=> Of course, that's what I meant :)

Hesham

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: JINMEI Tatuya / 神明達哉 <[email-masked]>
Date: Sat, 14 Feb 2004 16:32:55 +0900

>>>>> On Fri, 13 Feb 2004 10:55:37 -0500, 
>>>>> Soliman Hesham <[email-masked]> said:

> => yes

Okay, then I'd rather put this requirement in "Router Configuration
Variables" (Section 6.2.1).  That is, I'd add to the following part

      AdvPrefixList
	...
                   Automatic address configuration [ADDRCONF]
                   defines additional information associated with
                   each the prefixes:
	...
                        AdvPreferredLifetime

an additional requirement like this:

		   The value MUST not be larger than AdvValidLifetime.

Because this issue is particularly for the router behavior.  For the
host part, it is already pretty clear that host must ignore a prefix
if preferred lifetime > valid lifetime.

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]