Subject: RE: I-D ACTION:draft-ietf-ipv6-rfc2096-update-06.txt

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Mon, 2 Feb 2004 15:02:26 +0100

> > By the way I like Mike's proposal to make it (0..2040), which would
> > line up with the max size of an InetAddress (255 octets).
> 
> This makes indeed sense. One can ask whether this range should not be
> added to the InetPrefixLength TC itself so that the range is already
> bound to the TC. Of course, applying to your logic above, you would 
> repeat the range (0..2040) anyway just to be explicit that zero is 
> included...
> 
> So what do we do?
> 
> a) Add the range (0..2040) to the InetPrefixLength TC? (Now 
> is the right
>    time to do this.)
> 
> b) Add the range (0..2040) just to the objects in question 
> that use the
>    InetPrefixLength TC?
> 
> c) Do both?
> 
> I think I prefer a) at the moment.
> 
I agree that a) is the best solution.

And it does make the warning go away too!

Bert
> /js
> 
> -- 
> Juergen Schoenwaelder		    International University Bremen
> <http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 
> 28725 Bremen, Germany
> 

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "C. M. Heard" <[email-masked]>
Date: Mon, 2 Feb 2004 07:31:22 -0800 (PST)

> I agree that a) is the best solution.

That is my opinion, too.

Mike

---

From: Brian Haberman <[email-masked]>
Date: Mon, 02 Feb 2004 16:53:53 -0500

>>I agree that a) is the best solution.

I prefer a) as well.  It makes it cleaner for all the docs involved.

Brian