Subject: RE: Appeal on "Unique Local IPv6 Unicast Addresses"

From: [email-masked]
Date: Mon, 8 Mar 2004 16:02:22 +0200

Thomas Narten wrote:
> why we can't make such assignments permanent. (Note: I'd agree with
> you that the assignments shouldn't be permanent if there was a case to
> be made that it may become necessary to reclaim them at some future
> time. Is there?)
> 

What if someone manages to hoard the address space and then starts to sell them? Assume a bug in the system managing the allocations and someone exploiting it and getting 1/2 of the whole address space that they now "own" for good.

Maybe there should be a notion of reclaiming prefixes that should not have been allocated in the first place?

Regards,

	Jarno

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 09 Mar 2004 09:45:50 +0100

Jarno, this is exactly why the fixed charge is suggested - to make
the cost of bulk hoarding significant. 

And no, I don't want to imagine such a bug - I have more confidence than
that in IANA and the organisations IANA delegates to.

    Brian

-- 
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Brian E Carpenter 
Distinguished Engineer, Internet Standards & Technology, IBM

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 09 Mar 2004 11:06:32 -0800

Hello Brian,

I think that the fixed charge is a mistake, and
should be avoided.

To avoid hoarding, of course it would be good to
avoid bugs.  In case, that is considered impossible
(sigh!) we can also demand that each address and/or
prefix be accompanied by a certificate generated
by IANA with a one-way hash to validate it.
The hash is to be unforgeable.  The certificate
is to contain the time of issuance.

Nobody is going to be able to present a billion
certificates satisfying the time constraint that
each one be separated by one or more seconds.
This can be made to be machine verifiable also.

Maybe there is another way, but in any case I
strongly think the fixed charge should be avoided.

And, finally, I assert that the bugs can be
avoided anyway.  It doesn't have to be more
than a few hundred lines of code.

Regards,
Charlie P.

---

From: Bob Hinden <[email-masked]>
Date: Tue, 09 Mar 2004 11:41:10 -0800

Charlie,

>I think that the fixed charge is a mistake, and

I trust that everyone commenting on this has actually read the current 
draft.  A fixed charge was removed several drafts ago.

The current draft does not impose a fixed charge for a prefix, but instead 
sets a requirement that the allocation authority implement a mechanism that 
prevents hoarding.  Specifically from section 3.2.1 Centrally Assigned 
Global IDs:

    - Provide mechanisms that prevent hoarding of these allocations.

    ....

    The allocation service should include sufficient provisions to avoid
    hoarding of numbers.  This can be accomplished by various ways, for
    example, requiring an exchange of documents, a verbal contact, or a
    proof that the request is on behalf of a human rather than a machine.
    The service may charge a small fee in order to cover its costs, but
    the fee should be low enough to not create a barrier to anyone
    needing one.  The precise mechanisms should be decided by the
    registration authority.

Bob

> > > What if someone manages to hoard the address space and then starts to 
> sell them? Assume a bug in the system managing the allocations and 
> someone exploiting it and getting 1/2 of the whole address space that 
> they now "own" for good.
> > >

---

From: Fred Templin <[email-masked]>
Date: Tue, 09 Mar 2004 12:12:33 -0800

Has there been any resolution as to a name for the new addresses?
As I recall, there was some earlier discussion to this point.

Thanks - Fred
[email-masked]

Bob Hinden wrote:

> The current draft does not impose a fixed charge for a prefix, but 
> instead sets a requirement that the allocation authority implement a 
> mechanism that prevents hoarding.  Specifically from section 3.2.1 
> Centrally Assigned Global IDs:
>
>> > > What if someone manages to hoard the address space and then 
>> starts to sell them? Assume a bug in the system managing the 
>> allocations and someone exploiting it and getting 1/2 of the whole 
>> address space that they now "own" for good.
>> > >
>> > > Maybe there should be a notion of reclaiming prefixes that should 
>> not have been allocated in the first place?
>> > >
>> > > Regards,
>> > >
>> > >         Jarno
>> > >

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 10 Mar 2004 06:52:32 +0100

Yes, I appologise for accidentally resurrecting the fixed charge,
by typing "is suggested" when my brain was thinking "was suggested."

We did indeed all agree to delegate *that* choice to IANA.

   Brian

---

From: Alain Durand <[email-masked]>
Date: Tue, 09 Mar 2004 22:12:15 -0800

> We did indeed all agree to delegate *that* choice to IANA.

This is the part that bothers me. If we delegate the choice of the 
anti-hoarding mechanism to IANA,
why don't we also delegate to IANA the decision to make the allocation 
permanent or reclaimable?

	- Alain.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 10 Mar 2004 09:19:34 +0100

> permanent or reclaimable?

Because (in my mind) the whole technical purpose of these assignments is 
permanence. The only reason I would want one is permanence.

   Brian