Subject: RE: Multiple DRs on a link

From: "Soliman Hesham" <[email-masked]>
Date: Thu, 11 Mar 2004 22:30:32 -0500

> *If* we want to pursue this path at a minimum the host needs to know
 > whether using the original 1st hop router is better or not.
 > One way to do this is to require that routers on the same link
 > must advertise the same set of prefixes (and make the router 
 > advertisement
 > consistency in RFC 2461 check this?).
 > If we did that then the hosts could assume that when 
 > different routers
 > advertise different sets, the routers are not managed by the same
 > entity and the host should use a 1st hop router that is 
 > consistent with
 > the source address. But the host could switch 1st hop 
 > routers among the
 > set of routers that advertise the same set of prefixes.

=> I think that it's generally a good idea to recommend
that, despite the fact that we don't yet have a full
solution. I.e. there is nothing to lose if we recommend
that and there are potential gains. This will also
simplify MIP movement detection a bit.

Should we strengthen the language on this in 2461bis?
There is already a recommendation that routers should 
check other RAs for consistency, but I don't think
it says anything about advertising the same prefixes.
Perhaps we can add that as a "RECOMMEND".

 > 
 > I don't know whether we could make the operational 
 > requirement that the routers
 > on the same link (that don't want source-based routing) must 
 > advertise the
 > same set of prefixes stick. Depends on what the current 
 > operational practices
 > I guess.

=> Agreed. But then again better now, when there is not
global deployment, than few years down the road when
it is widely deployed.

Hesham

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Erik Nordmark <[email-masked]>
Date: Fri, 12 Mar 2004 09:42:25 -0800 (PST)

> Perhaps we can add that as a "RECOMMEND".

RFC 2461 explicitly doesn't require checking the set of prefixes (but
it does say to check that the lifetimes on a prefix which both routers
advertise are consistent, etc).
*If* we are going to change this, I don't think it should be a subtle
setence in 2461bis; I think it should be a standalone RFC so
that operators and implementors pay attention.
If we do that, making 2461bis have the same message makes sense.

Perhaps writing up a draft for v6ops would be a good start.
Pointing out that the current flexibility (of different prefixes
advertised by different routers) doesn't have any operational use, but
allowing hosts, for Nemo and multihoming reasons, to tell when
there are source address constraints might have some use.

  Erik

---

From: "James Kempf" <[email-masked]>
Date: Fri, 12 Mar 2004 09:47:07 -0800

> there are source address constraints might have some use.

I agree.

            jak