Subject: RE: Response to AD comments on draft-ietf-ipv6-unique-local-addr-03.txt

From: Dan Lanciani <[email-masked]>
Date: Fri, 9 Apr 2004 01:19:32 -0400 (EDT)

"Soliman Hesham" <[email-masked]> wrote:

| > That is why it is stated as "are not expected to be in the 
| > global DNS".
| > There will be issues caused by them being advertised yet not 
| > reachable.
| > Would you rather see a stronger statement against inclusion in the
| > global DNS?
|
|=> I think this makes sense. Something like "SHOULD NOT".

I would prefer not to see such language.

| > My personal opinion is that they should never be in the 
| > global DNS, 
|
|=> Agreed.
|
|   but
| > that didn't seem to be the consensus of the WG.
|
|=> At least you and I agree FWIW :) 
|Perhaps I missed this discussion, but I can't see 
|why they should be put in the global DNS.

One might want to build an overlay network where consenting sites know how
to reach each other by constructing dynamic tunnels based on some (yet to
be defined) mapping function.  Thus the addresses may well be reachable in
some sense.

				Dan Lanciani
				ddl@danlan.*com

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Kurt Erik Lindqvist <[email-masked]>
Date: Fri, 9 Apr 2004 11:21:52 +0200

> be defined) mapping function.  Thus the addresses may well be 

But is this reason enough to have them in the global DNS tree. I don't 
think so...

- - kurtis -

---

From: Mark Smith <[email-masked]>
Date: Fri, 9 Apr 2004 19:46:19 +0930

On Fri, 9 Apr 2004 11:21:52 +0200
Kurt Erik Lindqvist <[email-masked]> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> 
> But is this reason enough to have them in the global DNS tree.
> I don't think so...
> 

Rather than the dynamic mappings Dan suggested, I
could imagine a corporate, WAN type IPsec VPN scenario, were the
global DNS entry destinations are only accessible across the
IPsec tunnels, to devices residing behind the IPsec VPN gateways.
Placing unique-local addresses in the global DNS infrastructure
would save having to setup split / duplicate DNS in this
scenario, minimising costs.

Regards,
Mark.

---

From: "Stephen Sprunk" <[email-masked]>
Date: Sat, 10 Apr 2004 01:38:04 -0500

Thus spake "Kurt Erik Lindqvist" <[email-masked]>
> But is this reason enough to have them in the global DNS tree. I don't

My justification is that some sites may choose to communicate privately
(i.e. not via the Internet) using their local addresses.  Having these
addresses in the global DNS (both forward and reverse) means that each site
doesn't need to add its partners' zones to all of their name servers, which
is rather error-prone.  Also, if local addresses somehow leak into the
Internet, having reverse entries in DNS may help trace the leak.

Suggested text for 7.0:

AAAA and PTR records for Local IPv6 addresses MAY be installed in the global
DNS at the option of the site to which they are assigned.  It is expected
that most sites will not make use of this option, but some sites may find
benefits in doing so.

S

Stephen Sprunk        "Stupid people surround themselves with smart
CCIE #3723           people.  Smart people surround themselves with
K5SSS         smart people who disagree with them."  --Aaron Sorkin

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 15 Apr 2004 09:36:49 +0200

Stephen Sprunk wrote:
...
> that most sites will not make use of this option, but some sites may find

Can we just say yes to this, rather than arguing endlessly about who would 
or wouldn't do so?

   Brian

---

From: Bob Hinden <[email-masked]>
Date: Thu, 15 Apr 2004 07:25:16 -0700

Brian,

>Can we just say yes to this, rather than arguing endlessly about who would

This works for me.  I think going beyond this moves it into operational 
aspects that might be better discussed elsewhere.

Bob

---

From: Hans Kruse <[email-masked]>
Date: Thu, 15 Apr 2004 16:11:27 -0400

The suggested language seems fine to me (aka just say yes...).

--On Thursday, April 15, 2004 09:36 +0200 Brian E Carpenter 
<[email-masked]> wrote:

> Stephen Sprunk wrote:
> ....
>> Suggested text for 7.0:
>>
>> AAAA and PTR records for Local IPv6 addresses MAY be installed in the
>> global DNS at the option of the site to which they are assigned.  It is
>> expected that most sites will not make use of this option, but some
>> sites may find benefits in doing so.
>
> Can we just say yes to this, rather than arguing endlessly about who
> would  or wouldn't do so?
>
>    Brian
>
>
>

Hans Kruse, Associate Professor
J. Warren McClure School of Communication Systems Management
Adjunct Associate Professor of Electrical Engineering and Computer Science
Ohio University, Athens, OH, 45701
740-593-4891 voice, 740-593-4889 fax