Subject: RE: [psg.com #245] Mixed host/router behavior

From: "Soliman Hesham" <[email-masked]>
Date: Mon, 28 Jun 2004 08:21:37 -0400

> > 	- (if really necessary) in Appendix, talk about mixed mode node,
 > > 	  and benefits/caveats/pitfalls in doing so.  even if 
 > we do not write
 > > 	  it up, vendors will do it anyways so my preference is 
 > not to mention
 > > 	  mixed mode at all.
 > 
 > If folks have already built such things or are thinking 
 > about building them
 > I think we need to write down at least as much necessary for the ND
 > protocol to still interoperate with those boxes. Thus I don't think
 > we need to write down how to make such boxes "work" in general,
 > but we do need to write down how they should act on the
 > interfaces on which they prentend to be a router and on the 
 > interfaces
 > on which they pretend to be hosts as it pertains to the ND messages
 > that are sent and received.

=> I agree with this approach. I don't think we need to
get into further details in 2461bis.

Hesham
 >   Erik

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Bound, Jim" <[email-masked]>
Date: Mon, 28 Jun 2004 10:19:41 -0400

I agree with Itojun.  Lets leave this alone it is very CLEAR to me as
implementer completely.  We should not add new words to these specs
unless an implementation is broken or not clear.  I have heard no
complaints per implementation and this has been tested well via TAHI,
UNH, and the IPv6 Logo.  All get it.

Thanks
/jim 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Jun-ichiro itojun Hagino
> Sent: Friday, June 25, 2004 11:50 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: [psg.com #245] Mixed host/router behavior
> 
> > >  > 	i'm for simple "router or host" in document, and leave 
> > >  > per-interface
> > >  > 	"router" as a exercise for reader ("virtual router" 
> > >  > concept is not new
> > >  > 	so vendors will make such device anyways).
> > > 
> > > => The issue at hand is that the doc is not clear on 
> nodes that are 
> > > both hosts and routers. Do you see any harm in making the 
> definition 
> > > per interface?
> > 
> > 	yes.  i see a big harm and disambiguity introduced by 
> the change.
> > 	again, keep the document simple, and let vendors do 
> funny/complex
> > 	things if they want to.
> 
> 	s/disambiguity/ambiguity/
> 
> itojun
>

---

From: "Bound, Jim" <[email-masked]>
Date: Mon, 28 Jun 2004 10:25:32 -0400

Ack to Itojun and I am not clear we need to do this at all or add text.
/jim 

> Sent: Monday, June 28, 2004 5:37 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> > How about a compromise that makes it clear that
> >  - isRouter and all other ND configuration and state is per 
> interface
> >    thus there is nothing in the specification which prevents a node
> >    being a host on some interfaces and a router on other interfaces.
> >    The behavior of such nodes on a particular interface is specified
> >    in this document.
> >  - the details of how such nodes work across interfaces 
> i.e. how the node
> >    determines which interfaces forward packets between each 
> other etc
> >    are out of scope for the document.
> 
> 	i do not like this way.  i would like to put:
> 	- a node is either a host or a router.  it is a 
> per-host property,
> 	  not per-interface property.  "advertising interface" 
> has nothing
> 	  to do with host/router (as jinmei described)