Subject: some question on "draft-ietf-ipv6-rfc2462bis-02.txt"

From: "CTO YAN Renxiang" <[email-masked]>
Date: Fri, 25 Jun 2004 11:27:31 +0800

Hi, Jinmei,

I read recent draft, still got some questions:
1. In page 9,  it states:  A "managed address configuration (M)" flag indicates  whether hosts can use stateful autoconfiguration [6] to obtain addresses. An "other stateful configuration (O)" flag indicates  whether hosts can use stateful autoconfiguration [7] to obtain  additional information (excluding addresses). 

What do you mean by "can use stateful autoconfiguration..."? how to force host using DHCP instead of RA?

2.In RFC2461, page 19, it states "when M is set, hosts use the administered (stateful) protocol for address autoconfiugration in addition to any addresses autoconfigured using stateless address autoconfiguration."

Does it mean host can get two independent IPv6 addresses using RA and DHCP? For example, host get an address "3FFE:XXXX:XXXX.../64" using RA and "2001:aaaa:aaaa:xxxx:xxxx/128" using DHCP.  

3. If address is allocated using DHCP, how to get the "prefix lengh" of this address? since DHCP did not have such an option. In DHCPv4, network mask is sent using a specific option.

4. What does the "Autonomous flag" mean? could you explain it a bit detail?

Thanks

-renxiang yan
Research&Innovation Center
Alcatel Shanghai Bell

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Fri, 25 Jun 2004 17:29:50 +0900

>>>>> On Fri, 25 Jun 2004 11:27:31 +0800, 
>>>>> "CTO YAN Renxiang" <[email-masked]> said:

> 1. In page 9,  it states:  A "managed address configuration (M)"
> flag indicates  whether hosts can use stateful autoconfiguration [6]
> to obtain addresses. An "other stateful configuration (O)" flag
> indicates  whether hosts can use stateful autoconfiguration [7] to
> obtain  additional information (excluding addresses). 

> What do you mean by "can use stateful autoconfiguration..."?

It means there is a DHCPv6 server that can allocate addresses for the
host in the network (the server may be off-link reachable via a relay).

> how to
> force host using DHCP instead of RA?

We cannot force using DHCPv6 within the specification of rfc2462bis.
Instead, the M/O flags just indicate the corresponding DHCPv6 services
are *available* for hosts that want to use these services.  This is
based on the consensus in the wg during a long discussion for the
rfc2462bis work.  If you have time, you can find the discussion from
the ML archive.

> Does it mean host can get two independent IPv6 addresses using RA and DHCP? For example, host get an address "3FFE:XXXX:XXXX.../64" using RA and "2001:aaaa:aaaa:xxxx:xxxx/128" using DHCP.  

Yes, if the host invokes DHCPv6 (note again that we do not enforce
using DHCPv6 with the M flag in the specification of rfc2462bis).

> 3. If address is allocated using DHCP, how to get the "prefix lengh" of this address? since DHCP did not have such an option. In DHCPv4, network mask is sent using a specific option.

By a prefix length option of an RA, with the L flag being set.  (Note:
this is not directly related to rfc2462bis.  The question should
actually go to RFC2461 or rfc2461bis)

> 4. What does the "Autonomous flag" mean? could you explain it a bit detail?

It means the receiving host should configure an address using the
prefix specified in the prefix information option by the stateless
address autoconfiguration mechanism.  (I'd rather recommend you to go
through RFC2461 or rfc2461bis for this question though).

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]