Subject: Re: WLAN (was Re: IPv6 Host Configuration of Recursive DNS Server)

From: Masataka Ohta <[email-masked]>
Date: Wed, 16 Jun 2004 22:15:51 +0900

Hi, Greg;

>>>>>If 802.11 was successfully emulating an Ethernet I would say yes. 

>>>>Broadcast over 802.11 is much less reliable than that over Ethernet.
>>>> PERIOD.

>>>Actually multicast isn't, if the multicast packet
>>>is only going toward the AP.

So, you wanted to say "only going to the AP or toward AP to the
wired part behind the AP but not toward AP to the wireless part
around the AP".

Then, you could have been right.

It explains why IPv4 with ARP is working fine over leaf WLAN
even with certain congestion expected at IETF meetings.

But, it is not the case with, say, MANET, nor IPv6 with ND.

Anyway,

>>>>>If 802.11 was successfully emulating an Ethernet I would say yes. 

you must say no.

						Masataka Ohta

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Greg Daley <[email-masked]>
Date: Wed, 16 Jun 2004 22:00:54 +1000

Hi Masakata, 

----- Original Message -----
From: Masataka Ohta <[email-masked]>
Date: Wednesday, June 16, 2004 1:40 pm
Subject: Re: WLAN (was Re: IPv6 Host Configuration of Recursive DNS 
Server)

> >> Broadcast over 802.11 is much less reliable than that over 
> Ethernet.>> PERIOD.
> 
> Apparently, you misunderstand that the problem were caused
> by hidden terminals and were generic to radio.

Indeed I do not!

> It is not. The problem is caused by lack of ACK for
> multicast/broadcast and is specific to CSMA/CA.

This is incorrect,

multicast is unacknowledged on the path from the AP to the
STA _only_,

_Not_ in the reverse direction from the STA to the AP.

from 802.11 (1999), section 9.2.7, paragraph 2:

"There is no MAC-level recovery on broadcast or multicast
frames, except for those frames sent with the ToDS bit set.
..."

from 802.11 (1999), section 9.2.8, paragraph 2:

"Upon successful reception of a frame of a type that
requires acknowledgment with the ToDS bit set, an AP
shall generate an ACK frame. ..."

For multicast frames going from the wireless medium to the
wired medium, the ToDS bit is set, which means the 802.11
Address 1 is the (unicast) identifier of the 802.11 AP, and 
thus it should send an acknowldegement.
(The multicast destination to which the frame is bridged 
is carried in Address 3).

This means that for the upstream channel from the host to the
AP, multicast receives the _same_ treatment as unicast.

It is therefore exactly as reliable as unicast.

Greg