Subject: Re: question about DHCPv6 prefix delegation usage

From: [email-masked]
Date: Wed, 02 Jun 2004 10:52:42 +0200

Thank you Tony and Christian for your answers.

In my question, I missed the point that the ISP and CPE are in different 
domain,
so the distribution of the /48 to the CPE is supposed to follow a 
different policy
than how the /64 are distributed.
And having 2 levels of DHCPv6 PD servers is scalable.

Yes, of course A and B are DHCPv6 clients, and the CPE (in my initial 
question) was supposed to be a working DHCP relay.

I have other questions based on the same (theorical) network:

             ISP (ISP DHCPv6 PD server, gives /48 to the CPE)
              |
              |
             CPE  (Customer DHCPv6 PD server, gives /64 prefixes)
             / \
            /   \
        ---B----A---
           |    |

How many /64 prefixes A and B are supposed to request (to the CPE),
and for what usage ?  Only for connectivity with the CPE ?

Does the link between A and B have any sense
or are A and B part of different clients / organisations ?

Is there any (private?) network connected to A and B ?

=> In others words, what kind of networks/links are supposed to be 
connected this CPE when using DHCPv6 PD ?

And now the CPE is a DHCPv6 PD server, it should be able to delegate not 
only /64 prefixes, right ?

Regards,

Laurent

Tony Hain wrote:

>You are asking a question which mixes technology with policy. The simple
>answer to your question is YES. The complex answer is a function of the
>policy at the ISP DHCP server. Will it accept requests from A & B? Are you
>expecting the set of /64's allocated to A & B to be contained within the /48
>at the CPE? If so what mechanism enforces that at the DHCP server? (IE: how
>does the DHCP server associate A or B with the CPE?) 
>
>What is the point of such a broken deployment model? If the expectation is
>to allocate a /48 to the CPE using DHCP-PD (which it should be), then put a
>DHCP server in the CPE and have it delegate /64's from that space. This
>ensures that A & B get their space from the appropriate point in the
>hierarchy, as well as distributes the load. Consider that it will not be
>long before A & B have expanded to ~10^3 devices behind that CPE, multiple
>the number of CPE by that and figure out how to scale the authentication &
>association logic for a central DHCP server to ensure everything works as
>expected. Then reconsider the simplicity of distributing that function to
>the CPE.
>
>Tony
>
>
>  
>
>>-----Original Message-----
>>From: [email-masked] [mailto:[email-masked]] On Behalf Of
>>[email-masked]
>>Sent: Tuesday, June 01, 2004 7:12 AM
>>To: [email-masked]; Ralph Droms
>>Subject: question about DHCPv6 prefix delegation
>>
>>Hi All,
>>
>>I have a question about DHCPv6 prefix delegation (RFC 3633).
>>
>>Given the following network:
>>
>>
>>             ISP (Location of DHCPv6 server)
>>              |
>>              |
>>             CPE           /48
>>             / \
>>            /   \
>>        ---B----A---
>>           |    |
>>
>>
>>Is it possible to configure the DHCP server to allocate  :
>>- a /48 prefix to the CPE node
>>- and several /64 prefixes to the nodes A and B ?
>>
>>Thank you for any help,
>>
>>Regards,
>>
>>Laurent
>>
>>--
>>Laurent Clévy
>>Alcatel CIT, R&I             Voice: +33 (0)1 69 63 18 34
>>Route de Nozay               Fax  : +33 (0)1 69 63 13 59
>>91460 Marcoussis             mailto:[email-masked]
>>
>>
>>
>>--------------------------------------------------------------------
>>IETF IPv6 working group mailing list
>>[email-masked]
>>Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
>>--------------------------------------------------------------------
>>    
>>
>
>
>  
>

-- 
Laurent Clévy                
Alcatel CIT, R&I             Voice: +33 (0)1 69 63 18 34
Route de Nozay               Fax  : +33 (0)1 69 63 13 59
91460 Marcoussis             mailto:[email-masked]

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Ralph Droms <[email-masked]>
Date: Wed, 02 Jun 2004 14:02:05 -0400

Laurent - assuming you want aggregation for routing, the ISP DHCPv6 server
would have to be configured to recognize that A and B are downstream from
the CPE, and therefor should be assigned /64s that somehow aggregate under
the /48 assigned to the CPE.

Pushing the responsibility to a DHCPv6 server in the CPE allows the CPE to
assign prefixes from its /48 to the links between A and B, and other
prefixes to the DHCPv6 server for delegation to A and B.

In the picture below, the CPE would be reponsible for assigning a /64 from
its /48 to the links between the CPE and A and B.  A and B would request
prefix(es) for their downstream links.  A might request a /64 if it has only
one downstream link, or a shorter prefix if it has more than one downstream
link.

A and B could be part of the same organization as the CPE, or part of
different organizations.  It's not clear whether a link between A and B
would be useful or sensible.

If ythere is a link between A and B, there's an issue about
whether A or B (or both?) should assign a prefix to that link.

- Ralph