Subject: RE: [psg.com #245] Mixed host/router behavior

From: "Bound, Jim" <[email-masked]>
Date: Mon, 28 Jun 2004 10:28:22 -0400

Erik,

This is all just adding superfluous text to an already 90+ page document.  Again what implementer or customer have you found that has noted a problem.  Or we just masturbating RFC 2461 again out of boredom.  We have so much work to do in the IETF here and elsewhere I don't get why this is a good use of our email time or WG time when nothing is broken.

What problem do you believe this solves?  

Thanks

/jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Erik Nordmark
> Sent: Monday, June 28, 2004 5:45 AM
> To: JINMEI Tatuya / 神明達哉
> Cc: Soliman Hesham; [email-masked]; Jun-ichiro itojun Hagino
> Subject: Re: [psg.com #245] Mixed host/router behavior
> 
> > Regarding rfc2461bis, if we allow the mixed behavior, we 
> also need to 
> > clarify (at least) some other things that include:
> > 
> > - whether a mixed node can receive an RA on a "host" interface to
> >   configure a default router list
> 
> Why? Per RFC 2461 the per router list is per interface.
> There is an issue for the implementations (probably all 
> implementations) which have a per-node default router list, 
> but from the perspective of the RFC 2461 specification it has 
> already punted on all aspects of multi-interfaced hosts.
> 
> > So, (if we concentrate on the "simple" cases), I think we should 
> > emphasize that even if an interface is not an advertising interface 
> > the node still acts as a router on that interface (e.g., it can 
> > forward from/to that interface, exchange routing 
> information on that 
> > interface, etc)
> 
> Whether or not we concentrate on the "simple" case, I think 
> it makes sense to state that a non-advertising interface is 
> still one that behaves as a router e.g. the R-bit in the NA 
> should be set since another router might redirect hosts to 
> use the router that doesn't advertise itself.
> 
>   Erik
> 
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
> 
> 
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Erik Nordmark <[email-masked]>
Date: Mon, 28 Jun 2004 08:00:56 -0700 (PDT)

> This is all just adding superfluous text to an already 90+ page document.
> Again what implementer or customer have you found that has noted a problem.
> Or we just masturbating RFC 2461 again out of boredom.  We have so much work
> to do in the IETF here and elsewhere I don't get why this is a good use of
> our email time or WG time when nothing is broken.

Jinmei seemed to say that he was concerned that folks have or will
misinterpret the meaning of a non-advertising interface on a router.
If this is indeed the case (and I trust Jinmei had a reason to bring it
up) I don't see any harm in clarifying this.

Or did your "this" refer to something other than the email to which you
replied?

    Erik

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Tue, 29 Jun 2004 15:41:25 +0900

>>>>> On Mon, 28 Jun 2004 08:00:56 -0700 (PDT), 
>>>>> Erik Nordmark <[email-masked]> said:

> misinterpret the meaning of a non-advertising interface on a router.

Yes, this is the concern I raised in the message that Jim cited
(http://www1.ietf.org/mail-archive/web/ipv6/current/msg02912.html)

And note that this is separate from whether we should allow the
"mixed" behavior in rfc2461bis as pointed out by Erik (and I agreed in
a very recent message, which is perhaps not delivered to the list yet).

> up) I don't see any harm in clarifying this.

See, for example, the following message (I referred to this one in my
first response to this thread):

http://www1.ietf.org/mail-archive/web/ipv6/current/msg01524.html

Apparently, there was a confusion about the relationship between 
"forwarding interfaces" defined in RFC2460 and "advertising
interfaces" defined in RFC2461.

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]