Subject: Issue about RFC3595 - Textual Conventions for IPv6 Flow Label

From: [email-masked]
Date: Tue, 30 Nov 2004 09:49:27 +0800

RFC 3595 - Textual Conventions for IPv6 Flow Label refers to:
"IPv6FlowLabelOrAny ::= TEXTUAL-CONVENTION
       DISPLAY-HINT  "d"
       STATUS         current
       DESCRIPTION   "The flow identifier or Flow Label in an IPv6
                      packet header that may be used to discriminate
                      traffic flows.  The value of -1 is used to
                      indicate a wildcard, i.e. any value.
                     "
       SYNTAX         Integer32 (-1 | 0..1048575)"

Here, I have a little problem as follows:
How does flow label value represent -1?

Thanks.

***********************************************
信息安全声明：本邮件包含信息归ZTE所有，
ZTE对该邮件拥有所有权利。请接收者注意
保密，未经发件人书面许可，不得向任何第
三方组织和个人透露本邮件所含信息的全部
或部分。以上声明仅适用于工作邮件。
Information Security  Notice：
The information contained in this mail is
solely property of  ZTE Corporation. 
This mail communication is confidential.
Recipients named above are obligated to
maintain secrecy and are not permitted to
disclose the contents of this communication
to others.
***********************************************
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 30 Nov 2004 12:38:46 +0100

> How does flow label value represent -1?

The flow label in an IPv6 packet does not represent -1. The TC 
is called IPv6FlowLabelOrAny and the -1 stands for "any"; a special 
value which is used to indicate that any flow label value is matched 
in say a filter expression. If you want to represent a flow label 
alone, use the IPv6FlowLabel TC defined in the same RFC.

/js

-- 
Juergen Schoenwaelder		    International University Bremen
<http://www.eecs.iu-bremen.de/>	    P.O. Box 750 561, 28725 Bremen, Germany