Subject: RE: <draft-ietf-ipv6-2461bis-02.txt>

From: "Soliman, Hesham" <[email-masked]>
Date: Tue, 26 Apr 2005 17:44:06 -0400

Peter, Tatuya

Thanks for catching that. 

Comments below

 > > On page 59, 7.2.5 is written:
 > -> 
 > > If the Neighbor Cache entry is not in INCOMPLETE state, 
 > the receiving
 > >    node performs the following steps:
 > 
 > >     - It records the link-layer address in the Neighbor 
 > Cache entry.
 > 
 > >     - If the advertisement's Solicited flag is set, the 
 > state of the
 > >       entry is set to REACHABLE, otherwise it is set to STALE.
 > 
 > >     - It sets the IsRouter flag in the cache entry based 
 > on the Router
 > >       flag in the received advertisement.
 > 
 > >     - It sends any packets queued for the neighbor awaiting address
 > >       resolution.
 > > <-
 > > In version 1 of the draft the same paragraph was applied to state
 > > INCOMPLETE.
 > > The whole paragraph can nor refer to state not INCOMPLETE, 
 > as in such a
 > > state
 > > There should be no queued packets.
 > 
 > I think you're correct.  This (the "not") should be a misspelling.
 > 
 > I don't know the background of this change, even if we removed the
 > "not"...  The corresponding part of RFC2461 is:
 > 
 > =============================================================
 > ==========
 >    If the target's Neighbor Cache entry is in the INCOMPLETE 
 > state when
 >    the advertisement is received, one of two things happens.  If the
 >    link layer has addresses and no Target Link-Layer address 
 > option is
 >    included, the receiving node SHOULD silently discard the received
 >    advertisement.  Otherwise, the receiving node performs 
 > the following
 >    steps:
 > 
 >     - It records the link-layer address in the Neighbor Cache entry.
 > 
 >     - If the advertisement's Solicited flag is set, the state of the
 >       entry is set to REACHABLE, otherwise it is set to STALE.
 > 
 >     - It sets the IsRouter flag in the cache entry based on 
 > the Router
 >       flag in the received advertisement.
 > 
 >     - It sends any packets queued for the neighbor awaiting address
 >       resolution.
 > 
 >    Note that the Override flag is ignored if the entry is in the
 >    INCOMPLETE state.
 > =============================================================
 > ==========
 > 
 > and this part of 2461bis now reads:
 > 
 > =============================================================
 > ==========
 >    In any state, if the link layer has addresses and an unsolicited
 >    Neighbor Advertisement is received with the O flag 
 > cleared, with no
 >    Target Link-Layer address option included, the receiving 
 > node SHOULD
 >    silently discard the received advertisement.
 > 
 >    If the target's Neighbor Cache entry is in the INCOMPLETE 
 > state when
 >    the advertisement is received, one of two things happen: If the
 >    advertisement were solicited, the state is changed to REACHABLE.
 >    Otherwise, the state is set to STALE. Note that the 
 > Override flag is
 >    ignored if the entry is in the
 >    INCOMPLETE state.
 > 
 >    If the Neighbor Cache entry is not in INCOMPLETE state, 
 > the receiving
 >    node performs the following steps:
 > 
 >     - It records the link-layer address in the Neighbor Cache entry.
 > 
 >     - If the advertisement's Solicited flag is set, the state of the
 >       entry is set to REACHABLE, otherwise it is set to STALE.
 > 
 >     - It sets the IsRouter flag in the cache entry based on 
 > the Router
 >       flag in the received advertisement.
 > 
 >     - It sends any packets queued for the neighbor awaiting address
 >       resolution.
 > =============================================================
 > ==========
 > 
 > I suspect the first paragraph (new in 2461bis) tried to catch
 > something, but the entire result does not seem to implement the
 > intent...

=> RFC 2461 was unclear about the "two things" that it referred to. I believe it was 
your comment to change this paragraph that resulted in the change. I think the 
"not" was a typo and should be removed. Do you see any other errors in the current
logic compared to 2461?

Hesham

 > 
 > 					JINMEI, Tatuya
 > 					Communication Platform Lab.
 > 					Corporate R&D Center, 
 > Toshiba Corp.
 > 					[email-masked]
 > 
 > --------------------------------------------------------------------
 > IETF IPv6 working group mailing list
 > [email-masked]
 > Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
 > --------------------------------------------------------------------
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: JINMEI Tatuya / 神明達哉<[email-masked]>
Date: Wed, 27 Apr 2005 17:11:31 +0900

>>>>> On Tue, 26 Apr 2005 17:44:06 -0400, 
>>>>> "Soliman, Hesham" <[email-masked]> said:

> your comment to change this paragraph that resulted in the change.

I guess you mean comment #12 of this post:
http://www1.ietf.org/mail-archive/web/ipv6/current/msg04369.html

If so, it was specifically for the 01 version of 2461bis document, not
for the original RFC2461.

Here is a copy of 2461bis-01 in question:

=======================================================================
   If the target's Neighbor Cache entry is in the INCOMPLETE state when
   the advertisement is received, one of two things happens.
   Otherwise, the receiving node performs the following
   steps:

    - It records the link-layer address in the Neighbor Cache entry.
    [...]
=======================================================================

And this is the corresponding part in RFC2461:

=======================================================================
   If the target's Neighbor Cache entry is in the INCOMPLETE state when
   the advertisement is received, one of two things happens.  If the
   link layer has addresses and no Target Link-Layer address option is
   included, the receiving node SHOULD silently discard the received
   advertisement.  Otherwise, the receiving node performs the following
   steps:

    - It records the link-layer address in the Neighbor Cache entry.
    [...]
=======================================================================

In the latter, the meaning of the "two things" is pretty clear:

1. If the link layer has addresses....
2. Otherwise, ...
     - It records...
     - ...

On the other hand, above item 1 was removed in rfc2461bis-01, which
made the "two things" unclear.  Am I now clear enough?

One may still think the original text in RFC2461 is not 100% clear
about the "two things" and want to see clarification.  If so, I don't
oppose to that action per se, but  personally I'm just fine with the
original text (in RFC2461).

> I think the 

It depends on the resolution of the more fundamental point above.
Let's make a consensus on this first.

					JINMEI, Tatuya
					Communication Platform Lab.
					Corporate R&D Center, Toshiba Corp.
					[email-masked]