Subject: DAD

From: giuseppe <[email-masked]>
Date: Tue, 17 May 2005 14:48:23 +0900

In IPv6 stateless address autoconfiguration, how is it possible that the 
generated address could be duplicated?
The MAC that host appends to the link prefix is unique, isn't it?
Replies appreciated
G

-- 
----------------------
----------------------
Giuseppe De Marco, Ph.D.

Dipartimento di Ingegneria 
dell'Informazione e Ingegneria Elettrica
DIIIE, University of Salerno
via ponte don Melillo 1, Fisciano, Salerno
tel: +39 089 964012
email: [email-masked]

Department of Information and 
Communication Engineering 
Faculty of Information Engineering 
Fukuoka Institute of Technology (FIT)
3-30-1 Wajiro-Higashi, Higashi-ku, Fukuoka 811-0295 
Japan
email: [email-masked]
--------------------

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Mark Smith <[email-masked]>
Date: Tue, 17 May 2005 15:28:52 +0930

On Tue, 17 May 2005 14:48:23 +0900

> The MAC that host appends to the link prefix is unique, isn't it?

Not necessarily, a mistake could have been made during manufacturer
assignment of serial numbers, or a net admin could make a mistake if
they choose to use locally assigned MAC addresses. A few examples of
this happening were raised on this ML a while back, the thread can be
accessed here :

http://www.mail-archive.com/[email-masked]/msg12198.html

Regards,
Mark.