Subject: IANA considerations in rfc2461bis

From: Elwyn Davies <[email-masked]>
Date: Fri, 12 Aug 2005 17:49:37 +0100

Hi.

Having done a consistency check across all the ICMP updates, I believe 
that the IANA considerations of this draft need an overhaul.

In particular:
- the master policies for types are (or will be) defined in the RFC that 
comes from draft-ipngwg-icmp-v3 instead of RFC2780.
- this document needs to define/continue the registry and explicitly 
define the policy for the Neighbour Discovery options (since this hasn't 
previously been properly defined).
- it should probably explicitly define the ICMP types and ND options 
which are being continued from RFC2461 as they don't have an explicit 
registration in RFC2461.

Regards,
Elwyn

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www1.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Soliman, Hesham" <[email-masked]>
Date: Fri, 12 Aug 2005 13:27:04 -0400

> >=> I'm not sure I understand what you mean here. What do you
 > >mean by "don't have an explicit registration in RFC2461."?
 > >  
 > >
 > The IANA considerations section in RFC2461 was very skimpy 
 > and didn't 
 > explicitly say what new ICMPv6 message types were being 
 > added or what 
 > the set of ND options being defined were.  It would be 
 > useful to have 
 > the list in the update as the set of registrations that are being 
 > 'continued'.

=> Is this basically a summary of what's already in the document
in several sections? 

 > I assume from your comment above that there is a new version 
 > in the offing!

=> Yes, just for this comment, so I want to make sure I understand
exactly what we're required to do. 

thx,
Hesham

 > >Hesham
 > > > Administrative Requests: 
 > https://www1.ietf.org/mailman/listinfo/ipv6
 > > > 
 > >===========================================================
 > >This email may contain confidential and privileged material 
 > for the sole use
 > > of the intended recipient.  Any review or distribution by 
 > others is strictly
 > > prohibited.  If you are not the intended recipient please 
 > contact the sender
 > > and delete all copies.
 > >===========================================================
 > >
 > >  
 > >
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================