Subject: Re: RFC3484 destination address selection rule 2 is buggy

From: Gabi Nakibly <[email-masked]>
Date: Tue, 18 Mar 2008 07:08:45 -0700 (PDT)

I certainly agree that the benefit of the simplicity of this rule is very desirable. However, this rule may be too restrictive. I am worried that there might be cases where it is desirable to send a packet to a (on-link) global address using a link-local address or ULA. Straight off the top of my head, I can think of a solicited RA. This message must use as a source address the router's link-local address and as a destination address the address of the node that sent the RS, that may very well be global.

----- Original Message ----
From: Fred Baker <[email-masked]>
To: Gabi Nakibly <[email-masked]>
Cc: Pekka Savola <[email-masked]>; [email-masked]; Iljitsch van Beijnum <[email-masked]>
Sent: Tuesday, March 18, 2008 2:33:15 PM
Subject: Re: RFC3484 destination address selection rule 2 is buggy

On Mar 18, 2008, at 5:10 AM, Gabi Nakibly wrote:

> Determining whether the destination address is in the zone of a  
> source address can be tricky. However, it is fairly easy in the  
> common case where the source address is link-local and the  
> destination address is global. If the latter is not on-link, than  
> it is not in the zone of the link-local source address and this  
> source address should not be included in the candidate set. If the  
> above rule will be applied in the scenario of http://tools.ietf.org/ 
> html/draft-ietf-v6ops-v6onbydefault-03, the candidate set of the v6  
> address will be empty and therefore it will be avoided by  
> destination address selection rule 1.

Speaking for myself, there is a simpler rule in that special case  
that imght be instructive in the ULA case.

There is no sense in using a link-local address as a source address  
unless one is sending to someone on the same LAN. Hence, there is no  
sense in suing a link-local address as the source if one cannot also  
use one in the destination.

Similarly, there is no sense using a ULA source address unless the  
destination is in the same ULA. If the destination is a global  
address it might or might not be able to reply, but the sender can't  
tell.

Hence, in sender address choice:
  - use a link-local source address if and only if the destination  
is a link-local address
  - use a ULA source address if and only if the destination is a ULA  
in the same prefix
  - otherwise, use a global address

      ____________________________________________________________________________________
Be a better friend, newshound, and 
know-it-all with Yahoo! Mobile.  Try it now.  http://mobile.yahoo.com/;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ 
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Sebastien Roy <[email-masked]>
Date: Tue, 18 Mar 2008 10:24:42 -0400

Gabi Nakibly wrote:
> I certainly agree that the benefit of the simplicity of this rule is 
> very desirable. However, this rule may be too restrictive. I am worried 
> that there might be cases where it is desirable to send a packet to a 
> (on-link) global address using a link-local address or ULA. Straight off 
> the top of my head, I can think of a solicited RA. This message must 
> use as a source address the router's link-local address and as a 
> destination address the address of the node that sent the RS, that may 
> very well be global.

In that particular case, the source address selection algorithm isn't 
applicable.  There are a number of such cases where RFCs specify a 
specific source address to use for specific packets (echo replies are 
another example), and where source address selection doesn't occur.  Your 
general concern is valid, though.

-Seb