Subject: [Ipoverib] IPoIB TC MIB

From: "Hal Rosenstock" <[email-masked]>
Date: Mon, 19 Dec 2005 16:33:47 -0500

Hi,

In draft-ietf-ipoib-ibmib-tc-mib-07.txt, there is ibPartitionKey as follows:

IbPartitionKey ::= TEXTUAL-CONVENTION
    DISPLAY-HINT "x"
    STATUS      current
    DESCRIPTION
       "The 16-bit Partition Key."
    SYNTAX Unsigned32 (0..65535)How about an ibPartition with a definition something like the following:IbPartition ::= TEXTUAL-CONVENTION
    DISPLAY-HINT "x"
    STATUS      current
    DESCRIPTION
       "The 15-bit Partition Key Base without the membership bit."
    SYNTAX Unsigned32 (0..32767)-- Hal

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: "David M. Brean" <[email-masked]>
Date: Tue, 20 Dec 2005 04:09:48 -0500

Hello,

Hal Rosenstock wrote:

>    SYNTAX Unsigned32 (0..65535)
>
>How about an ibPartition with a definition something like the following:
>
>IbPartition ::= TEXTUAL-CONVENTION
>    DISPLAY-HINT "x"
>    STATUS      current
>    DESCRIPTION
>    SYNTAX Unsigned32 (0..32767)
>

A partition has full and limited members where all 16-bits define the 
partition.  In fact, text says "A collection of endnodes with the same 
P_Key in their P_Key Tables are referred to as being members of a 
partition, or in a partition. A P_Key Table can specify one of two types 
of partition membership: Limited or Full."  So, I think that you should 
choose a different name, if this is needed.  Also, how do you propose to 
use this new definition?

By the way, a nit: the MIB also defines the "IbSmPortList".  Can it be 
called "IbSmaPortList" or "IbPortList"?  It's used in the SMA MIB.

-David

> 
>
>-- Hal
>
>------------------------------------------------------------------------
>

---

From: "Hal Rosenstock" <[email-masked]>
Date: Tue, 20 Dec 2005 06:33:05 -0500

Hi David,

Are you referring to the IBA definition of partition ? Then my quibble is with this. If full and limited members are in the same partition, it seems there are 2 PKeys for the partition (and look at the valuie range for ibPartitionKey) so my comment is then as follows:

While ibPartition is a 16 bit value, it is filled with the low 15 bits of the PKey with the high bit being zero. That is not clear (and that is how I think it needs to be used).

I want a partition based table (with full and limited members) not separate ones (for full and limited members).

-- Hal
  ----- Original Message ----- 
  From: David M. Brean 
  To: Hal Rosenstock 
  Cc: IPoverIB 
  Sent: Tuesday, December 20, 2005 4:09 AM
  Subject: Re: [Ipoverib] IPoIB TC MIB

  Hello,

  Hal Rosenstock wrote:

    Hi,

  A partition has full and limited members where all 16-bits define the partition.  In fact, text says "A collection of endnodes with the same P_Key in their P_Key Tables are referred to as being members of a partition, or in a partition. A P_Key Table can specify one of two types of partition membership: Limited or Full."  So, I think that you should choose a different name, if this is needed.  Also, how do you propose to use this new definition?

  By the way, a nit: the MIB also defines the "IbSmPortList".  Can it be called "IbSmaPortList" or "IbPortList"?  It's used in the SMA MIB.

  -David

 -- Hal----------------------------------------------------------------------------
_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: "David M. Brean" <[email-masked]>
Date: Tue, 20 Dec 2005 11:08:12 -0500

Hal Rosenstock wrote:

> Hi David,
>  
> Are you referring to the IBA definition of partition ?

Yes.

> Then my quibble is with this. If full and limited members are in the 
> same partition, it seems there are 2 PKeys for the partition (and look 
> at the valuie range for ibPartitionKey) so my comment is then as follows:
>  

Yes, there are two different 16-bit P_Keys that can be used by ports 
communicating in the same partition.

> While ibPartition is a 16 bit value, it is filled with the low 15 bits 
> of the PKey with the high bit being zero. That is not clear (and that 
> is how I think it needs to be used).
>  

> I want a partition based table (with full and limited members) not 
> separate ones (for full and limited members).
>  

In general, I'd prefer to have the membership bit exposed since it 
impacts the communication capabilities of a port in a partition.  Also, 
I'm not sure what you mean by "not separate ones" because a P_Key table 
can store P_Keys with both full and limited membership.

-David

>     *From:* David M. Brean <mailto:[email-masked]>
>     *To:* Hal Rosenstock <mailto:[email-masked]>
>     *Cc:* IPoverIB <mailto:[email-masked]>
>     *Sent:* Tuesday, December 20, 2005 4:09 AM
>     *Subject:* Re: [Ipoverib] IPoIB TC MIB
>
>     Hello,
>
>     Hal Rosenstock wrote:
>
>>     Hi,
>>      
>     A partition has full and limited members where all 16-bits define
>     the partition.  In fact, text says "A collection of endnodes with
>     the same P_Key in their P_Key Tables are referred to as being
>     members of a partition, or in a partition. A P_Key Table can
>     specify one of two types of partition membership: Limited or
>     Full."  So, I think that you should choose a different name, if
>     this is needed.  Also, how do you propose to use this new definition?
>
>     By the way, a nit: the MIB also defines the "IbSmPortList".  Can
>     it be called "IbSmaPortList" or "IbPortList"?  It's used in the
>     SMA MIB.
>
>     -David
>
>> 
>>
>>-- Hal
>>

---

From: "Hal Rosenstock" <[email-masked]>
Date: Tue, 20 Dec 2005 11:26:23 -0500

Hi David,

See <hnr>...</hnr> comments embedded below.

-- Hal
  ----- Original Message ----- 
  From: David M. Brean 
  To: Hal Rosenstock 
  Cc: IPoverIB 
  Sent: Tuesday, December 20, 2005 11:08 AM
  Subject: Re: [Ipoverib] IPoIB TC MIB

  Hal Rosenstock wrote:

    Hi David,

  Yes.

    Then my quibble is with this. If full and limited members are in the same partition, it seems there are 2 PKeys for the partition (and look at the valuie range for ibPartitionKey) so my comment is then as follows:

  Yes, there are two different 16-bit P_Keys that can be used by ports communicating in the same partition.

  <hnr> Understood. </hnr>

  In general, I'd prefer to have the membership bit exposed since it impacts the communication capabilities of a port in a partition.  Also, I'm not sure what you mean by "not separate ones" because a P_Key table can store P_Keys with both full and limited membership.

  <hnr> Yes, the membership is exposed but in a different way. As to separate, I'm referring to the use of ibPartitionKey in the SM MIB in the partition table. Maybe I'm wrong but partition key is different from partition. It seems that there is some redundancy in that table if indeed the ibPartitionKey is the full 16 bits. </hnr>

  -David

    -- Hal
      ----- Original Message ----- 
      From: David M. Brean 
      To: Hal Rosenstock 
      Cc: IPoverIB 
      Sent: Tuesday, December 20, 2005 4:09 AM
      Subject: Re: [Ipoverib] IPoIB TC MIB

      Hello,

      Hal Rosenstock wrote:

        Hi,

      -David

 -- Hal------------------------------------------------------------------------
_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib