Subject: Has SRP been approved as a standard?

From: "Diao Peiyong" <[email-masked]>
Date: Fri, 25 May 2001 09:48:51 +0800

Dear Sir,

I work for a Cisco partner & now my customer
asks me a question: is DPT a standard approved
by IETF or IEEE?

I searched on the Internet but got no answer, so
I think you might be the right person to ask.

Your reply will be highly appreciated.

Thanks,
Peiyong

---

From: "A.Herrera" <[email-masked]>
Date: Fri, 25 May 2001 00:21:24 -0400

The IEEE formed a new working group called 802.17 RPRWG to
define a new MAC for Resilient Packet Rings (RPR). DPT is one 
of the approaches tabled and under consideration within this new WG.
Ref: http://www.ieee802.org/rprsg/index.html 

The IETF approved formation of a new WG called IP over RPR
to produce a Framework document that will articulate L2/L3
interaction and requirements between IP and 802.17.
Ref: http://www.ietf.org/html.charters/iporpr-charter.html

Albert

---- Original Message ----- 
  From: Diao Peiyong 
  To: [email-masked] 
  Sent: Thursday, May 24, 2001 9:48 PM
  Subject: Has SRP been approved as a standard?

  Dear Sir,

  Thanks,
  Peiyong

---

From: RJ Atkinson <[email-masked]>
Date: Fri, 25 May 2001 08:19:23 -0400

Hi,

	While Albert is being precise, kindly permit me 
to add crystal clarity:

	Cisco's SRP/DPT is NOT an approved standard by anyone.
Not by IEEE and not by IETF.  

	There are multiple competing technology proposals that
have been sumitteed to IEEE 802.17, with no clear leading proposal 
within 802.17 at this time.  Cisco attempted to get IETF 
to standardise DPT/SRP, but the IETF explicitly decided NOT
to do that.  Instead, IETF referred the topic to IEEE as this 
sort of Layer-2 MAC protocol standard is within the scope of 
IEEE 802, and is outside the scope of IETF.  SRP/DPT is only
one of several proposals to IEEE 802.17.

	More information on 802.17 can be obtained from
http://www.ieee802.org and more information on the IETF
RPR WG (which will work on IP over 802.17, to the extent
any work is needed) is at http://www.ietf.org.

	There are a range of timeframes in which folks believe
that 802.17 might actually produce a fully approved standard.
The shortest that I have heard so far is 2 years from now --
and 3-4 years would be more typical for an IEEE 802 standard.
It seems impossible that 802.17 would approve any completed
standard this year.  Your mileage might vary.

Cheers,

Ran
[email-masked]

---

From: "A.Herrera" <[email-masked]>
Date: Fri, 25 May 2001 11:18:57 -0400

Thanks Ran for the expanded clarity. Much appreciated.

Albert

---

From: "Diao Peiyong" <[email-masked]>
Date: Sat, 26 May 2001 10:14:12 +0800

Dear All,

Thanks for your answers, it's very useful &
I do appreciate it.

Thanks,
Peiyong

----- Original Message ----- 
From: "Mike Takefman" <[email-masked]>
To: "Diao Peiyong" <[email-masked]>
Sent: Friday, May 25, 2001 11:44 AM
Subject: Re: Has SRP been approved as a standard?

> Dear Peiyong, 
> 
> I regret to inform you that DPT is not yet a
> standard in either body. I am the chair of 
> IEEE 802.17 and we are at the early stages of
> defining the standard. Cisco has submitted SRP
> to 802.17 for consideration. As to how close
> the 802.17 standard is to SRP will be seen
> in the future.
> 
> An IETF information RFC (RFC 2892) is available
> but does not imply any sort of standardization.
> 
> I hope that helps, if you have any other questions
> please do not hesitate to ask.
> 
> cheers, 
> 
> mike
> 
> > Diao Peiyong wrote:
> > 
> > Dear Sir,
> > 
> -- 
> Michael Takefman              [email-masked]
> Manager HW Engineering,       Cisco Systems
> Chair IEEE 802.17 Stds WG
> 2000 Innovation Dr, Ottawa, Canada, K2K 3E8
> voice: 613-271-3399       fax: 613-271-4867
>