Subject: IPORPR Presentation to IEEE 802.17WG

From: Albert Herrera <[email-masked]>
Date: Wed, 18 Jul 2001 11:55:02 -0400

I presented the Framework draft as input to 
last week's IEEE 802.17WG plenary. The
presentation can be accessed at:

http://grouper.ieee.org/groups/802/17/documents/presentations/jul2001/aph_ip
orpr_01.pdf

We presented three approaches of running 
IP over 802.17. The third approach which is
'Enhanced L2/l3 Interaction' got the most
questions as well as objections.

The concern was that 802.17 will be specifying
advanced features such as congestion control
and avoidance, bandwidth management, customer
separation, protection, etc. To the group, these 
seem to be a large overlap in functionality and
in fact might be difficult and complex to 
synchronize in the future compared to the other
first two approaches which simply treats the RPR 
ring as a multi-access or overlay structure.

I mentioned that IPORPR and 802.17WG might have to 
work closer the coming months to make sure that
any synchronization issues gets resolved the same
way we synchronize existing overlapping features
today such as protection mechanisms from L1,L2&L3.

If you have any comments along these lines, 
raise it on the list or at our next meeting in
August so we can openly discuss.

Albert Herrera
Co-Chair - IPORPR Working Group

---

From: RJ Atkinson <[email-masked]>
Date: Wed, 18 Jul 2001 13:27:39 -0400

At 11:55 18/07/01, Albert Herrera wrote:
>last week's IEEE 802.17WG plenary. 

Albert,

        As I said at the last IETF meeting, I think the current 
Framework draft is essentially misguided and isn't solving 
any real problem, whether technical or procedural.  I suppose
it probably does help bolster the authors' resumes.

>questions as well as objections.

I heartily agree with those objections.  This IETF WG ought NOT 
be modifying ANY IEEE or IETF protocols just for 802.17.  IP/802.17 
*ought* to just work without changing anything, just as FDDI did 
and as other LAN type media do and as POS does.

>today such as protection mechanisms from L1,L2&L3.

        I actually think that your continued attempts to use
IETF to leverage your personal views within 802.17 are
totally inappropriate.  The comments and feedback at the
last IETF meeting were really CLEAR that most folks in 
attendance did NOT agree with the drafts presented at that 
meeting and that most folks do NOT want IETF to be telling
IEEE how to design their 802.17 MAC protocol.

        I further object to you making presentations to IEEE
as if the content of those presentations were something
that had IETF WG consensus, when in fact such consensus 
does not exist in this WG.

Yours,

Ran
[email-masked]

---

From: "Kastenholz, Frank" <[email-masked]>
Date: Thu, 19 Jul 2001 08:08:54 -0400

Ran

First, if you have substantive comments, even broad ones,
on the document then please make them. Comments of
the form "it's misguided" are not useful. At the very
least, please tell the author's _how_ it is misguided
and broadly what direction you believe it should go.

Second, comments about possible hidden agendas that the
document's authors may or may not have are inappropriate
to a mailing list that in theory is for technical discussion.
They are even more inappropriate when coming from someone
who is on the IAB. 

If you have proof of your allegation, I'd like to see it.
If not, an apology is in order.

>and as other LAN type media do and as POS does.

This working group is not chartered to modify IETF protocols,
that is true. However, if the working group decides that some
modification is needed, or simply desireable, then the working
group should bring that issue forward, so that the appropriate
working group can deal with it. This is more-or-less just what
the document does. It describes three levels of IP-over-RPR,
the first one of which is "RPR is a big ethernet so nothing
significant need be done" while the last is "if these
changes/extensions to existing IETF protocols are made
then 'cool things' can be done". 

>IEEE how to design their 802.17 MAC protocol.

First, all but one of the drafts discussed at the last
IETF meeting were out-of-scope for the working group.
_That_ is what the working group disagreed with, the
chairs included. They all were directed to working groups
more appropriate to their topics (one discussed some
kind of fast recovery scheme, so was directed to CCAMP
as being more appropriate for their work). The working
group DID NOT disagree with working on the framework
draft, which is the document that seems to be giving you
no small amount of agita.

As to the "IETF telling the IEEE how to design their ...
protocol", the working group's charter is to 
        "produce a requirements and framework document 
        which will be used as input to the IEEE RPRSG 
        to help it formulate its requirements"
which is what the framework document is supposed to be
doing. If you do not believe it does that, then specific
comments are invited and encouraged. 

Frank Kastenholz
co-chair, IPRPR working group

---

From: RJ Atkinson <[email-masked]>
Date: Thu, 19 Jul 2001 17:08:25 -0400

>and broadly what direction you believe it should go.

        The document should delete most/all of the current text
and re-focus on (1) identifying what sorts SNMP MIB objects
will be needed and (2) how to approach actual framing for IP/802.17
(e.g. SNAP/LLC, EtherType, other).

>to a mailing list that in theory is for technical discussion.

        Agree.  Whether or not true, such comments are inappropriate.
For that, I apologise.

>the document does. 

        The issue is that the document has been presented to IEEE
by folks in positions of responsibility within this IETF WG
in a manner that led more than one attendee at 802.17 to
erroneously conclude that the document represents some form
of rough consensus here.

        I'd specifically ask that the document be edited with a 
tombstone at the beginning making it clear that "No IETF IPoRPR 
consensus is implied by the existence of this document as an I-D" 
or other words of Chair's choice to similar effect.

>It describes three levels of IP-over-RPR,

        Of those, only the "RPR is a typical LAN/MAN protocol,
so nothing significant need be done" is appropriate, IMHO.

>The working group DID NOT disagree with working on the 
>framework draft, which is the document that seems to be 
>giving you no small amount of agita.

        Not my claim.  Apologies for being unclear.

        My claim is that numerous folk in the IPoRPR WG
room participating in the WG gave negative feedback
to the Framework document authors, which feedback
seems to have been ignored so far.  An example is Peter
Lothberg standing up and saying that 802.17 was a LAN/MAN
protocol just like FDDI and should not have the extraneous
other gorp to make it hard to deploy in his large IP network.

>comments are invited and encouraged. 

        I am reliably told that the document has more than once been 
represented as IETF consensus or IETF input over in IEEE, when it has 
no clear IETF consensus behind it (at least not yet) and is instead 
(at least in past and at present) the personal views of its authors.  
This behaviour is badly broken.  If/when consensus were achieved, 
only then would it be appropriate to send the input over to IEEE, 
presumably as a formal liaison input.  Presumably, the presence of 
consensus behind the document would also mean that the document was 
ready to go out as some sort of RFC and usual procedures had been 
followed/completed.

Ran
[email-masked]

---

From: Pankaj K Jha <[email-masked]>
Date: Wed, 18 Jul 2001 14:22:01 -0700

Dear RJ:

While I fully agree with your other objections, I take exception to your
sentence that this (IPoRPR) is done to help bolster authors' resumes.

I for one (and I'm speaking on behalf of many others) can tell that I
don't need to bolster my resume. I don't even have a resume, and unless
things go sour I probably don't need a resume for some time to come.

Albert may not have meant it, but it did come out sounding as if IETF
was in agreement on all the work, and they had their support behind it.
I think
IPoRPR intentions are good - to see if there would be any changes or
enhancements required for upper layer. If it so turns out there are
none, then it's a great
news. If there are some extensions to OSPF/BGP needed for enhanced
performance (just like MPLS did) then it would make people start to
think now. However, at this stage I feel the IPoRPR should stop at just
that and let RPR evolve first.

For a packet-oriented approach such as RPR has, IETF'ers would hate to
see modifications needed to IP. Most of us understand that.I 'm not
supporting an approach for pushing IETF "proceedings" into RPR.

RJ, the very reason you even come to work, participate in any
committees, publish any papers is that it helps you personally (even
when it helps the company it indirectly helps you, either by earning a
paycheck or fame/shame, or both). These are pretty obvious to any mature
person. This applies to all of us, including you. If this were not the
case, you would be at the beaches of Bahamas, relaxing on your own, and
you wouldn't worry about anything else. People who sit in IETF, or ISOC,
or such committees also chase the same goals that others do. No use
pretending otherwise.

There are a whole bunch of people hanging around IETF for a long time,
participating endlessly in useless discussions on real low-tech mailing
threads  just to show that they are still alive as networking engineers,
and are active IETF'ers. What do you think they do it for?

The IPoRPR was started with a clean objective; there may be flaws in it,
and we need to fix it or shut it down. Not by going after people, but by
going after issues.

I'd appreciate if you could refrain from making such statements in poor
taste in future.

Best regards,
Pankaj