Subject: RE: IPORPR Presentation to IEEE 802.17WG

From: Raj Sharma <[email-masked]>
Date: Wed, 18 Jul 2001 16:45:13 -0700

I am reposting my original email to the general reflector that
sent a month ago to Albert and the other authors who started 
reviewing the framework document.

I think the IPORPR WG is very speculative and premature
at this stage. My suggestion below was to reduce the 
document to a one page document - in essence it makes
sense NOT to have such a draft since what is leftover
is of little or no value to anyone. 

raj

-----Original Message-----
From: Raj Sharma [mailto:[email-masked]]
Sent: Monday, June 18, 2001 5:22 PM
To: 'A.Herrera'; Khaled Amer; Pankaj Jha; Russ White; Raj Sharma
Cc: Frank Kastenholz; Sanjay Agrawal; Vinay Bannai; Jason Fan
Subject: RE: Revised iporpr framework (2)

I feel the that IPORPR framework document is premature
at this point in time. 

I suggest the following modifications to the draft.

Section 1. Introduction

CHANGE FROM
"The primary goal of IETFs IPORPR WG is to articulate a set of 
features that integrates the RPR MAC functions as defined by the 
802.17 RPRWG with network layer routing."

TO
"The primary goal of IETF's IPORPR WG is to describe how the IP
network layer expects to interacts with the RPR MAC."

DELETE section 1.2 - this is misleading the IETF community
on the nature of general consensus within 802.17 WG. Further,
consensus is still evolving and that will make this more
like the Sunday newspaper.

Section 2. IPORPR Objectives

DELETE this section - this should be a part of the charter
of the IPORPR WG. This is only justifying the existence of 
IPORPR

[I am really getting concerned about the words "set of features
and functionality" defined by IP in IPORPR.  Are you saying
that are features and functions that do not exist in IP that
need to be defined by IPORPR? Or do you mean that folks involved
in 802.17 are IP illiterate that they you need to spell it 
out to them which feature in IP they need to tweak 802.17
for?]

I am intrigued at that fact that fundamental IP layer interaction
with Layer 2 issues like ARP, RARP and multicast issues have not 
been addressed here

BTW, there is an internet draft by Phil Karn et al on 
"Advice for Internet Subnetwork Designers"
draft-ietf-pilc-link-design-05.txt that I recommend be read
before we embark upon this by using it as a frame of reference]

Section 3. Motivation for IPORPR

DELETE this section - this should also be a part of the charter
of the IPORPR WG. Once again it only justifies the existence
of IPORPR.

[look, if you want the IP layer to pick direction during working
and protected mode, be my guest. All you need to do is to stand
up in front of 200 people of the 802.17 WG and ask for such a motion.
Couching this in an IETF draft wont get you there]

Section 4 Requirements for 802.17

DELETE entire section. If needed, substituted the following
words only

"The primary requirements set forward by IPORPR is that the IEEE 802.17
WG MUST require NO CHANGE in IP for IP to use 802.17 as a link layer
protocol"

If the following changes are not suitable to you then I suggest you drop
my name as a contributor. 

I will take the liberty of posting this document to the 802.17 reflector 
and present my comments and solicit feedback on these issues if you wish.
Please let me know if you wish to do this?

Raj Sharma

-----Original Message-----
From: A.Herrera [mailto:[email-masked]]
Sent: Saturday, June 09, 2001 4:46 AM
To: Khaled Amer; Pankaj Jha; Russ White; Raj Sharma
Cc: Frank Kastenholz
Subject: Re: Revised iporpr framework (2)

Modified draft-ietf-iporpr-framework-01.txt
after initial feedback. Will wait for more feedback
until the end of next week before we release to
the list.

Thanks,
Albert 

-----Original Message-----
From: Albert Herrera [mailto:[email-masked]]
Sent: Wednesday, July 18, 2001 11:32 AM
To: 'RJ Atkinson'
Cc: [email-masked]
Subject: RE: IPORPR Presentation to IEEE 802.17WG 

Ran,

You're right. I should step aside and get back
to chairing. So I'll let others that share an 
opposite viewpoint have their opinions be heard.

Albert

> -----Original Message-----
> From: RJ Atkinson [mailto:[email-masked]]
> Sent: Wednesday, July 18, 2001 2:11 PM
> To: Albert Herrera
> Cc: [email-masked]
> Subject: RE: IPORPR Presentation to IEEE 802.17WG 
> 
> 
> At 14:01 18/07/01, Albert Herrera wrote:
> >However, if you look back at how we tried to do
> >IP after most ATM was done, you don't exactly
> >find a smooth integration. And maybe you're right,
> >maybe we shouldn't have made any changes to IP
> >to accommodate ATM. We're just trying to be
> >pro-active here and hopefully bypass any bumps 
> >as we had with ATM.
> 
> ATM is radically different than a LAN technology
> such as 802.17 is developing, so is a tremendously
> poor comparison point.  ATM had actual circuits
> and signalling and packet shredders and other gorp.
> Comparing with ATM is an approach with tremendous
> intellectual poverty.
> 
> in contrast, FDDI makes for a good comparison.  Neither 
> FDDI nor IP needed changes for the two technologies
> to work well together.  FDDI had dual-counter
> rotating rings and lots of Layer-2 capabilities
> (e.g. in SMT).
> 
> >As for presenting at IEEE, I presented the draft 
> >as NOT a final consensus but as a work-in-progress
> 
> Folks at IEEE 802.17 report that it came across as
> being an "IETF perspective", so your disclaimers
> need work for next time.  Also, the WG ought to
> have been given a chance to review the proposed
> presentation, given that it came across as an IETF
> position.
> 
> >I guess you'd rather someone design a pan for you to boil 
> >water on rather than suggesting that maybe you need a kettle
> >if it would serve them just as well.
> 
>         I'd rather have WG Chairs focus on chairing,
> instead of using their position to advance their
> personal views which are not supported by WG
> consensus.
> 
> >I believe we have very useful work here and the parallel
> >efforts can only benefit both IEEE and IETF in the long 
> >run.
> 
>         At the last meeting there was a lot of vocal disagreement
> with the sentence above.  I guess you didn't hear that part.
> The primary useful work proposed here so far has been 
> some joint work with 802.17 on an SNMP MIB, IMHO.
> 
> Ran
> [email-masked]
> 
>

---

From: Pankaj K Jha <[email-masked]>
Date: Wed, 18 Jul 2001 19:47:58 -0700

Raj:
As we'd discussed before, I agree with your approach. Since RPR has not taken
any shape and we don't know what it can and cannot do, doing a L3 counterpart
to it doesn't have much weight or purpose at this point of time. Let's wait
until things settle down in RPR before we decide whether L3 needs any work at
all. For this, further work on IPoRPR isn't of any value at present.

-Pankaj

---

From: Russ White <[email-masked]>
Date: Thu, 19 Jul 2001 11:26:52 -0400 (EDT)

There is _nothing_ here which proposes modifying IP to work over
RPR. There are things here which propose to _add to_ RPR to
provide capabilities that IP layer protocols _may_ take advantage
of, but this isn't restrictive, merely supplemental.

It may not be time to work on what these extensions might be, but
it is certainly the right time to propose extensions to RPR so
future interactios might be possible. Beyond this, any and all
L3 extensions which would take advantage of these L2 extensions
would be well out of the scope of this working group.

Please quote the section of the framework doc which proposes
modifying anything in any L3 protocol.

:-)

Russ

> > > some joint work with 802.17 on an SNMP MIB, IMHO.

_____________________________
[email-masked] <>< Grace Alone