Subject: [IPORPR] Our proposed new charter

From: "Kastenholz, Frank" <[email-masked]>
Date: Thu, 04 Oct 2001 09:38:27 -0400

Hi folks

Over a week ago we sent out a proposal for
a new charter. There has not been a lot
of discussion nor have there been many
comments on it.

Does this mean that everyone has read it
and is extremely happy with it and that
Albert and I should go ahead and submit 
it to the IESG?

Frank Kastenholz
co-chair, IPoRPR

_______________________________________________
IPORPR mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/iporpr

---

From: "Glenn Parsons" <[email-masked]>
Date: Thu, 4 Oct 2001 15:34:53 -0400

Frank,

Since no one has spoken up, I will say something (reminds me of the London
meeting :-)

Generally, I think the revision is good.  As I mentioned in the London
meeting, option 1 will likely be the choice made by most.  Certainly, the
other options will require more time to understand the complexities and
perhaps detail them.  So it makes sense to separate them into different
documents.  Further, I am happy to see alignment with the 802.17 milestones.
There is no point second-guessing what 802.17 might specify -- we have to
wait for their stable output before discussing the details of IPoRPR.

That said, I do have a couple of comments:
	 - I gather from the discussion at the meeting and the lack of a
milestone that the IPoRPR Framework will not be published as an RFC and that
it is merely an Internet Draft  placeholder for the issues.  I would suggest
that this is made a little clearer in the charter.
	- I object to the seemingly judgmental terms 'basic' and 'advanced'
for the two protocol documents.  I think 'core' and 'extended' would be more
appropriate ... or even just first and second.
	- I had thought based on London, that we would propose a MIB
document for this group.  The charter now encourages WG members to input
into the 802.17 MIB.  While I agree with this, it raises a bigger and more
fundamental question -- so let me play the devil's advocate.  If we
encourage the MIB work to be rolled into the 802.17 spec, why don't we do
the same thing for the use of IP on RPR?

Cheers,
Glenn.

> ----------
> From: 	Kastenholz, Frank
> Sent: 	Thursday, October 4, 2001 9:38 AM
> To: 	[email-masked]
> Subject: 	[IPORPR] Our proposed new charter
> 
> 
> Hi folks
>

---

From: "Kastenholz, Frank" <[email-masked]>
Date: Thu, 04 Oct 2001 19:06:00 -0400

Wow, someone is reading my email!
:-)

At 03:34 PM 10/4/01 -0400, Glenn Parsons wrote:
> - I gather from the discussion at the meeting and the lack of a milestone that the IPoRPR Framework will not be published as an RFC and that it is merely an Internet Draft  placeholder for the issues.  I would suggest that this is made a little clearer in the charter.
We probably will put it forward as an
RFC sometime ... don't know exactly when.
The idea is to keep it open as an ID
so that it can be easily updated as 
revisions are desired.  These revisions
might be in response to something 802
does, they might be something we think
of, or maybe because it's thursday...
>- I object to the seemingly judgmental terms 'basic' and 'advanced' for the two protocol documents.  I think 'core' and 'extended' would be more appropriate ... or even just first and second.
No judgement was meant. 
Will change to Core/Extended.

>- I had thought based on London, that we would propose a MIB document for this group.  The charter now encourages WG members to input into the 802.17 MIB.  While I agree with this, it raises a bigger and more fundamental question -- so let me play the devil's advocate.  If we encourage the MIB work to be rolled into the 802.17 spec, why don't we do the same thing for the use of IP on RPR?
The MIB is an "interesting issue".
There are two basic options here
- We do a MIB
- 802 does a MIB

The argument for us doing the MIB is that the IETF has the SNMP/
SMI/... expertise so whatever we produce is almost guaranteed
by definition to be "right" with regard to those issues. Of course,
what the IETF does _not_ have is 802.17 technical knowledge, so
while the MIB might pass all the SMI tests, it might not actually
be good for anything.  So the avenue that we're pursuing is to
- have 802.17 do all the MIB work
- we encourage IETF-ers, especially those with MIB/SMI
  experience, to participate in the 802 work. They can
  then exert any needed corrective influences.
- Bert Wijnen, one of our ADs, is looking for a sharp
  MIB-person who can be convinced to go join the 802.17
  work in the spirit of the previous bullet item.
- Albert and I will try to arrange some informal
  reviews by us of the IEEE MIB when the time is right.
As you might have guessed, thisis all quite informal. 
Since it's informal, we really can't put it into the
charter. If we try to formalize things then there is a 
whole big IESG/IAB morass that is best avoided. 
If these methods fail, there are other avenues that
we can go down, but it's best to hold them as a
strategic reserve...

A secondary issue that has been raised is availability of the 
actual MIB document.  This should not be all that big a deal
since 802 specs are now available online for $0.00. 

So, if you are interested in seeing a good MIB
come out of 802.17, I suggest you join their
group (see http://www.ieee802.org/17/ for info)

Frank Kastenholz
Co-Chair, IPoRPR

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 7 Oct 2001 19:15:42 +0200

Hi,

My 2 cents on the MIB issue, based upon my experience with the Ethernet
MIBs. 

The approach that is proposed below has chances to work if the IEEE
802.17 WG agrees to include an SNMP MIB in its list of deliverables. I
emphasize SNMP MIB, because other IEEE 802 WGs - like 802.3 (Ethernet)
chose in the past to write 'protocol independent' MIBs - which were
defining the structure and behavior of the management objects, and allow
for 'protocol specific' MIBs (SNMP, CMIP!) to be defined by other
organizations.

Regards,

Dan

> document for this group.  The charter now encourages WG 
> members to input into the 802.17 MIB.  While I agree with 
> this, it raises a bigger and more fundamental question -- so 
> let me play the devil's advocate.  If we encourage the MIB 
> work to be rolled into the 802.17 spec, why don't we do the 
> same thing for the use of IP on RPR?

---

From: "Kastenholz, Frank" <[email-masked]>
Date: Tue, 09 Oct 2001 10:29:51 -0400

At 07:15 PM 10/7/01 +0200, Romascanu, Dan (Dan) wrote:
>802.17 WG agrees to include an SNMP MIB in its list of deliverables.

We, the IETF's IPoRPR working group, can not tell the IEEE 802.17
group what to do, of course. Hence the strong encouragement for
individual IPoRPR participants with specific interests to take 
part in the 802.17 working group... (hint, hint, :-)

>I

If that happens, we (the IETF IPoRPR group) should be able to 
quickly put together a SNMP/SMI/IETF-specific form of the MIB...
But we'd rather see the 802.17 group "do the right thing"

Frank Kastenholz
co-chair, IPoRPR