Subject: [IPORPR] SRP - Algorithm selector?

From: Stephen Egbert <[email-masked]>
Date: Wed, 3 Oct 2001 18:31:16 -0500

In my review of one of the RPR Access Protocol, SRP; I've been reviewing the
various SRP algorithms such as SRP-fa and other vendor's SRP-specific
algorithm.

Shouldn't we investigate the possibility of adding another
field/control-packet to inform neighbor nodes of which SRP algorithm is
being used?

Apparently, Cisco's SRP-fa certainly is the early entrant and predominate
leader so far.  There's words in other vendors' RPR presentations found in
RPRAlliance.Org and ieee802.org/17 websites touting better merits over
SRP-fa, but I'm more concern about fractional division within the RPR
market, particularly SRP algorithm.

I suggest we explore whether we should stay with one SRP algorithm or not,
and if not, whether we should provide for algorithm selection or informing
with neighbor nodes.

Steve Egbert
TippingPoint Technologies, Inc.

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 3 Oct 2001 17:53:49 -0700

I think all stations on the ring would have to 
implement the same "fairness" algorithm, or we 
won't be able to achieve fairness.  I don't have 
a formal proof for this, but that's how it 
appears to be, intuitively.  If vendor A and
vendor B implement different algorithms, and a 
provider uses their boxes on the same ring, 
exchanging this information will be not be of 
any use.  (Unless of course vendors implement 
multiple fairness algorithms and pick the appropriate 
one after negotiating this with other nodes on the 
ring.  But it doesn't seem likely that anyone
would want to do that.)

-Anoop

-----Original Message-----
From: Stephen Egbert [mailto:[email-masked]]
Sent: Wednesday, October 03, 2001 4:31 PM
To: [email-masked]'
Subject: [IPORPR] SRP - Algorithm selector?

_______________________________________________
IPORPR mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/iporpr

---

From: Leon Bruckman <[email-masked]>
Date: Thu, 4 Oct 2001 10:00:50 +0200

I agree with Anoop that all nodes in a ring should use the same fairness
algorithm, but my understanding is that Stephen means to have an indication
of which algorithm is to be used in a node to avoid nodes in the same ring
using different fairness algorithms without any warning or alarm.
My opinion is that since the 802.17 WG is still debating the fairness
algorithm issue, and it is still trying to come to a single solution, the
IPORPR should wait until it is clear if more than one fairness algorithm
will be standardized.

Leon

-----Original Message-----
From: Anoop Ghanwani [mailto:[email-masked]]
Sent: Thursday, October 04, 2001 2:54 AM
To: 'Stephen Egbert'; [email-masked]'
Subject: RE: [IPORPR] SRP - Algorithm selector?

-Anoop

---

From: Albert Herrera <[email-masked]>
Date: Thu, 4 Oct 2001 08:52:13 -0400

A single fairness algorithm would be best.
However, should any negotiations be required, 
it should be done by 802.17 and the information
relayed to L3 if necessary.

Albert 

> From: Leon Bruckman [mailto:[email-masked]]
> Sent: Thursday, October 04, 2001 4:01 AM
> To: [email-masked]'