Subject: [IPORPR] cisco srp doubts

From: "Raj Raman" <[email-masked]>
Date: Tue, 29 Jan 2002 11:31:29 -0800

Hi All,

I'm trying to understand Cisco's SRP implementation and I had a few doubts. 
I would really appreciate any clarifications.

- A node advertises it's my_usage which has been low pass filtered
[lp_my_usage - (LP_MU - 1) * lp_my_usage + my_sage / LP_MU].
Qn : I'm a little confused as to why this is done.

- Topology Discovery related :  ... If there is a wrap on the ring, the 
wrapped node will indicate a wrap when appending its mac binding and wrap 
the packet. When the topology packets travel on the wrapped ring, with the 
ring identifier being different from that of the topology packet itself, ...
Qn : The ring identifier refers to the R bit in the SRP header would refer 
to the wrapped ring id (say inner)in question. Right ?
If so, the macType.RingId in the last mac binding inserted by the wrapped 
node should be outer, but the Wrapped node is set to 1. Is my understanding 
correct ?

Qn : The way a node figures out if a particular topology message is a 
wrapped message is by inspecting the macType.wrappednode of the last mac 
binding. Is this correct ?

Thanks,

-- Raj

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp.

_______________________________________________
IPORPR mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iporpr

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 30 Jan 2002 12:23:22 -0800

> Qn : I'm a little confused as to why this is done.

You send "my_usage" because the way the algorithm works
is that you tell everyone else to limit the traffic
that they insert to what you were able to insert on 
the ring.  The low pass filter function is applied so
that the rate doesn't vary like a step function from 
one interval to the next.

> binding. Is this correct ?

I'm not sure I fully understand the question, but I'll answer
based on what I think you're asking.  The RingId in every 
packet identifies the ring that the packet was put on
by the originating node.  If the packet is received at
a node, and the RingId does not match the ring that 
it was received on, then the node knows that this is a
packet that was "wrapped" at some point.

By the way, this list is for discussion of IP over RPR
issues.  For RPR-only issues such as these, the right 
place to post questions would be the IEEE 802.17 mailing 
list.  You can get information about this at: 
http://www.ieee802.org/17.

-Anoop