Subject: [IPORPR] Layering of L3 interfaces on RPR mac

From: "Vinay Bannai" <[email-masked]>
Date: Fri, 22 Nov 2002 11:10:51 -0800

Hi folks,

I have written a proposal for layering of L3 interfaces (IP interface) on RPR Mac to be included in the proposed draft text.
To summarize, the proposal specifies two mechanisms of layering the IP interface. The first mechanism (most commonly used) would have one IP interface on top of the RPR Mac. The other mechanism would have a IP interface per ringlet. This mechanism eventhough more complex would provide IP multipath load balancing if one so wishes to not use RPR ringlet selection.

Thanks
Vinay Bannai
Luminous Networks

---

From: Anoop Ghanwani <[email-masked]>
Date: Fri, 22 Nov 2002 13:21:02 -0800

Vinay,

Here's my 2 cents on this.

First, one can have multiple IP interfaces on top
of any MAC when one uses VLANs.  Therefore, showing only
a single IP interface on top of the MAC (or just 2 for
that matter) is a bit misleading.

Second, the 802.17 MAC only has a single client sitting
on top of it.  Therefore, for a given IP interface (which
would typically use a VLAN off that client), it should be
possible for the client to use either direction to go
around the ring.  Basically, if a span goes down and
ring goes into protection, all of the IP interfaces
are still reachable.  Therefore, the only solution that
makes sense (at least to me) is the first one, except
of course, that you can have multiple IP interfaces 
sitting on top of the MAC if you have VLANs.

Of course, the RPR MAC presents a new type of interface 
where its possible to go both directions around the ring.
Which direction is chosen should be implementation 
specific.  The routing client can do ringlet
selection by accessing the topology, protection, and
fairness information exposed by the 802.17 MAC to its
client.

-Anoop

-----Original Message-----
From: Vinay Bannai [mailto:[email-masked]]
Sent: Friday, November 22, 2002 11:11 AM
To: [email-masked]
Subject: [IPORPR] Layering of L3 interfaces on RPR mac

Hi folks,

I have written a proposal for layering of L3 interfaces (IP interface) on
RPR Mac to be included in the proposed draft text.
To summarize, the proposal specifies two mechanisms of layering the IP
interface. The first mechanism (most commonly used) would have one IP
interface on top of the RPR Mac. The other mechanism would have a IP
interface per ringlet. This mechanism eventhough more complex would provide
IP multipath load balancing if one so wishes to not use RPR ringlet
selection.

Thanks
Vinay Bannai
Luminous Networks

_______________________________________________
IPORPR mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iporpr