Subject: RE: [IPORPR] RPR protection with MPLS

From: George Suwala <[email-masked]>
Date: Mon, 11 Nov 2002 18:09:32 -0800

Indeed successful RPR protection should not trigger MPLS protection (should have no impact on the MPLS protection).

However if RPR protection fails, MPLS should be triggered to protect. The exact method of doing it could be an IPORPR discussion topic, with timeouts being one of the options (so MPLS could be configured to ignore failures unless they persist for more than say 100ms, which would indicate a failure of the underlying RPR layer)

thanks

George
 
At 02:41 PM 11/11/2002 -0800, Nader Vijeh wrote:
>RPR is supposed to provide a protected Data Link Layer and should hide the
>operation of the DL from upper layers, including MPLS. This implies that
>MPLS should not trigger a protection event, if the RPR has recovered from
>the fault.
>
>-----Original Message-----
>From: nitin panjwani [mailto:[email-masked]]
>Sent: Monday, November 11, 2002 2:25 PM
>To: Frank Kastenholz; Glenn Parsons; [email-masked]
>Subject: [IPORPR] RPR protection with MPLS
>
>
>Hi All,
>
>I am new to RPR world and probably have not great
>undrstanding of it yet.
>I was thinking how the network will work when there is
>mpls protection working over RPR network. Wouldn't
>this double protection delay the traffic and probably
>affect the throughput and speed. Is there any document
>available which talks about this and what are the
>thoughts of RPR gurus about it.
>
>Regards,
>Nitin 
>
>
>__________________________________________________
>Do you Yahoo!?
>U2 on LAUNCH - Exclusive greatest hits videos
>http://launch.yahoo.com/u2
>_______________________________________________
>IPORPR mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/iporpr
>_______________________________________________
>IPORPR mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/iporpr 

_______________________________________________
IPORPR mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iporpr

---

From: Frank Kastenholz <[email-masked]>
Date: Tue, 12 Nov 2002 08:43:20 -0500

>However if RPR protection fails, MPLS should be triggered to protect. The exact method of doing it could be an IPORPR discussion topic, with timeouts being one of the options (so MPLS could be confi…

Two questions
1. When the 802.17 ring has a failure and invokes its protection
   procedure, do the higher layers see it as a brief failure in
   the link (i.e. there is an "interface down" event followed a
   few ms later by an "interface up" event) or does it happen
   transparently, with no interface failure (i.e. it would appear
   to the higher layers as just a brief moment of packet loss)

2 If an 802.17 ring fails and can not go into single-ring-mode
  for some reason, wouldn't it appear as a link failure to MPLS
  causing MPLS mechanisms to invoke fast reroute, just as if, say,
  a PPP link went kablooey or an ethernet lost its ether?

Frank Kastenholz

---

From: raj sharma <[email-masked]>
Date: Tue, 12 Nov 2002 19:27:29 -0800 (PST)

Although, RPR provides fast protection at the DL layer
I still feel multi-layer resiliency requires some
form of coordination. I feel, as MPLS and other
upper layers are attempting to protect faster than
before we may soon across situations like what Frank 
mentions here.

Raj Sharma
Luminous Networks.

--- Frank Kastenholz <[email-masked]> wrote:
> >Indeed successful RPR protection should not trigger
> MPLS protection (should have no impact on the MPLS
> protection).
> >
> >However if RPR protection fails, MPLS should be
> triggered to protect. The exact method of doing it
> could be an IPORPR discussion topic, with timeouts
> being one of the options (so MPLS could be
> configured to ignore failures unless they persist
> for more than say 100ms, which would indicate a
> failure of the underlying RPR layer)
> 
> Two questions