Subject: RE: [IPORPR] draft of a core protocol spec

From: Anoop Ghanwani <[email-masked]>
Date: Fri, 8 Nov 2002 08:55:49 -0800

> -----Original Message-----
> From: Frank Kastenholz [mailto:[email-masked]]
> Sent: Thursday, November 07, 2002 2:35 PM
> To: [email-masked]; [email-masked]
> Subject: RE: [IPORPR] draft of a core protocol spec
> 
> 
> At 02:29 PM 11/7/2002 -0800, [email-masked] wrote:
> >>>         TTL In the absence of any recommended value in 
> IEEE 802.17, 
> >>>             the TTL SHOULD be set to 255. 
> >>>lb] There is no need (nor a standard way) to indicate TTL 
> to the MAC. The
> >>>MAC can calculate it based on the DA
> >>
> >>There does not need to be a standard way of indicating the TTL to
> >>the MAC. That's an implementation issue.  However, that's 
> irrelevant.
> >>If the MAC can insert the "correct" TTL, that's _probably_ all we
> >>need and I'll revise the spec to say that. One question, when a node
> >>is added to the ring, does the MAC update its notion of what TTL
> >>to use "quickly"?
> >
> >There is *no* way to indicate TTL to the MAC. TTL is set 
> internally by the MAC. And, yes, the MAC adjusts the TTL 
> value as needed, including when topology changes. 
> 
> 
> I just looked. I'd have sworn that there was a TTL field
> in the MA_DATA.request. I just looked. I'm wrong. I'll remove
> all the TTL goop.
> 

There used to be a TTL many draft versions ago, so that's
probably the reason for your recollection :).  It was subsequently 
removed because it was decided that anything above the MAC 
shouldn't need to know about TTL.

-Anoop
_______________________________________________
IPORPR mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iporpr

---

From: "A.Herrera" <[email-masked]>
Date: Sat, 9 Nov 2002 11:30:53 -0500

----- Original Message -----
From: "Anoop Ghanwani" <[email-masked]>
To: "'Frank Kastenholz'" <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Friday, November 08, 2002 11:55 AM
Subject: RE: [IPORPR] draft of a core protocol spec
> shouldn't need to know about TTL.

Just a quick question for the WG. It could be
outside the scope of the core spec or it might be
a non-issue altogether.

How is L3 TTL reconciled with RPR TTL. Given that
we no longer deal with LANs but rather large
MANs.

Say, a packet from a traditional mesh hits,
traverses, then exits 3 large metro rings (of
over 100 nodes each), does the L3 TTL decrement by
3. And should this packet somehow find an entry back
to the first ring, shouldn't there be a mechanism for
an earlier discard. Or do we treat these rings the
way PWE3 treats their tunnels where the TTLs don't
percolate up nor percolate down.

Albert

---

From: Vinay Bannai <[email-masked]>
Date: Sat, 09 Nov 2002 08:58:22 -0800

Hi Albert,

Your later observation is correct. The setting of the RPR TTL is directly a
funtion of the local ring topology and it does not and should not have any
bearing on the L3 TTL. It would correct to keep the TTL from percolating up
and down the layers. The L3 TTL and the RPR TTL serve two entirely different
purposes and should not have linkage. The L3 TTL avoids infinite looping in
a network whereas, the RPR TTL serves the function of keeping the packet
looping infinitely within a RPR ring.

If one were to choose to use a MPLS label between the layer 2 and layer 3,
then the issue of setting of the MPLS label becomes slightly interesting but
that has nothing to do with RPR.

Vinay

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
A.Herrera
Sent: Saturday, November 09, 2002 8:31 AM
To: Anoop Ghanwani; 'Frank Kastenholz'; [email-masked];
[email-masked]
Subject: Re: [IPORPR] draft of a core protocol spec

----- Original Message -----
From: "Anoop Ghanwani" <[email-masked]>
To: "'Frank Kastenholz'" <[email-masked]>; <[email-masked]>;
<[email-masked]>

Albert

---

From: "A.Herrera" <[email-masked]>
Date: Sat, 9 Nov 2002 22:46:44 -0500

Will it be a big layer violation to allow L3 clients
to optionally set RPR TTL. Given that we're dealing
with 10gig, near-WAN, 100+node ring topologies that
can easily carry megabit streams gone astray.

I agree L3 TTL checks network loops and RPR TTL
checks ring loops but a large ring is a large network
by itself :-)

Albert

----- Original Message -----
From: "Vinay Bannai" <[email-masked]>
To: "A.Herrera" <[email-masked]>; "Anoop Ghanwani" <[email-masked]>;
"'Frank Kastenholz'" <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Saturday, November 09, 2002 11:58 AM
Subject: RE: [IPORPR] draft of a core protocol spec