Subject: RE: [IPORPR] RPR protection with MPLS

From: Nader Vijeh <[email-masked]>
Date: Mon, 11 Nov 2002 14:41:57 -0800

RPR is supposed to provide a protected Data Link Layer and should hide the
operation of the DL from upper layers, including MPLS. This implies that
MPLS should not trigger a protection event, if the RPR has recovered from
the fault.

-----Original Message-----
From: nitin panjwani [mailto:[email-masked]]
Sent: Monday, November 11, 2002 2:25 PM
To: Frank Kastenholz; Glenn Parsons; [email-masked]
Subject: [IPORPR] RPR protection with MPLS

Hi All,

I am new to RPR world and probably have not great
undrstanding of it yet.
I was thinking how the network will work when there is
mpls protection working over RPR network. Wouldn't
this double protection delay the traffic and probably
affect the throughput and speed. Is there any document
available which talks about this and what are the
thoughts of RPR gurus about it.

Regards,
Nitin 

__________________________________________________
Do you Yahoo!?
U2 on LAUNCH - Exclusive greatest hits videos
http://launch.yahoo.com/u2
_______________________________________________
IPORPR mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iporpr
_______________________________________________
IPORPR mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/iporpr

---

From: [email-masked]
Date: Tue, 19 Nov 2002 09:14:06 -0800

Definitely.

-----Original Message-----
From: A.Herrera [mailto:[email-masked]]
Sent: Monday, November 18, 2002 11:21 PM
To: John Lemon; [email-masked]; [email-masked]
Subject: Re: [IPORPR] RPR protection with MPLS

John,

I agree, protection kicks in quickly and there's no
need nor time for MPLS to intervene. I was referring
more to other scenarios where multiple faults occur
with multiple Signal Fails or combinations of Signal
Degrades and instances where a few nodes are isolated
creating 'island' sub-rings.

In these cases, the WG might like to look at scenarios
where MPLS might compliment RPR protection.

Albert

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Monday, November 18, 2002 1:51 PM
Subject: RE: [IPORPR] RPR protection with MPLS

Albert,

I'm not sure what you mean by "RPR protection settles". There is no "settling"
for protection. It just switches to the alternate path, as quickly as the link
problem is detected. Since the RPR MAC owns the interface to the physical layer,
the RPR MAC will learn first and react first.

jl

-----Original Message-----
From: A.Herrera [mailto:[email-masked]]
Sent: Tuesday, November 12, 2002 4:17 PM
To: nitin panjwani; David Zelig; 'Frank Kastenholz'; [email-masked]
Subject: Re: [IPORPR] RPR protection with MPLS

----- Original Message -----
From: "nitin panjwani" <[email-masked]>
To: "David Zelig" <[email-masked]>; "'Frank Kastenholz'"
<[email-masked]>; <[email-masked]>
Sent: Tuesday, November 12, 2002 3:09 PM
Subject: RE: [IPORPR] RPR protection with MPLS

>
> Hi David and all,
> Shouldn't it be something like: either RPR or MPLS
> protection will take charge of rerouteing the traffic;
> and one which assures minimum packate loss and delay
> will win and take charge.
> On this, usually upper layer(MPLS) depends on the
> lower layer(RPR)(as it simplifies the implementation
> and serves the perfect goal of layering approach)and
> shouldn't it be upto MPLS to decide wheathet to take
> charge of protection or wait for RPR, depending on how
> critical network and the passing traffic is(this
> should be configurable).
> Please correct me.
>
> Tahnks,
> Nitin
>
Both MPLS FRR and RPR steer/wrap are localized
reactions to divert within ms. to a pre-determined
detour path or alternate ring direction. So I'll
assume that operator preferences to fault scenarios
are pre-determined and pre-configured as per network
planning based on critical flows.

In this case, I would think, that sufficient feedback from
RPR as to the nature of the faults (i.e. multiple or
combinations of Signal Fail/Degrade, etc.) will allow MPLS
to choose to divert even before RPR protection settles.
For single occurrances of SF, etc, RPR is more than
sufficient protection for critical flows.

These mechanisms and scenarios should be discussed
and further clarified within the WG.

Albert