Subject: [Ipoverib] another thought

From: "Anderson, Bill" <[email-masked]>
Date: Fri, 28 Sep 2001 17:12:51 -0400

I forgot to mention one other issue .  The issue centers around the
SmaPortInfoEntry smaLocalPortNum and the NodeInfo Group smaPortGuid
fields.  I believe both of objects require knowledge of the port that
the request came from to calculate the response.  Now if we are dealing
with SNMP tunneling over MADs or a SNMP Proxy via MADs I guess this
isn't an issue but what do we do if the request comes in some out of
band channel.  
 
1 Would it be sufficent to just assume the port is the management port. 
2 We could add a port index through the NodeInfo Table 
3 ????
 
Im not sure what the right answer is have you given it any thought yet.
 
-Bill

Bill Anderson                      [email-masked]
<mailto:[email-masked]> 
InfiniSwitch, Corp.             Phone: (508) 599-6336
134 Flanders Road            www.infiniswitch.com
Westborough, MA 01581  fax:(508) 870-3146 

_______________________________________________
IPoverIB mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ipoverib

---

From: "Bill Swortwood" <[email-masked]>
Date: Fri, 28 Sep 2001 15:20:52 -0700

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Anderson, Bill
Sent: Friday, September 28, 2001 2:13 PM
To: [email-masked]
Subject: [Ipoverib] another thought

----

[whs] The smaLocalPortNumber object assumes 0 unless it it tunneled, which
would then be the port that the tunneling occured on :

smaLocalPortNum OBJECT-TYPE
    SYNTAX      Integer32
    MAX-ACCESS      read-only
    STATUS      current
    DESCRIPTION
    "The number of the link port which received this SNMP request,
     otherwise 0."
    ::= { smaAttributeComponent 9 }

*********
The PortInfo Attribute table would then map for a CA what CA port this is
applied to, and likewise for the switch, would be the link port this applies
to (wording below
in description is a misnomer) :

smaPortLocalPortNum  OBJECT-TYPE
    SYNTAX      Integer32
    MAX-ACCESS      read-only
    STATUS      current
    DESCRIPTION " The number of the link port which received this SMP."
    ::= { smaPortInfoEntry 8 }

****

If there is port specific information that needs to be reflected this can
be indexed back to the PortInfo entry information .

cheers,

---------------------------
Bill Swortwood
Sanera Systems
Oregon Design Center
(w) 503 601 0261
[email-masked]
---------------------------