Subject: RE: [Ipoverib] IPoIB advanced capabilities

From: "Arvind Murching" <[email-masked]>
Date: Fri, 11 Jan 2002 17:07:20 -0800

Vivek, two issues regarding the capabilities flags:

(a) From a purist point of view, the link layer address is not the right
place to specify end-node capabilities.

(b) Section 3.2 says:

	  The method by which a host decides it wants to use
	  the IPoIB-RC/UC/RD services is beyond the scope
        of this specification.

However, this means that two nodes that conform to this specification,
and decide to use the capability bits, can easily fail to interoperate.
This is because this document does not specify how they, for example,
set up RC/UC connections (what service ID is used etc). We should either
fully specify the encapsulation and connection mechanisms for these
other transport methods (if time permits), or simply label the bits used
for this purpose as "Reserved" in this spec, and require all conformant
implementations to set this to 0 on transmit and ignore on receive.
Later versions of this spec can define these bits, along with details of
how they are used.

- Arvind

-----Original Message-----
From: Vivek Kashyap [mailto:[email-masked]] 
Sent: Friday, January 11, 2002 4:34 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Ipoverib] IPoIB advanced capabilities

Folks,
        We have discussed IP over non-UD links a few times on this
        mailing list.The capability-flags in the address-resolution
        packets provide the necessary hook to implementing such
        solutions in an interoperable way. I presented a solution at
        the IPoIB WG meeting at SLC earlier this month.

        Attached is a draft that I submitted a few days back. It
        hasn't been announced yet but I thought that we need to move
        forward. The draft and the solution is completely disjoint
        from the encapsulation draft except for the capability-bits
        being included in the address resolution packet.

	I look forward to your comments. 

Vivek
<snip>

---

From: Yaron Haviv <[email-masked]>
Date: Sat, 12 Jan 2002 18:14:32 +0200

Arvind,
 
In our case the capability (RC/UD)  is part of the link layer attributes
The host could always use UD if they want to, however if both of them
support RC and for some reason (MTU ..) want to work RC they can
As far as I know Vivek has a proposal for how to set an RC connection, I'm
not sure if he posted it yet
 
Another capability bit I would like to add that would help is and "SDP"
capability bit
Since with the new proposal there is no need to go to the SM for ARP, in
order to know if a node supports SDP I must add an SM lookup to the process
That could slow the process significantly
If we add this bit we could avoid that and quite easily know if we could use
SDP for the connection
Since protocol offloading is an integral (non-optional) part of InfiniBand
it also makes sense to put it as part of the IB ARP
(not to mention that it is specified in SDP that it uses the IP over IB
address resolution)
 
Yaron
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Arvind Murching
Sent: Saturday, January 12, 2002 3:07 AM
To: Vivek Kashyap; [email-masked]
Cc: [email-masked]
Subject: RE: [Ipoverib] IPoIB advanced capabilities
 
Vivek, two issues regarding the capabilities flags:
(a) From a purist point of view, the link layer address is not the right
place to specify end-node capabilities.
(b) Section 3.2 says:
          The method by which a host decides it wants to use
          the IPoIB-RC/UC/RD services is beyond the scope
        of this specification.
However, this means that two nodes that conform to this specification, and
decide to use the capability bits, can easily fail to interoperate. This is
because this document does not specify how they, for example, set up RC/UC
connections (what service ID is used etc). We should either fully specify
the encapsulation and connection mechanisms for these other transport
methods (if time permits), or simply label the bits used for this purpose as
"Reserved" in this spec, and require all conformant implementations to set
this to 0 on transmit and ignore on receive. Later versions of this spec can
define these bits, along with details of how they are used.
- Arvind
-----Original Message-----
From: Vivek Kashyap [ mailto:[email-masked]]
Sent: Friday, January 11, 2002 4:34 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Ipoverib] IPoIB advanced capabilities
Folks,

---

From: Vivek Kashyap <[email-masked]>
Date: Mon, 14 Jan 2002 14:17:47 -0800 (PST)

yaron,	
        I have posted the draft and it got announced today-
        draft-kashyap-ipoib-advanced-capabilities-00.txt 

        The RC flag certainly doesn't imply SDP. I leave it to the WG
        to decide and I can accordingly update the flag.

        In general I agree with you and prefer avoiding the SM and
        multiple-resolution messages between the nodes. Thus an
        address resolution packet that gives us the necessary
        information is better.

        Include the following in the packet:

	LID - you don't have to go the SM.
	QPN - you don't have to back and forth between the two endpoints
		Secondly if SIDR is not supported the solution breaks down.
	GID - allows proxy-ARP of the type RogerR discussed for bridging
	      allows future expansion across IB subnets
        cap-flags- provides for the kind of issues you mention and
                   also allows interoperability among all
                   implementations 
                   In general I would like to restric the capabilitY
                   flags to RC and QPN. If SDP is agreed to by WG then
                   that could the third flag. I am not sure if there
                   are many takers for UC/RD.

Vivek 

> 
> This is a multi-part message in MIME format.
> 
> --Boundary_(ID_MH0w1LW5oe3PQ6xdgF91BA)
> Content-type: text/plain; charset=us-ascii
> Content-Transfer-Encoding: 7BIT
> 
> Arvind,
>  
> --Boundary_(ID_MH0w1LW5oe3PQ6xdgF91BA)
> Content-type: text/html; charset=us-ascii
> Content-Transfer-Encoding: 7BIT
> 
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
> <html xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns="http://www.w3.org/TR/REC-html40">
> 
> <head>
> <META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=us-ascii">
> 
> 
> <meta name=ProgId content=Word.Document>
> <meta name=Generator content="Microsoft Word 9">
> <meta name=Originator content="Microsoft Word 9">
> <link rel=File-List href="cid:[email-masked]">
> <title>RE: [Ipoverib] IPoIB advanced capabilities</title>
> <!--[if gte mso 9]><xml>
>  <o:OfficeDocumentSettings>
>   <o:DoNotRelyOnCSS/>
>  </o:OfficeDocumentSettings>
> </xml><![endif]--><!--[if gte mso 9]><xml>
>  <w:WordDocument>
>   <w:Zoom>0</w:Zoom>
>   <w:DocumentKind>DocumentEmail</w:DocumentKind>
>   <w:EnvelopeVis/>
>  </w:WordDocument>
> </xml><![endif]-->
> <style>
> <!--
>  /* Font Definitions */
> @font-face
> 	{font-family:Tahoma;
> 	panose-1:2 11 6 4 3 5 4 4 2 4;
> 	mso-font-charset:0;
> 	mso-generic-font-family:swiss;
> 	mso-font-pitch:variable;
> 	mso-font-signature:553679495 -2147483648 8 0 66047 0;}
>  /* Style Definitions */
> p.MsoNormal, li.MsoNormal, div.MsoNormal
> 	{mso-style-parent:"";
> 	margin:0in;
> 	margin-bottom:.0001pt;
> 	mso-pagination:widow-orphan;
> 	font-size:12.0pt;
> 	font-family:"Times New Roman";
> 	mso-fareast-font-family:"Times New Roman";}
> a:link, span.MsoHyperlink
> 	{color:blue;
> 	text-decoration:underline;
> 	text-underline:single;}
> a:visited, span.MsoHyperlinkFollowed
> 	{color:blue;
> 	text-decoration:underline;
> 	text-underline:single;}
> p.MsoAutoSig, li.MsoAutoSig, div.MsoAutoSig
> 	{margin:0in;
> 	margin-bottom:.0001pt;
> 	mso-pagination:widow-orphan;
> 	font-size:12.0pt;
> 	font-family:"Times New Roman";
> 	mso-fareast-font-family:"Times New Roman";}
> p
> 	{margin-right:0in;
> 	mso-margin-top-alt:auto;
> 	mso-margin-bottom-alt:auto;
> 	margin-left:0in;
> 	mso-pagination:widow-orphan;
> 	font-size:12.0pt;
> 	font-family:"Times New Roman";
> 	mso-fareast-font-family:"Times New Roman";}
> span.EmailStyle18
> 	{mso-style-type:personal-reply;
> 	mso-ansi-font-size:10.0pt;
> 	mso-ascii-font-family:Arial;
> 	mso-hansi-font-family:Arial;
> 	mso-bidi-font-family:Arial;
> 	color:navy;}
> @page Section1
> 	{size:8.5in 11.0in;
> 	margin:1.0in 1.25in 1.0in 1.25in;
> 	mso-header-margin:.5in;
> 	mso-footer-margin:.5in;
> 	mso-paper-source:0;
> 	mso-gutter-direction:rtl;}
> div.Section1
> 	{page:Section1;}
> -->
> </style>
> </head>
> 
> <body lang=EN-US link=blue vlink=blue style='tab-interval:.5in'>
> <!-- Converted from text/rtf format -->
> 
> <div class=Section1 dir=RTL>
> 
> <p class=MsoNormal dir=LTR><span class=EmailStyle18><font size=2 color=navy
> face=Arial><span style='font-size:10.0pt;mso-bidi-font-size:12.0pt;font-family:
> Arial'>Arvind,<o:p></o:p></span></font></span></p>
> 
> <p class=MsoNormal dir=LTR><span class=EmailStyle18><font size=2 color=navy
> face=Arial><span style='font-size:10.0pt;mso-bidi-font-size:12.0pt;font-family:
> Arial'><![if !supportEmptyParas]>&nbsp;<![endif]><o:p></o:p></span></font></span></p>
> 
> <p class=MsoNormal dir=LTR><span class=EmailStyle18><font size=2 color=navy
> face=Arial><span style='font-size:10.0pt;mso-bidi-font-size:12.0pt;font-family:
> Arial'>In our case the capability (RC/UD) <span style="mso-spacerun:
> yes">&nbsp;</span>is part of the link layer attributes <o:p></o:p></span></font></span></p>
> 
> <p class=MsoNormal dir=LTR><span class=EmailStyle18><font size=2 color=navy
> face=Arial><span style='font-size:10.0pt;mso-bidi-font-size:12.0pt;font-family:
> Arial'>The host could always use UD if they want to, however if both of them
> support RC and for some reason (MTU ..) want to work RC they can<o:p></o:p></span></font></span></p>
> 
> <p class=MsoNormal dir=LTR><span class=EmailStyle18><font size=2 color=navy
> face=Arial><span style='font-size:10.0pt;mso-bidi-font-size:12.0pt;font-family:
> Arial'>As far as I know Vivek has a proposal for how to set an RC connection, I&#8217;m
> not sure if he posted it yet<o:p></o:p></span></font></span></p>
> 
> <p class=MsoNormal dir=LTR><span class=EmailStyle18><font size=2 color=navy
> face=Arial><span style='font-size:10.0pt;mso-bidi-font-size:12.0pt;font-family:
> Arial'><![if !supportEmptyParas]>&nbsp;<![endif]><o:p></o:p></span></font></span></p>
> 
> <p class=MsoNormal dir=LTR><span class=EmailStyle18><font size=2 color=navy
> face=Arial><span style='font-size:10.0pt;mso-bidi-font-size:12.0pt;font-family:
> Arial'>Another capability bit I would like to add that would help is and &#8220;SDP&#8221;
> capability bit<o:p></o:p></span></font></span></p>
> 
> <p class=MsoNormal dir=LTR><span class=EmailStyle18><font size=2 color=navy
> face=Arial><span style='font-size:10.0pt;mso-bidi-font-size:12.0pt;font-family:
> Arial'>Since with the new proposal there is no need to go to the SM for ARP, in
> order to know if a node supports SDP I must add an SM lookup to the process<o:p></o:p></span></font></span></p>
> 
> <p class=MsoNormal dir=LTR><span class=EmailStyle18><font size=2 color=navy
> face=Arial><span style='font-size:10.0pt;mso-bidi-font-size:12.0pt;font-family:
> Arial'>That could slow the process significantly<o:p></o:p></span></font></span></p>
> 
> <p class=MsoNormal dir=LTR><span class=EmailStyle18><font size=2 color=navy
> face=Arial><span style='font-size:10.0pt;mso-bidi-font-size:12.0pt;font-family:
> Arial'>If we add this bit we could avoid that and quite easily know if we could
> use SDP for the connection<o:p></o:p></span></font></span></p>
> 
> <p class=MsoNormal dir=LTR><span class=EmailStyle18><font size=2 color=navy
> face=Arial><span style='font-size:10.0pt;mso-bidi-font-size:12.0pt;font-family:
> Arial'>Since protocol offloading is an integral (non-optional) part of InfiniBand
> it also makes sense to put it as part of the IB ARP<o:p></o:p></span></font></span></p>
> 
> <p class=MsoNormal dir=LTR><span class=EmailStyle18><font size=2 color=navy
> face=Arial><span style='font-size:10.0pt;mso-bidi-font-size:12.0pt;font-family:
> Arial'>(not to mention that it is specified in SDP that it uses the IP over IB
> address resolution) <o:p></o:p></span></font></span></p>
> 
> <p class=MsoNormal dir=LTR><span class=EmailStyle18><font size=2 color=navy
> face=Arial><span style='font-size:10.0pt;mso-bidi-font-size:12.0pt;font-family:
> Arial'><![if !supportEmptyParas]>&nbsp;<![endif]><o:p></o:p></span></font></span></p>
> 
> <p class=MsoNormal dir=LTR><span class=EmailStyle18><font size=2 color=navy
> face=Arial><span style='font-size:10.0pt;mso-bidi-font-size:12.0pt;font-family:
> Arial'>Yaron<o:p></o:p></span></font></span></p>
> 
> <p class=MsoNormal dir=LTR><span class=EmailStyle18><font size=2 color=navy
> face=Arial><span style='font-size:10.0pt;mso-bidi-font-size:12.0pt;font-family:
> Arial'><![if !supportEmptyParas]>&nbsp;<![endif]><o:p></o:p></span></font></span></p>
> 
> <p class=MsoNormal dir=LTR style='margin-left:.5in'><font size=2 color=black
> face=Tahoma><span style='font-size:10.0pt;font-family:Tahoma;color:black'>-----Original
> Message-----<br>
> <b><span style='font-weight:bold'>From:</span></b> [email-masked]
> [mailto:[email-masked]]<b><span style='font-weight:bold'>On Behalf Of </span></b>Arvind
> Murching<br>
> <b><span style='font-weight:bold'>Sent:</span></b> Saturday, January 12, 2002
> 3:07 AM<br>
> <b><span style='font-weight:bold'>To:</span></b> Vivek Kashyap;
> [email-masked]<br>
> <b><span style='font-weight:bold'>Cc:</span></b> [email-masked]<br>
> <b><span style='font-weight:bold'>Subject:</span></b> RE: [Ipoverib] IPoIB advanced
> capabilities</span></font></p>
> 
> <p class=MsoNormal dir=LTR style='margin-left:.5in'><font size=3
> face="Times New Roman"><span style='font-size:12.0pt'><![if !supportEmptyParas]>&nbsp;<![endif]><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>Vivek,</span></font><font
> color=black><span style='color:black'> </span></font><font size=2 color=black
> face="Courier New"><span style='font-size:10.0pt;font-family:"Courier New";
> color:black'>two issues regarding the capabilities flags:</span></font><font
> color=black><span style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>(a) From a
> purist point of view, the link layer address is not the right place to specify
> end-node capabilities.</span></font><font color=black><span style='color:black;
> mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>(b)</span></font><font
> color=black><span style='color:black'> </span></font><font size=2 color=black
> face="Courier New"><span style='font-size:10.0pt;font-family:"Courier New";
> color:black'>Section 3.2 says:</span></font><font color=black><span
> style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=3 color=black
> face="Times New Roman"><span style='font-size:12.0pt;color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
> </span></font><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>&nbsp;</span></font><font
> color=black><span style='color:black'> </span></font><font size=2 color=black
> face="Courier New"><span style='font-size:10.0pt;font-family:"Courier New";
> color:black'>The method by which a host decides it</span></font><font
> color=black><span style='color:black'> </span></font><font size=2 color=black
> face="Courier New"><span style='font-size:10.0pt;font-family:"Courier New";
> color:black'>wants to use</span></font><font color=black><span
> style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=3 color=black
> face="Times New Roman"><span style='font-size:12.0pt;color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
> </span></font><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>&nbsp;</span></font><font
> color=black><span style='color:black'> </span></font><font size=2 color=black
> face="Courier New"><span style='font-size:10.0pt;font-family:"Courier New";
> color:black'>the IPoIB-RC/UC/RD services is beyond the scope</span></font><font
> color=black><span style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
> of this specification.</span></font><font color=black><span style='color:black;
> mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>However, this
> means that two</span></font><font color=black><span style='color:black'> </span></font><font
> size=2 color=black face="Courier New"><span style='font-size:10.0pt;font-family:
> "Courier New";color:black'>nodes that conform to this specification,</span></font><font
> color=black><span style='color:black'> </span></font><font size=2 color=black
> face="Courier New"><span style='font-size:10.0pt;font-family:"Courier New";
> color:black'>and</span></font><font color=black><span style='color:black'> </span></font><font
> size=2 color=black face="Courier New"><span style='font-size:10.0pt;font-family:
> "Courier New";color:black'>decide to use the capability bits,</span></font><font
> color=black><span style='color:black'> </span></font><font size=2 color=black
> face="Courier New"><span style='font-size:10.0pt;font-family:"Courier New";
> color:black'>can easily fail to interoperate. This is because this document
> does not specify how</span></font><font color=black><span style='color:black'> </span></font><font
> size=2 color=black face="Courier New"><span style='font-size:10.0pt;font-family:
> "Courier New";color:black'>they, for example, set up RC/UC connections (what
> service ID is used etc).</span></font><font color=black><span style='color:
> black'> </span></font><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>We should either
> fully specify the encapsulation and</span></font><font color=black><span
> style='color:black'> </span></font><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>connection
> mechanisms for these other transport methods (if time permits), or</span></font><font
> color=black><span style='color:black'> </span></font><font size=2 color=black
> face="Courier New"><span style='font-size:10.0pt;font-family:"Courier New";
> color:black'>simply label the bits used for this purpose as
> &quot;Reserved&quot; in this spec, and require all conformant implementations
> to set this to 0 on transmit and ignore on receive.</span></font><font
> color=black><span style='color:black'> </span></font><font size=2 color=black
> face="Courier New"><span style='font-size:10.0pt;font-family:"Courier New";
> color:black'>Later versions of this spec can define these bits, along with
> details of how they are used.</span></font><font color=black><span
> style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>- Arvind</span></font><font
> color=black><span style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>-----Original
> Message-----<br>
> From: Vivek Kashyap [<a href="mailto:[email-masked]">mailto:[email-masked]</a>]<br>
> Sent: Friday, January 11, 2002 4:34 PM<br>
> To: [email-masked]<br>
> Cc: [email-masked]<br>
> Subject: [Ipoverib] IPoIB advanced capabilities</span></font><font color=black><span
> style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>Folks,</span></font><font
> color=black><span style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
> We have discussed IP over non-UD links a few times on this</span></font><font
> color=black><span style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
> mailing list.The capability-flags in the address-resolution</span></font><font
> color=black><span style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
> packets provide the necessary hook to implementing such</span></font><font
> color=black><span style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
> solutions in an interoperable way. I presented a solution at</span></font><font
> color=black><span style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
> the IPoIB WG meeting at SLC earlier this month.</span></font><font color=black><span
> style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
> Attached is a draft that I submitted a few days back. It</span></font><font
> color=black><span style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
> hasn't been announced yet but I thought that we need to move</span></font><font
> color=black><span style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
> forward. The draft and the solution is completely disjoint</span></font><font
> color=black><span style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
> from the encapsulation draft except for the capability-bits</span></font><font
> color=black><span style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
> being included in the address resolution packet.</span></font><font
> color=black><span style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=3 color=black
> face="Times New Roman"><span style='font-size:12.0pt;color:black'>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
> </span></font><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>I look forward
> to your comments. </span></font><font color=black><span style='color:black;
> mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>Vivek</span></font><font
> color=black><span style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> <p dir=LTR style='margin-left:.5in'><font size=2 color=black face="Courier New"><span
> style='font-size:10.0pt;font-family:"Courier New";color:black'>&lt;snip&gt;</span></font><font
> color=black><span style='color:black;mso-color-alt:windowtext'><o:p></o:p></span></font></p>
> 
> </div>
> 
> </body>
> 
> </html>
> 
> --Boundary_(ID_MH0w1LW5oe3PQ6xdgF91BA)--
> 
> _______________________________________________
> IPoverIB mailing list
> [email-masked]
> http://www.ietf.org/mailman/listinfo/ipoverib
> 

-- 
Vivek Kashyap
Linux Technology Center, IBM
[email-masked] 
[email-masked] 
503 578 3422 (o)
-- 
Vivek Kashyap
Linux Technology Center, IBM
[email-masked] 
[email-masked] 
503 578 3422 (o)

_______________________________________________
IPoverIB mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ipoverib