Subject: RE: [Ipoverib] InfiniBand Management Software-----DLID issue

From: "Mehra, Pankaj" <[email-masked]>
Date: Mon, 28 Jan 2002 19:51:30 -0800

1.0.a version of Vol 1. Page 644. Table 155. SMP Directed Route format.

DrSLID and DrDLID.

The next such question will cost you money!

Pankaj

-----Original Message-----
From: Rakesh Khurana [mailto:[email-masked]]
Sent: Monday, January 28, 2002 7:15 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Ipoverib] InfiniBand Management Software-----DLID issue

Hi All ,
We are develpoing the Management Software for the InfiniBand fabric. We
are
stuck at one point.
Whenever the LID routed packet is receieved by the manaagement
entities(Agents) how the SLID and DLID is extracted as there is no such
field in LID routed Management Packet.

Rakesh Khurana
(Infini Group)
DCM Technologies 
Gurgaon , India

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: Rakesh Khurana <[email-masked]>
Date: Tue, 29 Jan 2002 09:30:05 +0530

Hi Mr Pankaj 
I am not talking abt the Directed routed packet i am talking abt the LID
routed Management Packets.
Rakesh

-----Original Message-----
From: Mehra, Pankaj [mailto:[email-masked]]
Sent: Tuesday, January 29, 2002 9:22 AM
To: Rakesh Khurana; [email-masked]
Cc: [email-masked]
Subject: RE: [Ipoverib] InfiniBand Management Software-----DLID issue

DrSLID and DrDLID.

Pankaj

-----Original Message-----
From: Rakesh Khurana [mailto:[email-masked]]
Sent: Monday, January 28, 2002 7:15 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Ipoverib] InfiniBand Management Software-----DLID issue

Hi All ,

Rakesh Khurana
(Infini Group)
DCM Technologies 
Gurgaon , India

---

From: "Culley, Paul" <[email-masked]>
Date: Tue, 29 Jan 2002 08:02:24 -0600

DLID and SLID are in the packet header; LRH: DLID/SLID/SL.  See 1.0.a
page 128.  For HCAs these can be accessed for UD service in the Poll for
completion verb.  See page 534 table 84.  The DLID is actually only
returned as the low order "path" bits, to assemble the full DLID you
have to mix in the base DLID from the PortInfo Attribute, also
accessible for HCAs via the Query HCA verb.

Of course for TCAs, the designer is on his own for returning this
information.

Paul R. Culley
Compaq Sr. Fellow
281-514-5543

-----Original Message-----
From: Rakesh Khurana [mailto:[email-masked]]
Sent: Monday, January 28, 2002 9:15 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Ipoverib] InfiniBand Management Software-----DLID issue

Hi All ,

Rakesh Khurana
(Infini Group)
DCM Technologies 
Gurgaon , India

---

From: Brian Forbes <[email-masked]>
Date: Tue, 29 Jan 2002 10:04:00 -0800

I'm always worried by questions that seem simple, but: are you referring to
something besides the existence of the DLID and SLID in the Local Route
Header of the Unreliable Datagram that carries the management packet? (e.g.
section 5.2.1 in Vol 1) Or are you referring to how these header fields get
passed to management software?

Brian Forbes
Brocade Communications 

-----Original Message-----
From: Rakesh Khurana [mailto:[email-masked]]
Sent: Monday, January 28, 2002 7:15 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Ipoverib] InfiniBand Management Software-----DLID issue

Hi All ,
We are develpoing the Management Software for the InfiniBand fabric. We are
stuck at one point.
Whenever the LID routed packet is receieved by the manaagement
entities(Agents) how the SLID and DLID is extracted as there is no such
field in LID routed Management Packet.

Rakesh Khurana
(Infini Group)
DCM Technologies 
Gurgaon , India