Subject: [Ipoverib] encapsulation issues

From: Vivek Kashyap <[email-masked]>
Date: Thu, 17 Jan 2002 20:45:42 -0800 (PST)

> > 
> > 
> > 2. 	I believe based on the recent set of mails that the consensus no
> >         longer favours inclusion of the 'ethertype'. Is there a
> >         disagreement ?
> 
> There were many that said that an Ethertype was desirable and useful in
> their implementations.  Your counter argument was that it was not needed
> because it could be inferred through other means so why add an additional
> mechanism.  If you would allow us to use the same logic used in #1 above
> ("the architecture not forcing a limited solution on any set of
> aspirations"), then I would like an Ethertype defined as part of the
> payload.  As noted earlier, the inclusion of an Ethertype does not handicap
> or restrict any solution.
> 
> Roy

        I know that many found it desirable in the beginning but it
        appeared to me that people had changed their mind.

        The reason ethertype is unnecessary is that it doesn't buy us
        the solution it is supposed to due to the requirement that
        every other IB protocol follows the same rules. IPoIB has no
        control over that.

Vivek

> 
> > 
> > 
> > 3. 	As many have noted in the last couple of days that using IB
> >         over non-UD modes or utilising QPNs mapped to specific
> >         endpoints is desirable. A complete, interoperable solution has
> >         been presented in
> >         draft-kashyap-ipoib-advanced-capabilities-00.txt. 
> > 
> > 	Please review and comment. 
> > 
> > Vivek
> > 
> > 
> > 	
> > 
> > -- 
> > Vivek Kashyap
> > Linux Technology Center, IBM
> > [email-masked] 
> > [email-masked] 
> > 503 578 3422 (o)
> > 
> > _______________________________________________
> > IPoverIB mailing list
> > [email-masked]
> > http://www.ietf.org/mailman/listinfo/ipoverib
> > 
> 

-- 
Vivek Kashyap
Linux Technology Center, IBM
[email-masked] 
[email-masked] 
503 578 3422 (o)
-- 
Vivek Kashyap
Linux Technology Center, IBM
[email-masked] 
[email-masked] 
503 578 3422 (o)

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: [email-masked]
Date: Wed, 23 Jan 2002 11:52:47 +0900

Vivek,

Hello.
We have been catching up almost every ipoib mail-thread and thinking "gaps"
 between our ipoib driver(incl.its related modules) implementations and
 latest ipoib mail-thread arguments.

I hope you read my comments about ethertype in payload.

>From: Vivek Kashyap <[email-masked]>
>Message-Id: <[email-masked]>
>To: [email-masked]
>Date: Thu, 17 Jan 2002 20:45:42 -0800 (PST)

We also need EtherType field in IB packet payload.

Let me explain the reasons
1. Our ipoib datalink driver binds multiple protocols (IPv4,ARP,IPv6)
 to a single QP (per ipoib datalink interface),
 and No upper layer (which dispatch packets according to its protocol kind
 for received packets) exists above us(ipoib datalink driver).
 i.e. If IPv4 stack would receive ARP packets, IPv4 just discard them
    and vice versa.
2. In our some environments, we provide another upper datalink modules
 (which exist between IPv4/ARP/IPv6 stacks and ipoib datalink driver).
 They want to use ANOTHER ethertypes other than IPv4/ARP/IPv6. They are
 upper layers using ipoib but not-IPv4/ARP/IPv6.
 It should be possible that other protocols packets than IPv4/ARP/IPv6 can be
  carried over ipoib.

Thanks,
------------------------------------------------------------------------------
Akihiko Imai/Development Dept.5, Infrastructure Systems Division, Fujitsu Ltd.
  e-mail: [email-masked]  TEL: +81-044-754-3456 (ext)7113-8706
  address: 4-4-1 Kamiodanaka Nakahara-ku, Kawasaki 211-8588, Japan