Subject: RE: [ipoverib] reasons for not using LID ?

From: "Jim Pinkerton" <[email-masked]>
Date: Sun, 20 Jan 2002 07:46:02 -0800

Yaron,

The product your company has announced and demoed is much more than a
router - it is a layer 7 gateway. As such, parsing the internals of
every packet is no big deal - presumably that is what the box was
designed for. 

I believe Arvind was referring to the minimum functionality designed in
by the IBTA for an IB router - where parsing the packet body is
distinctly not required. Only parsing the LRH/GRH is required. The main
complexity is in managing the routing tables - the design intent is to
simply forward the data, while overwriting some of the LRH header fields
(such as the SLID, SL, etc). How to optimize this type of hardware
design is fairly well understood. In that world parsing each packet
payload in the fashion you describe really is a substantial amount of
additional work.

Jim

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Yaron Haviv
Sent: Thursday, January 17, 2002 5:46 PM
To: Arvind Murching; [email-masked]
Subject: RE: [ipoverib] reasons for not using LID ?

Arvind,

The only real argument you make is implementation in Routers
Since we build such boxes, I could tell you dealing with an ARP in the
router in case of IP span IB is complex anyway 
Believe me, the simplification you are offering me creates more work
than help inside the router 
As you also stated in the passed there are also very little amount of
ARP packets, so replacing it in one or two paces doesn't change anything

Yaron

-----Original Message-----
From: Arvind Murching [mailto:[email-masked]]
Sent: Friday, January 18, 2002 3:34 AM
To: [email-masked]; [email-masked]
Subject: RE: [ipoverib] reasons for not using LID ?

Below...

-----Original Message-----
From: Yaron Haviv [mailto:[email-masked]]
Sent: Thursday, January 17, 2002 5:31 PM
To: Arvind Murching; [email-masked]; [email-masked]
Subject: RE: [ipoverib] reasons for not using LID ?

My remarks attached

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of
Arvind Murching
Sent: Friday, January 18, 2002 2:57 AM
To: [email-masked]; [email-masked]
Subject: RE: [ipoverib] reasons for not using LID ?

The argument should be the other way around, i.e. fields need to justify
their necessity to be part of a protocol.
[YH] I think many arguments where already raised, now it's the
opposition
turn to put their arguments
[Arvind] The need for a redundant field is not obvious.

Some reasons why not:

- LID values cannot be used across IB subnet boundaries
[YH] you would any way need to store both LID (Router) and GID (node) in
this case somewhere, you wouldn't go to the SM for any new IP packet
wont
you
the routers in this case will any way need to change the LID in the ARP
packets (Proxy ARP and all that)
I believe this case is the one that benefits most from the LID, avoiding
the
long and complex multi-subnet resolution process
[Arvind] Consider the most general case of an IB router routing between
IB subnets. This router will not modify an ARP reply packet to insert
its LID into the payload. However, it will insert its SLID into the IB
header of packets that it forwards. Proxy ARP boxes can do the same,
too.

- A LID cannot be used as part of a static ARP entry
[YH] We didn't say not to have GID, you could still put GID as a static
entry

- The SLID is already present in case someone needs it
[YH] also regular ARP has it, so why not follow that path
[Arvind] This is not an argument for adding redundant fields.

My 2c
- Arvind

-----Original Message-----
From: Yaron Haviv [mailto:[email-masked]]
Sent: Thursday, January 17, 2002 4:47 PM
To: [email-masked]
Subject: [ipoverib] reasons for not using LID ?

By now it is obvious that there are the ones that wants LID's in the ARP
packets

Could the ones that don't give their reasons for why not to
Not just things like "you don't need it", "we want to save 16-bit", etc'
But, reasons for what problems could arouse from having it in the packet
I haven't heard any real argument that would make me consider removing
it
until now
we then will review them and see if it is possible to deal with those
cases,
if not I personally would drop my support in LID's

If people want it for their reasons, the ones that don't also need to do
some explaining

Yaron

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: Yaron Haviv <[email-masked]>
Date: Sun, 20 Jan 2002 19:08:24 +0200

Jim

As I mentioned in my previous email
I asked for reasons not just empty phrases, and people like Bill and Paul
presented good reasons
So I backed up from my previous position, this should be the nature of the
discussion I think
(My intention was to deal with ARP's in a different way than you describe
which is not so complicated however now it is behind us)

I accept the compromise that there will be an invalid SLID bit
This will enable in the common case to still avoid the SM as me and Vivek
wanted
And the routers will not need to look for the LID

I think Vivek by now agrees with me too, and we could move to the next topic
if there is such

Yaron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Jim Pinkerton
Sent: Sunday, January 20, 2002 5:46 PM
To: [email-masked]; Arvind Murching; [email-masked]
Subject: RE: [ipoverib] reasons for not using LID ?

Yaron,

Jim

-----Original Message-----

Arvind,

Yaron

-----Original Message-----
From: Arvind Murching [mailto:[email-masked]]
Sent: Friday, January 18, 2002 3:34 AM
To: [email-masked]; [email-masked]
Subject: RE: [ipoverib] reasons for not using LID ?

Below...

-----Original Message-----
From: Yaron Haviv [mailto:[email-masked]]
Sent: Thursday, January 17, 2002 5:31 PM
To: Arvind Murching; [email-masked]; [email-masked]
Subject: RE: [ipoverib] reasons for not using LID ?

My remarks attached

-----Original Message-----

Some reasons why not:

My 2c
- Arvind

-----Original Message-----
From: Yaron Haviv [mailto:[email-masked]]
Sent: Thursday, January 17, 2002 4:47 PM
To: [email-masked]
Subject: [ipoverib] reasons for not using LID ?

Yaron