Subject: RE: [Ipoverib] Interoperability

From: "Ashwin Kamath" <[email-masked]>
Date: Fri, 18 Jan 2002 13:29:17 -0600

Roger,
 Yes, my phrasing is incorrect. Without the SA did not mean that the SA did
not exist in the subnet, or did not have a part to play in the definition of
addresses. So is the interop question a moot question?

-Ashwin.

-----Original Message-----
From: Roger Ronald [mailto:[email-masked]]
Sent: Friday, January 18, 2002 1:22 PM
To: Ashwin Kamath
Subject: Re: [Ipoverib] Interoperability

I wouldn't agree with your phrasing.

The two camps are
1) Those who believe that the SA should be consulted directly based
on a single GID passed in the ARP request; and
2) Those who believe that other information may be directly passed
from the ARP requestee to the requestor.

In both cases, there is no doubt that the SA was involved in originally
defining the addresses that will be used. It's merely a question about
the wisdom of allowing an intermediary to resend that information.

RR

----- Original Message -----
From: "Ashwin Kamath" <[email-masked]>
To: <[email-masked]>
Sent: Friday, January 18, 2002 1:03 PM
Subject: [Ipoverib] Interoperability

> There are two major implementation camps, with SA and without SA. Is it
the
> goal of the architecture to be complete enough to deal with
interoperability
> between implementations? Is interop supposed to be gauranteed if two
> distinct implementations adhere to the specs?
>  In my opinion, it must be complete enough that two distinct
> implementations, must interoperate if they adhere to IpoIB spec.
Comments...
>
> -Ashwin.
>
>
> _______________________________________________
> IPoverIB mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipoverib
>
>

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: "Roger Ronald" <[email-masked]>
Date: Fri, 18 Jan 2002 14:14:36 -0600

No, your question is a very important one. 

My opinion is that if the protocol allows two different 
processes for address resolution, they should both
interoperate if the protocol is to be judged successful.

Just to speculate, it may be that the two methods quickly converge
and work the same....or the two methods may have circumstances
where rules must be added to prevent different answers.
There will be quite a bit of analysis needed to answer the question,
but we obviously have an interested and vocal community to do 
the work. :-)

RR