Subject: RE: [ipoverib] reasons for not using LID ?

From: "Arvind Murching" <[email-masked]>
Date: Thu, 17 Jan 2002 16:56:55 -0800

The argument should be the other way around, i.e. fields need to justify
their necessity to be part of a protocol.

Some reasons why not:

- LID values cannot be used across IB subnet boundaries
- A LID cannot be used as part of a static ARP entry
- The SLID is already present in case someone needs it

My 2c
- Arvind

-----Original Message-----
From: Yaron Haviv [mailto:[email-masked]] 
Sent: Thursday, January 17, 2002 4:47 PM
To: [email-masked]
Subject: [ipoverib] reasons for not using LID ?

By now it is obvious that there are the ones that wants LID's in the ARP
packets

Could the ones that don't give their reasons for why not to
Not just things like "you don't need it", "we want to save 16-bit", etc'
But, reasons for what problems could arouse from having it in the packet
I haven't heard any real argument that would make me consider removing
it
until now
we then will review them and see if it is possible to deal with those
cases,
if not I personally would drop my support in LID's

If people want it for their reasons, the ones that don't also need to do
some explaining

Yaron

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: Yaron Haviv <[email-masked]>
Date: Fri, 18 Jan 2002 03:31:03 +0200

My remarks attached

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Arvind Murching
Sent: Friday, January 18, 2002 2:57 AM
To: [email-masked]; [email-masked]
Subject: RE: [ipoverib] reasons for not using LID ?

The argument should be the other way around, i.e. fields need to justify
their necessity to be part of a protocol.
[YH] I think many arguments where already raised, now it's the opposition
turn to put their arguments

Some reasons why not:

- LID values cannot be used across IB subnet boundaries
[YH] you would any way need to store both LID (Router) and GID (node) in
this case somewhere, you wouldn't go to the SM for any new IP packet wont
you
the routers in this case will any way need to change the LID in the ARP
packets (Proxy ARP and all that)
I believe this case is the one that benefits most from the LID, avoiding the
long and complex multi-subnet resolution process

- A LID cannot be used as part of a static ARP entry
[YH] We didn't say not to have GID, you could still put GID as a static
entry

- The SLID is already present in case someone needs it
[YH] also regular ARP has it, so why not follow that path

My 2c
- Arvind

-----Original Message-----
From: Yaron Haviv [mailto:[email-masked]]
Sent: Thursday, January 17, 2002 4:47 PM
To: [email-masked]
Subject: [ipoverib] reasons for not using LID ?

Yaron