Subject: RE: [ipoverib] moving forward with the open Issues - end node

From: "Grun, Paul" <[email-masked]>
Date: Thu, 7 Feb 2002 16:15:37 -0800

I thought that there was consensus early on that we would assume that an IBA
fabric supporting IPoverIB would provide a minimum MTU of 2K bytes?  Didn't
we agree not to pursue the smaller MTUs?
-paul

> -----Original Message-----
> From: Vivek Kashyap [mailto:[email-masked]]
> Sent: Thursday, February 07, 2002 4:12 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [ipoverib] moving forward with the open Issues - end node
> 
> 
> > 
> > Yaron, 
> > Thanks for your response.
> > 
> > BTW, I think "what IPoIB-default-MTU should be" is an open issue.
> > right ?
> 
> Akihiko,
> 
>         We don't have a default MTU; the administrator is free to set
>         any of the 5 possible values (256,512,1024,2048,4096 bytes)
>         based on the capacity of the CAs/switches in the subnet.
> 
>         In general using a minimum link MTU (and hence choosing the
>         'right' equipment) of 2048 bytes makes sense. This link MTU
>         allows for the IP MTU to be set to 1500 (ethernet
>         internetworking) or 1280 (IPv6 minimum) if so desired. The
>         smaller MTUs are not optimal.
> 
>         No default though except in terms of :
> 
>         If No-ethertype in payload
> 
> 		IP MTU = IPoIB link MTU 
> 
> 	else
> 		IP MTU = IPoIB link MTU - sizeof('ethertype')
> 
> 
> 
> Vivek
> 
> > 
> > >-----Original Message-----
> > >From: [email-masked] 
[mailto:[email-masked]]On Behalf Of
> >[email-masked]
> >Sent: Friday, February 01, 2002 5:20 AM
> >To: [email-masked]
> >Cc: 'Michael Krause'; [email-masked]
> >Subject: Re: [ipoverib] moving forward with the open Issues - end node
> >
> >>Date: Thu, 31 Jan 2002 20:36:34 +0200
> >>From: Yaron Haviv <[email-masked]>
> >>Subject: RE: [ipoverib] moving forward with the open Issues - end node
> >>Mike,
> >>
> >>If you look at my last email from yesterday
> >>I acknowledge that, and say that we need to look into in the future and
not
> >>in this RFC, so this issue isn't open anymore
> >>The only open issue currently is the Ethertype field
> >>
> >>Yaron
> >
> >Please let me confirm this default MTU issue.
> >
> >If Ethertype is not in payload, default IP-MTU is 2048.
> >Otherwise (=if Ethertype is in payload),
> > default IP-MTU is not 2048.
> >It's 2048 - EterhType field length. (4? probably not 2)
> >

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: "Roger Ronald" <[email-masked]>
Date: Fri, 8 Feb 2002 07:52:20 -0600

I've assumed the MTU was decided and have not weighed in to try
and change it. If it's still an open issue, I would argue that wide
interoperability is the primary goal that should be met and that 
mandating sizes to insure performance sacrifices some
ability to interoperate (i.e., some first generation parts can't do 2K UD).

This isn't an "end-of-the-world" problem. Most of the 1st gen
IBA chips are never going to end customers.

I would recommend a stong SHOULD for supporting 2K MTUs
rather than a MUST. This would allow 1st gen chips to play and
reduce their temptation to use something wholely incompatible
(like IB-LAN).

RR

---

From: "Sukanta Ganguly" <[email-masked]>
Date: Sat, 23 Feb 2002 20:50:09 -0800

I thought so too. I was beaten down to a pulp by Bill on this one. I do agree with him after understanding his reasonings.

SG

*********** REPLY SEPARATOR  ***********