Subject: [Ipoverib] Structure Packing

From: Lee Young <[email-masked]>
Date: Sat, 2 Feb 2002 01:24:21 -0800 (PST)

Hi All,

This question is regarding the packing involved in
Infiniband Protocol Specs Version 1.0a.

Are the Infiniband structures naturally aligned at 8
byte boundaries ?

What I wish to say that if I have a compiler which
doesn't support packing,
then does it make any difference in the size of
structures ?

Also, the structure NodeInfo (Page 663, Table 122) has
a "Reserved" component which is 64 bits.
long. This field is preceded by '4' 8-bit entities.
This will create a hole in the NodeInfo structure.
Is there any specific reason to do so ?

Regards
Lee

__________________________________________________
Do You Yahoo!?
Great stuff seeking new owners in Yahoo! Auctions! 
http://auctions.yahoo.com

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: Brian Forbes <[email-masked]>
Date: Mon, 4 Feb 2002 10:06:27 -0800

Hi, Lee. The general answer is that IB structures are 4-byte aligned;
suggestions to align on 8-byte boundaries have been made and pretty
thoroughly rejected.

The reserved field in NodeInfo is provided for backwards compatibility with
very early (pre-1.0) IB implementations. There is a proposal in the
Management Working Group to use this field in post 1.0a iplementations, but
of course you can't bet on it until it's gospel.

Brian Forbes
Brocade Communications 

-----Original Message-----
From: Lee Young [mailto:[email-masked]]
Sent: Saturday, February 02, 2002 1:32 AM
To: [email-masked]
Subject: [Ipoverib] Structure Packing

Hi All,

Regards
Lee