Subject: Re: [Ipoverib] IPv4/IPv6 interdependencies

From: "H.K. Jerry Chu" <[email-masked]>
Date: Wed, 6 Mar 2002 11:08:11 -0800 (PST)

Roy,

I'm not sure which draft you're referring to. Any proposal that imposes
an interdependency between IPv4 and IPv6 is inferior in my opinion.
(Remember someday we may all migrate to v6.)

I believe Vivek's proposal on the "Advanced Capabilities" have the
bits embeded in the hardware/link-layer addresses so it's applicable
equally to both v4 and v6. There is no interdependency.

There are still a lot of details to be worked out in the advanced
area. You're certainly welcome to submit drafts.

Jerry

>From: "Larsen, Roy K" <[email-masked]>
>To: [email-masked]
>Date: Wed, 6 Mar 2002 10:35:02 -0800 
>MIME-Version: 1.0
>Subject: [Ipoverib] IPv4/IPv6 interdependencies
>X-Mailman-Version: 1.0
>List-Id: IP over InfiniBand WG Discussion List <ipoverib.ietf.org>
>X-BeenThere: [email-masked]
>
>Given that ARP is/will be the mechanism for conveying additional transport
>capabilities, does the draft need to touch on the possible interdependencies
>of IPv4 and IPv6?  That is, IPv6-only fabrics that want to use transports
>other than UD MUST support IPv4 or can we put this off until the other
>capabilities are defined?
>
>Roy
>
>_______________________________________________
>IPoverIB mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ipoverib

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: "Larsen, Roy K" <[email-masked]>
Date: Wed, 6 Mar 2002 11:40:39 -0800

Vivek and Jerry,

Absolutely right.  There is no need to clarify.  I was pondering some
half-baked ideas on RC and service IDs and thought I had detected the
interdependency.  Just a brain-check on my part.

Roy 

-----Original Message-----
From: Vivek Kashyap [mailto:[email-masked]]
Sent: Wednesday, March 06, 2002 11:12 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Ipoverib] IPv4/IPv6 interdependencies

Roy,
        I am assuming that you are talking in terms of the draft:
        draft-kashyap-ipoib-advanced-capabilities-00.txt. 

        When using IPv6, ND is the method of conveying the additional
        capabilities. When using IPv4 it is ARP. IPv6 only fabrics
        don't have to support IPv4. I'll clarify it in the draft if it
        is not defined clearly.

Vivek

-- 
Vivek Kashyap
Linux Technology Center, IBM
[email-masked] 
[email-masked] 
503 578 3422 (o)