Subject: Re: [Ipoverib] 4/9 deadline for a consensus call

From: "H.K. Jerry Chu" <[email-masked]>
Date: Mon, 8 Apr 2002 11:29:27 -0700 (PDT)

>I do not know if that would count, but I am against that,

It's not clear to me what you are against? (Including EtherType?)

>because to make a lower level driver to poke into something that
>belongs to upper levels seems a little retarded to me. My gut

But the above argument seems to favor EtherType.

>feeling (e.g. distilled expirience), suggests that such choice
>may also result in a performance hit down the road. Or may be not,
>we'll see.
>
>Since I am NOT a member of the working group, but a mere implemntor

IETF membership is determined by participation. So you have just
become a member now :-).

Jerry

>of what was designed by smarter people (like you), I kept quiet.
>I am going to write some code and see if this works well.
>Unfortunately, it may be a little too late to change standards
>by that time...
>
>-- Pete
>
>> From: "Larsen, Roy K" <[email-masked]>
>> Date: Mon, 8 Apr 2002 10:23:32 -0700 
>
>> I recently went through the old mails on the EtherType issue and found that
>> of those folks expressing an opinion, more wanted or were willing to accept
>> the encapsulation field than were dead set against it.  There certainly
>> wasn't a strong consensus against.  
>> 
>> Roy
>> 
>> -----Original Message-----
>> From: Michael Krause [mailto:[email-masked]]
>> Sent: Monday, April 08, 2002 7:22 AM
>> To: [email-masked]
>> Cc: [email-masked]
>> Subject: Re: [Ipoverib] 4/9 deadline for a consensus call
>> 
>> 
>> At 12:15 PM 4/6/2002 -0800, H.K. Jerry Chu wrote:
>> >At the Minneapolis/IETF meeting we had a "room concensus" on the
>> >following:
>> >
>> >1. Embedding EtherType in the IPoIB UD payload.
>> 
>> I've seen strong consensus on the reflector that indicates it should not be 
>> used.  I don't want to resurface all of the arguments but there were more 
>> against this from what I could see.
>> 
>> >2. Requiring IPv4 over IB to have a minimal MTU of 1500.
>> >(This effectively rules out all the IB MTUs less than 2K for
>> >running IPoIB.)
>> 
>> Clarified to be for IB UD transport service.
>> 
>> Mike
>
>_______________________________________________
>IPoverIB mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ipoverib

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: "Larsen, Roy K" <[email-masked]>
Date: Wed, 10 Apr 2002 13:49:23 -0700

Humm, when Pete says he doesn't want to poke into something that belongs to
the upper levels, do you think he was talking about an IPoIB encapsulation
field?  I'm guessing he's referring to peeking into the IP header.

Pete, could you clarify your position?  The options before us are adding an
explicit LSAP (Ethertype) to the IPoIB encapsulation header to demultiplex
ARP and IPv4 frames or looking into the upper nibble of the first bytes of
the payload to infer whether it is an ARP or IPv4 frame.

Roy

-----Original Message-----
From: Vivek Kashyap [mailto:[email-masked]]
Sent: Wednesday, April 10, 2002 1:34 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked];
[email-masked]

I agree with Pete. I too don't see any benefit in adding type field
in the payload.

Vivek

-- 
Vivek Kashyap
Linux Technology Center, IBM
[email-masked] 
[email-masked] 
503 578 3422 (o)