Subject: RE: [Ipoverib] 4/9 deadline for a consensus call

From: "Larsen, Roy K" <[email-masked]>
Date: Mon, 8 Apr 2002 10:23:32 -0700

I recently went through the old mails on the EtherType issue and found that
of those folks expressing an opinion, more wanted or were willing to accept
the encapsulation field than were dead set against it.  There certainly
wasn't a strong consensus against.  

Roy

-----Original Message-----
From: Michael Krause [mailto:[email-masked]]
Sent: Monday, April 08, 2002 7:22 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Ipoverib] 4/9 deadline for a consensus call

At 12:15 PM 4/6/2002 -0800, H.K. Jerry Chu wrote:
>At the Minneapolis/IETF meeting we had a "room concensus" on the
>following:
>
>1. Embedding EtherType in the IPoIB UD payload.

I've seen strong consensus on the reflector that indicates it should not be 
used.  I don't want to resurface all of the arguments but there were more 
against this from what I could see.

>2. Requiring IPv4 over IB to have a minimal MTU of 1500.
>(This effectively rules out all the IB MTUs less than 2K for
>running IPoIB.)

Clarified to be for IB UD transport service.

Mike

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: Pete Zaitcev <[email-masked]>
Date: Mon, 8 Apr 2002 14:00:34 -0400

I do not know if that would count, but I am against that,
because to make a lower level driver to poke into something that
belongs to upper levels seems a little retarded to me. My gut
feeling (e.g. distilled expirience), suggests that such choice
may also result in a performance hit down the road. Or may be not,
we'll see.

Since I am NOT a member of the working group, but a mere implemntor
of what was designed by smarter people (like you), I kept quiet.
I am going to write some code and see if this works well.
Unfortunately, it may be a little too late to change standards
by that time...

-- Pete

> From: "Larsen, Roy K" <[email-masked]>
> Date: Mon, 8 Apr 2002 10:23:32 -0700

---

From: Bill Strahm <[email-masked]>
Date: Mon, 8 Apr 2002 11:19:00 -0700

Just on a note from the WG chair...

By definition you ARE a member of the working group by subscribing
to the mailing list and offering the opinion below...

I am very interested in hearing what implementors have to say, I am
of the opinion that including Ethertype in the payload of the packet
is not the right thing to do, however, based on hearing some 
implementation reports from people who actually ARE doing the work, I
am very close to changing my mind again.  

Can you provide a quick summary on your position (I think I read that
you are against the Ethertype field, but I could be wrong) and especially
any technical reasons for that opinion, such as I can/can't do this
if the field is/isn't there...

Bill

---

From: Yaron Haviv <[email-masked]>
Date: Mon, 08 Apr 2002 21:48:11 +0200

Agree with Roy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Larsen, Roy K
Sent: Monday, April 08, 2002 7:24 PM
To: 'Michael Krause'; [email-masked]
Cc: [email-masked]
Subject: RE: [Ipoverib] 4/9 deadline for a consensus call

Roy

-----Original Message-----
From: Michael Krause [mailto:[email-masked]]
Sent: Monday, April 08, 2002 7:22 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Ipoverib] 4/9 deadline for a consensus call

Mike

---

From: Vivek Kashyap <[email-masked]>
Date: Wed, 10 Apr 2002 13:34:09 -0700 (PDT)

I agree with Pete. I too don't see any benefit in adding type field
in the payload.

Vivek

-- 
Vivek Kashyap
Linux Technology Center, IBM
[email-masked] 
[email-masked] 
503 578 3422 (o)

---

From: Pete Zaitcev <[email-masked]>
Date: Wed, 10 Apr 2002 18:36:05 -0400

I think you saw a typical "first mail" blunder from me. Naturally
I expected that different QPNs would be used for IPv4 and ARP,
but since then I observed that it is not so. The clause 6.1.1
says "All IP communication to the relevant IPoIB interface
MUST be directed to this QPN. In the case of IPv4 subnets
[...] ARP reply packets are also directed to the same QPN".

Please discount my mail. I hope I did not cause you to blow
the 4/9 deadline?

-- Pete

> Date: Mon, 8 Apr 2002 11:19:00 -0700
> From: Bill Strahm <[email-masked]>

---

From: Bill Strahm <[email-masked]>
Date: Wed, 10 Apr 2002 15:42:14 -0700

I'd just like to be very clear here, since we are going for concensus
here...
Can I get you (And anyone else who wants to chime in as well) to complete
the following sentence

I am [for|against] including the Ethertype header in the IPoIB encapsulation
draft.

That way Jerry and I do not have to try to interpret very differing
language and guess at what people are really trying to say...

Bill