Subject: RE: [Ipoverib] moving forward

From: "H.K. Jerry Chu" <[email-masked]>
Date: Fri, 31 May 2002 13:22:54 -0700 (PDT)

>I think the encapsulation draft is in good shape.  The only remaining
>clarification I would like to see is explicit memory layout in those figures
>containing more than one byte.  For example, in figure 3, is the Reserved
>byte MSB or LSB? 

All the figures are in network byte-order (big endian).

>I have been assuming it has been MSB->LSB but that isn't
>true for figure 2.

I'm confused. I thought all the IB spec. follow the networking
convention too.

>Do we also need to make an explicit statement about
>endian-ness for multi-byte values?

No. The convention is network byte order.

Jerry

>
>WRT multicast, I don't think we have much choice other than to proceed as
>you suggest.  For those that want to make forward progress in development
>until conformant CAs and SMs are available, we can temporarily equate
>multicast to broadcast.
>
>Roy
>
>-----Original Message-----
>From: H.K. Jerry Chu [mailto:[email-masked]]
>Sent: Wednesday, May 29, 2002 9:32 PM
>To: [email-masked]
>Subject: [Ipoverib] moving forward
>
>
>For the past month or so IBTA has been working on resolving
>a number of multicast related IB issues (summarized below)
>that affect how IPoIB operates.
>
>1. a "join-to-send" operation that is required for a multicast
>sender that is not already a member of the target multicast
>group.
>
>2. a facility to enable an IB client (e.g. the IPoIB driver) to
>be notified when a new IB multicast group is created, or an
>existing one is deleted.
>
>3. a facility to allow the software emulation of the promiscuous
>multicast mode.

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: Vivek Kashyap <[email-masked]>
Date: Fri, 31 May 2002 13:26:05 -0700 (PDT)

Yes, everything including IBA is in network byte order.

Vivek

-- 
Vivek Kashyap
Linux Technology Center, IBM
[email-masked] 
[email-masked] 
503 578 3422 (o)