Subject: [Ipoverib] Yokohama IETF

From: Jerry Chu <[email-masked]>
Date: Thu, 27 Jun 2002 15:56:40 -0700

With the Yokohama meeting fast approaching, it is
time to prepare for the agenda. We need to first
decide if there are enough topics to discuss. What I
need from you are -

1. how many of you are planning to attend the meeting
2. how many have slides to present (including the topic)

Please let me know asap. Even if you can't make it to
Yokohama in person, you can still make slides and give
them to me. I will present the slides on your behalf.

On a separate topic, the three basic drafts for IPoIB communication
listed below

draft-ietf-ipoib-link-multicast-02.txt
draft-ietf-ipoib-ip-over-infiniband-01.txt
draft-ietf-ipoib-dhcp-over-infiniband-01.txt

have gone through several rounds of review and seem
to be in pretty good shape for a WG last call, pending
the resolution of the promisucous multicast mode
support. Bill and I would like to see if there is
enough interest to extend the current WG chart to
cover a number of more advanced features such as

1. running IP over non-UD IB transports
2. demultiplexing IP packets into multiple QPs based
on, e.g. layer 4 fields

This is the time to bring up any remaining topics
you may have for the WG to cover. Note that in order
to get the permission from the ADs to add any work
group item to the current charter, the item must be well-defined and
scoped, with enough interest from the WG to support the work.

Your friendly co-chairs
Jerry and Bill

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: Yaron Haviv <[email-masked]>
Date: Fri, 28 Jun 2002 02:36:19 +0200

Jerry,

Regarding the extra topics:
I think the IPoIB over RC is important to improve both performance and
robustness

The demuxing to few QP's might be useful too for some applications

Another thing that IB ARP can help in is detecting SDP (Socket Direct)
clients e.g. through a capability bit
I'm not sure if it requires changes in the WG charter

Yaron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Jerry Chu
Sent: Friday, June 28, 2002 12:57 AM
To: ipoverib
Subject: [Ipoverib] Yokohama IETF

Your friendly co-chairs
Jerry and Bill

---

From: Vivek Kashyap <[email-masked]>
Date: Thu, 27 Jun 2002 16:45:03 -0700 (PDT)

Jerry, Yaron,

        As you know these ideas have been proposed by me in the draft:

	draft-kashyap-ipoib-advanced-capabilities-00.txt.

	I had presented a set of slides at IETF-53. See slides 16 to 24 at:

	http://www.ietf.org/proceedings/02mar/slides/ipoib-1/index.html

Vivek

PS. I won't be attending IETF-54.

-- 
Vivek Kashyap
Linux Technology Center, IBM
[email-masked] 
[email-masked] 
503 578 3422 (o)

---

From: Yaron Haviv <[email-masked]>
Date: Fri, 28 Jun 2002 22:03:36 +0200

Vivek,

Maybe we can add to the IPoIB RC a feature we once discussed
For TCP/UDP checksum offloading no need to specify the exact method now
Just mention it is a possible future goal

Yaron

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Vivek Kashyap
Sent: Friday, June 28, 2002 1:45 AM
To: [email-masked]
Cc: 'Jerry Chu'; 'ipoverib'
Subject: Re: [Ipoverib] Yokohama IETF

Jerry, Yaron,

Vivek