Subject: RE: [Ipoverib] I-D ACTION:draft-ietf-ipoib-channel-adapter-mib-02 .txt

From: Larry Butler <[email-masked]>
Date: Fri, 26 Jul 2002 08:58:54 -0700

Dear IPoIB WG,

I have a couple of very minor comments on the Channel Adapter MIB in
addition to those I made earlier.

I'd like to suggest that ibCaHasSubnetManager (OBJECT-TYPE ::= {
ibCaAttrInfo 14 }) be changed to ibCaSupportsSubnetManager. The DESCRIPTION
section says "Flag that indicates whether this CA supports a Subnet Manager
(SM) instance." From an implementation perspective, host based systems may
not be able to easily tell if they "have" a Subnet Manager running as this
is a process that may not be visible at the CA level. But they will know if
they have the capabilities to run a Subnet Manager on the CA.

There are typographical errors in the REFERENCE section of
ibCaSupportsMultipathing (OBJECT-TYPE ::= { ibCaPortAttrInfo 6 }. The
REFERENCE section should read, "InfiniBand Architecture Release 1.0.a Vol 1.
Section 17.2.1.3 and Table 255. Also, Section 7.11.1 Multipathing
Requirements on End Node."

There are typographical errors in the REFERENCE section of
ibCaValidatesInPktDlid (OBJECT-TYPE ::= { ibCaPortAttrInfo 7 }. The
REFERENCE section should read, "InfiniBand Architecture Release 1.0.a Vol 1.
Section 17.2.1.3 and Table 255."

There are typographical errors in the REFERENCE section of
ibCaMaxGidsPerPort (OBJECT-TYPE ::= { ibCaPortAttrInfo 8 }. The REFERENCE
section should read, "InfiniBand Architecture Release 1.0.a Vol 1. Section
17.2.1.3 and Table 255." I'd also like to suggest that adding an additional
statement to the DESCRIPTION (for clarification), "Each port will support at
least one (1) GID." Which brings me to another suggestion, that perhaps the
SYNTAX should be changed to Integer32(1..65535) so that the lower bound of 1
is checked? These are the same bounds applied to ibCaPortGidIndex
(OBJECT-TYPE ::= { ibCaPortGidEntry 2 }).

Thanks,

Larry Butler
JNI Corporation
10945 Vista Sorrento Parkway
San Diego, CA 92130
858-523-7149 

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: [email-masked]
Date: Fri, 26 Jul 2002 17:52:10 +0000

Hello Sean and Larry - 

Just 2 brief comments marked [whs].
 --
Bill Swortwood     Sr. Software 
Architect                                
OmegaBand Inc.
(512) 401-8208 X144 (Office)
(512) 401-8268      (Fax)
(512) 431-2876      (Cell)
9020-I Capital of Texas Highway North,
Suite 270 Austin, TX. 78759
Email : [email-masked]
Web:  http://www.omegaband.com
Obligatory Famous Quote : "It's all just code..."
> they have the capabilities to run a Subnet Manager on the CA.

[whs] The CA via the verbs layer is set by the SM to advertise 
the existence of itself to the outside world. From an InfiniBand 
perspective to the IB fabric it is an imperative to advertise
the existence of the SM running via the CA's SMA in the
PortInfo CababilityMask:IsSM bit. If this MIB is a reflection
of the state and intent of the SMA then I think Sean's
naming is correct.

> Requirements on End Node."

[whs] Mike Krause pointed out that a majority of vendors
are looking to standardize on the upcoming 1.1 version 
of the specification. What might make sense is that we
hold our fire on references until then, as we might
have to change these yet again. Sean has done a massive
amount of work putting these in to begin with; I'd 
keep a note of this, but wait until 1.1 so that we 
don't waste "Sean cycles".

---

From: "Rosenstock, Hal" <[email-masked]>
Date: Fri, 26 Jul 2002 10:00:50 -0400

Hi,

I have a few comments on the Channel Adapter MIB.

Specific comments on what is in the MIB:

It appears there is one port GUID per CA (ibCaPortGuid) but isn't this per
CA port ? Should this be moved 
into ibCaPortAttrInfo ?

In ibCaPortAttrInfo, rather than 3 separate truth values for type of
physical interface, why not one enumerated value with the three types ? 

As multipathing is required, by ibCaSupportsMultipathing, I presume you are
referring to LMC not 0 as it appears that is included in the IBA definition
of multipathing.

Isn't ibCaValidatesInPktDlid a requirement so why is this needed ?

What about the optional inbound PKey checking ? Shouldn't there be
ibCaInboundPkeyChecking ?

Also, a couple of comments on what might be added:

There are other CA parameters which could be added. Things like number of
QPs, number of WQEs, number of CQs supported, number of EECs, max message
size, class of fault behavior, ... If this is a direction which is of
interest, I can provide a better list of these.

Will ibCaSystemImageGuid be added in for IBA 1.1 ? (There may also be some
other 1.1 things to add).

Thanks.

-- Hal

---

From: "Rosenstock, Hal" <[email-masked]>
Date: Fri, 26 Jul 2002 12:05:50 -0400

Hi again,

I have another comment on the CA MIB.

I am not sure why the SM is singled out (ibCaHasSubnetManager). Indication
of whether any of the other optional managers (PerfMgr, BM, DM, ...) are
supported should also be indicated.

-- Hal

---

From: [email-masked]
Date: Fri, 26 Jul 2002 21:31:55 +0000

I think the reason for this is that the CA itself does 
have a mechanism to advertise the SM via it's on the IB 
subnet  query mechanisms, but other managers are assumed 
to advertise as ServiceRecords with the SA. Now if we 
had a SA MIB, I suppose we could look there for a few
items of interest..... ;^ )

--
Bill Swortwood 
Sr. Software Architect                                
OmegaBand Inc.

---

From: [email-masked]
Date: Fri, 26 Jul 2002 22:38:26 +0000

There are instances that the location of a manager is not
desired to be advertised, as in the case of a B1 
implementation of, say, a security service. Yes, that is 
esoteric, but some companies have expressed the desire 
to do something like this. To each his own.

The managers in IB are somewhat relative -- there could 
be a number of device managers, for example, which
are defined relatively to each port via settings in
each Manager classes ClassPortInfo attribute. So the
advertisement is on the lines of "I am your 
device manager". If one was paranoid, one could
choose to just tell the device agent but not the
SA as to a device manager's location.

Personally I would find an SA MIB useful. There was
an SM MIB proposed by TopSpin, this was dropped, 
apparently, not clear on the particulars. It was
not in Sean's charter presentation. An SA MIB
would provide a fairly complete mapping of the IB  
fabric universe, and also provide hours of entertainment 
for those writing all of the table mechanisms:-)

There was also a Device Management MIB, I have 
converted this to SMIv2, but have not republished 
as I had not gotten a lot of feedback on it. There
was also no charter for this, either. 

> Hi Bill,
> 
> Not even all managers register themselves. When I saw your last response on
> verbs (and standard interfaces), I could see the rational here. It was just
> a thought on things we might want to know about a CA, but unfortunately the
> information is from many different places, some of which may not be
> standardized
> in IB. Does that mean it shouldn't be in an IETF MIB ?
> 
> Also, your point about an SA MIB reminds me, whatever did happen to the SM
> MIB ?
> Is it out of scope with the current charter ?
> 
> -- Hal
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, July 26, 2002 5:32 PM
> To: Rosenstock, Hal
> Cc: [email-masked]
> Subject: RE: [Ipoverib] I-D
> ACTION:draft-ietf-ipoib-channel-adapter-mib-02 .txt
> 
>

---

From: "Rosenstock, Hal" <[email-masked]>
Date: Fri, 26 Jul 2002 18:10:15 -0400

Hi Bill,

-- Hal