Subject: RE: [Ipoverib] new charter statement

From: Larry Butler <[email-masked]>
Date: Wed, 30 Oct 2002 08:01:00 -0800

I see a need for the SM and SA MIBs allowing SNMP network management to gain
read-only access to the objects representing the IB subnet. This need is
based upon real customer demand. Having MIB access to each SM/SA allows
management a view at the IB subnet level, while MIB access to the IB
interface, Channel Adapter and SMA/GSI Agents provides a node level view.
Additional GSI Agent MIBS are nice too.

Larry

-----Original Message-----
From: H.K. Jerry Chu [mailto:[email-masked]]
Sent: Monday, October 28, 2002 6:46 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ipoverib] new charter statement

Sean Harnedy actually brought up to me and Bill a few other MIBs
that may be of interest to the WG. They are

SM (Subnet Manager) MIB
SA (Subnet Adminstration) MIB
other General Services Agent MIBs (device MIB, connection MIB)

If we can determine the interest level from the WG on these MIBs
now, we may be able to decide whether to include them in this
round. Otherwise they will have to wait later.

Any comments?

Jerry

>From: "Rosenstock, Hal" <[email-masked]>
>To: "H.K. Jerry Chu" <[email-masked]>
>Cc: [email-masked], [email-masked]
>Subject: RE: [Ipoverib] new charter statement
>Date: Mon, 28 Oct 2002 15:41:23 -0500
>MIME-Version: 1.0
>
>Hi,
>
>Should a SA (Subnet Administration) MIB be in scope for the new IPoIB
>charter as well ?
>
>Thanks.
>
>-- Hal
>
>-----Original Message-----
>From: H.K. Jerry Chu [mailto:[email-masked]]
>Sent: Thursday, October 24, 2002 4:38 PM
>To: [email-masked]
>Cc: [email-masked]
>Subject: [Ipoverib] new charter statement
>
>
>The following is the proposed new WG charter statement. Changes are
>made to reflect the latest status on various WG documents, and also
>to include a new work item. (See Work items 5 below.)
>
>Please take a look at the proposed charter, and send your comments
>in before COB Monday 10/28/02 5pm EST. I'd like to submit the new
>charter to the IESG for review/approval asap.
>
>Note that among all the new proposals, only the "encapsulation over
>IB connected transports" is adopted. The rest are dropped due to
>either lack of interest from the WG, or other architectural concerns.
>
>Jerry & Bill,
>IPoIB WG co-chairs
>
>--------------------------------------------------------------------
>Description of Working Group:
>
>InfiniBand is an emerging standard intended as an interconnect for
>processor and I/O systems and devices (see the Infiniband Trade
>Association web site at http://www.infinibandta.org for details). IP
>is one type of traffic (and a very important one) that could use this
>interconnect. InfiniBand would benefit greatly from a standardized
>method of handling IP traffic on IB fabrics. It is also important to
>be able to manage InfiniBand devices in a common way.
>
>This working group has two tasks:
>
>  - specify the protocols and encapsulations to transport IPv4/v6 over
>    an InfiniBand fabric.
>
>  - specify a set of MIB objects to allow management of the InfiniBand
>    fabric itself.
>
>The initial scope of the WG was limited to the use of the basic IB
>Unreliable Datagram (UD) transport mode for transporting IP over
>Infiniband. With that work mostly done, the scope has been extended to
>develop an optional mechanism for transporting IP over other IB
>transport modes. In particular, there is a desire to transport IP over
>one or both of IB's connected modes, which enable the use of a much
>larger MTU than the IB link MTU size. They also provide improved
>reliability and performance through the use of link level orderly and
>reliable delivery, and IB's automatic path migration (APM) feature.
>
>Other more advanced functionalities such as mapping IP QOS into IB-specific
>capabilities remain out of scope of the WG charter.
> 
>Work items
> 
>1. Specify standards track procedures for transporting IP over
>IB. This includes:
>
>  - supporting ARP/ND packets in order to map IP addresses into IB
>    link-layer addresses.
>  - define encapsulations for carrying ARP, IPv4 and IPv6
>    packets over IB
>  - Define  how to transport IP multicast over IB. 
> 
>2. Specify a standards track channel adapter MIB that allows
>management of an InfiniBand channel adapter. There will require that
>InfiniBand types be added to the ifType defined by IANA
> 
>3. Specify a standards track baseboard management MIB that will allow
>management of specified device properties
> 
>4. Specify sample counter MIBs to allow InfiniBand sample counters to be
>exposed to external SNMP management applications
> 
>5. Specify an optional, standards track encapsulation for carrying IPv4
>and IPv6 packets over either IB unreliable connections or reliable
>connections.
> 
>Goals and Milestones:
> 
> Done        Submit initial Internet-Draft of ARP encapsulation
> Done        Submit initial Internet-Draft of Requirements/Overview
> Done        Submit initial Internet-Draft of IP V4/V6 Encapsulation
> NOV 02      Submit initial Internet-Draft of Advanced Encapsulation over
>Connected Transports
> Done        Submit initial Internet-Draft of Infiniband-Like MIB
> Done        Submit initial Internet-Draft of Channel Adapter MIB
> Done        Submit initial Internet-Draft of Multicast
> Done        Submit initial Internet-Draft of Baseboard MIB
> MAR 03      Submit initial Internet-Draft of Sample Counter MIB
> Done        Submit initial Internet-Draft of Subnet Mangement MIB
> Done        Submit ARP/IP/Multicast encapsulation drafts for IESG Last
>             Call
> MAR 03      Submit Advanced Encapsulation draft for IESG Last Call
> MAR 03      Submit Infiniband-Like MIB for IESG Last Call
> MAR 03      Submit Channel Adapter MIB for IESG Last Call
> 
>Internet-Drafts:
> 
>Definitions of Managed Objects for Infiniband Interface Type (63237 bytes)
>Definition of Managed Objects for the Infiniband Subnet Management Agent
>(SMA) (130205 bytes)
>Definition of Textual Conventions and OBJECT-IDENTITIES for IP Over
>InfiniBand (IPOVERIB) Management (23269 bytes)
>IP link and multicast over InfiniBand networks (27638 bytes)
>IP encapsulation and address resolution over InfiniBand networks (27997
>bytes)
>DHCP over InfiniBand (12532 bytes)
>Definitions of Managed Objects for Infiniband Channel Adapters (CA) (40642
>bytes)
>Definitions of Managed Objects for the Infiniband Baseboard Management
Agent
>(BMA) (82455 bytes)
> 
>No Request For Comments
>
>
>_______________________________________________
>IPoverIB mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ipoverib

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib
_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: "Bill Strahm" <[email-masked]>
Date: Wed, 30 Oct 2002 13:07:32 -0800

Did I just hear a volunteer to write these MIBs ???

Almost just kidding.  The real problem in the management area is there
just aren't enough people to write and update the documents.  I would
really like Sean to be able to get done with some of his documents
before adding more workload.  In the IETF sometimes (many times) it
boils down to if you want it, write it and you will get help pushing it
through and reviewing it.  That said, if you are interested, I can help
get the documents on the charter and placed on agendas

Bill

-----Original Message-----
From: Larry Butler [mailto:[email-masked]] 
Sent: Wednesday, October 30, 2002 8:01 AM
To: 'H.K. Jerry Chu'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ipoverib] new charter statement

I see a need for the SM and SA MIBs allowing SNMP network management to
gain read-only access to the objects representing the IB subnet. This
need is based upon real customer demand. Having MIB access to each SM/SA
allows management a view at the IB subnet level, while MIB access to the
IB interface, Channel Adapter and SMA/GSI Agents provides a node level
view. Additional GSI Agent MIBS are nice too.

Larry

-----Original Message-----
From: H.K. Jerry Chu [mailto:[email-masked]]
Sent: Monday, October 28, 2002 6:46 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ipoverib] new charter statement

Sean Harnedy actually brought up to me and Bill a few other MIBs that
may be of interest to the WG. They are

SM (Subnet Manager) MIB

If we can determine the interest level from the WG on these MIBs now, we
may be able to decide whether to include them in this round. Otherwise
they will have to wait later.

Any comments?

Jerry

>made to reflect the latest status on various WG documents, and also to 
>include a new work item. (See Work items 5 below.)
>
>Please take a look at the proposed charter, and send your comments in 
>before COB Monday 10/28/02 5pm EST. I'd like to submit the new charter 
>to the IESG for review/approval asap.
>
>Note that among all the new proposals, only the "encapsulation over IB 
>connected transports" is adopted. The rest are dropped due to either 
>lack of interest from the WG, or other architectural concerns.
>
>Jerry & Bill,
>IPoIB WG co-chairs
>
>Association web site at http://www.infinibandta.org for details). IP is

>one type of traffic (and a very important one) that could use this 
>method of handling IP traffic on IB fabrics. It is also important to be

>able to manage InfiniBand devices in a common way.
>
>Other more advanced functionalities such as mapping IP QOS into 
>IB-specific capabilities remain out of scope of the WG charter.
> 
>Work items
> 
>1. Specify standards track procedures for transporting IP over IB. This

>includes:
>2. Specify a standards track channel adapter MIB that allows management

>of an InfiniBand channel adapter. There will require that InfiniBand 
>types be added to the ifType defined by IANA
> 
>4. Specify sample counter MIBs to allow InfiniBand sample counters to 
>be exposed to external SNMP management applications
> 

>Definitions of Managed Objects for Infiniband Interface Type (63237 
>bytes) Definition of Managed Objects for the Infiniband Subnet 
>Management Agent
>(SMA) (130205 bytes)
Agent
>[email-masked] https://www1.ietf.org/mailman/listinfo/ipoverib

_______________________________________________
IPoverIB mailing list
[email-masked] https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: "Bill Strahm" <[email-masked]>
Date: Wed, 30 Oct 2002 13:07:32 -0800

Bill

-----Original Message-----
From: Larry Butler [mailto:[email-masked]] 
Sent: Wednesday, October 30, 2002 8:01 AM
To: 'H.K. Jerry Chu'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ipoverib] new charter statement

Larry

-----Original Message-----
From: H.K. Jerry Chu [mailto:[email-masked]]
Sent: Monday, October 28, 2002 6:46 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [Ipoverib] new charter statement

SM (Subnet Manager) MIB

Any comments?

Jerry

Agent