Subject: RE: [Ipoverib] IPv4 Directed Broadcast

From: "Rosenstock, Hal" <[email-masked]>
Date: Tue, 3 Dec 2002 13:54:43 -0500

Hi Vivek,

That takes care of net directed and all subnet directed broadcast. Is the
same true of 
subnet directed broadcast ? Are these also on the same broadcast group with
the
hosts filtering them if they do not match the subnet ? I presume that is how
it needs to
work based on your statement that all IP broadcasts use the broadcast group.

Thanks. 

-- Hal

-----Original Message-----
From: Vivek Kashyap [mailto:[email-masked]]
Sent: Tuesday, December 03, 2002 1:24 PM
To: Rosenstock, Hal
Cc: [email-masked]; [email-masked]
Subject: Re: [Ipoverib] IPv4 Directed Broadcast

Hal,

The broadcast-group is a link-layer broadcast address (the equivalent of
all 1's ethernet address). The broadcast group is used for any kind of IP
broadcast. The rest of the mapping is for IP  multicast addresses only.

For example:
      10.255.255.255 or 255.255.255.255 are both broadcasts and should map
to the Broadcast group -> FF12:401B:<P_Key>::255.255.255.255

      But:
      Multicast address 225.0.0.1 will map to the GID derived as per the
rules in the draft t -> FF12:401B:<P_Key>::1.0.0.1

Vivek
--
Vivek Kashyap
Linux Technology Center, IBM
[email-masked]
[email-masked]
Ph: 503 578 3422 T/L: 775 3422

                      "Rosenstock, Hal"

                      <hal@pacelinesyst        To:       [email-masked]

                      ems.com>                 cc:

                      Sent by:                 Subject:  [Ipoverib] IPv4
Directed Broadcast                                            
                      ipoverib-admin@ie

                      tf.org

                      12/03/2002 05:28

                      AM

> Hi,
>
> In IPv4, there are two forms of directed broadcast (net directed and
> subnet directed). In draft-ietf-ipoib-link-multicast-02.txt, section 7 on
> The IPoIB Broadcast Group states "The broadcast group for IPv4 will serve
> to provide a broadcast service for protocol like ARP to use.." Is it
> correct to assume that this also includes (IPv4) directed broadcasts as
> well (rather than forming additional IB multicast groups out of the low
28
> bits of the IP address for this purpose) ? If so, should this be added to
> clarify the spec ?
>
> Thanks.
>
> -- Hal
_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: Vivek Kashyap <[email-masked]>
Date: Tue, 3 Dec 2002 16:26:43 -0800 (Pacific Standard Time)

> work based on your statement that all IP broadcasts use the broadcast group.

Yes, that is correct. The underlying reason is that any IP broadcast,
whether limited or directed (net, subnet, or all-subnets) are broadcast
on the local link, and therefore use the link-layer broadcast address.

Vivek

> rules in the draft t -> FF12:401B:<P_Key>::1.0.0.1

__

Vivek Kashyap

---

From: Vivek Kashyap <[email-masked]>
Date: Tue, 3 Dec 2002 16:26:43 -0800 (Pacific Standard Time)

Vivek

__

Vivek Kashyap