Subject: RE: [Ipoverib] Please read - proposed WG termination

From: Carl Hensler <[email-masked]>
Date: Mon, 29 Aug 2005 19:48:21 -0700 (PDT)

The IETF process is so unwieldy that I think we should just let
the WG terminate.  I think further IB standardization should take 
place in IBTA or OpenIB, where people actually care about IB.

Carl

> Subject: RE: [Ipoverib] Please read - proposed WG termination
> Date: Mon, 29 Aug 2005 21:02:51 +0300
> Thread-Topic: [Ipoverib] Please read - proposed WG termination
> From: "Yaron Haviv" <[email-masked]>
> To: "H.K. Jerry Chu" <[email-masked]>, <[email-masked]>
> X-Spam-Score: 0.0 (/)
> X-Scan-Signature: cf3becbbd6d1a45acbe2ffd4ab88bdc2
> Cc: [email-masked], [email-masked]
> List-Id: IP over InfiniBand WG Discussion List <ipoverib.ietf.org>
> List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/ipoverib>, 
<mailto:[email-masked]?subject=unsubscribe>
> List-Post: <mailto:[email-masked]>
> List-Help: <mailto:[email-masked]?subject=help>
> List-Subscribe: <https://www1.ietf.org/mailman/listinfo/ipoverib>, 
<mailto:[email-masked]?subject=subscribe>
> 
> Jerry,
> 
> I believe there is one issue that deserves further attention
> Which is delivering highly available IPoIB solutions 
> 
> In traditional GbE MAC faking techniques can be used to fail over
> between hosts or between routers (e.g. VRRP)
> Unfortunately this is not applicable to IPoIB (given the IB routing & SA
> structure)
> 
> Going into more commercial/enterprise environments this becomes a real
> necessity, today some vendors (including us) use proprietary solutions
> however a standard approach is required 
> 
> I proposed few directions in the pass to address the problem, e.g. using
> UNARP (like Sonet does) or using the SA/SM 
> 
> Yaron
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On
> > Behalf Of H.K. Jerry Chu
> > Sent: Monday, August 29, 2005 1:38 PM
> > To: [email-masked]
> > Cc: [email-masked]; [email-masked]
> > Subject: [Ipoverib] Please read - proposed WG termination
> > 
> > Hi folks,
> > 
> > With the DHCP over IB draft in IESG's hand, we are done with all
> > the basic IPoIB work, including the architecture (informational),
> > encapsulation, and DHCP (standard tracked). Now seems a good time
> > to decide the next step for the WG.
> > 
> > The work on IPoIB connected mode and most of the MIB drafts started
> > a while back (2003/2002). Over the years the interest/participation
> > level on these work has not been high, and now the work seems to drag
> > on indefinitely. The AD has recently questioned whether the remaining
> > work should be continued or not.
> > 
> > The following is a quick update on their status:
> > 
> > 1. IPoIB connected mode
> > draft-ietf-ipoib-connected-mode-00.txt
> > updated recently
> > 
> > 2. MIB drafts
> > IPoIB Textual Conventions MIB
> > draft-ietf-ipoib-ibmib-tc-mib-06.txt
> > 
> > IPoIB InfiniBand Interfaces MIB
> > draft-ietf-ipoib-ibif-mib-07.txt
> > 
> > IPoIB subnet Management Agent MIB
> > draft-ietf-ipoib-subnet-mgmt-agent-mib-07.txt
> > 
> > IPoIB Channel Adapter MIB
> > draft-ietf-ipoib-channel-adapter-mib-06.txt
> > 
> > IPoIB Baseboard Management Agent MIB
> > draft-ietf-ipoib-baseboard-mgmt-agent-mib-02.txt
> > 
> > IPoIB performance Management Agent MIB
> > draft-ietf-ipoib-perf-mgmt-agent-mib-03.txt
> > 
> > The above 6 MIB drafts have gone through the
> > MIB doctor (Randy Presuhn) review late 2003 and
> > updated accordingly. All the updated drafts expired
> > in April 2005.
> > 
> > 3. IPoIB Subnet Manager MIB
> > draft-ietf-ipoib-subnet-manager-mib-00.txt
> > 
> > Submitted 3/2004 but has expired too.
> > 
> > If you want to see any of the above work continue in the WG,
> > AND is willing to participate to get the work completed, please
> > speak up NOW! You will have until Sep. 20 to do so. After
> > that unless there is evidence a "sufficient" interest level
> > on any of the work above still exists, the WG will be disbanded
> > (or become dormant in order to handle the on-going work on
> > the standard-tracked RFCs) and the unfinished work abandoned.
> > 
> > Note that authors of the above drafts may choose to resubmit
> > their drafts as individual submissions if they want to continue
> > to pursue their work at IETF.
> > 
> > Thank you!
> > 
> > Jerry & Bill
> > 
> > IPoIB co-chairs
> > 
> > 
> > _______________________________________________
> > IPoverIB mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ipoverib
> 
> _______________________________________________
> IPoverIB mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ipoverib
> 

_______________________________________________
IPoverIB mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ipoverib

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Tue, 30 Aug 2005 07:49:03 +0200

Three comments from the peanut gallery:

- Standardization of purely Infiniband functions shouldn't happen in the 
IETF.
I have no particular opinion on whether failover for IPoIB is a purely 
Infiniband function.

- Closing the WG doesn't prevent people from pushing the MIBs and CM draft 
through the IETF process - they just have to be finished, and then the 
author can ask for publication as a Proposed standard as an individual 
contribution.

- Like most other endeavors, an IETF WG grinds to a halt when there are no 
people actively participating who care. Being an open organization with no 
formal membership also means that people very informally leave....

                       Harald