Subject: RE: IPP> Host to device

From: [email-masked]
Date: Fri, 3 Apr 1998 17:03:18 -0500

Charles:

TCP/IP is the inbound transport from the client to the server.  We are
talking here about the server to the printer.  That connection could be
anything.  This discussion is certainly appropriate for the Printer Working
Group chartered IPP group.  While the IETF can pretend that only TCP/IP is
used for communication, the reality is that most printers are not connected
to computers using TCP/IP.

**********************************************
* Don Wright                 [email-masked] *
* Product Manager, Strategic Alliances       *
* Lexmark International                      *
* 740 New Circle Rd                          *
* Lexington, Ky 40550                        *
* 606-232-4808 (phone) 606-232-6740 (fax)    *
**********************************************

To:   Don Wright@Lexmark, [email-masked]
cc:   [email-masked],
      [email-masked]
bcc:
Subject:  RE: IPP> Host to device

Given that IPP is the Internet Printing Protocol, do we really need to
support anything else besides TCP/IP?  Is the IPP working group even
mandated to worry about non TCP/IP environments?
                         --- Charles
> -----Original Message-----
> From:   [email-masked] [SMTP:[email-masked]]
> Sent:   Friday, April 03, 1998 4:22 PM
> To:     [email-masked]
> Cc:     [email-masked]; [email-masked]
> Subject:     RE: IPP> Host to device
>
>
> Randy:
>
> My biggest concern is that your proposal is TCP/IP only.  Is does not
> solve
> the problem for printers connected to servers via:
>
> - Parallel
> - Serial
> - USB
> - 1394
> - IPX/SPX
> - AppleTalk
> - DLC/LLC
> - etc., etc., etc.
>
> If I'm going to use TCP/IP then I might as well go ahead with the HTTP
> based implementation.  You don't provide more status and control or
> anything else that really buys me anything other than a slightly
> lighter
> transport.  It's just not work the trouble for the return on
> investment.
>
> Don
>
> **********************************************
> * Don Wright                 [email-masked] *
> * Product Manager, Strategic Alliances       *
> * Lexmark International                      *
> * 740 New Circle Rd                          *
> * Lexington, Ky 40550                        *
> * 606-232-4808 (phone) 606-232-6740 (fax)    *
> **********************************************
>

---

From: Jay Martin <[email-masked]>
Date: Fri, 03 Apr 1998 17:14:54 -0500

I was really hoping the IPP WG would be constrained to *only*
handling print requests over the "Internet", and that the more
functional host-to-device protocol would be addressed via a
different project within the PWG (or WG under the IETF, if that's
preferred).

If I read Roger's approach correctly, it would appear that TIP/SI
is being used as nothing more than a thin wrapper around IPP in
exactly the same manner as the HTTP approach.  This is highly
undesirable, IMHO.

	...jay

----------------------------------------------------------------------
--  JK Martin               |  Email:   [email-masked]          --
--  Underscore, Inc.        |  Voice:   (603) 889-7000              --
--  41C Sagamore Park Road  |  Fax:     (603) 889-2699              --
--  Hudson, NH 03051-4915   |  Web:     http://www.underscore.com   --
----------------------------------------------------------------------