Subject: RE: IPP> Re: New IPP Scheme

From: [email-masked]
Date: Fri, 17 Jul 1998 09:06:26 -0700 (PDT)

Make this port or ports - you can listen on multiple ports...

Patrick

i.e. -

It is REQUIRED that a printer implementation support HTTP over
the IANA assigned Well Known Port 631 (the IPP default port),
though a printer implementation may be configured to listen
on some other port(s) instead." 
                      
>     -Carl

---

From: "Carl Kugler" <[email-masked]>
Date: 17 Jul 1998 16:45:04 -0000

> on some other port(s) instead." 

Still not quite right:  the "other" seems exclusive of 631, but in the multiple ports case, 631 might be included.

> >     -Carl
 
Here's another try:

Replace:

    It is REQUIRED that a printer implementation support HTTP over the IANA assigned Well Known Port 631 (the IPP default port), though a printer implementation may support HTTP over port some other port as well.  In addition, a printer may have to support another port for privacy (See Section 5 “Security Considerations”. 
Note: even though port 631 is the IPP default, port 80 remains the default for an HTTP URI.  Thus a URI for a printer using port 631 MUST contain an explicit port, e.g. "http://forest:631/pinetree".

with:

IANA has assigned Well Known Port 631 to the default IPP port number.  An IPP server listens on port 631 unless explicitly configured to listen on one or more ports instead of, or in addition to, port 631.  If the port is empty or not given in an "ipp" schemed URL, port 631 is assumed.

    -Carl

-----
Original Message: http://www.findmail.com/list/ipp/?start=4154
Start a FREE email list at http://www.FindMail.com/