Subject: RE: RE: IPP> Identifying jobs in requests

From: Robert Herriot <[email-masked]>
Date: Mon, 08 Jun 1998 13:24:08 -0700

Charset clearly needs to be at the beginning so that a receiving process 
knows how to decode string fields before it encounters any of them.  The 
charset field is a string field, but the names are all ASCII so the decoding 
need not be known for the class of encodings that IPP support. BTW, XML puts 
charset at the beginning for the same reason.

Natural language is the next most important value because it specifies the 
language of any text or name field.  Processing is easier if the implicit 
language is known at the time a text or name field is encountered. XML has 
similar rules for language.

The printer-uri/job-uri/job-id should be easy to find if it not in the 
enclosing layer.  For HTTP, the position of the target isn't important 
because the target is redundant. The position would be important for a 
transport where the target is specified only in IPP layer.

So that's the reasoning. Do you agree?

Bob Herriot

At 11:42 AM 6/8/98 , Paul Moore wrote:
>I obviously missed this one. So 'special position' means that literally. I
>thought it mean 'special purpose'. 
>
>For my interest. Why are we putting things in special positions?
>
>> -----Original Message-----
>> From:        Robert Herriot [SMTP:[email-masked]]
>> Sent:        Friday, June 05, 1998 8:46 PM
>> To:  Paul Moore; 'Carl Kugler'; [email-masked]
>> Subject:     RE: RE: IPP> Identifying jobs in requests
>> 
>> We agreed recently that the following operation attributes would be
>> ordered.
>>     attributes-charset (always first for requests and responses)
>>     attributes-natural-language (always second for requests and response)
>>     printer-uri or job-uri (always third for requests, though we are
>> discusses whether it should be present)
>>     job-id (always fourth for requests if present )
>> 
>> At 05:00 PM 6/5/98 , Paul Moore wrote:
>> >       I think we are approaching group consensus on this.  I propose
>> that
>> >we remove "printer-uri" and "job-uri" as request Operation attributes,
>> but
>> >leave them in their special position in the protocol.  
>> >
>> >       [Paul Moore]  What 'special position'? 
>> > 
>> 
>

---

From: "Carl Kugler" <[email-masked]>
Date: 8 Jun 1998 21:35:39 -0000

> --=====================_6796152==_.ALT
> Content-Type: text/plain; charset="us-ascii"
> 
> knows how to decode string fields before it encounters any of them.  

That depends on your implementation.  But I don't object to putting charset up front.

> The 

I'm curious about what kind of processing is easier.  On the Printer side, natural language seems irrelevant except for deciding what language to respond in (for Printer-generated text).  On the client side I guess it's used to decide whether text runs right-to-left or top-to-bottom?  Are we expecting to see clients supporting multiple languages simultaneously; mixing up various text flows to present, say, the results of a Get-Jobs operation?

> transport where the target is specified only in IPP layer.

Do we really need to provide for a future IPP-specific transport?  Is it likely that one will be created?  If so, since it would be IPP-specific anyway, couldn't we still put the target in the transport layer?

> --=====================_6796152==_.ALT
> Content-Type: text/html; charset="us-ascii"
> 
> <html>
> <font size=3>Charset clearly needs to be at the beginning so that a
> receiving process <br>
> knows how to decode string fields before it encounters any of them.&nbsp;
> The <br>
> charset field is a string field, but the names are all ASCII so the
> decoding <br>
> need not be known for the class of encodings that IPP support. BTW, XML
> puts <br>
> charset at the beginning for the same reason.<br>
> <br>
> Natural language is the next most important value because it specifies
> the <br>
> language of any text or name field.&nbsp; Processing is easier if the
> implicit <br>
> language is known at the time a text or name field is encountered. XML
> has <br>
> similar rules for language.<br>
> <br>
> <br>
> enclosing layer.&nbsp; For HTTP, the position of the target isn't
> important <br>
> <br>
> transport where the target is specified only in IPP layer.<br>
> <br>
> So that's the reasoning. Do you agree?<br>
> <br>
> Bob Herriot<br>
> <br>
> At 11:42 AM 6/8/98 , Paul Moore wrote:<br>
> &gt;I obviously missed this one. So 'special position' means that
> literally. I<br>
> &gt;thought it mean 'special purpose'. <br>
> &gt;<br>
> &gt;For my interest. Why are we putting things in special 
> positions?<br>
> &gt;<br>
> &gt;&gt; -----Original Message-----<br>
> &gt;&gt;
> From:<x-tab>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</x-tab>Robert
> Herriot [SMTP:[email-masked]]<br>
> &gt;&gt;
> Sent:<x-tab>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</x-tab>Friday,
> June 05, 1998 8:46 PM<br>
> &gt;&gt; To:<x-tab>&nbsp;&nbsp;</x-tab>Paul Moore; 'Carl Kugler';
> [email-masked]<br>
> &gt;&gt; Subject:<x-tab>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</x-tab>RE: RE:
> IPP&gt; Identifying jobs in requests<br>
> &gt;&gt; <br>
> &gt;&gt; We agreed recently that the following operation attributes would
> be<br>
> &gt;&gt; ordered.<br>
> &gt;&gt;&nbsp;&nbsp;&nbsp;&nbsp; attributes-charset (always first for
> requests and responses)<br>
> &gt;&gt;&nbsp;&nbsp;&nbsp;&nbsp; attributes-natural-language (always
> second for requests and response)<br>
> &gt;&gt;&nbsp;&nbsp;&nbsp;&nbsp; printer-uri or job-uri (always third for
> requests, though we are<br>
> &gt;&gt; discusses whether it should be present)<br>
> &gt;&gt;&nbsp;&nbsp;&nbsp;&nbsp; job-id (always fourth for requests if
> present )<br>
> &gt;&gt; <br>
> &gt;&gt; At 05:00 PM 6/5/98 , Paul Moore wrote:<br>
> &gt;&gt; &gt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; I think we are
> approaching group consensus on this.&nbsp; I propose<br>
> &gt;&gt; that<br>
> &gt;&gt; &gt;we remove &quot;printer-uri&quot; and &quot;job-uri&quot; as
> request Operation attributes,<br>
> &gt;&gt; but<br>
> &gt;&gt; &gt;leave them in their special position in the protocol.&nbsp;
> <br>
> &gt;&gt; &gt;<br>
> &gt;&gt; &gt;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; [Paul Moore]&nbsp; What
> 'special position'? <br>
> &gt;&gt; &gt; <br>
> &gt;&gt; <br>
> &gt; </font><br>
> </html>
> 
> --=====================_6796152==_.ALT--
> 
> 
>