Subject: RE: IPP> Implications of a new scheme, etc

From: Josh Cohen <[email-masked]>
Date: Fri, 5 Jun 1998 16:04:04 -0700

Hi Roger,

 I've got some comments on this. (I dont imagine your surprised :)

For the IPP: (new scheme proposals)
 I think putting 'no impact' for proxies is 100% inaccurate.
a new IPP scheme will break *every* existing Proxy.  I challenge
the wg to find a proxy which will pass this exception, if one exists.

In the case of the new method, most current proxies will be
able to handle it with minimal effort, as you indicated, some will
handle it as shipped (MSproxy) and some will need a patch. (squid)
If this is a holdup for a new method, I volunteer to submit
a patch to the squid group to fix this.

To use a new scheme means that proxies must understand the 
IPP protocol inner workings (which means that it has to know
that its really just HTTP on the wire).   To use a new
method means that IPP is a service on HTTP that is identified
by its different method (PRINT).

> -----Original Message-----
> From: Roger K Debry [mailto:[email-masked]]
> Sent: Friday, June 05, 1998 1:00 PM
> To: [email-masked]
> Subject: IPP> Implications of a new scheme, etc
> 
> 
> As suggested on Wednesday's teleconference, Harry Lewis,
> Carl Kugler, and I produced the attached table (in .pdf format)
> which hopefully summarizes the many views which have been
> expressed on this subject over the last couple of weeks. Our
> intent is that this would help support our position with Keith Moore.
> 
> 
> 
> Roger K deBry
> Senior Technical Staff Member
> Architecture and Technology
> IBM Printing Systems
> email: [email-masked]
> phone: 1-303-924-4080
>

---

From: "Carl Kugler" <[email-masked]>
Date: 6 Jun 1998 00:03:35 -0000

> the wg to find a proxy which will pass this exception, if one exists.

Josh, I think you've misread the chart.  For the proposal that puts the "ipp:" scheme ON THE WIRE, we listed "Breaks most installed  proxies. At best proxies have to be reconfigured".  The column that says "No impact" for Proxies is for the Larry's proposal (http://www.findmail.com/list/ipp/3754.html) which is actually HTTP on the wire.  (See http://www.findmail.com/list/ipp/3785.html for more info.)

    -Carl