Subject: RE: IPP> Implementation question re.: chunking

From: Paul Moore <[email-masked]>
Date: Fri, 24 Jul 1998 10:24:54 -0700

You might find that some implementations dont support chunking.

> -----Original Message-----
> From:	Randy Turner [SMTP:[email-masked]]
> Sent:	Friday, July 24, 1998 10:05 AM
> To:	Carl Kugler
> Cc:	[email-masked]
> Subject:	Re: IPP> Implementation question re.:  chunking
> 
> At 04:51 PM 7/24/98 +0000, you wrote:
> >draft-ietf-ipp-protocol-06.txt says the client and server MUST support
> the
> "chunked" transfer encoding when receiving.  My question is:  Can we count
> on this?  I.e., if our client always transmits requests using the
> "chunked"
> transfer encoding, will we be able to interoperate with the vast majority
> of IPP server implementations?
> >
> >    -Carl
> 
> 
> There are no vast majority of IPP server implementations (yet). I think
> the
> only worry is if someone plans to deploy IPP behind a generic web server
> that doesn't support chunking. However, Apache and most other of the more
> popular HTTP/1.1 servers will support this. It should definitely be a
> bullet item (checkoff item) at the upcoming bake-off, however.
> 
> Randy
> 
> >

---

From: "Carl Kugler" <[email-masked]>
Date: 24 Jul 1998 19:02:39 -0000

Okay, as a practical matter it looks like we need to be able to support HTTP/1.0 in addition to HTTP/1.1, and "Content-Length" in addition to "Transfer-Encoding: chunked" whether sending or receiving.  

This leads me to my next question: What is the transition sequence for the cases in which an HTTP/1.1 client that normally uses chunking wants to make a request of a server that is HTTP/1.0 and/or doesn't understand chunking?  

Does this scenario look correct?:

1. Client requests HTTP/1.1, Transfer-Encoding: chunked 
2. Server responds HTTP/1.0 501 (Unimplemented), and closes the connection
3. Client opens new connection and requests HTTP/1.0, Content-Length

Also, don't some HTTP/1.0 implementations understand Transfer-Encoding as an extension?  We have some client situations where we can't avoid chunking, so it would be nice if even the HTTP/1.0 servers understood chunked transfer coding.  (Presumably all HTTP/1.1 applications are able to receive and decode the “chunked” transfer coding.)

    -Carl

> > bullet item (checkoff item) at the upcoming bake-off, however.

-----
Original Message: http://www.findmail.com/list/ipp/?start=4179
Start a FREE email list at http://www.FindMail.com/

---

From: "Larry Masinter" <[email-masked]>
Date: Fri, 24 Jul 1998 14:23:56 PDT

> Okay, as a practical matter it looks like we need to be able to 
> support HTTP/1.0 in addition to HTTP/1.1, and "Content-Length" in 
> addition to "Transfer-Encoding: chunked" whether sending or receiving.  
> 
> This leads me to my next question: What is the transition sequence 
> for the cases in which an HTTP/1.1 client that normally uses chunking 
> wants to make a request of a server that is HTTP/1.0 and/or doesn't 
> understand chunking?  

There is no 'installed base' of IPP clients and servers which do not
support HTTP/1.1. As a practical matter, it seems unreasonable to
posit one or to create one.

---

From: "Carl Kugler" <[email-masked]>
Date: 27 Jul 1998 16:59:53 -0000

> posit one or to create one.

Maybe this is something we could discuss at the next telecon.  

Here is our situation.  For reasons beyond the scope of this discussion, we need to build a client-side API that supports an open,write,write...close|cancel paradigm for sending the document data.  This is easy to do with chunking.  It may be impossible to do with Content-Length (due to buffering limitations).  So our client will normally use chunking.  We'd really to avoid having to design it to fall-back to Content-Length when it encounters an HTTP/1.0 IPP server, because that would be complicated and expensive, and won't always work.  On the other hand, we don't want to paint ourselves into a corner and build a client that relies heavily on chunking, only to find out that many server implementations can't receive and decode the chunked transfer coding.

Is it safe to assume that all IPP 1.0 products will support HTTP/1.1 (and therefore chunking), even if prototype implementations don't?

    -Carl

-----
Original Message: http://www.findmail.com/list/ipp/?start=4184
Start a FREE email list at http://www.FindMail.com/

---

From: "Carl Kugler" <[email-masked]>
Date: 27 Jul 1998 16:59:53 -0000

-Carl

-----