Subject: Re: IPP>MOD maximum lengths of some strings not explicitly stated in model

From: [email-masked] (Robert Herriot)
Date: Tue, 18 Nov 1997 18:43:26 -0800

> From [email-masked] Tue Nov 18 18:08:15 1997
> 
> Robert Herriot wrote:
> > 
> > The model document specifies the maximum lengths for text, name,
> > keywords and octet-string, but NOT for charset, natural-language,
> > mimeMediaType, uri and uri-scheme.  Instead the model refers to other
> > documents which specify no upper bound.
> > 
> > Although in practice, all of these types except uri are short, probably less
> > that 255 bytes, the question is what must all of the interoperable
> > implementations minimally support.
> 
> Make it 100K bytes. That should hold them.
> 
> Honestly, is there any reason to make the minimum any smaller? Given
> that the printers have to spool large documents, anyway?
> 
> Larry
> 

It just makes the code a bit more complex and adds yet another test
case that may never be tested until a customer tries it.  Other
than that, it doesn't matter.

---

From: Larry Masinter <[email-masked]>
Date: Tue, 18 Nov 1997 18:52:41 PST

> than that, it doesn't matter.

No matter what the length limit is, you'll have to implement the limit
and test the limit.

Why is testing 1K bytes easier than testing 100K bytes?

Larry