Subject: RE: IPP> MOD - Updated Section 15.3 from Bob, Scott, Roger,

From: "Zehler,Peter" <[email-masked]>
Date: Wed, 10 Dec 1997 04:58:34 PST

Scott, Carl,
   I must have missed the original posting.  If the question is "Do we
need a Validate-Job operation?" I do have an opinion.  I believe this
would be very useful for large jobs across the Internet where fidelity
is required.  I also see this useful in intranets and long job printing.

   I was under the impression that Paul Moore wanted this operation to
initiate security challenges.  I would assume any operation could
accomplish this.  
I hope we leave it in and let implementations of IPP print systems
determine its viability.  There is very little overhead for support of
this operation.
Pete

__________________________________        
Email:   [email-masked]
US Mail: Peter Zehler
         Xerox Corp.
         800 Phillips Rd.
         Webster NY, 14580-9701
Voice:   (716) 265-8755
FAX:     (716)265-8792
__________________________________        
"I always wanted to be somebody, 
  but I should have been more specific." 
                                         Lily Tomlin
__________________________________        

> -----Original Message-----
> From:	Scott Isaacson [SMTP:[email-masked]]
> Sent:	Wednesday, December 10, 1997 12:24 AM
> To:	[email-masked]; [email-masked]
> Subject:	Re: IPP> MOD - Updated Section 15.3 from Bob, Scott,
> Roger,
> 
> Carl has suggested that there might not be a need Validate-Job.
> 
> I haven't seen any public responses?  Does silence mean AGREE or
> DISAGREE?
> Or is
> everyone like me - don't know yet.
> 
> Carl also asks:
> 
> >>> Carl Kugler <[email-masked]> 12/05 9:26 AM >>>
> > Side question:  does an IPP error response have an HTTP status code
> of
> > Successful "200 OK"?
> 
> The answer to this is YES.  The HTTP POST worked fine.  The
> "application/ipp" body within
> the POST had the error.
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
>

---

From: Roger K Debry <[email-masked]>
Date: Wed, 10 Dec 1997 08:32:44 -0500

I'd prefer to leave it in.

Roger K deBry
Senior Technical Staff Member
Architecture and Technology
IBM Printing Systems
email: [email-masked]
phone: 1-303-924-4080

---------------------- Forwarded by Roger K Debry/Boulder/IBM on 12/10/97 06:32
AM ---------------------------

        [email-masked]
        12/09/97 10:43 PM
Please respond to [email-masked] @ internet

To: Carl Kugler/Boulder/IBM@ibmus, [email-masked] @ internet
cc:
Subject: Re: IPP> MOD - Updated Section 15.3 from Bob, Scott, Roger,

I haven't seen any public responses?  Does silence mean AGREE or DISAGREE?
Or is
everyone like me - don't know yet.

Carl also asks:

> Side question:  does an IPP error response have an HTTP status code of
> Successful "200 OK"?

---

From: [email-masked] (Steve Zilles)
Date: Wed, 10 Dec 1997 09:05:38 -0800

At 12:54 AM 12/10/97, Carl-Uno Manros wrote:
>At 09:24 PM 12/9/97 PST, Scott Isaacson wrote:
>As this was NOT raised as an issue during the Last Call period, my
>assumption is it stays as it is in the current draft.
>
>Carl-Uno

I agree with Carl-Uno and, as I remember it, Validate-Job is needed because
Create-Job is not mandatory so there is no other guaranteed way to check
out a single document job.
        Steve Zilles

--------------------------------------------------------------
Stephen N. Zilles             |  e-mail: [email-masked]   |
Adobe Systems Inc.            |                              |
Mailstop W14                  |  tel: (work)  (408) 536-4766 |
345 Park Avenue               |       (Admin) (408) 536-4751 |
San Jose, CA 95110-2704       |  fax:         (408) 537-4042 |
--------------------------------------------------------------