Subject: RE: IPP> Notifications

From: "Turner, Randy" <[email-masked]>
Date: Tue, 3 Feb 1998 13:29:20 -0800

I remember we talked about maintaining persistent connections to the
server during job processing, as well as possibly having the clients
allocate a socket to receive UDP or TCP - based notifications from a
server.  And on your last statement, I disagree that we have a
device-level protocol; Most IPP servers, including your own, will be
implemented on server-based systems, detached from the actual physical
printer. Its possible that some server-based implementations might not
have device-level access or at least accurate realtime access to device
status.

Nonetheless, I would like to see further discussion on this topic via
the mailing list. I personally favor something along the lines of a UDP
message sent to a client socket from the server which includes some type
of encapsulated notification message.

Randy

	-----Original Message-----
	From:	Paul Moore [SMTP:[email-masked]]
	Sent:	Tuesday, February 03, 1998 1:05 PM
	To:	'Turner, Randy'; [email-masked]'
	Subject:	RE: IPP> Notifications

	The minutes dont really discuss it. There is talk about email vs
'IPP
	notifications' But no real discussion of how IPP notification
could be done.
	A device-level protocol that does not allow Out of band feedback
seems
	pretty broken 

	> -----Original Message-----
	> From:	Turner, Randy [SMTP:[email-masked]]
	> Sent:	Tuesday, February 03, 1998 11:29 AM
	> To:	Paul Moore; [email-masked]'
	> Subject:	RE: IPP> Notifications
	> 
	> 
	> Yes, this was discussed. Several solutions were proposed.
Check out the
	> minutes of the IPP meeting that Don just posted.
	> I think some of the ideas were included in the minutes.
	> 
	> Randy
	> 
	> 
	> 	-----Original Message-----
	> 	From:	Paul Moore [SMTP:[email-masked]]
	> 	Sent:	Tuesday, February 03, 1998 10:51 AM
	> 	To:	[email-masked]'
	> 	Subject:	IPP> Notifications
	> 
	> 	Has anybody noticed that IPP will be useless for
notifications
	> due to the
	> 	asymmetry of the protocol? As currently constituted a
printer
	> cannot send an
	> 	unsolicted message to anybody. 
	> 
	> 	Was this discussed later on on the Thursday brainstorm?

---

From: Larry Masinter <[email-masked]>
Date: Tue, 3 Feb 1998 16:56:20 PST

I like the idea of the client supplying, as part of a request,
the URL for notifications. In email, this address could be
supplied by the disposition-notification-to header, as with any
kind of receipt notification. For requests that get delivered
via IPP and POST, the address to which notifications get posted
could be supplied by the client via a URL, too. Clients would
have to know their own address, though, and make some kind of
service guarantee that they're willing to listen to responses
at that address. In some cases, the address of notification will
be different than the client address.

In email delivery for Internet Fax, we've also wanted to have
a notification protocol for "successful printing"; I'd like to
make sure that IPP and Internet Fax don't invent different
mechanisms for no good reason.

Larry
-- 
http://www.parc.xerox.com/masinter