Subject: RE: IPP> IPP document set - naming convention(s)

From: "Turner, Randy" <[email-masked]>
Date: Fri, 13 Mar 1998 12:11:15 -0800

I'm curious why the existing binary encoding is inherently dependent on
chunking?....I thought chunking was a part of the transport of the
encoding. I don't think there is anything inherent (or explicitly
referenced) by the current encoding that involves chunking. You're right
that another transport would have to solve the chunking problem, but
it's a TRANSPORT issue, so this would naturally fall into a transport
mapping document. If there was a bit or byte that specified HTTP
chunking within the binary encoding, then this is a different story.

Randy

	-----Original Message-----
	From:	Robert Herriot [SMTP:[email-masked]]
	Sent:	Friday, March 13, 1998 12:06 PM
	To:	Turner, Randy; [email-masked]'
	Subject:	Re: IPP> IPP document set - naming convention(s)

	I think we had this discussion in Austin as part of Tom's
proposal.  We 
	decided to change the name of the protocol document. Its new
name is 
	"Internet Printing Protocol/1.0: Encoding and Transport".  We
decided not to 
	split the two documents.

	Although the IPP encoding is, in theory, transport independent.
In fact, it 
	depends on HTTP chunking. With an alternate transport, we would
have to 
	solve the chunking problem.  It would be more efficient if the
document data 
	were the only part chunked, but that would require a change to
the encoding 
	layer.

	So, at this point, I don't endorse separating the two documents.

	Bob Herriot

	At 03:36 PM 3/12/98 , Turner, Randy wrote:
	>
	>Would anyone have any problem(s) splitting the protocol (not
model)
	>document into two documents?
	>
	>Document 1 would be an encoding document
	>Document 2 would describe how to transport the encoding over
HTTP 1.1
	>?
	>Randy

---

From: Jay Martin <[email-masked]>
Date: Fri, 13 Mar 1998 15:25:13 -0500

I agree with Randy completely.  The way Bob describes it,
IPP is absolutely bound to HTTP...theory or not.

Why is it such a big deal to split the document into its
two respective parts?  I would think that those who truly
believe the IPP encoding is "transport independent" would
insist on such a separation of the documentation.  Further,
I don't think the IETF cares all that much about whether
there is one document or two.

	...jay

----------------------------------------------------------------------
--  JK Martin               |  Email:   [email-masked]          --
--  Underscore, Inc.        |  Voice:   (603) 889-7000              --
--  41C Sagamore Park Road  |  Fax:     (603) 889-2699              --
--  Hudson, NH 03051-4915   |  Web:     http://www.underscore.com   --
----------------------------------------------------------------------