Subject: Re: IPP> Where do we stand in the debate?

From: Harry Lewis <[email-masked]>
Date: Wed, 15 Jul 1998 11:02:01 -0400

Carl-Uno. thank you very much for the summary. This is quite helpful. I would
like to seek even further clarification.

>"ipp:" will NEVER be used on the HTTP layer.

Is this the same as saying that (by example)
ipp://my.printer.com   will ALWAYS mean
http://my.printer.com:631
and (by further example)
ipp://my.printer.com:444   will mean
http://my.printer.com:444?

Harry Lewis - IBM Printing Systems

---

From: Randy Turner <[email-masked]>
Date: Wed, 15 Jul 1998 08:56:20 -0700

>Harry Lewis - IBM Printing Systems

I don't think that's what the compromise says. The quick take is,

1. "Published" URLs (that users and administrators will see) will be "ipp:"
URLs.
2. Within application/ipp body parts, "ipp:" URLs will be used to reference
IPP printer and job objects.
3. But you will never see "ipp:" URLs in HTTP 1.1 request headers.

This is very close to our usage model published last week at Monterey.

Randy