Subject: Re: IPP>MOD maximum lengths of some strings not explicitly stated in model

From: [email-masked] (Robert Herriot)
Date: Tue, 18 Nov 1997 19:02:27 -0800

> From [email-masked] Tue Nov 18 18:52:40 1997
> 
> > It just makes the code a bit more complex and adds yet another test
> > case that may never be tested until a customer tries it.  Other
> > than that, it doesn't matter.
> 
> No matter what the length limit is, you'll have to implement the limit
> and test the limit.
> 
> Why is testing 1K bytes easier than testing 100K bytes?
> 
> Larry
> 

I expect to read the URI string into a fixed size buffer which I would
prefer not to be 100K bytes.  If I have a limit of n, a single read into
this fixed-size buffer of size n suffices. If I don't have a limit, I have to
loop doing reads and concatenates of k bytes at a time.

Bob Herriot

---

From: [email-masked]
Date: Wed, 19 Nov 1997 07:54:18 -0500

Larry Masinter said:
>
>Make it 100K bytes. That should hold them.
>
>Honestly, is there any reason to make the minimum any smaller? Given
>that the printers have to spool large documents, anyway?
Your assumption is incorrect.  IPP is designed so that printers
do not have to spool large documents.  100K is a ridiculous
assumption; in fact with the exception of perhaps a URI 1K
is probably going too far.  Please put away your DocuTech
and think about printers that cost less than $1000.

Don

**********************************************
* Don Wright                 [email-masked] *
* Product Manager, Strategic Alliances       *
* Lexmark International                      *
* 740 New Circle Rd                          *
* Lexington, Ky 40550                        *
* 606-232-4808 (phone) 606-232-6740 (fax)    *
**********************************************