Subject: RE: IPP> Re: New IPP Scheme

From: [email-masked]
Date: Tue, 14 Jul 1998 13:18:39 -0400

Larry Masinter said:

>Don, your "printer" URL here is broken and it will fail to work,
>because the default port for ipp is "631"

Sorry Larry, but my printer isn't on the default IPP port of 631.  Mine is
on 80 so my URL is exactly right.  Not all implementations MUST be on 631.
That is simply the default for IPP.  I could have also chosen to publish my
printer as:

Printer: http://printer1.bldg035.lexmark.com:444

which would have also be correct if my printer was on port 444.

**********************************************
* Don Wright                 [email-masked] *
* Product Manager, Strategic Alliances       *
* Lexmark International                      *
* 740 New Circle Rd                          *
* Lexington, Ky 40550                        *
* 606-232-4808 (phone) 606-232-6740 (fax)    *
**********************************************

---

From: "Carl Kugler" <[email-masked]>
Date: 16 Jul 1998 16:18:26 -0000

...
> on 80 so my URL is exactly right.  Not all implementations MUST be on 631.
...
That's not how I read ftp://ftp.pwg.org/pub/pwg/ipp/new_PRO/ipp-pro-980630

It says "It is REQUIRED that a printer implementation support HTTP over the IANA assigned Well Known Port 631...".  Therefore, a conforming implementation MUST be on 631, although it might also be on some other port simultaneously.

-----
Original Message: http://www.findmail.com/list/ipp/?start=4106
Start a FREE email list at http://www.FindMail.com/

---

From: Keith Moore <[email-masked]>
Date: Thu, 16 Jul 1998 17:41:51 -0400

> It says "It is REQUIRED that a printer implementation support HTTP over the 
> IANA assigned Well Known Port 631...".  Therefore, a conforming 
> implementation MUST be on 631, although it might also be on some other 
> port simultaneously.

No, I don't think so.  Implementations should default to port 631, but
people who buy these things should be able to change that default to
anything they want.

Here's how I would say this:

1. Implementations MUST support the ability to accept IPP requests on
   port 631.  
2. Implementations MAY support the ability to accept IPP requests on
   other ports instead of, or in addition to, port 631, but only 
   if explicitly configured to do so by the printer administrator.

Keith