Subject: IPP> RE: TES:binary files

From: "Zehler,Peter" <[email-masked]>
Date: Tue, 9 Dec 1997 06:35:41 PST

Steve,
   Even when we test across the internet we will still need to capture
the results.  I am all for anything that will help us move along.  
   I have created a directory called "Traces" under the new_TES
directory for the time being.  We can decide on a directory structure at
a later time.  I assume that we will capture traces in more than one
form.  
  We need to decide on a naming convention.  For this purpose I assume
that we will limit each trace file to a single request or response.  The
naming convention should provide for the pairing of the request to its
response.  The naming convention should facilitate the capturing of an
extended IPP conversation.  A conversation is a sequence of IPP
operations on an IPP printer.  
     We need to designate the session, operation, request|response, and
sequence in the conversation.  A suggestion would be "SSSSOR##.trc"
where
SSSS: an arbitrary unique sequence identifier.  The identifier 
           would be unique within the "Traces" directory.
O: The operation of the request/response.  This is the 
     hexadecimal value of the IPP operation enum.
R: Designates request or response.  A=request
     B=response.
##: sequence number of the operation in the IPP conversation.
   We will also need to catalogue the contents of the directory.  This
can be accomplished by a pdf file containing a table with relevant
information.  I can keep this up to date if contributors send me the
information.  I think some concise description of the objective/purpose
of the IPP conversation would be appropriate.  

I found that putting up an IPP emulator through an ISV is trivial.  The
emulator is the front end of my IPP printer.  I have this anyway since
small printers do not have very rich debug environments.

I think we need to know if there is any interest in pursuing binary
trace files.  Do any other individuals have any feelings on this?

What do you think?
Pete
__________________________________        
Email:   [email-masked]
US Mail: Peter Zehler
         Xerox Corp.
         800 Phillips Rd.
         Webster NY, 14580-9701
Voice:   (716) 265-8755
FAX:     (716)265-8792
__________________________________        
"I always wanted to be somebody, 
  but I should have been more specific." 
                                         Lily Tomlin
__________________________________        

> -----Original Message-----
> From:	Steve Gebert [SMTP:[email-masked]]
> Sent:	Monday, December 08, 1997 3:39 PM
> To:	[email-masked]
> Subject:	
> 
> For interoperability testing, we were wondering if people were
> interested in
> exchanging binary files
>   corresponding to IPP Requests and Responses. The parties using these
> files
> would simply need to
>   construct a simple program to feed the file data into their server
> or client
> and read data from their
>   server or client into a file.
> 
>   These files could be sent as email attachments and for the near term
> help
> with interoperability testing
>    prior to people setting up machines outside filewalls. Perhaps we
> could even
> catalog the files and
>    make them available for download so that there would be a common
> test
> baseline for early testing.
> 
>    We could make some example files available if there is any
> interest. What do
> you think Peter?
> 
> 
> Steve Gebert

---

From: Tom Hastings <[email-masked]>
Date: Wed, 10 Dec 1997 08:32:45 PST

Peter,

I agree on your approach to putting up trace files.

However, I have a couple of suggestions:

1. There should be both a printable form (.txt) and a binary form (.trc).
Actually, if the printable form is in MS-WORD, it should have line
numbers on it, so that it is easier to talk about.  Then there should
be .doc and .pdf forms of the printable form.

2. The printable form of the trace file should contain all the 
information about the request or response in English at the beginning 
of the file, including:

a. the person posting the trace file
b. contact information for that person
c. the unique sequence number for the conversation (SSSS)
d. the name of the operation (O)
d. whether it is a request or a response (R)
e. the file name of the file
f. the date
g. a comment about the intent of the operation request or response,
such as "submitting a job with fidelity 'false'" or 
"intentional invalid request, expecting a client-error-bad-request
rejection" or "rejection response of 'client-error-bad-request'".

3. The binary form would just be the raw binary of each request or response.

Then a bunch of trace files can be printed and the printout will
completely identify the content.

A few questions, suggestions below.

>           would be unique within the "Traces" directory.

Rather than this being numeric, how about the two letter initials of the 
person submitting the trace and a two digit sequence number that they
keep track of?

>##: sequence number of the operation in the IPP conversation.

Starting at 00?

So if I posted a trace of Validate-Job, Print-Job, Get-Jobs, there would
be six printable files:

TH004A00.txt
TH004B01.txt
TH002A02.txt
TH002B03.txt
TH00AA04.txt
TH00AB04.txt

and six binary files:
TH004A00.trc
TH004B01.trc
TH002A02.trc
TH002B03.trc
TH00AA04.trc
TH00AB04.trc

>trace files.  Do any other individuals have any feelings on this?

Good idea.  But can we have printable ones too?  Do we need a tool to
dump a binary trace file into a printable one?