Subject: RE: IPP> Implications of a new scheme, etc

From: Roger K Debry <[email-masked]>
Date: Mon, 8 Jun 1998 08:34:28 -0400

Josh,

I will make the impact statement for IPP on the wire stronger, as
you suggest. I think Carl Kugler has pointed out that the HTTP
on the wire column is just Larry Masinter's proposal, which I
hope you will agree causes no impact to proxies.  Since this
column does imply a new port number, isn't this enough to
distinguish this for firewall purposes?

Roger K deBry
Senior Technical Staff Member
Architecture and Technology
IBM Printing Systems
email: [email-masked]
phone: 1-303-924-4080

[email-masked] on 06/05/98 05:04:37 PM
Please respond to [email-masked]
To: [email-masked], Roger K Debry/Boulder/IBM@ibmus
cc:
Subject: RE: IPP> Implications of a new scheme, etc

Hi Roger,

 I've got some comments on this. (I dont imagine your surprised :)

For the IPP: (new scheme proposals)
 I think putting 'no impact' for proxies is 100% inaccurate.
a new IPP scheme will break *every* existing Proxy.  I challenge
the wg to find a proxy which will pass this exception, if one exists.

In the case of the new method, most current proxies will be
able to handle it with minimal effort, as you indicated, some will
handle it as shipped (MSproxy) and some will need a patch. (squid)
If this is a holdup for a new method, I volunteer to submit
a patch to the squid group to fix this.

To use a new scheme means that proxies must understand the
IPP protocol inner workings (which means that it has to know
that its really just HTTP on the wire).   To use a new
method means that IPP is a service on HTTP that is identified
by its different method (PRINT).

> -----Original Message-----
> From: Roger K Debry [mailto:[email-masked]]
> Sent: Friday, June 05, 1998 1:00 PM
> To: [email-masked]
> Subject: IPP> Implications of a new scheme, etc
>
>
> As suggested on Wednesday's teleconference, Harry Lewis,
> Carl Kugler, and I produced the attached table (in .pdf format)
> which hopefully summarizes the many views which have been
> expressed on this subject over the last couple of weeks. Our
> intent is that this would help support our position with Keith Moore.
>
>
>
> Roger K deBry
> Senior Technical Staff Member
> Architecture and Technology
> IBM Printing Systems
> email: [email-masked]
> phone: 1-303-924-4080
>

---

From: Roger K Debry <[email-masked]>
Date: Mon, 8 Jun 1998 08:38:06 -0400

The inclusion of URLs in IPP responses seems to be the subject
of a lot of debate just now.   If the outcome of the debate is that they
stay in the response, and include the scheme, then there is some
impact, but I'd judge it pretty small. Would you agree?

Roger K deBry

[email-masked] on 06/05/98 03:25:13 PM
Please respond to [email-masked]
To: Roger K Debry/Boulder/IBM@ibmus
cc: [email-masked]
Subject: Re: IPP> Implications of a new scheme, etc

Is it true that there is "no impact" on the Servers for the
IPP:X (HTTP on the Wire) scenario?  I know that there are URI's
that a server has to return to the client, so I am just wondering
if there is going to be any server problems (because the URI's
will have to be presented as IPP:, right?).

curious...
...walker

--
Jim Walker <[email-masked]>
System Architect/DAZEL Wizard
DAZEL Corporation, Austin, TX

---

From: "Zehler, Peter " <[email-masked]>
Date: Mon, 8 Jun 1998 07:38:05 PDT

Jim,
As I understand it, there are 3 basic "types" of URLs in IPP.
1) externally configured, such as the printer's "printer-uri-supported"
2) internally generated, such as the job's "job-uri"
3) references to objects outside the IPP model, such as the printer's
"printer-more-info"

As long as we have consistent naming for items 1 and 2 I see no IPP server
problem.  I assume that the attribute URLs will contain "ipp" as the method.
This put the responsibility on the client to translate.

For item 3 IPP would not perform any translation.  These URLs refer to
objects external to the IPP model and must be left as specified.

Pete 

				Peter Zehler
				XEROX
				Networked Products Business Unit
				Email: [email-masked]
				Voice:    (716) 265-8755
				FAX:      (716) 265-8792 
				US Mail: Peter Zehler
				        Xerox Corp.
				        800 Phillips Rd.
				        M/S 111-02J
				        Webster NY, 14580-9701

	-----Original Message-----
	From:	James Walker [SMTP:[email-masked]]
	Sent:	Friday, June 05, 1998 5:06 PM
	To:	Roger K Debry
	Cc:	[email-masked]
	Subject:	Re: IPP> Implications of a new scheme, etc

	curious...
	...walker

---

From: Josh Cohen <[email-masked]>
Date: Mon, 8 Jun 1998 13:16:13 -0700

Correct me if Im wrong, this is my understanding of that
proposal: (from the proxy/firewall perspective)

IPP URLS are always to port 380 (or whatever we choose)
Proxies and firewalls can filter IPP by enabling or disabling
URLS to port 380.

?

> Sent: Monday, June 08, 1998 5:34 AM
> To: Josh Cohen
> Cc: [email-masked]