Subject: IPP> Proposal for new IPP scheme

From: Roger K Debry <[email-masked]>
Date: Wed, 17 Jun 1998 08:51:31 -0400

In resposne to Randy's post ...

POST http://myhost.com:374/myprinter/myqueue HTTP/1.1
Host: myproxy.com:374
Content-type: application/ipp
Transfer-Encoding: chunked

<RKD> Why would the Host line have the 374 port?

3. A full IPP URL   (e.g., ipp://myhost.com/myprinter/myqueue)

<RKD> I don't understand why this would be required. If it
<RKD> is, then I think it breaks the proposal.

---

From: "Larry Masinter" <[email-masked]>
Date: Wed, 17 Jun 1998 12:52:58 PDT

> In response to Randy's post ...
> 

Please see section 14.23 ("Host") of draft-ietf-http-v11-spec-rev-03.txt
which lays out the requirements and conditions more clearly.

> <RKD> is, then I think it breaks the proposal.

Please see section 5.1.2 ("Request-URI") of 
draft-ietf-http-v11-spec-rev-03.txt.