Subject: RE: RE: IPP> Identifying jobs in requests

From: Robert Herriot <[email-masked]>
Date: Fri, 05 Jun 1998 20:46:10 -0700

We agreed recently that the following operation attributes would be ordered.
    attributes-charset (always first for requests and responses)
    attributes-natural-language (always second for requests and response)
    printer-uri or job-uri (always third for requests, though we are discusses
whether it should be present)
    job-id (always fourth for requests if present )

At 05:00 PM 6/5/98 , Paul Moore wrote:
>       I think we are approaching group consensus on this.  I propose that
>we remove "printer-uri" and "job-uri" as request Operation attributes, but
>leave them in their special position in the protocol.  
>
>       [Paul Moore]  What 'special position'? 
>

---

From: "Carl Kugler" <[email-masked]>
Date: 8 Jun 1998 15:55:59 -0000

> --=====================_33814923==_.ALT
> Content-Type: text/plain; charset="us-ascii"
> 

Agreed, but I am using "special position" in the sense that it was used earlier, in the PRO document, to describe attributes that are outside the normal attribute groups, placed either in the transport layer or in a fixed position in the application/ipp body.

> --=====================_33814923==_.ALT
> Content-Type: text/html; charset="us-ascii"
> 
> <html>
> <font size=3>We agreed recently that the following operation attributes
> would be ordered.<br>
> &nbsp;&nbsp;&nbsp; attributes-charset (always first for requests and
> responses)<br>
> &nbsp;&nbsp;&nbsp; attributes-natural-language (always second for
> requests and response)<br>
> &nbsp;&nbsp;&nbsp; printer-uri or job-uri (always third for requests,
> though we are discusses whether it should be present)<br>
> &nbsp;&nbsp;&nbsp; job-id (always fourth for requests if present )<br>
> <br>
> At 05:00 PM 6/5/98 , Paul Moore wrote:<br>
> &gt;<x-tab>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</x-tab>I think we
> are approaching group consensus on this.&nbsp; I propose that<br>
> &gt;we remove &quot;printer-uri&quot; and &quot;job-uri&quot; as request
> Operation attributes, but<br>
> &gt;leave them in their special position in the protocol.&nbsp; <br>
> &gt;<br>
> &gt;<x-tab>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</x-tab>[Paul
> Moore]&nbsp; What 'special position'? <br>
> &gt; </font><br>
> </html>
> 
> --=====================_33814923==_.ALT--
> 
> 
>