Subject: IPP> Re: New IPP Scheme

From: [email-masked]
Date: Mon, 13 Jul 1998 07:22:19 -0400

Keith Moore said:

>> My argument stands, the right people to deal
>> with the user's perception are the people shipping the products and they
>> have reach consensus that "ipp:" is the wrong answer.
>
>The folks who are shipping printers aren't even close to representative
>of the people who are going to be using this stuff.

Too bad you don't know the people that have been working on this for more
than a year.  The group includes people not only from the printer
manufacturers you seem to think haven't the foggiest what their users want
but also _people_ with a great deal of experience in Operating Systems
(employees of Microsoft, Sun & IBM), Network Operating Systems (employees
of Microsoft, IBM & Novell) as well as printing software (employees of
Underscore & North Lake.)  Not only do these people have a great deal of
experience in this area but, despite the IETF's blinders, as
representatives of companies developing commercial products, _we_ and our
companies are going to have to support this when it hits the field.  Are
you making a multimillion dollar support committment to the "ipp:" concept?

In conjunction with those of us who not only manufacture printers but also
provide both Web and non-Web based configuration and management utilities,
I think this group has a great understanding of what real-world users want
and expect.  Oh, and by the way, _we_ all are also computer users generally
using the fairly up to date operating system, etc. on a day to day basis.

IPP is not a printer manufacturer "railroad."  It is a broad-based,
printing industry cooperative effort that has reach its conclusion based
upon years and years of experience.

**********************************************
* Don Wright                 [email-masked] *
* Product Manager, Strategic Alliances       *
* Lexmark International                      *
* 740 New Circle Rd                          *
* Lexington, Ky 40550                        *
* 606-232-4808 (phone) 606-232-6740 (fax)    *
**********************************************

---

From: Roger K Debry <[email-masked]>
Date: Thu, 16 Jul 1998 14:25:54 -0400

I suppose in Don's case it depends on what he means by "administratively set".
It almost sounded
like port 80 was hard wired in. Can an adminsitrator choose to use a different
port Don?

Roger K deBry
Senior Technical Staff Member
Architecture and Technology
IBM Printing Systems
email: [email-masked]
phone: 1-303-924-4080

[email-masked] on 07/16/98 12:12:08 PM
Please respond to [email-masked]
To: Carl Kugler/Boulder/IBM@ibmus
cc: [email-masked]
Subject: Re: IPP> Re: New IPP Scheme

I believe that if a product offers compliant operation--but also
offers configuration options to disable compliant operation--that
the product is still considered compliant.

Letting the customer do what the CUSTOMER wants should be ok, right?

 ...jay

----------------------------------------------------------------------
--  JK Martin               |  Email:   [email-masked]          --
--  Underscore, Inc.        |  Voice:   (603) 889-7000              --
--  41C Sagamore Park Road  |  Fax:     (603) 889-2699              --
--  Hudson, NH 03051-4915   |  Web:     http://www.underscore.com   --
----------------------------------------------------------------------

Carl Kugler wrote:
>
> Carl:
> >
> > The implementation MUST support port 631 however, mine is administratively
> > set to only OPERATE on port 80.  The code is compliant.
> >
> > Don
> >
> >
> Hmmm... I think we need some clarification in the wording here, because I
think it's ambiguous as it stands.  Here's another quote:  "IPP server
implementations MUST offer IPP services using HTTP over the IANA assigned Well
Known Port 631 (the IPP default port). IPP server implementations may support
other ports, in addition to this port."
>
> So you read "suport" and "offer IPP services" to mean "can be configured to
listen on" rather than "is required to listen on"?
>
>     -Carl
>
> >
> >
> > "Carl Kugler" <[email-masked]> on 07/16/98
> > 12:18:26 PM
> >
> > To:   [email-masked]
> > cc:    (bcc: Don Wright)
> > bcc:  Don Wright
> > Subject:  RE: IPP> Re: New IPP Scheme
> >
> >
> >
> >
> > ...
> > > Sorry Larry, but my printer isn't on the default IPP port of 631.  Mine
> > is
> > > on 80 so my URL is exactly right.  Not all implementations MUST be on
> > 631.
> > ...
> > That's not how I read ftp://ftp.pwg.org/pub/pwg/ipp/new_PRO/ipp-pro-980630
> >
> > It says "It is REQUIRED that a printer implementation support HTTP over the
> > IANA assigned Well Known Port 631...".  Therefore, a conforming
> > implementation MUST be on 631, although it might also be on some other port
> > simultaneously.
> >
> > -----
> > Original Message: http://www.findmail.com/list/ipp/?start=4106
> > Start a FREE email list at http://www.FindMail.com/
> >
> >
> >
> >
> >
> >
>
> -----
> Original Message: http://www.findmail.com/list/ipp/?start=4138
> Start a FREE email list at http://www.FindMail.com/

---

From: [email-masked]
Date: Thu, 16 Jul 1998 14:34:07 -0400

Roger and all:

I am speaking rather theoretically about an example from an e-mail (what
seems like a long time ago) where the administrator wanted to offer print
services on port 80.  In this theoretical product, it's "out of the box"
configuration is port 631 put that can be changed when the product is
installed.

Roger K Debry <[email-masked]> on 07/16/98
02:25:54 PM

I suppose in Don's case it depends on what he means by "administratively
set".
It almost sounded
like port 80 was hard wired in. Can an adminsitrator choose to use a
different
port Don?

Roger K deBry

 ...jay

think it's ambiguous as it stands.  Here's another quote:  "IPP server
implementations MUST offer IPP services using HTTP over the IANA assigned
Well
Known Port 631 (the IPP default port). IPP server implementations may
support
other ports, in addition to this port."
> > That's not how I read
ftp://ftp.pwg.org/pub/pwg/ipp/new_PRO/ipp-pro-980630

---

From: [email-masked]
Date: Fri, 17 Jul 1998 07:31:56 -0700 (PDT)

This appears to be a reasonable approach to this problem.
I note carefully that there are still some nasty problems lurking
with proxies,  etc., but nothing that would be serious for a skilled
person in dealing with nasty problems with proxies.

Patrick Powell

> From [email-masked] Wed Jul 15 19:01:11 1998
> Date: Wed, 15 Jul 1998 18:41:27 -0700
> To: Keith Moore <[email-masked]>
> From: Robert Herriot <[email-masked]>
> Cc: [email-masked]
> --=====================_97913321==_.ALT
> Content-Type: text/plain; charset="us-ascii"
>
> Action item from Robert Herriot and Tom Hastings:
>
> The IPP working group reached an agreement with Keith Moore in this 
> morning's teleconference. This document is our best understanding of the 
> details of this agreement.
>
> Summary:
>
> The quick summary is that IPP should support a new scheme 'ipp', which 
> clients and servers use in IPP attributes. Such attributes are in a message 
> body whose Content-Type is application/ipp.  A client maps 'ipp' URLs to 
> 'http' URLs, and then follows the HTTP/1.1 rules for constructing a 
> Request-Line and HTTP headers. The IPP document will not prohibit 
> implementations from supporting other schemes in IPP attributes, but such 
> support is not defined by this document.

---

From: "Manros, Carl-Uno B" <[email-masked]>
Date: Fri, 17 Jul 1998 10:45:41 PDT

Carl,

I think we should take the text suggested by Keith yesterday.

Carl-Uno

> -----Original Message-----
> From: Carl Kugler [mailto:[email-masked]]
> Sent: Friday, July 17, 1998 9:45 AM
> To: [email-masked]
> True!
> How about this instead:
> IANA has assigned Well Known Port 631 to the default IPP port 
> number.  An IPP
> server listens on port 631 unless explicitly configured to 
> listen on one or
> more ports instead of, or in addition to, port 631.  If the 
> port is empty or
> not given in an "ipp" schemed URL, port 631 is assumed.
> 
>   -Carl
> 
> 
> 
> [email-masked] on 07/16/98 05:30:00 PM
> Please respond to [email-masked]
> cc:
> Carl,
> Your proposal isn't quite right either. An IPP server can 
> also listen to
> several ports e.g port 631 and port 80.
> 
> Carl-Uno
> 
> > -----Original Message-----
> > From: Carl Kugler [mailto:[email-masked]]
> > Sent: Thursday, July 16, 1998 2:10 PM
> > To: [email-masked]
> > --=====================_160811464==_.ALT
> > > I wrote the sentences that you are asking about.  I tried
> > to pick words that
> > > would be unambiguous.
> > >
> > > The intention is that IPP software must be able to listen
> > on port 631 and
> > > may be able to listen on other ports.
> > > If such software allows an administrator to configure the
> > ports, then such
> > > an adminstrator may be able to have IPP software listen
> > other ports, such as
> > > port 80 and might make it be the only port that the IPP
> > server listens on.
> > > The customer has the right to do what he wants, even if we
> > don't think it is
> > > the wisest choice.
> > >
> > > Bob Herriot
> > >
> >
> > What I find ambiguous, then, are the words "in addition to"
> > and "as well" in these sentences:
> >
> >     "IPP server implementations may support other ports, in
> > addition to this port."
> >
> >     "It is REQUIRED that a printer implementation support
> > HTTP over the IANA assigned Well Known Port 631 (the IPP
> > default port), though a printer implementation may support
> > HTTP over port some other port as well."
> >
> > Maybe it should say:
> >
> >     "It is REQUIRED that a printer implementation support
> > HTTP over the IANA assigned Well Known Port 631 (the IPP
> > default port), though a printer implementation may be
> > configured to listen on some other port instead."
> >
> >     -Carl
> >
> > >
> > > At 10:24 AM 7/16/98 , Carl Kugler wrote:
> > > >Carl:
> > > >>
> > > --=====================_160811464==_.ALT
> > > Content-Type: text/html; charset="us-ascii"
> > >
> > > <html>
> > > <font size=3>I wrote the sentences that you are asking
> > about.&nbsp; I
> > > tried to pick words that <br>
> > > would be unambiguous.<br>
> > > <br>
> > > The intention is that IPP software must be able to listen
> > on port 631 and
> > > <br>
> > > may be able to listen on other ports.<br>
> > > If such software allows an administrator to configure the
> > ports, then
> > > such <br>
> > > an adminstrator may be able to have IPP software listen
> > other ports, such
> > > as <br>
> > > port 80 and might make it be the only port that the IPP
> > server listens
> > > on.&nbsp; <br>
> > > The customer has the right to do what he wants, even if we
> > don't think it
> > > is <br>
> > > the wisest choice.<br>
> > > <br>
> > > Bob Herriot<br>
> > > <br>
> > > <br>
> > > At 10:24 AM 7/16/98 , Carl Kugler wrote:<br>
> > > &gt;Carl:<br>
> > > &gt;&gt; <br>
> > > &gt;&gt; The implementation MUST support port 631 however, mine is
> > > administratively<br>
> > > &gt;&gt; set to only OPERATE on port 80.&nbsp; The code is
> > > compliant.<br>
> > > &gt;&gt; <br>
> > > &gt;&gt; Don<br>
> > > &gt;&gt; <br>
> > > &gt;&gt; <br>
> > > &gt;Hmmm... I think we need some clarification in the 
> wording here,
> > > because I think it's ambiguous as it stands.&nbsp; Here's another
> > > quote:&nbsp; &quot;IPP server implementations MUST offer
> > IPP services
> > > using HTTP over the IANA assigned Well Known Port 631 (the
> > IPP default
> > > port). IPP server implementations may support other ports,
> > in addition to
> > > this port.&quot;<br>
> > > &gt;<br>
> > > &gt;So you read &quot;suport&quot; and &quot;offer IPP
> > services&quot; to
> > > mean &quot;can be configured to listen on&quot; rather 
> than &quot;is
> > > required to listen on&quot;?<br>
> > > &gt;<br>
> > > &gt;&nbsp;&nbsp;&nbsp; -Carl<br>
> > > &gt;<br>
> > > &gt;&gt; <br>
> > > &gt;&gt; <br>
> > > &gt;&gt; &quot;Carl Kugler&quot;
> > > &lt;[email-masked]&gt; on 07/16/98<br>
> > > &gt;&gt; 12:18:26 PM<br>
> > > &gt;&gt; <br>
> > > &gt;&gt; To:&nbsp;&nbsp; [email-masked]<br>
> > > &gt;&gt; cc:&nbsp;&nbsp;&nbsp; (bcc: Don Wright)<br>
> > > &gt;&gt; bcc:&nbsp; Don Wright<br>
> > > &gt;&gt; Subject:&nbsp; RE: IPP&gt; Re: New IPP Scheme<br>
> > > &gt;&gt; <br>
> > > &gt;&gt; <br>
> > > &gt;&gt; <br>
> > > &gt;&gt; <br>
> > > &gt;&gt; ...<br>
> > > &gt;&gt; &gt; Sorry Larry, but my printer isn't on the
> > default IPP port
> > > of 631.&nbsp; Mine<br>
> > > &gt;&gt; is<br>
> > > &gt;&gt; &gt; on 80 so my URL is exactly right.&nbsp; Not all
> > > implementations MUST be on<br>
> > > &gt;&gt; 631.<br>
> > > &gt;&gt; ...<br>
> > > &gt;&gt; That's not how I read
> > > <a
> > href="ftp://ftp.pwg.org/pub/pwg/ipp/new_PRO/ipp-pro-980630"
> > eudora="autourl"><font
> > size=3>ftp://ftp.pwg.org/pub/pwg/ipp/new_PRO/ipp-pro-980630</a><br>
> > > <font size=3>&gt;&gt; <br>
> > > &gt;&gt; It says &quot;It is REQUIRED that a printer 
> implementation
> > > support HTTP over the<br>
> > > &gt;&gt; IANA assigned Well Known Port 631...&quot;.&nbsp;
> > Therefore, a
> > > conforming<br>
> > > &gt;&gt; implementation MUST be on 631, although it might
> > also be on some
> > > other port<br>
> > > &gt;&gt; simultaneously.<br>
> > > &gt;&gt; <br>
> > > &gt;&gt; -----<br>
> > > &gt;&gt; Original Message:
> > > <a href="http://www.findmail.com/list/ipp/?start=4106"
> > eudora="autourl"><font
> > size=3>http://www.findmail.com/list/ipp/?start=4106</a><br>
> > > <font size=3>&gt;&gt; Start a FREE email list at
> > > <a href="http://www.findmail.com/" eudora="autourl"><font
> > size=3>http://www.FindMail.com/</a><br>
> > > <font size=3>&gt;&gt; <br>
> > > &gt;&gt; <br>
> > > &gt;&gt; <br>
> > > &gt;&gt; <br>
> > > &gt;&gt; <br>
> > > &gt;&gt; <br>
> > > &gt;<br>
> > > &gt;<br>
> > > &gt;<br>
> > > &gt;-----<br>
> > > &gt;Original Message:
> > > <a href="http://www.findmail.com/list/ipp/?start=4138"
> > eudora="autourl"><font
> > size=3>http://www.findmail.com/list/ipp/?start=4138</a><br>
> > > <font size=3>&gt;Start a FREE email list at
> > > <a href="http://www.findmail.com/" eudora="autourl"><font
> > size=3>http://www.FindMail.com/</a><br>
> > > <font size=3>&gt; </font><br>
> > > </html>
> > >
> > > --=====================_160811464==_.ALT--
> > >
> > >
> > >
> >
> >
> >
> > -----
> > Original Message: http://www.findmail.com/list/ipp/?start=4144