Subject: IPP> The impact on users for "ipp:" URL notation?

From: Jay Martin <[email-masked]>
Date: Fri, 03 Jul 1998 14:36:03 -0400

Keith Moore wrote on a related thread:

> Again, I don't think it's really the layering of IPP over HTTP that
> the IESG questions; rather, it's the odd use of the http URL.
> This may make sense to the IPP folks but looks really odd to IESG.
> (I suspect it won't make sense to users, either.)  And when IESG
> starts to examine the assumptions behind the design choice, it
> starts to look even stranger.  But a lot of this is beside the
> point - I really have no problem supporting the choice of HTTP
> as a substrate for IPP, and IESG isn't going to second-guess that
> choice.  The issue is only the use of the http: prefix.  It may be
> that IESG places a larger value on user friendliness than IPP does.

User-friendliness is extrememly important to all of us.
For this reason, I remain concerned about how an "ipp:"
prefix really impacts a user.

We have heard PWG people say things like:

  "You can put your IPP printer URL on your business card!"

But what does this really mean?  That is, how (and when and where)
would a user enter an IPP printer URL?  We have long come to
admit that it won't be applicable to mainstream browsers (one
of the top three reasons we wanted to use HTTP in the first
place, since fallen by the wayside in terms of IPP benefits).

>From what I can tell, IPP URLs are effectively hidden from
end users; instead, the end user's local printing system will
front-end any/all IPP interaction.

Is this an accurate depiction?

	...jay

----------------------------------------------------------------------
--  JK Martin               |  Email:   [email-masked]          --
--  Underscore, Inc.        |  Voice:   (603) 889-7000              --
--  41C Sagamore Park Road  |  Fax:     (603) 889-2699              --
--  Hudson, NH 03051-4915   |  Web:     http://www.underscore.com   --
----------------------------------------------------------------------

---

From: Keith Moore <[email-masked]>
Date: Fri, 03 Jul 1998 19:33:33 -0400

> Is this an accurate depiction?

from UNIX, I'd expect to be able to do

% setenv PRINTER ipp://spot.cs.utk.edu/slug
% lpr filename.pdf

(much like I do now)

>From a GUI interface, I'd expect to be able to pull-down a File menu 
and select a Print option which would pop up a dialog box that gave 
me the option of entering an ipp: URL as an alternative to choosing one of 
the preconfigured printers.  (similar to the option that lets me type 
in a network printer accessed by SMB) 

In an really nice world, the printer chooser would then talk to the
printer and figure out what kind of driver it needed to print. 
If the driver were not already installed, the dialog box would then 
give me the option of either installing a driver from disk, downloading
one from the net (hopefully with adequate authenticity/integrity 
protection), or using a generic driver to talk to the printer.  
(assuming my system already has a driver for common PDLs) 

Of course, the IPP group can't dictate OS vendors' user interfaces,
but I see no reason why the IPP protocol cannot be used in this way.

Keith

---

From: Jay Martin <[email-masked]>
Date: Fri, 03 Jul 1998 20:30:38 -0400

Keith,

Thanks for the reply.  Your vision sounds pretty good,
assuming the non-Unix platform vendors provide that (new)
capability in the future.  Given that Microsoft is somewhat
involved in the IPP process, then perhaps such capabilities
will appear before the end of the millenium.  (no joke)

A quick aside, your Unix example is quite nice, I agree.
However, those not familiar with Unix (and all the common
variants) should understand that your example is actually
not valid, at least from stock O/S vendors.

Perhaps you were thinking of the capabilities provided by
Patrick Powell's fine LPRng suite, which exposes network-
attached printers using standard hostname conventions
(rather than sysadmin-defined printer objects on the local
platform).

	...jay

---

From: Keith Moore <[email-masked]>
Date: Fri, 03 Jul 1998 21:50:45 -0400

> (rather than sysadmin-defined printer objects on the local

Actually, I was thinking about the lpr client that I wrote
many years ago, that allows the user to specify host and
printer name on the command-line.  

Sadly, most current UNIX print systems also require explicit 
configuration, even for a remote printer with a lpd interface.

Keith

---

From: Carl-Uno Manros <[email-masked]>
Date: Mon, 6 Jul 1998 08:01:49 PDT

At 11:36 AM 7/3/98 PDT, Jay Martin wrote:

>would a user enter an IPP printer URL?

Jay,

I was probably the one who brought this up. About the where, I think the
primary place would be to insert it in a printing dialogue window dedicated
to IPP printing.

Based on more recent discussions in the WG, I do not see a major difference
whether I write:

PRINTER: ipp://www.manros.com/ipp-printer

or

PRINTER: http://www.manros.com/ipp-printer

the same way as you use telephone numbers for both TEL: and FAX: on you
cards today.

Carl-Uno
Carl-Uno Manros
Principal Engineer - Advanced Printing Standards - Xerox Corporation
701 S. Aviation Blvd., El Segundo, CA, M/S: ESAE-231
Phone +1-310-333 8273, Fax +1-310-333 5514
Email: [email-masked]

---

From: "Larry Masinter" <[email-masked]>
Date: Mon, 6 Jul 1998 08:42:11 PDT

> the same way as you use telephone numbers for both TEL: and FAX: on you

The former would imply the IPP port, while the latter would imply
port 80.

The port used is a major difference.

Larry
-- 
http://www.parc.xerox.com/masinter    <--- NOT MY PRINTER

---

From: Carl-Uno Manros <[email-masked]>
Date: Mon, 6 Jul 1998 08:53:16 PDT

>The port used is a major difference.

Larry,

You are right the examples should have been:

or
 
	PRINTER: http://www.manros.com:631/ipp-printer

but I still do not think that the difference is that big.

Carl-Uno

Carl-Uno Manros