Subject: RE: IPP> Re: Implications of introducing new scheme and port for existing HTTP servers

From: "Zehler, Peter " <[email-masked]>
Date: Mon, 1 Jun 1998 12:52:21 PDT

Scott,
Will your product require no change at all if it is the front end for a
standard web server and an IPP Printer?  It seems this would require your
product to listen to 2 ports.  An alternative would be to have 2
instantiations, one for regular HTTP and one for IPP over HTTP.
Pete

				Peter Zehler
				XEROX
				Networked Products Business Unit
				Email: [email-masked]
				Voice:    (716) 265-8755
				FAX:      (716) 265-8792 
				US Mail: Peter Zehler
				        Xerox Corp.
				        800 Phillips Rd.
				        M/S 111-02J
				        Webster NY, 14580-9701

	-----Original Message-----
	From:	Scott Lawrence [SMTP:[email-masked]]
	Sent:	Monday, June 01, 1998 3:02 PM
	To:	[email-masked]
	Subject:	IPP> Re: Implications of introducing new scheme and
port for existing HTTP servers

	On Mon, 1 Jun 1998, Carl-Uno Manros wrote:

	> 1) the introduction of a new scheme called "ipp"
	> 2) the introduction a new default port number for IPP servers.
	> 
	> Before the IPP WG responds to those suggestions, the IPP WG would
like to
	> get some advice from the HTTP WG on the implications of such a
change.
	> In particular, we want some feedback on how easy or difficult it
would be
	> to configure existing web servers to accomodate the suggested
changes.

	  Answering for EmWeb, our embedded web server:

	  The new scheme (1) would require a very minor change from our
existing
	product, which requires that he scheme be 'http' if it is present at
	all.  We'd need to allow 'ipp', and perhaps add a check to ensure
that
	it is being used on the proper port (if that is deemed to be
important).
	If the client does not send the scheme, then there would be no
change.

	  The new port (2) would be no change at all, since it can already
	operate on any port.  One might wish to recognize that the default
port
	for an 'ipp:' scheme redirect would be different than for an 'http:'
	redirect, but that's a very minor matter.

---

From: Scott Lawrence <[email-masked]>
Date: Tue, 2 Jun 1998 09:07:29 -0400 (EDT)

On Mon, 1 Jun 1998, Zehler, Peter  wrote:

> product to listen to 2 ports.

  It is common for a single server to listen on multiple ports.  As
Peter Melquist from HP pointed out, there is even a well known port for
network management over HTTP (280).  Our server will listen on whatever
ports the system tells it to.

---

From: [email-masked]
Date: Wed, 3 Jun 1998 14:00:13 -0700

If you wish to add security, you may be dealing with up to four ports, 
     two for HTTP and two more for HTTP-S. Embedded web server 
     implementations should be able to deal with this fine. The issue 
     remains reconfiguratoin of Firewalls to allow inbound connections on 
     all ports. Firewalls can be easily configured, IT folks hate to do it 
     though.
     
     A beneficial side effect of using special ports for IPP is that of 
     easy IPP service discovery. Web crawler like tools can easily discover 
     IPP servers running on say , port 380, and thereby be able to find all 
     IPP printers within a network. This can allow IPP discovery using 
     standard tools today. The process would look something like...
     
     For all IP Valid Addresses...
        - perform HTTP HEAD request on port 380
        - If HEAD response
            Add URL to Directory Services List as IPP printer
     
     This same approach has been used by HP OpenView when discovering Web 
     enabled appliances for management purposes with success on port 280.
     
     The same can be done digging for URI's, it takes more work.
     
     Someone might pursue grabbing port 380 through IANA...
     
     Peter

______________________________ Reply Separator _________________________________
Subject: RE: IPP> Re: Implications of introducing new scheme and po
Author:  Non-HP-Peter.Zehler ([email-masked]) at 
HP-Roseville,mimegw4
Date:    6/1/98 12:52 PM

Scott,
     
                                Peter Zehler
                                XEROX

        -----Original Message-----
        From:   Scott Lawrence [SMTP:[email-masked]] 
        Sent:   Monday, June 01, 1998 3:02 PM
        To:     [email-masked]
        Subject:        IPP> Re: Implications of introducing new scheme and

like to
change.
would be
changes.