Subject: RE: IPP> Re: Suggested workplan - host to device protocol

From: "Turner, Randy" <[email-masked]>
Date: Tue, 17 Feb 1998 07:33:52 -0800

I think Roger (correct if I'm wrong, Roger) meant that IPP, as currently
defined, is the correct solution for server-to-printer protocol, IF the
printer device already has an embedded web server, like would probably
be used for overall management. And if this is the assertion, then I
tend to agree with it, although it depends on what the exact
*requirements* are for server-to-printer protocol.

Randy

	-----Original Message-----
	From:	[email-masked] [SMTP:[email-masked]]
	Sent:	Tuesday, February 17, 1998 7:24 AM
	To:	[email-masked]
	Subject:	IPP> Re: Suggested workplan - host to device
protocol

	Roger deBry said:

	>Assertions:
	>
	>(1) IPP, as it is currently defined, is the correct protocol
	>      for client to server, across the Internet.
	>
	>(2) IPP, as it is currently defined, is the correct protocol
	>      for client to server, across an Intranet
	>
	>(3) IPP, as it is currently defined, is the correct protocol
	>      between a server and a printer which contains an
	>      imbedded server.

	I can easily agree with Roger on #1 and #2.  I think where
	the problem lies is with #3.  I am not sure how broad the
	definition of "imbedded server" is?  Does that mean imbedded
	IPP server or any server?  All of my network printers today
	have available what we call an Internal Print Server which
	supports a wide range of protocols.  Is that what you mean
	Roger?  I don't think so.  I think the definition needs to
	be "imbedded, spooling print server."  And even then, I think
	we have lost a huge amount of control and status information
	that is available from TIPSI or even SNMP.  Maybe we need
	to define some kind of passthrough for IPP that allows
	the control and status information for the down and dirty
	hardware to be retrieved and set through IPP??

	Comments?

	**********************************************
	* Don Wright                 [email-masked] *
	* Product Manager, Strategic Alliances       *
	* Lexmark International                      *
	* 740 New Circle Rd                          *
	* Lexington, Ky 40550                        *
	* 606-232-4808 (phone) 606-232-6740 (fax)    *
	**********************************************

---

From: "Craig Whittle" <[email-masked]>
Date: Wed, 18 Feb 1998 07:04:29 -0700

It appears as if this thread is the beginnings of yet another print protocol.  I would argue in favor of using existing protocols "TIPSI or even SNMP," as suggested by Don or at least leverage their strengths.  I believe the protocol could be the same between client and server and client and printer.  IPP is a simple solution for Internet job submission but it doesn't address the complexities of printer management that TIPSI or  SNMP do. Is it the objective of the PWG to grow IPP to include printer management capabilities like TIPSI or SNMP and richer job control like DPA?  I would hope that over time there would be a convergence of protocols that meets the needs of embedded devices as well as the need of hosts to servers, perhaps in a single protocol.

**CW

Craig T. Whittle
[email-masked]

>>> "Turner, Randy" <[email-masked]> 02/17/98 08:33AM >>>

Randy

	-----Original Message-----
	From:	[email-masked] [SMTP:[email-masked]] 
	Sent:	Tuesday, February 17, 1998 7:24 AM
	To:	[email-masked] 
	Subject:	IPP> Re: Suggested workplan - host to device
protocol

	Comments?

---

From: Harry Lewis <[email-masked]>
Date: Wed, 18 Feb 1998 13:50:52 -0500

Craig,

>I believe the protocol could be the same between client and server and client
and printer.  >IPP is a simple solution for Internet job submission but it
doesn't address the >complexities of printer management that TIPSI or SNMP do.

IPP defines a PRINTER OBJECT and a JOB OBJECT.
IPP has the following operations
 - PrintJob (Request/Response)
   - (Submit single doc job with data. Unsupportted attributes returned.)
 - PrintURI ("Pull" printing)
 - ValidateJob
   - (Like PrintJob w/no data. Validate operations prior to submission.)
 - CreateJob
   - (Setup for multi document job)
 - SendDocument (Request/Response)
 - SendURI
 - GetJob (Request/Response)
   - When shopping for the shortest print queue
 - CancelJob (Request/Response)
   - Probably the best feature of all
 - GetPrinterAttributes (Request/Response)
   - Granted, a cumbersome intersection with the Printer MIB which (in my
     opinion) could possibly be strengthened or dilluted dependint on the
     tug-of-war between "in-band" and "side-channel" camps.
 - GetJobAttributes
   - A way to check job progress. Again, overlapping the Job MIB but,
     fortunately, correlated and potentially reconcilable.

Notification is the next big feature to be tackled by IPP (analogous to "Jobs"
in the Printer MIB, notification was counciously pared from the IPPv1 scope in
order to make progress).

What complexitis of printer management are you referring to which are currently
missing from IPP? Is it conceivable that these may fall nicely into the realm
of notification?

Harry Lewis - IBM Printing Systems

[email-masked] on 02/18/98 07:16:30 AM
Please respond to [email-masked] @ internet
To: [email-masked] @ internet
cc:
Subject: RE: IPP> Re: Suggested workplan - host to device protocol

It appears as if this thread is the beginnings of yet another print protocol.
I would argue in favor of using existing protocols "TIPSI or even SNMP," as
suggested by Don or at least leverage their strengths.  I believe the protocol
could be the same between client and server and client and printer.  IPP is a
simple solution for Internet job submission but it doesn't address the
complexities of printer management that TIPSI or  SNMP do. Is it the objective
of the PWG to grow IPP to include printer management capabilities like TIPSI or
SNMP and richer job control like DPA?  I would hope that over time there would
be a convergence of protocols that meets the needs of embedded devices as well
as the need of hosts to servers, perhaps in a single protocol.

**CW

Craig T. Whittle
[email-masked]

Randy

 -----Original Message-----
 From: [email-masked] [SMTP:[email-masked]]
 Sent: Tuesday, February 17, 1998 7:24 AM
 To: [email-masked]
 Subject: IPP> Re: Suggested workplan - host to device
protocol

 Comments?