Subject: Re: IPP> MOD - URGENT: Ok to call 2nd printer uri: "printer-map -uri"?

From: [email-masked] (Robert Herriot)
Date: Wed, 17 Dec 1997 13:03:23 -0800

I had a concern when "printer-map-uri" was considered that most people
would think of the English word "map" rather than see it as an
acronym for "mutual authentication and privacy".

But the reason for moving away from "secure-printer-uri" is that
the printer-uri is not totally insecure. It can have authentication.

Perhaps "printer-tls-uri" is the least bad, but we have had other
reasons for avoiding it.  It also the case, that if we went to name
another port (other than 80 and 443) in the protocol, the IESG would
want a single port for TLS and non-tls, so there might be a single
printer-uri. Though I expect that depPerhaps

> From [email-masked] Wed Dec 17 10:18:16 1997
> 
> 
> If I were to see "printer-map-uri" I would assume I could point my browser
> at thar uri and see were the printer is located on a MAP!!
> 
> What about being real straight-forward and calling it one of the following:
> 
> TLS-Printer-uri
> Printer-TLS-uri
> 
> Actually, secure-printer-uri is exactly what is says it is and printer-uri
> says
> nothing about security.  I'm not opposed to calling it what it is and
> living with
> the implications of that.
> 
> Don
> 
> 
> **********************************************
> * Don Wright                 [email-masked] *
> * Product Manager, Strategic Alliances       *
> * Lexmark International                      *
> * 740 New Circle Rd                          *
> * Lexington, Ky 40550                        *
> * 606-232-4808 (phone) 606-232-6740 (fax)    *
> **********************************************
> 
> -----------------------------------------------
> 
> 
> 
> To:   [email-masked]
> cc:   [email-masked],
>       [email-masked] (bcc: Don Wright)
> bcc:  Don Wright
> Subject:  IPP> MOD - URGENT: Ok to call 2nd printer uri: "printer-map-uri"?
> 
> 
> 
> 
> In Washington and before, there has been discussion that calling
> the second uri, "printer-secure-uri" makes it sound like the first
> "printer-uri" is not secure.  So we've been searching for a better
> term.
> Scott and Steve came up with the term (drum roll):
>    "Mutual Authentication and Privacy (MAP).
> So ok to call the second uri Printer attribute: "printer-map-uri"?
> It will be put right after the first uri: "printer-uri" secion
> 4.4.2 in the Model document.
> SEND COMMENTS TO DL, SO WE CAN FORWARD THE INTERNET-DRAFT THIS WEEK
> TO THE IESG.
> Thanks,
> Tom
> 
> 
> 
> 
> 
>

---

From: [email-masked] (Robert Herriot)
Date: Wed, 17 Dec 1997 13:12:07 -0800

The previous email was sent accidentally before it was complete.

The important issue is that "printer-map-uri" probably isn't right,
but I'm not sure what is.  We could switch around the acronym
to "pma" ("privacy and mutual authentication") to give us
"printer-pma-uri".

But the issue I started to raise in the previous email is what
a single dedicated port would look like. Would we still have
the "http" and "https" schemes on a single port, or would we
go to an "ipp" scheme with some other mechanism to determine whether
the TLS is being used.  This has implications for when the 
alternative printer-uri is used.

Perhaps another name is "printer-alt-uri" or "printer-alternate-uri".

Bob

> From: [email-masked]
> X-Lotus-Fromdomain: LEXMARK@LEXMTA
> To: [email-masked]
> Cc: [email-masked]
> Date: Wed, 17 Dec 1997 12:55:37 -0500
> Subject: Re: IPP> MOD - URGENT: Ok to call 2nd printer uri: "printer-map
> 	-uri"?
> Mime-Version: 1.0
> Sender: [email-masked]
> X-Lines: 58
> 
>