Subject: IPP> IBM's IPP Client Prototype Problems

From: [email-masked]
Date: Tue, 25 Nov 1997 15:19:36 +0900

Hello.

I am now working to develop prototypes with IPP documents.
IBM's client sent these data to ipp server as follows.

result of analysis:
  01 00 00 02 01 29 00 08 6A 6F 62 2D 6E 61 6D 65   .....)..job-name
  ~~1~~ ~~2~~ ~3 ~4 ~~5~~ ~~~~~~~~~~~6~~~~~~~~~~~
  00 04 6A 6F 62 31 29 00 16 69 70 70 2D 61 74 74   ..job1)..ipp-att
  ~~7~~ ~~~~~8~~~~~ ~9 ~~10~ ~~~~~~~~~~11~~~~~~~~
  72 69 62 75 74 65 2D 66 69 64 65 6C 69 74 79 00   ribute-fidelity.
  ~~~~~~~~~~~~~~~~~~~11~~~~~~~~~~~~~~~~~~~~~~~ ~12
  05 66 61 6C 73 65 29 00 0D 64 6F 63 75 6D 65 6E   .false)..documen
  ~~ ~~~~~~13~~~~~~ 14 ~~15~ ~~~~~~~~~16~~~~~~~~~
  74 2D 6E 61 6D 65 00 09 64 6F 63 75 6D 65 6E 74   t-name..document
  ~~~~~~~~16~~~~~~~ ~~17~ ~~~~~~~~~~~18~~~~~~~~~~
  31 02 15 00 06 63 6F 70 69 65 73 00 01 01 15 00   1....copies.....
  ~~ 19 20 ~~21~ ~~~~~~~~22~~~~~~~ ~~23~ 24 25 ~26
  0C 6A 6F 62 2D 70 72 69 6F 72 69 74 79 00 01 01   .job-priority...
  ~~ ~~~~~~~~~~~~~~~~~27~~~~~~~~~~~~~~~~ ~~28~ ~29
  03                                                .
  ~30

  1: IPP version 0x0100 -> IPP/1.0
  2: operation number 0x0002 -> Print-Job
  3: tag 0x01 -> operation-attributes-tag
  4: tag 0x29 -> this tag is reserved for future integer types
  5: length of attribute-name 0x0008 -> 8bytes
  6: attribute-name -> "job-name"
  7: length of attribute-value 0x0004 -> 4bytes
  8: attribute-value -> "job1"
  9: tag 0x29 -> this tag does not exist in IPP protocol specification
 10: length of attribute-name 0x0016 -> 22bytes
 11: attribute-name -> "ipp-attribute-fidelity"
 12: length of attribute-value 0x0005 -> 5bytes
 13: attribute-value -> false,
                In IPP model specification, ipp-attribute-fidelity is boolean
                type. And in IPP protocol specification, if 'false' then 0x00,
                if 'true' then 0x01.
 14: tag 0x29 -> this tag does not exist in IPP protocol specification
 15: length of attribute-name 0x000D -> 13bytes
 16: attribute-name -> "document-name"
 17: length of attribute-value 0x0009 -> 9bytes
 18: attribute-value -> "document1"
 19: tag 0x02 -> job-attributes-tag
 20: tag 0x15 -> this tag is reserved for future "out-of-band" values
 21: length of attribute-name 0x0006 -> 6bytes
 22: attribute-name -> "copies"
 23: length of attribute-value 0x0001 -> 1byte
 24: attribute-value -> 1
 25: tag 0x15 -> this tag does not exist in IPP protocol specification
 26: length of attribute-name 0x000C -> 12bytes
 27: attribute-name -> "job-priority"
 28: length of attribute-value 0x0001 -> 1byte
 29: attribute-value -> 1
 30: tag 0x03 -> data-tag

Item 4, 9, 12, 13, 14, 20, 25 are not based on IPP protocol specification.
So IBM Client can not access to ipp server.

Best Regards,

Norimi Kawashima

----------------
Norimi Kawashima
Ricoh System Kaihatsu(Kitami) Co.Ltd.
592-7, hakuyou-cho, kitami, Hokkaido, Japan 090-0013
e-mail:[email-masked]
phone :+81-157-22-2201
facsimile:+81-157-22-2202

---

From: Carl Kugler <[email-masked]>
Date: Tue, 25 Nov 1997 12:50:28 -0500

Norimi-

I agree with your analysis.  Looks like we accidently used decimal instead of
hex for our type tags.

So, for example, at

we sent

 Dec Hex Char
 41  29  )

instead of

 Dec Hex Char
 65 41 A

when we were trying to sepcify

   Tag Value (Hex)   Meaning
   0x41              text

I'm working on a fix.  Send me email directly at [email-masked] if you'd
like an updated copy.

Carl Kugler
IBM

[email-masked] on 11/24/97 11:38:27 PM
Please respond to [email-masked] @ internet
To: [email-masked] @ internet
cc:
Subject: IPP> IBM's IPP Client Prototype Problems

Hello.

result of analysis:

Best Regards,

Norimi Kawashima

----------------
Norimi Kawashima