Subject: [IPP] Canonical IPP way to set job-sheets to a different paper/tray/medium?

From: pipitas <[email-masked]>
Date: Mon, 10 Dec 2018 23:17:53 +0100

What is the canonical IPP-ish way to request printing of a job-sheet on
different media (or media drawn from a different paper tray)?

I remember many years ago to have hacked some PostScript files for a big
institutional customer who required red separator sheets because thousands
of their students shared a few dozen "public" printers: I then equipped the
PostScript/banner files with some 'setpagedevice' statements, saved them to
/usr/share/cups/banners/ and, presto, whenever such a sheet was requested
it printed from the paper tray specified by setpagedevice.

Is there an IPP-defined job attribute that lets me order job-sheets to be
printed on a specific medium?

Now that modern CUPS doesn't by default use banners/job-sheets any more
which are PostScript files, what is another valid way to do achieve this
with PDF files (or even with application/vnd.cups-banner files)?
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 10 Dec 2018 17:33:04 -0500

There isn't anything specifically you can do in CUPS for the banners - it will use the same paper/tray settings for the banners as for the rest of the job.

There is a job-sheets-col attribute (defined in PWG 5100.3: Production Printing Attributes - Set 1) that provides more control.  At present this attribute is not supported by CUPS.

> On Dec 10, 2018, at 5:17 PM, pipitas <[email-masked]> wrote:
> 
> What is the canonical IPP-ish way to request printing of a job-sheet on different media (or media drawn from a different paper tray)?
> 
> I remember many years ago to have hacked some PostScript files for a big institutional customer who required red separator sheets because thousands of their students shared a few dozen "public" printers: I then equipped the PostScript/banner files with some 'setpagedevice' statements, saved them to /usr/share/cups/banners/ and, presto, whenever such a sheet was requested it printed from the paper tray specified by setpagedevice.
> 
> Is there an IPP-defined job attribute that lets me order job-sheets to be printed on a specific medium?
> 
> Now that modern CUPS doesn't by default use banners/job-sheets any more which are PostScript files, what is another valid way to do achieve this with PDF files (or even with application/vnd.cups-banner files)?
> 

_________________________________________________________
Michael Sweet, Senior Printing System Engineer

---

From: pipitas <[email-masked]>
Date: Tue, 11 Dec 2018 00:10:54 +0100

Thanks for the fast reply, Mike.

So typically, it will only be IPP-capable "production printers" I can hope
to request job-sheets to come from a different tray?

Is there any chance for CUPS to support this in the future?

>From my observations, in institutions large schools, universities and the
like as well as in other big organizations they do use this feature
quite often. I'm under the impression that support/tolerance for the
"PostScript-hack" banner pages will not go away in the very near future...
but should it happen, this would be killing a lot of usefulness in running
CUPS print servers for them...
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet <[email-masked]>
Date: Mon, 10 Dec 2018 22:39:14 -0500

Best thing is to file an issue requesting support for job-sheets-col on the CUPS Github repository:

	https://github.com/apple/cups/issues

I can't make any promises...

> On Dec 10, 2018, at 6:10 PM, pipitas <[email-masked]> wrote:
> 
> So typically, it will only be IPP-capable "production printers" I can hope to request job-sheets to come from a different tray?
> 
> From my observations, in institutions large schools, universities and the like as well as in other big organizations they do use this feature quite often. I'm under the impression that support/tolerance for the "PostScript-hack" banner pages will not go away in the very near future... but should it happen, this would be killing a lot of usefulness in running CUPS print servers for them...
> 
>

---

From: pipitas <[email-masked]>
Date: Tue, 11 Dec 2018 12:00:15 +0100

Issue filed: https://github.com/apple/cups/issues/5459

Thanks!

On Tue, Dec 11, 2018 at 4:39 AM Michael Sweet <[email-masked]> wrote:

> > So typically, it will only be IPP-capable "production printers" I can
> hope to request job-sheets to come from a different tray?
> >
> > From my observations, in institutions large schools, universities and
> the like as well as in other big organizations they do use this feature

---

From: Uli Wehner <[email-masked]>
Date: Tue, 11 Dec 2018 11:23:05 +0000

Thank you. I was thinking about doing the same.

Sent from my Sprint Samsung Galaxy S9.

-------- Original message --------
From: pipitas <[email-masked]>
Date: 12/11/18 6:01 AM (GMT-05:00)
To: Michael Sweet <[email-masked]>
Cc: [email-masked]
Subject: Re: [IPP] Canonical IPP way to set job-sheets to a different paper/tray/medium?[EXTERNAL]

Issue filed: https://github.com/apple/cups/issues/5459<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_apple_cups_issues_5459&d=DwMFaQ&c=5hYF0Zu0Yz-C6S-kaHDItw&r=Kf2OsKTEH35gSgu0U6HqdHzbU1TrLWRQF9AyGiFJjds&m=FQ2eEvg5eIzOSFEhp7p4hoUxBtnf8fsL9l-2PNxMTTs&s=JGKz2qPCyf8fS2lwDB6wYLdZzMfhVLrTHca_kRhVolw&e=>

Thanks!

On Tue, Dec 11, 2018 at 4:39 AM Michael Sweet <[email-masked]<mailto:[email-masked]>> wrote:
Best thing is to file an issue requesting support for job-sheets-col on the CUPS Github repository:

        https://github.com/apple/cups/issues<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_apple_cups_issues&d=DwMFaQ&c=5hYF0Zu0Yz-C6S-kaHDItw&r=Kf2OsKTEH35gSgu0U6HqdHzbU1TrLWRQF9AyGiFJjds&m=FQ2eEvg5eIzOSFEhp7p4hoUxBtnf8fsL9l-2PNxMTTs&s=BbkeSu4isc6UhkIZDaw8acjG6QoKKCjIz8Ncsg0wWAw&e=>

> On Dec 10, 2018, at 6:10 PM, pipitas <[email-masked]<mailto:[email-masked]>> wrote:
>
> [email-masked]<mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.pwg.org_mailman_listinfo_ipp&d=DwMFaQ&c=5hYF0Zu0Yz-C6S-kaHDItw&r=Kf2OsKTEH35gSgu0U6HqdHzbU1TrLWRQF9AyGiFJjds&m=FQ2eEvg5eIzOSFEhp7p4hoUxBtnf8fsL9l-2PNxMTTs&s=i-gkZ9-5ZVxVMTuqY87HbMehu2k_Fdz_GgBlf4o6xnE&e=>

---

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Tue, 11 Dec 2018 16:04:45 +0000

If the Printer supported IPP "overrides", it might also be possible for a driver upstream of the IPP client to support this as a "driver feature" by adding a page to the start and/or end of the Job's Document and using "overrides" to specify the media source / type for the added banner pages.

On Dec 10, 2018, at 3:33 PM, Michael Sweet <[email-masked]<mailto:[email-masked]>> wrote:

On Dec 10, 2018, at 5:17 PM, pipitas <[email-masked]<mailto:[email-masked]>> wrote:

_______________________________________________
ipp mailing list
[email-masked]<mailto:[email-masked]>
https://www.pwg.org/mailman/listinfo/ipp<https://www.pwg.org/mailman/listinfo/ipp>

---

From: Ira McDonald <[email-masked]>
Date: Tue, 11 Dec 2018 11:14:54 -0500

Hi Smith,

Except that Client-side banner pages can't include info known only to the
Printer
(which typically is included in banner pages) such as actual time of
printing.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Dec 11, 2018 at 11:05 AM Kennedy, Smith (Wireless & Standards
Architect) <[email-masked]> wrote:

> If the Printer supported IPP "overrides", it might also be possible for a
> driver upstream of the IPP client to support this as a "driver feature" by
> adding a page to the start and/or end of the Job's Document and using
> "overrides" to specify the media source / type for the added banner pages.
>
> On Dec 10, 2018, at 3:33 PM, Michael Sweet <[email-masked]> wrote:
>
> There isn't anything specifically you can do in CUPS for the banners - it
> will use the same paper/tray settings for the banners as for the rest of
> the job.
>
> There is a job-sheets-col attribute (defined in PWG 5100.3: Production
> Printing Attributes - Set 1) that provides more control.  At present this
> attribute is not supported by CUPS.
>
>

---

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Tue, 11 Dec 2018 17:07:16 +0000

Ah, good point!

Should there be an addition to System Service to support banner page management? Or are we going to consider banner pages a resource managed out-of-band of IPP? System Service doesn't seem to have that currently.

Smith

On Dec 11, 2018, at 9:14 AM, Ira McDonald <[email-masked]<mailto:[email-masked]>> wrote:

Hi Smith,

Except that Client-side banner pages can't include info known only to the Printer
(which typically is included in banner pages) such as actual time of printing.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic<http://sites.google.com/site/blueroofmusic>
http://sites.google.com/site/highnorthinc<http://sites.google.com/site/highnorthinc>
mailto: [email-masked]<mailto:[email-masked]>
PO Box 221  Grand Marais, MI 49839  906-494-2434

On Tue, Dec 11, 2018 at 11:05 AM Kennedy, Smith (Wireless & Standards Architect) <[email-masked]<mailto:[email-masked]>> wrote:
If the Printer supported IPP "overrides", it might also be possible for a driver upstream of the IPP client to support this as a "driver feature" by adding a page to the start and/or end of the Job's Document and using "overrides" to specify the media source / type for the added banner pages.

---

From: Ira McDonald <[email-masked]>
Date: Tue, 11 Dec 2018 14:03:18 -0500

Hi Smith,

No need for System Service updates.

As Mike observed earlier in this thread, job-sheets-col (PWG 5100.3
Production Printing) already
covers this feature.

Cheers,
- Ira

On Tue, Dec 11, 2018 at 12:15 PM Kennedy, Smith (Wireless & Standards
Architect) <[email-masked]> wrote:

> Ah, good point!
>
> Should there be an addition to System Service to support banner page
> management? Or are we going to consider banner pages a resource managed
> out-of-band of IPP? System Service doesn't seem to have that currently.
>
> Smith
>
>
>
> On Dec 11, 2018, at 9:14 AM, Ira McDonald <[email-masked]> wrote:
>
> Hi Smith,
>

---

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Tue, 11 Dec 2018 19:58:10 +0000

Hi Ira,

5100.3 covers a Client using the Job Sheets feature via "job-sheets-col", which extends "job-sheets" with the ability to specify a "media" or "media-col" with the sheets. 

But what the Printer actually renders and prints onto the job sheets themselves isn't covered. The assumption seems to be that the content to be printed on the job sheets is implementation-specific. If I as an operator wanted the job sheet to present my organization's logo, the user's name, date, job name, printing statistics and print quota status, I would presumably need to create this myself using something provided by the printer vendor?

Am I missing something?

Smith

> On Dec 11, 2018, at 12:03 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Smith,
> 
> As Mike observed earlier in this thread, job-sheets-col (PWG 5100.3 Production Printing) already 
> covers this feature.
> 
> Cheers,
> - Ira
> 
> http://sites.google.com/site/blueroofmusic <https://protect-us.mimecast.com/s/yWSqCVOrBrc7LzZKtGNwIU?domain=sites.google.com>
> http://sites.google.com/site/highnorthinc <https://protect-us.mimecast.com/s/0nsvCW6vDvh2gN4YuxHqBJ?domain=sites.google.com>
> mailto: [email-masked] <mailto:[email-masked]>
> On Tue, Dec 11, 2018 at 12:15 PM Kennedy, Smith (Wireless & Standards Architect) <[email-masked] <mailto:[email-masked]>> wrote:
> Ah, good point!
> 
>> On Dec 11, 2018, at 9:14 AM, Ira McDonald <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Smith,
>> 
>> http://sites.google.com/site/blueroofmusic <https://protect-us.mimecast.com/s/yWSqCVOrBrc7LzZKtGNwIU?domain=sites.google.com>
>> http://sites.google.com/site/highnorthinc <https://protect-us.mimecast.com/s/0nsvCW6vDvh2gN4YuxHqBJ?domain=sites.google.com>
>> mailto: [email-masked] <mailto:[email-masked]>
>> On Tue, Dec 11, 2018 at 11:05 AM Kennedy, Smith (Wireless & Standards Architect) <[email-masked] <mailto:[email-masked]>> wrote:
>>> On Dec 10, 2018, at 3:33 PM, Michael Sweet <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>>> On Dec 10, 2018, at 5:17 PM, pipitas <[email-masked] <mailto:[email-masked]>> wrote:
>>>> 
>>>> [email-masked] <mailto:[email-masked]>
>>>> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/wUHOCXDwEwT1yk9NSDeYPn?domain=pwg.org>
>>> 
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/wUHOCXDwEwT1yk9NSDeYPn?domain=pwg.org>
>> [email-masked] <mailto:[email-masked]>
>> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/wUHOCXDwEwT1yk9NSDeYPn?domain=pwg.org>
>

---

From: Michael Sweet <[email-masked]>
Date: Tue, 11 Dec 2018 15:06:11 -0500

Ira,

I think Smith's question has more to do with whether a Client can create new banners (job sheets) via the System service, and then associate them with a Printer.

Conceptually we could add a "resource-type" value for job-sheets ('static-job-sheet' or 'template-job-sheet'?) - the main issue I'd have is how the Printer would know where to place job information on the sheet...

> On Dec 11, 2018, at 2:03 PM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Smith,
> 
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
>> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
>> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
>>>> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
>>> 
>>> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
>> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
>

---

From: "Kennedy, Smith (Wireless & Standards Architect)" <[email-masked]>
Date: Tue, 11 Dec 2018 20:12:25 +0000

> On Dec 11, 2018, at 1:06 PM, Michael Sweet <[email-masked]> wrote:
> 
> Ira,
> 

That's it - thanks Mike! Sorry to all for my struggles with being articulate. 

> Conceptually we could add a "resource-type" value for job-sheets ('static-job-sheet' or 'template-job-sheet'?) - the main issue I'd have is how the Printer would know where to place job information…

That did occur to me - creating that sounds like it opens up a bunch of work. (The old CUPS PostScript test page comes to mind...) But even with something static, a resource type would be needed.

> 
> 
>> On Dec 11, 2018, at 2:03 PM, Ira McDonald <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Smith,
>> 
>> http://sites.google.com/site/blueroofmusic <https://protect-us.mimecast.com/s/hF7DCOYkrkiJ9zLKtEulGy?domain=sites.google.com>
>> http://sites.google.com/site/highnorthinc <https://protect-us.mimecast.com/s/DHOICPNlvlcOr81xi0Sc7u?domain=sites.google.com>
>>> http://sites.google.com/site/blueroofmusic <https://protect-us.mimecast.com/s/hF7DCOYkrkiJ9zLKtEulGy?domain=sites.google.com>
>>> http://sites.google.com/site/highnorthinc <https://protect-us.mimecast.com/s/DHOICPNlvlcOr81xi0Sc7u?domain=sites.google.com>
>>>>> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/RpVxCQWmwmF8EM1WIMhL0B?domain=pwg.org>
>>>> 
>>>> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/RpVxCQWmwmF8EM1WIMhL0B?domain=pwg.org>
>>> https://www.pwg.org/mailman/listinfo/ipp <https://protect-us.mimecast.com/s/RpVxCQWmwmF8EM1WIMhL0B?domain=pwg.org>
>> 
>

---

From: Ira McDonald <[email-masked]>
Date: Wed, 12 Dec 2018 12:52:02 -0500

Hi Smith and Mike,

We thought about this use case (templates for content items of
job sheets) years ago in Open Printing WG and concluded that
exact layout (left top of page) was overkill and a simple ordered
list of content item keywords to be centered, in order, leaving
layout entirely to the Printer (font, point size, etc.) was a useful
approach.

It's certainly an interesting topic, due to its wide implementation
in enterprise, academic, and other managed networks.

All - Is there interest in pursuing this in IPP WG?

Cheers,
- Ira

On Tue, Dec 11, 2018 at 3:12 PM Kennedy, Smith (Wireless & Standards
Architect) <[email-masked]> wrote:

> I think Smith's question has more to do with whether a Client can create
> new banners (job sheets) via the System service, and then associate them
> with a Printer.
>
>
> Conceptually we could add a "resource-type" value for job-sheets
> ('static-job-sheet' or 'template-job-sheet'?) - the main issue I'd have is
> how the Printer would know where to place job information on the sheet...
>
>
> That did occur to me - creating that sounds like it opens up a bunch of
> work. (The old CUPS PostScript test page comes to mind...) But even with
> something static, a resource type would be needed.
>
>
>
> <https://protect-us.mimecast.com/s/hF7DCOYkrkiJ9zLKtEulGy?domain=sites.google.com>
> <https://protect-us.mimecast.com/s/DHOICPNlvlcOr81xi0Sc7u?domain=sites.google.com>
>> <https://protect-us.mimecast.com/s/hF7DCOYkrkiJ9zLKtEulGy?domain=sites.google.com>
>> <https://protect-us.mimecast.com/s/DHOICPNlvlcOr81xi0Sc7u?domain=sites.google.com>
>>> If the Printer supported IPP "overrides", it might also be possible for
>>> a driver upstream of the IPP client to support this as a "driver feature"
>>> by adding a page to the start and/or end of the Job's Document and using
>>> There isn't anything specifically you can do in CUPS for the banners -
>>> it will use the same paper/tray settings for the banners as for the rest of
>>> the job.
>>>
>>> <https://protect-us.mimecast.com/s/RpVxCQWmwmF8EM1WIMhL0B?domain=pwg.org>
>>>
>>>
>>> <https://protect-us.mimecast.com/s/RpVxCQWmwmF8EM1WIMhL0B?domain=pwg.org>
>>>
>>>
>>> <https://protect-us.mimecast.com/s/RpVxCQWmwmF8EM1WIMhL0B?domain=pwg.org>
>>>
>>
>>