Subject: [IPP] Adding "printer-service-contact" to IPP Enterprise Printing Extensions v2.0

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Thu, 22 Apr 2021 21:55:40 +0000

Hi there,

I'd like to pre-screen the addition of "printer-service-contact" to IPP Enterprise Printing Extensions v2.0. But I'm unsure how to model it. I have found "printer-contact-col" and "system-contact-col" in IPP System Service (5100.22). Should I clone that?

X.Y printer-service-contact-col (collection | unknown)

This REQUIRED Printer Description attribute identifies the Printer service agent. Table 10 lists this attribute's member attributes. When specified in a Set-Printer-Attributes operation [RFC3380], the collection value MUST contain all REQUIRED member attributes as the entire collection value is replaced.

X.Y.1 contact-name (name(MAX))

This REQUIRED member attribute contains the contact name, e.g., "Bob Smith".

X.Y.2 contact-uri (uri)

This REQUIRED member attribute contains the contact URI, e.g., “mailto:[email-masked]”.

X.Y.3 contact-vcard (1setOf text(MAX))
This RECOMMENDED member attribute contains the contact vCard [RFC6350].

Or should I do something simpler, like this:

X.Y printer-service-contact (uri)

This REQUIRED Printer Description attribute specifies a URI used to contact the service agent responsible for the Printer. The value MUST use the "mailto", "tel", "http" or "https" URI schemes.

Thoughts?

Smith

/**
    Smith Kennedy
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Fri, 23 Apr 2021 08:46:56 -0400

Smith,

We wanted "printer-service-contact-col" to be a collection with the same member attributes as "printer-contact-col" and "system-contact-col", so the first form is what you should go with.

(FWIW, the printer MIB element is just an octet string that has no defined format...)

> On Apr 22, 2021, at 5:55 PM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]> wrote:
> 
> Signed PGP part
> Hi there,
> 

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Fri, 23 Apr 2021 17:40:18 +0000

How's this for wording?

6.4.15 printer-service-contact-col (collection | unknown)
This REQUIRED Printer Description attribute contains contact information for the service agent responsible for maintaining the Printer, or the 'unknown' out-of-band value if no service agent contact information has been set. Table 12 lists the member attributes defined in this specification. A Printer MUST support the "contact-name" and "contact-uri" member attributes.

A Printer receiving this attribute in a Set-Printer-Attributes operation [RFC3380] replaces the entire existing value with the one received if the Printer acccepted the operation. A Printer receiving this attribute in a Set-Printer-Attributes operation where the collection lacks all the REQUIRED members MUST reject the request and return the 'client-error-bad-request' status code.

Table 12 - "printer-service-contact-col" Member Attributes
Member Attribute			Printer Conformance
contact-name (name(MAX))		REQUIRED
contact-uri (uri)			REQUIRED
contact-vcard (1setOf text(MAX))	RECOMMENDED

6.4.15.1 contact-name (name(MAX))
This REQUIRED member attribute provides the contact's name, e.g., "Bob Smith".

6.4.15.2 contact-uri (uri)
This REQUIRED member attribute provides a URI that can be used for contacting the Printer service agent, e.g., “mailto:[email-masked]” or "tel:+1-208-123-4567".

6.4.15.3 contact-vcard (1setOf text(MAX))
This RECOMMENDED member attribute contains the contact vCard [RFC6350].

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On Apr 23, 2021, at 6:46 AM, Michael Sweet <[email-masked]> wrote:
> 
> Smith,
>

---

From: Michael Sweet via ipp <[email-masked]>
Date: Sat, 24 Apr 2021 07:54:16 -0400

+1

> On Apr 23, 2021, at 1:40 PM, Kennedy, Smith (Wireless & IPP Standards) <[email-masked]> wrote:
> 
> How's this for wording?
> 

________________________
Michael Sweet