Subject: [IPP] RFC: Bring back S/MIME support for IPP Encrypted Jobs and Documents?

From: Michael Sweet via ipp <[email-masked]>
Date: Wed, 21 Apr 2021 06:27:49 -0400

All,

Somehow we missed this, but the IETF published an update to S/MIME in April of 2019:

    https://tools.ietf.org/html/rfc8551

Among other things, this update addresses the EFAIL cryptographic vulnerability in S/MIME by adding support for some new cipher suites with Galois/Counter Mode (GCM) instead of the old (insecure) Cipher Block Chaining (CBC) mode.

Using S/MIME bring the advantage that it shares most of the infrastructure that is already in place for TLS, particularly when it comes to trusting a third party.  PGP depends on the "web of trust" for this and may not be as attractive to some.

Thoughts?

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Wed, 21 Apr 2021 12:30:49 +0000

Wow, thanks for finding this! I’m sure that enterprises would prefer using S/MIME. We should definitely review this and work to restore S/MIME in TRUSTNOONE if we believe it is appropriate.

Cheers,
Smith
---
Smith Kennedy
[email-masked]

On Apr 21, 2021, at 4:28 AM, Michael Sweet via ipp <[email-masked]> wrote:

 All,

https://tools.ietf.org/html/rfc8551<https://tools.ietf.org/html/rfc8551>

Thoughts?

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp<https://www.pwg.org/mailman/listinfo/ipp>
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Wed, 21 Apr 2021 10:22:37 -0400

Hi Mike and Smith,

Excellent - I'll add this to IPP WG agenda for tomorrow - will send agenda
this afternoon.

Cheers,
- Ira
*Ira McDonald (Musician / Software Architect)*

*Chair - SAE Trust Anchors and Authentication TF*
*Co-Chair - TCG Trusted Mobility Solutions WG*

*Co-Chair - TCG Metadata Access Protocol SG*

*Chair - Linux Foundation Open Printing WGSecretary - IEEE-ISTO Printer
Working GroupCo-Chair - IEEE-ISTO PWG Internet Printing Protocol WGIETF
Designated Expert - IPP & Printer MIBBlue Roof Music / High North
Inchttp://sites.google.com/site/blueroofmusic
<http://sites.google.com/site/blueroofmusic>http://sites.google.com/site/highnorthinc
<http://sites.google.com/site/highnorthinc>mailto: [email-masked]
<[email-masked]>(permanent) PO Box 221  Grand Marais, MI 49839
906-494-2434*

On Wed, Apr 21, 2021 at 8:31 AM Kennedy, Smith (Wireless & IPP Standards)
via ipp <[email-masked]> wrote:

> Wow, thanks for finding this! I’m sure that enterprises would prefer using
> S/MIME. We should definitely review this and work to restore S/MIME in
> TRUSTNOONE if we believe it is appropriate.
>
> Cheers,
> Smith
> ---
> Smith Kennedy
> [email-masked]
>
>
> Among other things, this update addresses the EFAIL cryptographic
> vulnerability in S/MIME by adding support for some new cipher suites with
> Galois/Counter Mode (GCM) instead of the old (insecure) Cipher Block
> Chaining (CBC) mode.
>
> Using S/MIME bring the advantage that it shares most of the infrastructure
> that is already in place for TLS, particularly when it comes to trusting a
> third party. PGP depends on the "web of trust" for this and may not be as
> attractive to some.
>
> Thoughts?
>
> ________________________
> Michael Sweet
>
>
>

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Wed, 21 Apr 2021 15:04:32 +0000

Hi Ira,

Can you also add ipptool updates / IPP Everywhere Self-Certification toolset updates to the agenda? Want to discuss for ~5 minutes.

Smith

> On Apr 21, 2021, at 8:22 AM, Ira McDonald <[email-masked]> wrote:
> 
> Hi Mike and Smith,
> 
> Excellent - I'll add this to IPP WG agenda for tomorrow - will send agenda this afternoon.
> 
> Cheers,
> - Ira
> Ira McDonald (Musician / Software Architect)
> Chair - SAE Trust Anchors and Authentication TF
> Co-Chair - TCG Trusted Mobility Solutions WG
> Co-Chair - TCG Metadata Access Protocol SG
> Chair - Linux Foundation Open Printing WG
> Secretary - IEEE-ISTO Printer Working Group
> Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
> IETF Designated Expert - IPP & Printer MIB
> Blue Roof Music / High North Inc
> http://sites.google.com/site/blueroofmusic <http://sites.google.com/site/blueroofmusic>
> http://sites.google.com/site/highnorthinc <http://sites.google.com/site/highnorthinc>
> mailto: [email-masked] <mailto:[email-masked]>
> (permanent) PO Box 221  Grand Marais, MI 49839  906-494-2434
> 
> 
> On Wed, Apr 21, 2021 at 8:31 AM Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked] <mailto:[email-masked]>> wrote:
> [email-masked] <mailto:[email-masked]>
> 
> 
>> On Apr 21, 2021, at 4:28 AM, Michael Sweet via ipp <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>>  All,
>> 
>> https://tools.ietf.org/html/rfc8551 <https://tools.ietf.org/html/rfc8551>
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>
> [email-masked] <mailto:[email-masked]>
> https://www.pwg.org/mailman/listinfo/ipp <https://www.pwg.org/mailman/listinfo/ipp>