Subject: [IPP] IPP WG Agenda 3:00-4:30pm US Eastern (20 May 2021)

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 20 May 2021 08:26:57 -0400

Hi,

Our next regular IPP WG call will be on Thursday
at 12:00-13:30pm US Pacific / 3:00-4:30pm US Eastern

NOTE: Please USE the *NEW* WebEx meeting below!

-------------------------------------------------------
Meeting information
-------------------------------------------------------
PWG Chair is inviting you to a scheduled WebEx meeting.

Occurs every Thursday effective Thursday, January 14, 2021 from
3:00 PM to 4:30 PM, (UTC-05:00) Eastern Time (US & Canada)
1 hr 30 mins

Join meeting
<https://printerworkinggroup.my.webex.com/printerworkinggroup.my/j.php?MTID=m1ec63e3f9ccef2d69934882f93b83b3c>

*More ways to join:*

*Join from the meeting link*
https://printerworkinggroup.my.webex.com/printerworkinggroup.my/j.php?MTID=m1ec63e3f9ccef2d69934882f93b83b3c

*Join by meeting number*
Meeting number (access code): 126 908 4132
Meeting password: 6Zc7eJPWdQ8 (69273579 from phones and video systems)

*Tap to join from a mobile device (attendees only)*
+1-415-655-0001,,1269084132#69273579#
<%2B1-415-655-0001,,*01*1269084132%2369273579%23*01*> US Toll
Some mobile devices may ask attendees to enter a numeric meeting password.

*Join by phone*
+1-415-655-0001 US Toll
Global call-in numbers
<https://printerworkinggroup.my.webex.com/printerworkinggroup.my/globalcallin.php?MTID=m706cf95ad2262c1bb03cd4b84278830d>

*Join by video system, application or Skype for business*
Dial [email-masked]
You can also dial 173.243.2.68 and enter your meeting number.

Need help? Go to https://help.webex.com

-------------------------------------------------------

Agenda:
(1) PWG IP Policy, Minute Taker, Roll Call, and Agenda Review
- Volunteer as minute taker?
-- Status of all IPP documents in progress is up-to-date below

(2) Approve IPP minutes from previous meetings
- https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20210422.pdf
-- IPP WG call on 04/22/21
- https://ftp.pwg.org/pub/pwg/ipp/minutes-ippv2-f2f-minutes-20210505.pdf
-- IPP WG sessions at PWG/OP Virtual F2F in May 2021

<https://ftp.pwg.org/pub/pwg/ipp/minutes-ippv2-f2f-minutes-20210505.pdf>

<https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-f2f-minutes-20210505.pdf>

(3) Status/Review of various IPP mailing list notes
- https://www.pwg.org/archives/ipp/2021/020934.html
-- Fwd: [TLS] Protocol Action: 'The Datagram Transport Layer Security
(DTLS) Protocol Version 1.3' to Proposed Standard
(draft-ietf-tls-dtls13-43.txt)
- https://www.pwg.org/archives/ipp/2021/020935.html
-- Link to US CERT CISA weekly vulnerability summaries

(4) Status of AMSC and ISO liaisons w/ PWG (Paul)
- http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20210405.htm
- http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20210419.htm
- http://ftp.pwg.org/pub/pwg/general/sc/pwg-sc-call-minutes-20210517.htm
-- see PWG Steering Committee minutes from 04/05/21, 04/19/21, 05/17/21

(5) Status of PWG and IPP WG Formal Approvals and Last Calls (All)
* IPP Everywhere v1.1 Printer Self-Certification Tools Update 3 (Mike)
- https://www.pwg.org/archives/ipp/2021/020938.html
-- IPP WG Last Call started 05/17/21 ends 05/31/21 or later

(6) Review of IPP Storage Registration (Mike)
- https://www.pwg.org/archives/ipp/2021/020845.html
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippstorage10-20210129.pdf
-- Content is intended for IPP Enterprise Printing Extensions v2.0 (see
below)

<https://www.pwg.org/archives/ipp/2021/020845.html>

(7) Review of IPP Finishings v3.0 (Smith)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippfinishings30-20210412-rev.pdf
-- Prototype draft - for Major update
-- IPP WG review at PWG/OP F2F on 04/08/21
-- Schedule - Stable draft in Q3/Q4 2021

(8) Review of IPP Enterprise Printing Ext v2.0 (Smith)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippepx20-20210423-rev.pdf
-- RFC: printer-storage/-description attributes and printer-state-reasons
values
-- Prototype draft - for a Candidate Standard
-- PWG review at PWG/OP Virtual F2F in May 2021
-- stopped at section 6.2
-- Schedule - Stable draft in Q3/Q4 2021

(9) Review of IPP Driverless Printing Extensions v2.0 (Smith)
- https://ftp.pwg.org/pub/pwg/ipp/wd-ippnodriver20-20210501-rev.pdf
-- Interim draft - for a Candidate Standard
-- PWG review at PWG/OP Virtual F2F in May 2021
-- stopped at section 6.5.25
-- Schedule - Prototype draft in Q3/Q4 2021

(10) Status of recent IPP Wiki Pages (Mike)
- https://github.com/istopwg/ippsample/wiki/IPP
-Everywhere-Value-Proposition-Discussion-Points
-- IPP Everywhere Value Proposition Discussion Points
-- PWG discussion at PWG Virtual F2F on 18 August 2020
- https://www.pwg.org/archives/ipp/2020/020773.html
-- Wiki page started for errata discussions
-- Added on 20 November 2020

(11) Status of various IPP documents (All)
* IPP 2.0, 2.1, and 2.2 Update (Mike/Ira)
- https://github.com/istopwg/ippsample/wiki/Planned-PWG-Errata-Updates
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippbase23-20210424.pdf
-- Prototype draft - for a PWG Standard
-- PWG review at PWG/OP Virtual F2F in May 2021
-- Schedule - Prototype draft in Q3 2021

* IPP Production Printing Ext v2.0 (Mike)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ippppx20-20210424-rev.pdf
-- Prototype draft - for a Candidate Standard
-- PWG review at PWG/OP Virtual F2F in May 2021
-- Just waiting on prototyping in ippsample
-- Schedule - Stable draft in Q3 2021

* IPP Encrypted Jobs and Documents v1.0 (Mike/Smith)
- https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrustnoone10-20210428-rev.pdf
-- Prototype draft - for a Candidate Standard
-- PWG review at PWG/OP Virtual F2F in May 2021
-- Schedule - Stable draft in Q1 2022

* Cloud Registration with X.509 Certificates (Cihan/Mike)
-- Registrations or Updates to IPP INFRA and IPP System Service
-- Gathering a list of potential improvements/extensions
-- PWG discussion at PWG/OP Virtual F2F in May 2021
-- Schedule - TBD

* IPP Everywhere v2.0 (Mike)
- https://github.com/istopwg/ippsample/wiki/Planned-PWG-Errata-Updates
-- Major update - for a Candidate Standard
-- Add TLS/1.2 and/or TLS/1.3, Privacy, Job Accounting as Mandatory
-- Add Feature definitions for "vertical solution" use cases
-- Define a complete IPP Everywhere MFD (add Scan, FaxOut, System services)
-- Define tests to certify standard common features
-- PWG discussion at PWG/OP Virtual F2F in May 2021
-- Schedule – TBD

(12) Open Printing update (Ira)
-
https://ftp.pwg.org/pub/pwg/liaison/openprinting/presentations/op-plenary-may-2021-v1.pdf
-- See OP Plenary slides from PWG/OP Virtual F2F in May 2021
- OP Steering Committee
-- OP monthly calls 03/02/21, 04/06/21, 05/18/21, and upcoming 06/22/21

(13) Next IPP Meetings

- IPP WG call on Thu 3 June 2021 at 3:00-4:30pm US Eastern
-- regular meeting

- IPP WG call on Thu 17 June 2021 at 3:00-4:30pm US Eastern
-- regular meeting

- IPP WG call on Thu 1 July 2021 at 3:00-4:30pm US Eastern
-- regular meeting

Cheers,

- Ira

*Ira McDonald (Musician / Software Architect)*

*Chair - SAE Trust Anchors and Authentication TF*
*Co-Chair - TCG Trusted Mobility Solutions WG*

*Co-Chair - TCG Metadata Access Protocol SG*

*Chair - Linux Foundation Open Printing WGSecretary - IEEE-ISTO Printer
Working GroupCo-Chair - IEEE-ISTO PWG Internet Printing Protocol WGIETF
Designated Expert - IPP & Printer MIBBlue Roof Music / High North
Inchttp://sites.google.com/site/blueroofmusic
<http://sites.google.com/site/blueroofmusic>http://sites.google.com/site/highnorthinc
<http://sites.google.com/site/highnorthinc>mailto: [email-masked]
<[email-masked]>(permanent) PO Box 221  Grand Marais, MI 49839
906-494-2434*
_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Ira McDonald via ipp <[email-masked]>
Date: Thu, 20 May 2021 08:33:32 -0400

Hi,

Inevitably, I missed an update yesterday.

For IPP Encrypted Jobs and Documents, the correct link is:

https://ftp.pwg.org/pub/pwg/ipp/wd/wd-ipptrustnoone10-20210519-rev.pdf

Cheers,
- Ira

On Thu, May 20, 2021 at 8:26 AM Ira McDonald <[email-masked]>
wrote:

> https://ftp.pwg.org/pub/pwg/ipp/minutes/ippv2-concall-minutes-20210422.pdf