Subject: [IPP] finishings-supported and finishings-default

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Sun, 21 Nov 2021 19:32:48 +0000

Hi there,

If a Printer lists the following (ippserver .conf file syntax):

ATTR enum   finishings-supported   4,20,21,22,23 # matches "finishing-template-supported"
ATTR enum   finishings-default     3 # none

If a Printer supports doing "no finishings" (enum 3), is the Printer required to list 3 (none) in finishings-supported? Our IPP Everywhere Self-Certification doesn't support that scenario currently but STD92 is vague on this subject.

Smith

/**
    Smith Kennedy
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Mon, 22 Nov 2021 09:15:30 -0500

Smith,

> On Nov 21, 2021, at 2:32 PM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]> wrote:
> 
> Hi there,
> 

If 'none' is a supported value (and it must be if "finishings-default" uses it, just like any other xxx-default attribute), then it MUST also be listed in "finishings-supported".

It is conceivable that there might be a printer that always performs some sort of finishing, for example cutting a sheet from a roll, but most of the time I'd expect a printer that supports finishings to also support 'none'.

________________________
Michael Sweet