Subject: [IPP] Example value for "oauth-authorization-scope"?

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Thu, 28 Apr 2022 15:19:59 +0000

Greetings,

HP is curious what types of values a Client might expect to find supplied by the "oauth-authorization-scope" Printer Description attribute registered in May 2019:

https://ftp.pwg.org/pub/pwg/ipp/registrations/ippwg-oauth-authorization-scope-20190521.txt <https://ftp.pwg.org/pub/pwg/ipp/registrations/ippwg-oauth-authorization-scope-20190521.txt>

The registration talks about roles, such as User or Administrator. Is this the only range of information that a Client might encounter provided by this attribute? Or could it be more granular, like allowed operations, etc.? Looking at this page that points to the RFC and some examples, it seems like it could be application-specific: https://oauth.net/2/scope/ <https://oauth.net/2/scope/>

Thanks for any thoughts,

Smith

/**
    Smith Kennedy
    HP Inc.
*/

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 28 Apr 2022 11:33:26 -0400

Smith,

> On Apr 28, 2022, at 11:19 AM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]> wrote:
> 
> Signed PGP part
> Greetings,
> 
> https://ftp.pwg.org/pub/pwg/ipp/registrations/ippwg-oauth-authorization-scope-20190521.txt
> 
> The registration talks about roles, such as User or Administrator. Is this the only range of information that a Client might encounter provided by this attribute? Or could it be more granular, like allowed operations, etc.? Looking at this page that points to the RFC and some examples, it seems like it could be application-specific: https://oauth.net/2/scope/

It *is* application-specific, but I would expect the scope(s) to specify a role or functionality supported by the OAuth server.  I wouldn't expect it to be as fine-grained as individual IPP operations, but I can see admin/operator/user scopes for the Printer, much as Github exposes different scopes for read-only, read-write, and administrative access to repositories and organizations, in addition to scopes for access to contact/profile information.

________________________
Michael Sweet