Subject: [IPP] IPP WG Last Call: IPP Everywhere Printer Self-Certification Tools v1.1 Update 4

From: ISTO-PWG Internet Printing Protocol workgroup discussion forum via ipp <[email-masked]>
Date: Thu, 14 Apr 2022 10:40:13 -0400

All,

I have posted new candidate builds of the IPP Everywhere Printer Self-Certification Tools v1.1 Update 4 to:

	https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20220414-macos.zip
	https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20220414-rhel.tar.gz
	https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20220414-ubuntu.tar.gz
	https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20220414-windows.msi

These tools fix all of the known bugs in the self-certification tools and have been tested locally by me on some existing IPP Everywhere printers as well as the ippeveprinter test server.  Changes include:

- Added support for running the self-certification tools non-interactively with the "make test" command (Issue #56, Issue #62)
- The `ippevesubmit` program did not validate the correct number of tests for the document results (Issue #71)
- The DNS-SD TLS key test was incorrectly specified (Issue #72)
- The `ippevesubmit` program now validates and converts product web page URLs (Issue #75)
- The IPP and document tests now support printers that do not support US letter or ISO A4 sizes (Issue #78)
- The `ipptool` program can now generate PWG Raster documents dynamically for printers (Issue #79)
- The `ippevesubmit` program now uses the modification date of the plist files instead of the current date when generating the JSON submission file (Issue #81)
- The `ippfind` program did not correctly escape command-line arguments passed during the DNS-SD tests (Issue #83)
- The `ippevesubmit` program did not look for supported media sizes in the right place (Issue #84)
- Added the test numbers to all print job tests (Issue #85)
- Fixed the conditional requirements for "printer-supply-xxx" attributes with printers that do not have supplies.
- Fixed some problems with the Windows DNS-SD test script.
- Fixed the expected test counts in ippevesubmit and removed support for submitting IPP Everywhere v1.0 results.

This last call will end no earlier than April 29, 2022 and requires at least two members to confirm they have been able to successfully use the tools on their printers.

________________________
Michael Sweet

_______________________________________________
ipp mailing list
[email-masked]
https://www.pwg.org/mailman/listinfo/ipp

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Thu, 28 Apr 2022 19:07:39 +0000

Hi Mike,

For some reason, increasing the page count in tests D-1.4 and D-1.5 to 8 pages has caused failures at a late stage of firmware development for some of our printers. While not ideal, I think it is fair to not move the target in a dot release. HP is asking that, for this release, that the page count be reduced to 4 on lines 485 and 521:

https://github.com/istopwg/ippeveselfcert/blob/14ab1442bf400979f83f758810b963063c403b20/tests/document-tests.test#L485 <https://github.com/istopwg/ippeveselfcert/blob/14ab1442bf400979f83f758810b963063c403b20/tests/document-tests.test#L485>

https://github.com/istopwg/ippeveselfcert/blob/14ab1442bf400979f83f758810b963063c403b20/tests/document-tests.test#L521 <https://github.com/istopwg/ippeveselfcert/blob/14ab1442bf400979f83f758810b963063c403b20/tests/document-tests.test#L521>

Can we make this minor change and create a new release?

Smith

/**
    Smith Kennedy
    HP Inc.
*/

> On Apr 14, 2022, at 8:40 AM, ISTO-PWG Internet Printing Protocol workgroup discussion forum via ipp <[email-masked]> wrote:
> 
> Signed PGP part
> All,
>

---

From: Michael Sweet via ipp <[email-masked]>
Date: Thu, 28 Apr 2022 16:19:19 -0400

Smith,

Yes, I can make that change.

> On Apr 28, 2022, at 3:07 PM, Kennedy, Smith (Wireless & IPP Standards) via ipp <[email-masked]> wrote:
> 
> Signed PGP part
> Hi Mike,
> 
> https://github.com/istopwg/ippeveselfcert/blob/14ab1442bf400979f83f758810b963063c403b20/tests/document-tests.test#L485
> 
> https://github.com/istopwg/ippeveselfcert/blob/14ab1442bf400979f83f758810b963063c403b20/tests/document-tests.test#L521
> 

________________________
Michael Sweet

---

From: "Kennedy, Smith \(Wireless & IPP Standards\) via ipp" <[email-masked]>
Date: Fri, 29 Apr 2022 15:00:02 +0000

Thank you! Obviously, I could make the change to the test file myself very easily but I’m not able to kick off a build.

Cheers,
Smith
---
Smith Kennedy
[email-masked]

On Apr 28, 2022, at 2:19 PM, Michael Sweet <[email-masked]> wrote:

Smith,

> https://github.com/istopwg/ippeveselfcert/blob/14ab1442bf400979f83f758810b963063c403b20/tests/document-tests.test#L485<https://github.com/istopwg/ippeveselfcert/blob/14ab1442bf400979f83f758810b963063c403b20/tests/document-tests.test#L485>
>
> https://github.com/istopwg/ippeveselfcert/blob/14ab1442bf400979f83f758810b963063c403b20/tests/document-tests.test#L521<https://github.com/istopwg/ippeveselfcert/blob/14ab1442bf400979f83f758810b963063c403b20/tests/document-tests.test#L521>
>
>> https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20220414-macos.zip<https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20220414-macos.zip>
>> https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20220414-rhel.tar.gz<https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20220414-rhel.tar.gz>
>> https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20220414-ubuntu.tar.gz<https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20220414-ubuntu.tar.gz>
>> https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20220414-windows.msi<https://ftp.pwg.org/pub/pwg/ipp/wd/sw-ippeveselfcert11-20220414-windows.msi>
>>

________________________
Michael Sweet

<signature.asc>