Subject: RE: [ippm] Re: draft-ietf-ippm-owdp: should it be split?

From: "Cucchiara, Joan" <[email-masked]>
Date: Wed, 31 Jan 2001 14:04:43 -0500

Hello Henk,

I do not see the benefit of splitting this
one document into two for a couple of reasons:

1) if two different vendors want to
support OWDP, then aren't both the control and
test needed in order for the vendors to interoperate?

If that is true, then shouldn't both halves of this
protocol remain in the same document?  

2) As you point out, it is quite possible that the control portion
of the document is enhanced, but this would lead
to confusion because then a vendor would
have to specify which control versions and which test versions
and which combinations of these they support.  I think
that pointing to a single document and specifying which
revs of the document are supported would be much clearer.

  Thanks, 
    -Joan

> -----Original Message-----
> From: Henk Uijterwaal (RIPE-NCC) [mailto:[email-masked]]
> Sent: Wednesday, January 31, 2001 9:37 AM
> To: stanislav shalunov
> Cc: [email-masked]
> Subject: [ippm] Re: draft-ietf-ippm-owdp: should it be split?
> 
> 
> On 18 Dec 2000, stanislav shalunov wrote:
> 
> > There was a suggestion made during physical IPPM WG meeting that the
> > draft be split into two: one describing OWDP-Control, the other one
> > describing OWDP-Test.
> > 
> > What is everybody's opinion on this suggestion?
> 
> IMHO, split. 
> 
> > NOTE:  Split or not split, you *can* use OWDP-Test without 
> OWDP-Control.
> 
> If OWDP-test can be used without OWDP-control, then two documents
> documents, with the OWDP-T pointing to OWDP-C as a 
> possibility but not a
> necessity, sounds a lot more logical than a single document 
> with a remark
> "yes, we're describing OWDP-C here but you don't need that if 
> you prefer
> something else".
> 
> I can see that one can easily extend the OWDP-C protocol to accomodate
> other measurements, with a program on each measurement node 
> talking OWDP-C
> to the other nodes and setting up measurement sessions for 
> delay, loss,
> ... as necessary.  
> 
> Henk
> 
> --------------------------------------------------------------
> ----------------
> Henk Uijterwaal                    Email: [email-masked]
> RIPE Network Coordination Centre     WWW: 
http://www.ripe.net/home/henk
Singel 258                         Phone: +31.20.5354414
1016 AB Amsterdam                    Fax: +31.20.5354445 
The Netherlands                   Mobile: +31.6.55861746  
----------------------------------------------------------------------------
--

As long as you don't tell your friends how I played the hand,
then I won't tell my friends how you defended it.
(Anonymous)

_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm
_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm

---

From: "Henk Uijterwaal (RIPE-NCC)" <[email-masked]>
Date: Wed, 31 Jan 2001 21:29:36 +0100 (CET)

Joan,

> 1) if two different vendors want to support OWDP, then aren't both the
> control and test needed in order for the vendors to interoperate?

No, you need _a_ control mechanism, not necessarily OWDP-C, to set up a
measurement session.  This has been pointed out by Stanislav and is
mentioned in the document.  I think it is much cleaner to keep them
separate.

> 2) As you point out, it is quite possible that the control portion of
> the document is enhanced, but this would lead to confusion because
> then a vendor would have to specify which control versions and which
> test versions and which combinations of these they support.  I think
> that pointing to a single document and specifying which revs of the
> document are supported would be much clearer.

If OWDP is specified in this doc and another measurement is introduced,
then a vendor for the new measurement will still have to specify which
version of OWDP is being used and point to the appropriate version of the
OWDP document.

Henk

------------------------------------------------------------------------------
Henk Uijterwaal                    Email: [email-masked]
RIPE Network Coordination Centre     WWW: http://www.ripe.net/home/henk
Singel 258                         Phone: +31.20.5354414
1016 AB Amsterdam                    Fax: +31.20.5354445
The Netherlands                   Mobile: +31.6.55861746
------------------------------------------------------------------------------

As long as you don't tell your friends how I played the hand,
then I won't tell my friends how you defended it.                 (Anonymous)

---

From: "Henk Uijterwaal (RIPE-NCC)" <[email-masked]>
Date: Wed, 31 Jan 2001 21:29:36 +0100 (CET)

Joan,

Henk