Subject: RE: [ippm] Re: draft-ietf-ippm-owdp: should it be split?

From: "Cole, Robert G (Bob), ALSVC" <[email-masked]>
Date: Wed, 31 Jan 2001 14:31:11 -0500

Joan,
Stanislav,

I agree with Henk's request to split the document into two seperate
documents.  In fact I thought that the discussion at the San Diego meeting
was more of an agreement to split rather than a suggestion. But ....

There are other activities being worked on that would provide an alternative
means to control the OWDP, e.g., draft-kalbfleisch-sspm-00.txt.
There may be other methods to achieve OWDP-Control functions as well.
Therefore, some vendors may not implement OWDP-Control at all.

Because there are alternative methods to achieve the OWDP-Control
functions, I think it is much cleaner to work seperate documents.

Thanks,
Bob

> -----Original Message-----
> From:	Cucchiara, Joan [SMTP:[email-masked]]
> Sent:	Wednesday, January 31, 2001 7:05 PM
> To:	[email-masked]'; stanislav shalunov
> Cc:	[email-masked]'
> Subject:	RE: [ippm] Re: draft-ietf-ippm-owdp: should it be split?
> 
> 
> Hello Henk,
> 
> I do not see the benefit of splitting this
> one document into two for a couple of reasons:
> 
> 1) if two different vendors want to
> support OWDP, then aren't both the control and
> test needed in order for the vendors to interoperate?
> 
> If that is true, then shouldn't both halves of this
> protocol remain in the same document?  
> 
> 2) As you point out, it is quite possible that the control portion
> of the document is enhanced, but this would lead
> to confusion because then a vendor would
> have to specify which control versions and which test versions
> and which combinations of these they support.  I think
> that pointing to a single document and specifying which
> revs of the document are supported would be much clearer.
> 
>   Thanks, 
>     -Joan
> 
> > -----Original Message-----
> > From: Henk Uijterwaal (RIPE-NCC) [mailto:[email-masked]]
> > Sent: Wednesday, January 31, 2001 9:37 AM
> > To: stanislav shalunov
> > Cc: [email-masked]
> > Subject: [ippm] Re: draft-ietf-ippm-owdp: should it be split?
> > 
> > 
> > On 18 Dec 2000, stanislav shalunov wrote:
> > 
> > > There was a suggestion made during physical IPPM WG meeting that the
> > > draft be split into two: one describing OWDP-Control, the other one
> > > describing OWDP-Test.
> > > 
> > > What is everybody's opinion on this suggestion?
> > 
> > IMHO, split. 
> > 
> > > NOTE:  Split or not split, you *can* use OWDP-Test without 
> > OWDP-Control.
> > 
> > If OWDP-test can be used without OWDP-control, then two documents
> > documents, with the OWDP-T pointing to OWDP-C as a 
> > possibility but not a
> > necessity, sounds a lot more logical than a single document 
> > with a remark
> > "yes, we're describing OWDP-C here but you don't need that if 
> > you prefer
> > something else".
> > 
> > I can see that one can easily extend the OWDP-C protocol to accomodate
> > other measurements, with a program on each measurement node 
> > talking OWDP-C
> > to the other nodes and setting up measurement sessions for 
> > delay, loss,
> > ... as necessary.  
> > 
> > Henk
> > 
> > --------------------------------------------------------------
> > ----------------
> > Henk Uijterwaal                    Email: [email-masked]
> > RIPE Network Coordination Centre     WWW: 
> http://www.ripe.net/home/henk
> Singel 258                         Phone: +31.20.5354414
> 1016 AB Amsterdam                    Fax: +31.20.5354445 
> The Netherlands                   Mobile: +31.6.55861746  
> --------------------------------------------------------------------------
> --
> --
> 
> As long as you don't tell your friends how I played the hand,
> then I won't tell my friends how you defended it.
> (Anonymous)
> 
> 
> _______________________________________________
> ippm mailing list
> [email-masked]
> http://mailhost.advanced.org/mailman/listinfo/ippm
> _______________________________________________
> ippm mailing list
> [email-masked]
> http://mailhost.advanced.org/mailman/listinfo/ippm
_______________________________________________
ippm mailing list
[email-masked]
http://mailhost.advanced.org/mailman/listinfo/ippm

---

From: "Cucchiara, Joan" <[email-masked]>
Date: Wed, 31 Jan 2001 16:52:55 -0500

Hi Bob and Henk,

> There may be other methods to achieve OWDP-Control functions as well.

I agree.  In fact, Brix has developed a one-way delay (GPS-based)
protocol which is being deployed in our SLA Verification System.

> Therefore, some vendors may not implement OWDP-Control at all.

I disagree here.  The control-plane (at least as far as the 
draft-ietf-ippm-owdp-01.txt is concerned) sets up parameters for the
test-plane. 

Whether the control information is done via TCP or SNMPConf or COPS+ or 
something else, it is still necessary to set up the test 
from sender to receiver.  Don't you agree that this has to be 
done somehow?  

> functions, I think it is much cleaner to work seperate documents.

I have trouble accepting this for a standard document which says
that its motivation is to have OWDP be as "commonplace" as PING.
  
What other standard has multiple control-planes?  I don't know
of any.

NOTE:  this does not mean that other control-plane's cannot
be supported,  and it does not mean that other control-planes
can't be developed,  but for a standard, isn't it better to
adopt one and work to get that one perfected?  

I admit I may be missing something here, but how exactly does
having multiple control-planes benefit an IETF Standard which is 
supposed to be the basis for interoperability?  Aren't you really
saying that in order to interoperate you will need to now support
this subset of control planes?  Do we really want that?

I would agree that the document should definitely have
a section discussing how the control-plane needs to be implemented
such that it could be replaced (or superseded) by another control-plane,
but I'd prefer to adopt one control-plane for the basis of a
standard.

Thanks, 
  Joan

> ------------