Subject: [ippm] RD and TCP retransmit analysis

From: Nischal M Piratla <[email-masked]>
Date: Fri, 11 Mar 2005 15:02:18 -0700

Almost 8 months ago, we had a request for an analysis showing the use of RD in 
the context of TCP retransmits. Looks like some of you could not catch up with 
the messages. I am sending this analysis once more.
[Thanks to Mark Allman, who helped correct few errors then].

Consider Fast Retransmit definition from RFC 2581 and delayed ACK criterion 
from RFC 1122. Assume there is no packet duplication within the network. In 
addition, if a packet is reordered then the following packets in the sequence 
are not reordered with same or higher displacement. For such cases, a TCP 
packet is retransmitted after its ack is not found in four attempts:

Case 1: Duplicate ACKs for packet 3
Arrivals:            1    2   4   5    6   3      
ACKs:                        3   3   3    3   
Receive_index:       1    2   3   4    5   6    
Displacement:        0    0  -1  -1   -1   3

Case 2: Duplicate ACKs for packet 2
Arrivals:            1    3    4   5   2   
ACKs:                   2   2    2   2     
Receive_index:       1    2   3    4   5   
Displacement:        0   -1  -1   -1   3

Thus, the displacement (according to RD definitions) is greater than 2 for 
retransmitted packets. 
Therefore, "Sum of (all RD[k] for k >= 2) corresponds to fraction of packets 
that is unnecessarily retransmitted."

****************************************************
Research Assistant
Computer Networking Research Laboratory (CNRL)
C203,Dept. of Electrical & Computer Eng.
Colorado State University,
Fort Collins, CO 80523
Voice: 970-491-7067/7794
Fax:   970-491-2249
http://www.cnrl.colostate.edu
http://lamar.colostate.edu/~nischal
****************************************************

_______________________________________________
ippm mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ippm

---

From: Al Morton <[email-masked]>
Date: Mon, 28 Mar 2005 23:35:35 -0500

Consider this example:
Arrivals:            1   4   5   6   7   3   2
ACKs:                   2   2  2   2  2   2
Receive_index:       1   2   3   4   5   6   7
Displacement:        0  -2  -2  -2  -2   3   5

Is this an example of one of the circumstances you've excluded?
(with the following sentence)
>In addition, if a packet is reordered then the following packets
>in the sequence are not reordered with same or higher displacement.

Packet 3 follows 2 in the original sequence, and packet 3
has a lower displacement than packet 2. So Packet 3 may be
included, and using Displacement>2 would predict two
re-transmissions where only one seems likely.
However, you may have meant "following arrivals",  and then
packet 3 would be excluded.

In any case, how many arrivals must occur before Displacement
can be evaluated again?
IOW, the condition quoted above may also exclude this case:
Arrivals:  1 3 4 5 6 2 7 9 10 11 12 8
Displacement:        4              4
but this seems to be a case where there may be two re-transmissions.

We have not placed strong requirements like this on the measured
stream in the past, and this one appears to need some refinement.

Al

At 05:02 PM 03/11/2005, Nischal M Piratla wrote:
>...