Subject: [ippm] [store traceroutes] Is CtlSourceAddress mandatory or not?

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 2 Dec 2008 13:58:56 +0100

Section 5.2.1 of draft-ietf-ippm-storetraceroutes-12 says:

    o  1 optional "CtlSourceAddress" element;

But the schema mandates one element, there is no attribute default or
minOccurs:

    <xs:element name="CtlSourceAddress"
                     type="tr:inetAddressWithoutDns">
           <xs:annotation>
             <xs:documentation>Specifies the IP address (which has to
...
_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

---

From: "Thomas Dietz" <[email-masked]>
Date: Tue, 2 Dec 2008 14:25:04 +0100

Dear Stephane,

it is optional, but the missing default value is a deficiency of the XML
standard which only allows default values for simple types...

Best Regards,

Thomas

-- 
Thomas Dietz                 E-mail: [email-masked]
NEC Europe Ltd.              Phone:  +49 6221 4342-128
NEC Laboratories Europe      Fax:    +49 6221 4342-155
Network Research Division
Kurfuersten-Anlage 36
69115 Heidelberg, Germany    http://www.nw.neclab.eu

NEC Europe Limited           Registered in England 2832014
Registered Office: NEC House, 1 Victoria Road, London W3 6BL

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Stephane Bortzmeyer
> Sent: Dienstag, 2. Dezember 2008 13:59
> To: [email-masked]
> Subject: [ippm] [store traceroutes] Is CtlSourceAddress mandatory or
> not?
>

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 2 Dec 2008 14:28:01 +0100

On Tue, Dec 02, 2008 at 02:25:04PM +0100,
 Thomas Dietz <[email-masked]> wrote 
 a message of 163 lines which said:

> it is optional, but the missing default value is a deficiency of the
> XML standard which only allows default values for simple types...

(You mean W3C Schema standard?)

But how can I validate documents without <CtlSourceAddress>? The
validator I tested (xmllint) refused them and rightly so. Why not
adding minOccurs="0"?