Subject: [ippm] Comments for draft-ietf-ippm-twamp-reflect-octets-04

From: [email-masked]
Date: Sun, 18 Apr 2010 19:25:11 +0200

Hi Al

The last paragraph in draft-ietf-ippm-twamp-reflect-octets-04 section 3.1 is currently written as follows:

If the Control-Client intends to operate all test sessions invoked with this control connection using one or both of the new modes, it MUST set the Modes Field bit corresponding to that function in the Setup Response message.

I have two comments on this paragraph:

I believe you should replace the word Modes Field with Mode Field. The Modes Field is for the server greeting message and the Mode Field is for the Setup Response message.

In the OWAMP/TWAMP specs, it is stated that the client MUST respond with a Setup Response message with includes the Mode Field and one or zero bits MUST be set within last three bits.  In the new draft, you have stated that the last 7 bit positions of the Modes 32-bit Field are used but I think you have omitted to indicate that multiple bits can now be set in the Mode field sent by the client in the Setup Response message. I think it is best to explicitly state that multiple bits can now be set in the Mode field but not all possible combinations are possible.

Thank you

-Steve

---

From: Al Morton <[email-masked]>
Date: Mon, 19 Apr 2010 11:11:02 -0400

At 01:25 PM 4/18/2010, [email-masked] wrote:

...

...I think it is best to explicitly state that multiple bits can now
be set in the Mode field but not all possible combinations are possible.

OK.

Will post the requested changes, and try to anticipate some

IESG and IANA comments thanks to experience with the Individual Session

control draft.

Al