Subject: Re: [ippm] draft-baillargeon-ippm-twamp-value-added-octets-02

From: Steve Baillargeon <[email-masked]>
Date: Thu, 8 Sep 2011 14:10:13 -0400

Hi Henk
I made some minor corrections to the draft-baillargeon-ippm-twamp-value-added-octets. The latest version is 02.

I think the new proposal I made in Quebec to combine the various capacity measurement methods into 3 optional modes (128, 256 and 512) was well received by most people. As far as I know Al Morton is in agreement with its principles but he is the only person to opposite to it because of the IPR associated with mode 128.

I agree that the general rule on disputed topics is that the Working Group has to come to "rough consensus".
Can you evaluate if we have rough consensus on the new proposal?

Thank you

Regards
Steve

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henk Uijterwaal
Sent: August-30-11 7:06 AM
To: [email-masked]
Subject: Re: [ippm] Expiration impending: draft-baillargeon-ippm-twamp-value-added-octets

Steve,

> We would like to start a WGLC in order to move it forward.
> Any comments?

Well, a WGLC is only appropriate if rough consensus about the document has been reached and there is no need for further discussion.  The WGLC is there to catch the last remaining details.  I don't think that this document is in that stage.

In Quebec, one of the conclusions was that we should define what problem we are trying to solve with this draft (and similar).  The chairs are preparing a statement on that.  Once we have agreed on the problem, we should go back to solution space.  This draft will be valuable input.

Henk

> 
> -Steve
> 
> -----Original Message-----
> From: IETF Secretariat [mailto:[email-masked]]
> Sent: August-29-11 7:42 AM
> To: Steve Baillargeon; Christofer Flinta; Andreas Johnsson A; Svante 
> Ekelin
> Subject: Expiration impending: 
> draft-baillargeon-ippm-twamp-value-added-octets
> 
> The following draft will expire soon:
> 
> Filename: draft-baillargeon-ippm-twamp-value-added-octets
> Title:    TWAMP Value-Added Octets
> State:    I-D Exists
> Expires:  2011-09-08 (in 1 week, 2 days) 
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm

--
------------------------------------------------------------------------------
Henk Uijterwaal                           Email: henk(at)uijterwaal.nl
                                          http://www.uijterwaal.nl
                                          Phone: +31.6.55861746
------------------------------------------------------------------------------

There appears to have been a collective retreat from reality that day.
                                 (John Glanfield, on an engineering project) _______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

---

From: Henk Uijterwaal <[email-masked]>
Date: Fri, 09 Sep 2011 08:44:29 +0200

IPPM group,

On 08/09/2011 20:10, Steve Baillargeon wrote:

> I made some minor corrections to the
> draft-baillargeon-ippm-twamp-value-added-octets. The latest version is 02.
> 
> I think the new proposal I made in Quebec to combine the various capacity
> measurement methods into 3 optional modes (128, 256 and 512) was well
> received by most people. As far as I know Al Morton is in agreement with its
> principles but he is the only person to opposite to it because of the IPR
> associated with mode 128.
> 
> I agree that the general rule on disputed topics is that the Working Group
> has to come to "rough consensus". Can you evaluate if we have rough consensus
> on the new proposal?

If you contributed to the discussion in Quebec (or elsewhere), please read
the draft and commment.  Even a 1 line response like "I've read the draft and
my issues have been addressed" or similar is extremely useful.

Henk

There appears to have been a collective retreat from reality that day.
                                 (John Glanfield, on an engineering project)

---

From: Steve Baillargeon <[email-masked]>
Date: Fri, 9 Sep 2011 06:04:49 -0400

Hi
The link to the proposal discussed in Quebec is here.

http://www.ietf.org/proceedings/81/slides/ippm-5.pdf

-Steve

-----Original Message-----
From: Henk Uijterwaal [mailto:[email-masked]] 
Sent: September-09-11 2:44 AM
To: Steve Baillargeon
Cc: [email-masked]
Subject: Re: [ippm] draft-baillargeon-ippm-twamp-value-added-octets-02

IPPM group,

On 08/09/2011 20:10, Steve Baillargeon wrote:

> I think the new proposal I made in Quebec to combine the various 
> capacity measurement methods into 3 optional modes (128, 256 and 512) 
> was well received by most people. As far as I know Al Morton is in 
> agreement with its principles but he is the only person to opposite to 
> it because of the IPR associated with mode 128.
> 
> I agree that the general rule on disputed topics is that the Working 
> Group has to come to "rough consensus". Can you evaluate if we have 
> rough consensus on the new proposal?

If you contributed to the discussion in Quebec (or elsewhere), please read the draft and commment.  Even a 1 line response like "I've read the draft and my issues have been addressed" or similar is extremely useful.

Henk

---

From: Al Morton <[email-masked]>
Date: Fri, 09 Sep 2011 09:55:35 -0400

Henk and Steve,

Please see my comments in-line:

> > draft-baillargeon-ippm-twamp-value-added-octets. The latest version is 02.

Replacing RFC 1242/2544 Throughput with "datagram delivery rate"
fixes a major conceptual error, so that's good. But there are no
protocol modifications, and...

> > associated with mode 128.

that's not correct. Also, Yaakov gave his opinion that your slide
proposal violated fundamental principles of TWAMP, IIRC.

>my issues have been addressed" or similar is extremely useful.

I read the draft, and comments in this thread:
http://www.ietf.org/mail-archive/web/ippm/current/msg02634.html
have not been addressed. In fact, reluctance to accept
the session-reflector complexity/new formats as an issue
prompted the development of our alternative proposal:
http://tools.ietf.org/html/draft-morton-ippm-twamp-rate-00
which finally got Steve's attention.
In case it's not clear, the slide proposal discussed in
Quebec is not implemented in draft*value-added-octets-02,
but that's fine because the proposal was not agreed.

IMO, we now need to agree on the problem statement(s) for these
new features. We also need to find ways to work together productively,
where we are all carefully reading each other's messages
and finding ways to compromise and address new measurement needs.

regards to all,
Al

---

From: Steve Baillargeon <[email-masked]>
Date: Fri, 9 Sep 2011 13:27:06 -0400

Hi Al
Your proposal http://tools.ietf.org/html/draft-morton-ippm-twamp-rate-00 is actually breaking many protocol rules and this is why I oppose to it. It is adding more complexity on the system and the existing OWAMP is a better fit. I think we should not forget the following blog:
http://blog.dustintrammell.com/2008/11/17/how-not-to-write-a-protocol-specification/

My proposal in Quebec is actually intended to find a compromise while addressing capacity measurements in three possible TWAMP ways i.e. bi-directional, forward only and reverse only with a clear seperation between the control and data planes. 

Yes I agree that we must find ways to work together productively and this is what I came prepared to do in Quebec. Let's try again but you have indicated you are not willing to work with us because of the IPR associated with the TWAMP-value-added-octets draft. Is this still true? 

-Steve

-----Original Message-----
From: Al Morton [mailto:[email-masked]] 
Sent: September-09-11 9:56 AM
To: Henk Uijterwaal; Steve Baillargeon
Cc: [email-masked]
Subject: Re: [ippm] draft-baillargeon-ippm-twamp-value-added-octets-02

Henk and Steve,

Replacing RFC 1242/2544 Throughput with "datagram delivery rate"
fixes a major conceptual error, so that's good. But there are no protocol modifications, and...

> > capacity measurement methods into 3 optional modes (128, 256 and 
> > 512) was well received by most people. As far as I know Al Morton is 
> > in
> agreement with its
> > principles but he is the only person to opposite to it because of 
> > the IPR associated with mode 128.

that's not correct. Also, Yaakov gave his opinion that your slide proposal violated fundamental principles of TWAMP, IIRC.

>If you contributed to the discussion in Quebec (or elsewhere), please 
>read the draft and commment.  Even a 1 line response like "I've read 
>the draft and my issues have been addressed" or similar is extremely useful.
>
>Henk

I read the draft, and comments in this thread:
http://www.ietf.org/mail-archive/web/ippm/current/msg02634.html
have not been addressed. In fact, reluctance to accept the session-reflector complexity/new formats as an issue prompted the development of our alternative proposal:
http://tools.ietf.org/html/draft-morton-ippm-twamp-rate-00
which finally got Steve's attention.
In case it's not clear, the slide proposal discussed in Quebec is not implemented in draft*value-added-octets-02, but that's fine because the proposal was not agreed.

IMO, we now need to agree on the problem statement(s) for these new features. We also need to find ways to work together productively, where we are all carefully reading each other's messages and finding ways to compromise and address new measurement needs.

regards to all,
Al

---

From: Henk Uijterwaal <[email-masked]>
Date: Thu, 22 Sep 2011 10:14:55 +0200

All,

(Pretty much swamped with other things, and as a result well behind on IPPM work.)

> I think
> we should not forget the following blog: 

Well, he has a bit of a point, but I think he doesn't realize that TWAMP was
developed after OWAMP and when OWAMP was written, nobody thought that we
would need TWAMP in the future.   It is also not at all clear that one
will have to implement both in a single box.

> My proposal in Quebec is actually intended to find a compromise while
> addressing capacity measurements in three possible TWAMP ways i.e.
> bi-directional, forward only and reverse only with a clear seperation between
> the control and data planes.
> 
> Yes I agree that we must find ways to work together productively and this is
> what I came prepared to do in Quebec. Let's try again but you have indicated
> you are not willing to work with us because of the IPR associated with the
> TWAMP-value-added-octets draft. Is this still true?

What I took away from the Quebec discussion, is that we agreed that we
first have to agree what problem we want to solve _without_ looking at
possible and perhaps already existing solutions.   I think this has
not happened, so I suggest that the people who feel strongly about
this, do this.  As far as I'm concerned, it does not have to be an
ID, a mail on the list is fine as well (at least for now).

Only when we agree on the problem, we should look at solutions.  If one
of the proposed solutions has IPR associated with it, then we have to
know the conditions before selecting one.

Henk

---

From: Al Morton <[email-masked]>
Date: Thu, 22 Sep 2011 08:22:44 -0400

At 04:14 AM 9/22/2011, Henk Uijterwaal wrote:
...
>At 01:27 PM 9/9/2011, Steve Baillargeon wrote:
> > ...

Good, thanks Henk. My previous reply to Steve's proposal (to adopt
value-added-octets-02) still reflects my opinion:

At 09:55 AM 9/9/2011, Al Morton wrote:
...
>and finding ways to compromise and address new measurement needs.

Pointing to solutions and IPR issues won't help write requirements.
There have been lots of possibilities suggested for *WAMP this year.
we need to sort through what the community really needs and agrees
to work-on together in IPPM.

regards,
Al

---

From: Samita Chakrabarti <[email-masked]>
Date: Thu, 22 Sep 2011 13:36:11 -0400

Hi,

Has any work been started discussing or putting down the requirements in a short document?

I'd be interested in participating such discussion as well.

Thanks,
-Samita
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Al Morton
Sent: Thursday, September 22, 2011 5:23 AM
To: Henk Uijterwaal; Steve Baillargeon
Cc: [email-masked]
Subject: Re: [ippm] draft-baillargeon-ippm-twamp-value-added-octets-02

> > My proposal in Quebec is actually intended to find a compromise 
> > while addressing capacity measurements in three possible TWAMP ways i.e.
> > you are not willing to work with us because of the IPR associated 
> > with the TWAMP-value-added-octets draft. Is this still true?
>
>this, do this.  As far as I'm concerned, it does not have to be an ID, 
>a mail on the list is fine as well (at least for now).
>

>IMO, we now need to agree on the problem statement(s) for these new 
>features. We also need to find ways to work together productively, 
>where we are all carefully reading each other's messages and finding 
>ways to compromise and address new measurement needs.

Pointing to solutions and IPR issues won't help write requirements.
There have been lots of possibilities suggested for *WAMP this year.
we need to sort through what the community really needs and agrees to work-on together in IPPM.

regards,
Al