Subject: [ippm] Draft IPPM agenda for IETF 101 in London

From: Bill Cerveny <[email-masked]>
Date: Sun, 4 Mar 2018 23:08:58 -0500

I have posted the first draft of the IETF 101 (London) IPPM working group agenda at https://datatracker.ietf.org/doc/agenda-101-ippm/ <https://datatracker.ietf.org/doc/agenda-101-ippm/>

Note that time has been allocated for discussion of all working groups drafts. Talks on all other documents are being presented as lightning talks (5 minutes enforced as time permits).

Best Regards,

Bill Cerveny
IPPM working group co-chair

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 5 Mar 2018 16:17:02 -0800

Hi Bill and Brian,
thank you for the most timely update (agenda for IPPM meeting is one the
first to be announced). Appreciate your kind consideration of our requests
for presentation slots on STAMP work as well as on the new Hybrid two-step
measurement method. I have a question about some drafts placed in the
Lightning talk section for the meeting. These drafts propose specific data
plane encapsulation for telemetry information using iOAM data formats. I
couldn't find there any discussion of measurement methodology but only
proposed changes to encapsulations defined in various WGs in the Routing
Area. As I recall, in the discussion of the new charted for IPPM WG we've
agreed that application of the measurement methodology defined in IPPM WG
to the particular networking layer will be hosted in the WG that is
chartered to work on that network layer. For example, MPLS data plane -
MPLS WG, BIER - BIER WG, and so on. Had that been re-visited? How that is
related to the new IPPM WG charter? Had the appropriate WGs in the Routing
Area agreed to such arrangement?

Regards,
Greg

On Sun, Mar 4, 2018 at 8:08 PM, Bill Cerveny <[email-masked]> wrote:

> I have posted the first draft of the IETF 101 (London) IPPM working group
> agenda at https://datatracker.ietf.org/doc/agenda-101-ippm/
>
> Note that time has been allocated for discussion of all working groups
> drafts. Talks on all other documents are being presented as lightning talks
> (5 minutes enforced as time permits).
>
> Best Regards,
>
> Bill Cerveny
> _______________________________________________
> ippm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ippm
>
>

---

From: "Brian Trammell (IETF)" <[email-masked]>
Date: Tue, 6 Mar 2018 09:39:03 +0100

> On 6 Mar 2018, at 01:17, Greg Mirsky <[email-masked]> wrote:
> 
> Hi Bill and Brian,
> thank you for the most timely update (agenda for IPPM meeting is one the first to be announced). Appreciate your kind consideration of our requests for presentation slots on STAMP work as well as on the new Hybrid two-step measurement method. I have a question about some drafts placed in the Lightning talk section for the meeting. These drafts propose specific data plane encapsulation for telemetry information using iOAM data formats. I couldn't find there any discussion of measurement methodology but only proposed changes to encapsulations defined in various WGs in the Routing Area. As I recall, in the discussion of the new charted for IPPM WG we've agreed that application of the measurement methodology defined in IPPM WG to the particular networking layer will be hosted in the WG that is chartered to work on that network layer. For example, MPLS data plane - MPLS WG, BIER - BIER WG, and so on. Had that been re-visited? How that is related to the new IPPM WG charter? Had the appropriate WGs in the Routing Area agreed to such arrangement?

On discussion with the authors, we've decided that it makes sense to run a process like that we did for RFC8250: the core document is here in IPPM, interactions with other protocols (in 8250's case, the v6 DO; here, the encapsulations within other protocols) happen here but are sent over to the respective working groups on each update). Two reasons for this: one, IOAM is built around a core data model and shim specifications to add, and it makes sense for all of these to maintain a unified design, which suggests they should happen in the same WG. Second, since the documents to be adopted in each encapsulating WG really are *just* encapsulations, there can be a lower amount of interest (and thereby a higher barrier to adoption) than if all are adopted in the same place.

IOW, IOAM over MPLS is a feature of IOAM, which requires review and assent from the MPLS WG, but the development of the proposal need not happen there. Should the discussion in each encap WG lead to consensus in that an encap document should live there, instead, then we can move the document out.

This decision is based on Paragraph 5 of the IPPM charter: "Additional methods will be defined for the composition and calibration of IPPM-defined metrics, as well as active, passive and hybrid measurement methods for these metrics", since, as a hybrid measurement method, IOAM requires an encapsulation to function.

Regards,

Brian (as IPPM chair)

> I have posted the first draft of the IETF 101 (London) IPPM working group agenda at https://datatracker.ietf.org/doc/agenda-101-ippm/
>