Subject: Re: [ippm] optimize the IOAM YANG data model

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Sun, 25 Mar 2018 11:24:06 +0000

Hi Tianran and Greg,

While schema-mount would work, it is really intended for use-cases where there is a requirement to add a module in 2 or more locations (e.g. interfaces at top-level, in LNE and in NI).

I’ve taken a quick look at the model:

  *   The “enabled” leaf node under ioam-profiles (via grouping ioam-admin-config) says "When true, IOAM configuration is enabled for the system.". I think it’d make more sense if that enabled flag was to enable/disable IOAM data-plane functionality.
  *   Would be best to use yang-version 1.1 IMO.
  *   Please take a look at 6087bis.

Regards,
Reshad.

From: ippm <[email-masked]> on behalf of Tianran Zhou <[email-masked]>
Date: Wednesday, March 21, 2018 at 3:03 PM
To: "[email-masked]" <[email-masked]>
Cc: Lizhenbin <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [ippm] optimize the IOAM YANG data model

Hi Folks,

Thanks Greg to point out the flexibility of sub-profiles on the meeting. Here I would like to discuss the way to optimize this point for the IOAM YANG as described in:
https://datatracker.ietf.org/doc/draft-zhou-ippm-ioam-yang/

Although, as suggested, schema mount could help to dynamically mount sub-profiles to the IOAM configuration, IMHO, it may lead to the fragmentation of the model, I.e., several modules. And I cannot see the possibility to reuse the sub-profiles, except to this model.

With the same requirement, I would suggest to use “feature” to enable the supported IOAM encapsulation types. And use the “enable” within each sub-profile to indicate the actual used sub-profile by the instance.

Now four encapsulation types are supported according to the latest IOAM data specification. We may augment the model with more sub-profiles.

Thoughts?

Thanks,
Tianran

---

From: Tianran Zhou <[email-masked]>
Date: Mon, 26 Mar 2018 02:04:17 +0000

Hi Reshad,

Thanks for your comments.
Please see in line.

Cheers,
Tianran

From: Reshad Rahman (rrahman) [mailto:[email-masked]]
Sent: Sunday, March 25, 2018 7:24 PM
To: Tianran Zhou; [email-masked]
Cc: Lizhenbin; [email-masked]
Subject: Re: [ippm] optimize the IOAM YANG data model

Hi Tianran and Greg,

[ztr]Yes, that’s what I thought. So I suggested to use “feature” so that the can only support part of the encapsulation types.

  *   The “enabled” leaf node under ioam-profiles (via grouping ioam-admin-config) says "When true, IOAM configuration is enabled for the system.". I think it’d make more sense if that enabled flag was to enable/disable IOAM data-plane functionality.
[ztr]Yes, this is more clear. I will add the words to the document.

  *   Would be best to use yang-version 1.1 IMO.
  *   Please take a look at 6087bis.
[ztr]Could you please point out what part of the 6087bis I need to pay attention? And what is not yang 1.1?
I intended to follow yang 1.1 indeed. ☺

Regards,
Reshad.

From: ippm <[email-masked]<mailto:[email-masked]>> on behalf of Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 21, 2018 at 3:03 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Lizhenbin <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [ippm] optimize the IOAM YANG data model

Hi Folks,

Thoughts?

Thanks,
Tianran