Subject: [ippm] draft-ietf-ippm-ioam-data-04

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Tue, 23 Oct 2018 00:14:09 +0000

FYI - Back in the IPPM WE meeting at IETF 102 in Montreal we discussed the need to formally recognize IOAM namespaces in draft-ietf-ippm-ioam-data; IOAM namespaces were the last "clean up" item we identified before we'd consider moving to WG LC. The revision -04, which was posted on Saturday reflects IOAM namespaces formally now: A new section 4.1 discusses IOAM namespaces and introduces a Namespace-ID data field.

Frank

---

From: Shahram Davari <[email-masked]>
Date: Tue, 23 Oct 2018 18:12:55 -0700

Hi Frank,

Why didn’t you use the Reserved bits in IOAM headers to add the Name-Space-ID.  Shifting header fields after such a long time of the draft being stable is not a good idea. Some people have implemneted codes for IOAM. This shift of header fields would require a re-spin and re-testing of  those codes.

I suggest using the Reserved bits when possible. Wasn’t that the whole purpose of having Reserved bits?

Thx
Shahram

> On Oct 22, 2018, at 5:14 PM, Frank Brockners (fbrockne) <[email-masked]> wrote:
> 
>  
> FYI – Back in the IPPM WE meeting at IETF 102 in Montreal we discussed the need to formally recognize IOAM namespaces in draft-ietf-ippm-ioam-data; IOAM namespaces were the last “clean up” item we identified before we’d consider moving to WG LC. The revision -04, which was posted on Saturday reflects IOAM namespaces formally now: A new section 4.1 discusses IOAM namespaces and introduces a Namespace-ID data field.
>  
> Frank
> _______________________________________________
> ippm mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ippm <https://www.ietf.org/mailman/listinfo/ippm>

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Wed, 24 Oct 2018 05:52:00 +0000

Hi Shahram,

wrt/ using reserved bits for namespace-ID: This is exactly what we did for those types where a sufficient number of reserved bits were available. This was the case for E2E and POT types. For the trace options, there weren’t a sufficient number of reserved bits available. In addition we aligned the formats of the different options so that the namespace-id is always found at the same location. We’ve discussed the format with several different chipset vendors – and arrived at the currently proposed format. If you have an even better approach to include the namespace-id data field in mind, we’re obviously very interested in your suggestions.

Thanks, Frank

From: Shahram Davari <[email-masked]>
Sent: Dienstag, 23. Oktober 2018 18:13
To: Frank Brockners (fbrockne) <[email-masked]>
Cc: IETF IPPM WG <[email-masked]>
Subject: Re: [ippm] draft-ietf-ippm-ioam-data-04

Hi Frank,

Thx
Shahram

On Oct 22, 2018, at 5:14 PM, Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>> wrote:

Frank
_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm

---

From: Shahram Davari <[email-masked]>
Date: Wed, 24 Oct 2018 10:48:22 -0700

Hi Frank,

We (Broadcom) have not been consulted about this change. Also as shown below You didn’t use the Reserved bits for Namespace_ID in E2E and POT headers. 

The old format is draft-03 was:

    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |IOAM POT Type  | IOAM POT flags|           Reserved            |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

       0                   1                   2                   3
       0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |         IOAM-E2E-Type         |             Reserved          |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

The new format in draft-04 is:

 0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |       Namespace-ID            |IOAM POT Type  | IOAM POT flags|
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

       0                   1                   2                   3
       0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |        Namespace-ID           |         IOAM-E2E-Type         |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

So you have actually shuffled the format. 

The other issue is that now you don’t have a reserved bits for future changes. I will send you our proposal later today.

Thx
Shahram

> On Oct 23, 2018, at 10:52 PM, Frank Brockners (fbrockne) <[email-masked]> wrote:
> 
> Hi Shahram,
>  
> From: Shahram Davari <[email-masked] <mailto:[email-masked]>> 
> To: Frank Brockners (fbrockne) <[email-masked] <mailto:[email-masked]>>
> Cc: IETF IPPM WG <[email-masked] <mailto:[email-masked]>>
> On Oct 22, 2018, at 5:14 PM, Frank Brockners (fbrockne) <[email-masked] <mailto:[email-masked]>> wrote:
>  
>

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Wed, 24 Oct 2018 18:25:34 +0000

Hi Shahram,

thanks – looking forward to your proposal. Per what I mentioned initially, we moved header fields around to have the namespace-id always in the same place across the different options.
Also note that John from Broadcom participated in the discussions that led to the current text on IOAM namespaces (along with folks from companies such as Mellanox, Barefoot, Marvell, Cisco). He already mentioned to me that he’ll circle back with you to close the loop.

Cheers, Frank

From: Shahram Davari <[email-masked]>
Sent: Mittwoch, 24. Oktober 2018 10:48
To: Frank Brockners (fbrockne) <[email-masked]>
Cc: IETF IPPM WG <[email-masked]>; [email-masked]
Subject: Re: [ippm] draft-ietf-ippm-ioam-data-04

Hi Frank,

    0                   1                   2                   3

       0                   1                   2                   3

 0                   1                   2                   3

       0                   1                   2                   3

Thx
Shahram

On Oct 23, 2018, at 10:52 PM, Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Shahram,

Thanks, Frank

From: Shahram Davari <[email-masked]<mailto:[email-masked]>>
Sent: Dienstag, 23. Oktober 2018 18:13
To: Frank Brockners (fbrockne) <[email-masked]<mailto:[email-masked]>>
Cc: IETF IPPM WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] draft-ietf-ippm-ioam-data-04

Hi Frank,

Thx
Shahram

Frank