Subject: [ippm] Comment on draft-kumar-ippm-ifa-00

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 6 Nov 2018 01:57:19 +0000

IFA Authors, IPPM,

I read p/o https://tools.ietf.org/html/draft-kumar-ippm-ifa-00

As someone working on the Route Metrics draft, this point 
interested me:

2.2 Operational Requirements

   IFA MUST preserve the flow path across the network.

This is a useful and interesting requirement.
Care to say more (or point me to a section of the 
draft) where you say how this will be accomplished?

thanks,
Al

---

From: Jai Kumar <[email-masked]>
Date: Tue, 06 Nov 2018 12:11:06 +0700

Hi Al,

Thanks for reviewing the draft.

Idea is to preserve the L3 and L4 fields which are typically looked in the data plane for load balancing.
This essentially means following
- Do not tunnel IPv4 packets as load balancing will start using the tunnel header fields
- Preserve the L4 information and making sure its within a reachable distance(parse depth of silicon) for the data plane
	- e.g. inserting metadata on top of L4 header will push the L4 header too deep for data plane to access
	- this will also be indeterministic behavior depending the length of metadata stack in the ingress packet on a hop in the network path

Regards,
-Jai

On 11/6/18, 8:58 AM, "ippm on behalf of MORTON, ALFRED C (AL)" <[email-masked] on behalf of [email-masked]> wrote:

    IFA Authors, IPPM,

    

    
    thanks,
    Al
    
    _______________________________________________
    ippm mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/ippm