Subject: [ippm] In-situ OAM Data Type Extension

From: Tianran Zhou <[email-masked]>
Date: Wed, 25 Sep 2019 06:36:27 +0000

Hi Frank,

I am revisiting the mailing list. And I am interesting about Tom's discussion on IOAM Data Type Extension.
https://mailarchive.ietf.org/arch/msg/ippm/cp0E8-D0XbgTBy_3Bf6E21z00EA

You had the following reply:
"* 24 bits Trace type 
Per your suggestion, reserving a bit to allow for future scalability makes sense - and bit 23 would be an obvious choice; which would in turn mean that we'd need to assign a different bit for checksum complement. If everyone else is fine with this change, we can include this change in -07."

We also had a draft to address the same issue.
https://tools.ietf.org/html/draft-song-ippm-ioam-data-extension-01

I see the latest draft-ietf-ippm-ioam-data-07 reserved the bit 23. Are you going to define the usage of that bit or not?
Defer it to other draft or next version?

Regards,
Tianran

---

From: "Frank Brockners (fbrockne)" <[email-masked]>
Date: Wed, 25 Sep 2019 06:47:29 +0000

Hi Tianran,

Like what you state below: Per Tom's suggestion a reserved bit to ensure future extensibility was added in the most recent rev, i.e. draft-ietf-ippm-ioam-data-07.
We can define the use of the bit and potential extension once we're in need of extending. For now we still have plenty of spare bits.

Regards, Frank

> -----Original Message-----
> From: Tianran Zhou <[email-masked]>
> Sent: Mittwoch, 25. September 2019 08:36
> To: Frank Brockners (fbrockne) <[email-masked]>; Tom Herbert
> <[email-masked]>
> Cc: [email-masked]
> Subject: In-situ OAM Data Type Extension
> 
> Hi Frank,
> 
> Per your suggestion, reserving a bit to allow for future scalability makes sense -
> and bit 23 would be an obvious choice; which would in turn mean that we'd need
> to assign a different bit for checksum complement. If everyone else is fine with
> this change, we can include this change in -07."
>

---

From: Tianran Zhou <[email-masked]>
Date: Wed, 25 Sep 2019 07:09:32 +0000

Hi Frank,

OK. 
IMHO, since you have ready reserved that bit for potential extension, why not define it?
The data type could be namespace specific. The IETF namespace now does not use up the bits, but other namespace may need to extend.

Tianran

> From: Frank Brockners (fbrockne) [mailto:[email-masked]]
> Sent: Wednesday, September 25, 2019 2:47 PM
> To: Tianran Zhou <[email-masked]>; Tom Herbert <[email-masked]>
> Cc: [email-masked]
> Subject: RE: In-situ OAM Data Type Extension
> 
> Hi Tianran,
> 
> Like what you state below: Per Tom's suggestion a reserved bit to ensure future
> extensibility was added in the most recent rev, i.e.
> draft-ietf-ippm-ioam-data-07.
> We can define the use of the bit and potential extension once we're in need
> of extending. For now we still have plenty of spare bits.
> 
> Regards, Frank
> 
> > Per your suggestion, reserving a bit to allow for future scalability
> > makes sense - and bit 23 would be an obvious choice; which would in
> > turn mean that we'd need to assign a different bit for checksum
> > complement. If everyone else is fine with this change, we can include this
> change in -07."
> >
> > I see the latest draft-ietf-ippm-ioam-data-07 reserved the bit 23. Are
> > you going to define the usage of that bit or not?