Subject: [ippm] I-D Action: draft-ietf-ippm-capacity-metric-method-02.txt

From: [email-masked]
Date: Thu, 02 Jul 2020 10:24:28 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IP Performance Measurement WG of the IETF.

        Title           : Metrics and Methods for IP Capacity
        Authors         : Al Morton
                          Ruediger Geib
                          Len Ciavattone
	Filename        : draft-ietf-ippm-capacity-metric-method-02.txt
	Pages           : 22
	Date            : 2020-07-02

Abstract:
   This memo revisits the problem of Network Capacity metrics first
   examined in RFC 5136.  The memo specifies a more practical Maximum
   IP-layer Capacity metric definition catering for measurement
   purposes, and outlines the corresponding methods of measurement.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ippm-capacity-metric-method/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-ippm-capacity-metric-method-02
https://datatracker.ietf.org/doc/html/draft-ietf-ippm-capacity-metric-method-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-ippm-capacity-metric-method-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 2 Jul 2020 17:52:26 +0000

Hi IPPM,

I sent mail to the list with questions and proposed text.
The topic of multi-flow testing and unusual policy was prompted by discussion with 
folks outside IPPM, who are generally in agreement with active testing of Capacity.
In this version, I implemented the proposed text from that message.

Also, there has been progress and more references we can take advantage of:
  Sup60 for the Y.1540 version of the metric
  BBF is about to publish TR-471, their version of the metric and info model
  OpenSource release of udpst coming very soon.

I found good places to reference and highlight this work in other SDOs.
There is a new "Running Code" section, too.

Comments are welcome!

Al, for the co-authors

> -----Original Message-----
> From: I-D-Announce [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Thursday, July 2, 2020 1:24 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D Action: draft-ietf-ippm-capacity-metric-method-02.txt
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dcapacity-2Dmetric-
> 2Dmethod_&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=pbTSc6xNymp7Tt8LkquwRYByX_jUY
> Oly4UDALYqNVK4&s=256Q58HM3ChMIVcyTjjpVb1pBCnFT1Jj6EikFLNX1ys&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__tools.ietf.org_html_draft-2Dietf-2Dippm-2Dcapacity-2Dmetric-2Dmethod-
> 2D02&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=pbTSc6xNymp7Tt8LkquwRYByX_jUY
> Oly4UDALYqNVK4&s=GGXqHobDiwxCc4lUiyE0CfAlmat-Ao0NAYbXJbSdOEE&e=
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_html_draft-2Dietf-2Dippm-2Dcapacity-2Dmetric-
> 2Dmethod-2D02&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=pbTSc6xNymp7Tt8LkquwRYByX_jUY
> Oly4UDALYqNVK4&s=H2NZdN0jbIZlPuHNlAVCspihga3KvpCF_t4p7Nk3qRo&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-
> 3Furl2-3Ddraft-2Dietf-2Dippm-2Dcapacity-2Dmetric-2Dmethod-
> 2D02&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=pbTSc6xNymp7Tt8LkquwRYByX_jUY
> Oly4UDALYqNVK4&s=irynBqIyLcvp4Hop25g2VLwW7dSgTJ1KggJNvrl1DUs&e=
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-
> 2Ddrafts_&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=pbTSc6xNymp7Tt8LkquwRYByX_jUY
> Oly4UDALYqNVK4&s=oK0UeocN7qpyubHhjVO0NioYmKP-nNwX3oVWTnomxGM&e=
> 
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_i-2Dd-2Dannounce&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=pbTSc6xNymp7Tt8LkquwRYByX_jUY
> Oly4UDALYqNVK4&s=Ith7JD90HCO_fPuXWt_DyJ_93LHIJSqb5W9fBVBVeb8&e=
> Internet-Draft directories:
> https://urldefense.proofpoint.com/v2/url?u=http-
> 3A__www.ietf.org_shadow.html&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=pbTSc6xNymp7Tt8LkquwRYByX_jUY
> Oly4UDALYqNVK4&s=c8GE6BCrI8dUUOm4eSNYAhrlvN-Yz_EC-MvUEozjdoM&e=
> or https://urldefense.proofpoint.com/v2/url?u=ftp-
> 3A__ftp.ietf.org_ietf_1shadow-2Dsites.txt&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=pbTSc6xNymp7Tt8LkquwRYByX_jUY
> Oly4UDALYqNVK4&s=OuIWIheXIhOhCNML3Cl7yKH_o5yCkovTIgm5xowcJqo&e=