Subject: [ippm] About to measure Explicit Performances on user devices (mobile phones, PCs)

From: Cociglio Mauro <[email-masked]>
Date: Fri, 3 Jul 2020 12:33:22 +0000

Dear QUIC and IPPM WG members.
 
After Spin bit introduction, and now with packet loss measurement proposals*, the Explicit Performance Monitoring on client-server protocols (e.g. QUIC) becomes an interesting topic for Telco.
Explicit Performance Monitoring enables a passive Observer to measure delay and packet loss only watching the marking (a few bits) of production traffic packets.
 
We propose that the first place where to put the Explicit Performance Observer is on the user device (e.g. mobile phones, PCs).
Main reasons of this choice.
1. Scalability. On the user device there are few connections to monitor.
2. The Observer can monitor both directions: upload and download (inside the network is not always possible).
3. Some measurements, natively not end2end, became E2E (e.g. packet loss Q-bit)
4. It's possible to set alarm thresholds on the user device (and to signal to network probes to monitor only the sessions with impairments, in order to segment the performance measurements and to locate the faults). In this case observers, also embedded into network nodes, need to monitor only a limited number of connections (the ones that have problems).
 
Of course, to do this, the decision whether to activate the marking (e.g. Spin Bit) or not must be made by the device owner configuring the applications (e.g. browsers) based on protocols that supports Explicit Performance Monitoring (e.g. QUIC).
 
All applications should therefore provide for the activation or deactivation of the marking for the Explicit Performance Monitoring.
 
So, from this point of view, in the Client-Server handshake it should be the Client who decides whether the marking is active or not within a session and the Server should adapt.
 
The performance information thus obtained could then be kept on the user device or sent to "external bodies" according to the will of the device owner.
The main recipient would be the Internet Service Provider (see point 4 of the previous list), but these data could also be of interest to the national regulatory authorities and perhaps others.
 
Feedbacks are welcomed.
Best regards.
 
Mauro

* Explicit packet loss measurements proposals:
1) https://tools.ietf.org/html/draft-cfb-ippm-spinbit-measurements-02
2) https://tools.ietf.org/html/draft-ferrieuxhamchaoui-quic-lossbits-03

_____________________
Mauro Cociglio
Telecom Italia-TIM
Via G. Reiss Romoli, 274
10148 - Torino (Italy)
Tel.: +390112285028
Mobile: +393357669751
_____________________

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: <[email-masked]>
Date: Wed, 8 Jul 2020 06:34:50 +0000

Hi Mauro,

You suggest to base activation of the spin bit marking on a terminal configuration or on a user decision. That is reasonable, I think. An additional option is to activate the spin bit randomly on a number of connections. That might help to avoid situations where a set spin bit indicates that the performance of this flow is "rather likely" reported. A bit indicating that a flow's performance is likely to be reported to one or more interested parties should be taken as an incentive for preferential treatment.

The number of flows with randomly activated spin bit should be higher than those reporting performance, if this option is pursued.

Regards,

Ruediger

-----Ursprüngliche Nachricht-----
Von: ippm <[email-masked]> Im Auftrag von Cociglio Mauro
Gesendet: Freitag, 3. Juli 2020 14:33
An: IETF IPPM WG ([email-masked]) <[email-masked]>; [email-masked]
Cc: 'Riccardo Sisto' <[email-masked]>
Betreff: [ippm] About to measure Explicit Performances on user devices (mobile phones, PCs)

 
3. Some measurements, natively not end2end, became E2E (e.g. packet loss Q-bit) 4. It's possible to set alarm thresholds on the user device (and to signal to network probes to monitor only the sessions with impairments, in order to segment the performance measurements and to locate the faults). In this case observers, also embedded into network nodes, need to monitor only a limited number of connections (the ones that have problems).

 

Feedbacks are welcomed.
Best regards.
 
Mauro

_____________________
Mauro Cociglio
Telecom Italia-TIM
Via G. Reiss Romoli, 274
10148 - Torino (Italy)
Tel.: +390112285028
Mobile: +393357669751
_____________________

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

---

From: Cociglio Mauro <[email-masked]>
Date: Wed, 15 Jul 2020 09:12:14 +0000

Thanks Ruediger for your interesting comments.
Your suggested option to increase connections with randomly generated performance bits could be applied on connections that originate from users' devices that have not activated (or have actually deactivated) the explicit measurements.
As you wrote, in this case, connections with "variable" performance bits (either "random" or "correctly" set) could be the majority and it would be quite difficult to prioritize this traffic.
Best regards.
Mauro

-----Messaggio originale-----
Da: [email-masked] <[email-masked]> 
Inviato: mercoledì 8 luglio 2020 08:35
A: Cociglio Mauro <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Oggetto: [EXT] AW: About to measure Explicit Performances on user devices (mobile phones, PCs)

Hi Mauro,

Regards,

Ruediger

-----Ursprüngliche Nachricht-----
Von: ippm <[email-masked]> Im Auftrag von Cociglio Mauro
Gesendet: Freitag, 3. Juli 2020 14:33
An: IETF IPPM WG ([email-masked]) <[email-masked]>; [email-masked]
Cc: 'Riccardo Sisto' <[email-masked]>
Betreff: [ippm] About to measure Explicit Performances on user devices (mobile phones, PCs)

 

 
 
The performance information thus obtained could then be kept on the user device or sent to "external bodies" according to the will of the device owner..
The main recipient would be the Internet Service Provider (see point 4 of the previous list), but these data could also be of interest to the national regulatory authorities and perhaps others.
 
Feedbacks are welcomed.
Best regards.
 
Mauro

_____________________
Mauro Cociglio
Telecom Italia-TIM
Via G. Reiss Romoli, 274
10148 - Torino (Italy)
Tel.: +390112285028
Mobile: +393357669751
_____________________