Subject: [ippm] Request for WG adoption: Marking-based PBT

From: Haoyu Song <[email-masked]>
Date: Mon, 13 Jul 2020 17:50:47 +0000

https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/

Dear IPPM Chairs,

After the WG discussion in last meeting, the above draft has been truncated to only include the marking-based PBT. The instruction-based PBT has been merged into the WG document IOAM DEX a while ago.
Since IOAM data draft is in its WGLC, we think it's time to request the WG adoption for this draft for the following reasons:

1)     It has been discussed a lot in WG email list and meetings.

2)     Just like IOAM trace, IOAM DEX, and HTS, PBT-M merits to be an independent approach for network telemetry.

3)     The approach has been used in SRv6 OAM (the draft is currently in WGLC at 6man)  in which o-bit is used as a data collection trigger.

4)     Just like the IOAM data draft, we need a PBT-M draft to specify the related details so that it can be universally apply to each application scenario.

5)     Since the approach is closely related to other works in IPPM, we think it's better to coordinate the work in WG as early as possible.
Therefore, we request the IPPM to adopt the draft. Thank you very much for your consideration!

Best regards,
Haoyu Song

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 13 Jul 2020 12:59:27 -0700

Hello Haoyu,

The WG discussion at our last meeting, the chairs provided guidance that anything related to Direct Export should be folded into draft-ietf-ippm-ioam-direct-export, but we do not see the need to adopt this as a separate document.

Minutes are here:
https://datatracker.ietf.org/doc/minutes-interim-2020-ippm-01-202004010800/ <https://datatracker.ietf.org/doc/minutes-interim-2020-ippm-01-202004010800/>

We will not be issuing an adoption call for this at this time, based on the previous discussions.

Thanks,
Tommy

> On Jul 13, 2020, at 10:50 AM, Haoyu Song <[email-masked]> wrote:
> 
> https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/ <https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/>         
>  
> Dear IPPM Chairs,
>  
> Since IOAM data draft is in its WGLC, we think it’s time to request the WG adoption for this draft for the following reasons:
> 5)     Since the approach is closely related to other works in IPPM, we think it’s better to coordinate the work in WG as early as possible.
> _______________________________________________
> ippm mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/ippm <https://www.ietf.org/mailman/listinfo/ippm>

---

From: Haoyu Song <[email-masked]>
Date: Mon, 13 Jul 2020 22:31:59 +0000

Hi Tommy,

Yes, that’s why we have exactly removed all the discussion about PBT-I because it’s have been folded into IOAM DEX.
Now the remaining of the draft is only about PBT-M which is a standalone technique not covered anywhere else.
What we request is to adopt this (marking-based PBT, but not the instruction-based PBT) as a WG draft.
(I have explained this in the follow-up email discussion)

Best regards,
Haoyu

From: Tommy Pauly <[email-masked]>
Sent: Monday, July 13, 2020 12:59 PM
To: Haoyu Song <[email-masked]>
Cc: ippm-chairs <[email-masked]>; [email-masked]; IETF IPPM WG ([email-masked]) <[email-masked]>
Subject: Re: [ippm] Request for WG adoption: Marking-based PBT

Hello Haoyu,

Minutes are here:
https://datatracker.ietf.org/doc/minutes-interim-2020-ippm-01-202004010800/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fminutes-interim-2020-ippm-01-202004010800%2F&data=02%7C01%7Chaoyu.song%40futurewei.com%7Cf4f53ec9d3f945b0fd9608d82767430e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637302671749654638&sdata=XlvVra6aPRS0GRN4ykn7XlBM3UPsjMv1SuO%2F8t0OJaM%3D&reserved=0>

Thanks,
Tommy

On Jul 13, 2020, at 10:50 AM, Haoyu Song <[email-masked]<mailto:[email-masked]>> wrote:

https://datatracker.ietf.org/doc/draft-song-ippm-postcard-based-telemetry/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-song-ippm-postcard-based-telemetry%2F&data=02%7C01%7Chaoyu.song%40futurewei.com%7Cf4f53ec9d3f945b0fd9608d82767430e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637302671749664541&sdata=%2BghHqd5d5y1BrPbvlToyoEUAhxNqGzCWFzXjCgUgnWQ%3D&reserved=0>

Dear IPPM Chairs,

Best regards,
Haoyu Song

_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fippm&data=02%7C01%7Chaoyu.song%40futurewei.com%7Cf4f53ec9d3f945b0fd9608d82767430e%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637302671749664541&sdata=zsEJqPJz3h88xJtUDkkkN4lKch63iyZ39MuZFhfMZyI%3D&reserved=0>

---

From: Tianran Zhou <[email-masked]>
Date: Wed, 15 Jul 2020 23:55:42 +0000

Hi WG and the Chairs,

I think the marking-based PBT method worth documenting as informational ID that can be referenced.
We already see one application of PBT-M recently adopted in SRv6 OAM:
https://tools.ietf.org/html/draft-ietf-6man-spring-srv6-oam-06

It’s reasonable for the IPPM WG to describe the generic method, so that it could be referred  in many other protocol design.

Cheers,
Tianran

From: Haoyu Song [mailto:[email-masked]]
Sent: Tuesday, July 14, 2020 6:32 AM
To: Tommy Pauly <[email-masked]>
Cc: ippm-chairs <[email-masked]>; [email-masked]; IETF IPPM WG ([email-masked]) <[email-masked]>
Subject: RE: [ippm] Request for WG adoption: Marking-based PBT

Hi Tommy,

Best regards,
Haoyu

From: Tommy Pauly <[email-masked]<mailto:[email-masked]>>
Sent: Monday, July 13, 2020 12:59 PM
To: Haoyu Song <[email-masked]<mailto:[email-masked]>>
Cc: ippm-chairs <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; IETF IPPM WG ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ippm] Request for WG adoption: Marking-based PBT

Hello Haoyu,

Minutes are here:

Thanks,
Tommy

Dear IPPM Chairs,

Best regards,
Haoyu Song