Subject: Re: [ippm] Benjamin Kaduk's No Objection on draft-ietf-ippm-route-09: (with COMMENT) - extract: same flow

From: <[email-masked]>
Date: Mon, 10 Aug 2020 07:21:45 +0000

Al, Ben,

thanks for extensive reading and discussion and for proposed resolutions. Al asked for what others say in one point:

> 
>    o  TCP case: For IPv4, the fields Src, Dst, port-Src, port_Dst,
>       sequence number, and Diffserv Field SHOULD be the same.  For IPv6,
>       the field FlowLabel, Src and Dst SHOULD be the same.
> 
> Are we happy to pair "to maintain the same flow" (previous paragraph)
> with "SHOULD be the same" (here, and subsequent bullet points)?
[acm] 
There are ways to conduct valid measurements with SHOULD, IMO, but I see how MUST results in simplification.  Let's see what others say about this; no change proposed yet.

[RG] The set of packet information to base a load-sharing decision might be defined differently by a chain of nodes on an end-to-end path. Different operators may have different preferences and a Layer 4 device my base its decisions on other parameters than a core-router. The other way around: would a MUST kind of imply that we were able to offer a reference which of the mentioned fields specify a flow (we can not and we should not, I think)? Leaving it as a recommendation, and yes, a serious one, is better, I think. Thought the other way around: I some cases, there may be limited flexibility in flow definitions at some nodes along a path, and it may be useful.

Regards,

Ruediger

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, 10 Aug 2020 12:12:49 +0000

Thanks Ruediger. 

I feel a SHOULD is more appropriate than a MUST here given both application specifics as well as path selection algorithms — we do not want to limit based on the incorrect assumption that we know them all. 

Thanks!

Thumb typed by Carlos Pignataro.
Excuze typofraphicak errows

> 2020/08/10 午前3:22、"[email-masked]" <[email-masked]>のメール:
> 
> Al, Ben,
>