Subject: Re: [ippm] request for the wg adoption for draft-zhou-ippm-ioam-yang

From: tom petch <[email-masked]>
Date: Thu, 6 Aug 2020 16:25:00 +0000

From: Greg Mirsky <[email-masked]>
Sent: 13 July 2020 20:37

Hi Tom, et al.,
I believe that SFC WG has adopted draft-brokners-proof-of-transit<https://datatracker.ietf.org/doc/draft-brockners-proof-of-transit/> and draft-ietf-sfc-proof-of-transit is in WG LC. The datatracker reflects that. Updating the reference should be easy.
Hope that note helps to resolve one small issue.

<tp>
Greg
Thanks for the info.  I had a look at 
draft-ietf-sfc-proof-of-transit-06
and from a YANG point of view it looks like it needs some work - I am surprised that is in WGLC.
Look for example at prefix (not invalid but not a good choice), yang version ,  contacts, copyright date, reference '' , IANA (REQUIRED), security Boilerplate and such like.

The IPPM draft is in much better shape and it has yet to be adopted!

Tom Petch,
Regards,
Greg

On Fri, Jul 10, 2020 at 9:26 AM tom petch <[email-masked]<mailto:[email-masked]>> wrote:

________________________________________
From: Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Sent: 08 July 2020 13:20
To: tom petch; Srihari Raghavan (srihari); IETF IPPM WG ([email-masked]<mailto:[email-masked]>); ippm-chairs
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: request for the wg adoption for draft-zhou-ippm-ioam-yang

Hi Tom,

Yeah, I now understand.
I am awake. Come on, more comments please. :-)

<tp>
Eee that was quick:-)  a little something for the weekend.

I think that all the I-D that you have added as reference should be Normative.

A recent YANG doctor review said that all feature should also have a reference which seems right.

I was surprised that Frank's e-mail address was fbrockne@ but that looks consistent - perhaps Cisco limit identifiers to eight characters (Passwords too?)

brockners proof of transit has expired and gone from the repository - refresh before the window closes for the IETF108 (Monday?) would be good

I also want a reference for incremental so that  I can look up why 4.000.000.000 octet are needed for it!

I note that the I-D has four author, YANG only two - not wrong, just noteworthy

POT needs expanding on first use be it pot or POT

Tom Petch

Thanks,
Tianran
-----Original Message-----
From: tom petch [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, July 8, 2020 7:42 PM
To: Tianran Zhou <[email-masked]<mailto:[email-masked]>>; Srihari Raghavan (srihari) <srihari=[email-masked]<mailto:[email-masked]>>; IETF IPPM WG ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>; ippm-chairs <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: request for the wg adoption for draft-zhou-ippm-ioam-yang

From: Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Sent: 08 July 2020 11:00

Tom,

Thank you very much for your review and comments. I will address your comments in next version soon.
But still I am not clear about the following two comments:

1. "There are a number of admin type things that need fixing in this I-D as and when it is adopted."
What's this exactly mean. Could you please give me more hints?

<tp> See the rest of the e-mail:-)  I mean boiler plate, references, IANA, Security, Version, Copyright and so on as opposed to the more technical details such as why a leaf is int32 octet?  Why octet and why might there be 4.000.000.000 of them? for which I need a reference for the data structures and hoped that such would be forthcoming.  I tend to make admin comments first, to see if the authors are awake:-), and then get more technical later, a pattern that you may have seen from me before.

2. " Why is IPv6 the only defined protocol as an identity?"
We are going to include the working group adopted transport protocols for IOAM. IPv6 is one. Yes we may need to add some more.
What's your suggestion on this?
<tp>
You mention others in the text of the I-D so I was expecting them all to be there or an explanation as to why they are not there.  I know of none other than the ones you mention.

Tom Petch

Thanks,
Tianran

-----Original Message-----
From: tom petch [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, July 8, 2020 12:38 AM
To: Srihari Raghavan (srihari) <srihari=[email-masked]<mailto:[email-masked]>>; Tianran Zhou <[email-masked]<mailto:[email-masked]>>; IETF IPPM WG ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>; ippm-chairs <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: request for the wg adoption for draft-zhou-ippm-ioam-yang

________________________________________
From: ippm <[email-masked]<mailto:[email-masked]>> on behalf of Srihari Raghavan (srihari) <srihari=[email-masked]<mailto:[email-masked]>>
Sent: 07 July 2020 09:13

<tp>
There are a number of admin type things that need fixing in this I-D as and when it is adopted.

The module has zero references; they are required for any import and are needed for many of the nodes if they are to be understood.

YANG tree diagrams are defined in RFC8340

Requirements is out of date

YANG module lacks copyright

Why is IPv6 the only defined protocol as an  identity?

Tom Petch

Hi all

As a co-author of the IOAM yang model and implementor of the IOAM concept, would like to support and request the WG adoption of the data model draft as it adds value to the IOAM standardization and fills an important need for a common data model for all the five IOAM options.

Thanks
Srihari

From: Tianran Zhou <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 7 July 2020 at 6:43 AM
To: "IETF IPPM WG ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>, ippm-chairs <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: request for the wg adoption for draft-zhou-ippm-ioam-yang Resent from: <[email-masked]<mailto:[email-masked]>> Resent to: <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>> Resent date: Tuesday, 7 July 2020 at 6:43 AM

Correct the title and resend ☺

Hi IPPM WG and the Chairs,

We would like to request the WG adoption for the IOAM YANG data model as follows:
https://datatracker.ietf.org/doc/draft-zhou-ippm-ioam-yang/

This was presented 101 and 102. There were great comments from Greg Mirsky and Reshad Rahman on the model structure. Thanks.

Then the following revision keeps aligning with the IOAM data draft and IOAM-DEX draft.

As the IOAM data get mature, I think it’s the right get the YANG model adopted, so that we can implement the system.

Thanks,
Tianran
_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 6 Aug 2020 10:11:31 -0700

Hi Tom,
thank you for your helpful comments on the SFC document. Would you kindly
send your comments to the SFC WG? I don't recall the WGLC on PoT being
closed.

Regards,
Greg

On Thu, Aug 6, 2020 at 9:25 AM tom petch <[email-masked]> wrote:

> I believe that SFC WG has adopted draft-brokners-proof-of-transit<
> https://datatracker.ietf.org/doc/draft-brockners-proof-of-transit/> and
> draft-ietf-sfc-proof-of-transit is in WG LC. The datatracker reflects that.
> Updating the reference should be easy.
> Look for example at prefix (not invalid but not a good choice), yang
> version ,  contacts, copyright date, reference '' , IANA (REQUIRED),
> security Boilerplate and such like.
>
> Cc: [email-masked]<mailto:
> [email-masked]>
> I was surprised that Frank's e-mail address was fbrockne@ but that looks
> consistent - perhaps Cisco limit identifiers to eight characters (Passwords
> too?)
>
> brockners proof of transit has expired and gone from the repository -
> refresh before the window closes for the IETF108 (Monday?) would be good
>
> To: Tianran Zhou <[email-masked]<mailto:[email-masked]>>;
> Srihari Raghavan (srihari) <srihari=[email-masked]<mailto:
> [email-masked]>>; IETF IPPM WG ([email-masked]<mailto:
> [email-masked]>) <[email-masked]<mailto:[email-masked]>>; ippm-chairs <
> [email-masked]<mailto:[email-masked]>>
> Cc: [email-masked]<mailto:
> [email-masked]>
> <tp> See the rest of the e-mail:-)  I mean boiler plate, references, IANA,
> Security, Version, Copyright and so on as opposed to the more technical
> details such as why a leaf is int32 octet?  Why octet and why might there
> be 4.000.000.000 of them? for which I need a reference for the data
> structures and hoped that such would be forthcoming.  I tend to make admin
> comments first, to see if the authors are awake:-), and then get more
> technical later, a pattern that you may have seen from me before.
>
> We are going to include the working group adopted transport protocols for
> IOAM. IPv6 is one. Yes we may need to add some more.
> You mention others in the text of the I-D so I was expecting them all to
> be there or an explanation as to why they are not there.  I know of none
> other than the ones you mention.
>
> Tom Petch
>
> Thanks,
> Tianran
>
> To: Srihari Raghavan (srihari) <srihari=[email-masked]<mailto:
> [email-masked]>>; Tianran Zhou <[email-masked]<mailto:
> [email-masked]>>; IETF IPPM WG ([email-masked]<mailto:[email-masked]>)
> <[email-masked]<mailto:[email-masked]>>; ippm-chairs <[email-masked]
> <mailto:[email-masked]>>
> Cc: [email-masked]<mailto:
> [email-masked]>
> From: ippm <[email-masked]<mailto:[email-masked]>> on
> behalf of Srihari Raghavan (srihari) <srihari=[email-masked]
> <mailto:[email-masked]>>
> Sent: 07 July 2020 09:13
>
> <tp>
> The module has zero references; they are required for any import and are
> needed for many of the nodes if they are to be understood.
>
> As a co-author of the IOAM yang model and implementor of the IOAM concept,
> would like to support and request the WG adoption of the data model draft
> as it adds value to the IOAM standardization and fills an important need
> for a common data model for all the five IOAM options.
>
> Thanks
> Srihari
>
> To: "IETF IPPM WG ([email-masked]<mailto:[email-masked]>)" <[email-masked]
> <mailto:[email-masked]>>, ippm-chairs <[email-masked]<mailto:
> [email-masked]>>
> Cc: "[email-masked]<mailto:
> [email-masked]>" <
> [email-masked]<mailto:
> [email-masked]>>
> Subject: request for the wg adoption for draft-zhou-ippm-ioam-yang Resent
> from: <[email-masked]<mailto:[email-masked]>> Resent to: <
> [email-masked]<mailto:[email-masked]>>, <
> [email-masked]<mailto:[email-masked]>>, <
> [email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:
> [email-masked]>> Resent date: Tuesday, 7 July 2020 at 6:43 AM
>
> This was presented 101 and 102. There were great comments from Greg Mirsky
> and Reshad Rahman on the model structure. Thanks.
>
> As the IOAM data get mature, I think it’s the right get the YANG model
> adopted, so that we can implement the system.
>
> Thanks,
> Tianran