Subject: [ippm] Welcome comment on Performance Measurement on LAG

From: "[email-masked]" <[email-masked]>
Date: Fri, 7 Aug 2020 14:43:46 +0800

Hello All,

Performance Measurement on LAG, https://www.ietf.org/internet-drafts/draft-li-ippm-pm-on-lag-01.txt, was not presented in the past virtual meeting due to limited time. This doc defines extensions to OWAMP, TWAMP and STAMP to implement performance measurement on every member link of a Link Aggregation Group (LAG).  With the measured metrics of each member link of a LAG, it enables operators to enforce performance metric based traffic steering policy among the member links.

The requirements come from field networks, where the link delays of the member links of a LAG are different because the member links are over different transport paths.  To provide low delay service to time sensitive traffic, we have to know the link delay of each member link of a LAG and then steer traffic accordingly.

We appreciate all the comments and suggestions.

Best Regards,
Zhenqiang Li

[email-masked]

---

From: <[email-masked]>
Date: Tue, 11 Aug 2020 14:45:29 +0800 (CST)

Hi Zhenqiang,

Thanks for the nice draft addressing a real problem in field networks.

I propose to split this draft into two new drafts, one for OWAMP/TWAMP, another for STAMP. I think that will facilitate folks to read and evaluate them.

Best Regards,

Xiao Min

原始邮件

发件人：[email-masked] <[email-masked]>
收件人：ippm <[email-masked]>;
日 期 ：2020年08月07日 14:43
主 题 ：[ippm] Welcome comment on Performance Measurement on LAG

_______________________________________________
ippm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ippm

Hello All,

Best Regards,
Zhenqiang Li

--------------------------------------------------------------------------------

[email-masked]

---

From: Mach Chen <[email-masked]>
Date: Tue, 11 Aug 2020 07:11:56 +0000

Hi Zhengqiang,

Seems that the below link is not available, here is an alternative ( https://tools.ietf.org/html/draft-li-ippm-pm-on-lag-01 )

Best regards,
Mach

From: ippm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, August 7, 2020 2:44 PM
To: ippm <[email-masked]>
Subject: [ippm] Welcome comment on Performance Measurement on LAG

Hello All,

Performance Measurement on LAG, https://www.ietf.org/internet-drafts/draft-li-ippm-pm-on-lag-01.txt<https://www.ietf.org/internet-drafts/draft-li-ippm-pm-on-lag-00.txt>, was not presented in the past virtual meeting due to limited time. This doc defines extensions to OWAMP, TWAMP and STAMP to implement performance measurement on every member link of a Link Aggregation Group (LAG).  With the measured metrics of each member link of a LAG, it enables operators to enforce performance metric based traffic steering policy among the member links.

Best Regards,
Zhenqiang Li
________________________________
[email-masked]<mailto:[email-masked]>

---

From: Mach Chen <[email-masked]>
Date: Tue, 11 Aug 2020 07:17:27 +0000

Hi Xiaomin,

Thanks for the suggestion!

As one of the co-authors, I am open to keep them in one document or separate it into two documents.

Best regards,
Mach

From: ippm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, August 11, 2020 2:45 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [ippm] Welcome comment on Performance Measurement on LAG

Hi Zhenqiang,

Best Regards,

Xiao Min
原始邮件
发件人：[email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
收件人：ippm <[email-masked]<mailto:[email-masked]>>;
日 期 ：2020年08月07日 14:43
主 题 ：[ippm] Welcome comment on Performance Measurement on LAG
_______________________________________________
ippm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ippm
Hello All,

Best Regards,
Zhenqiang Li

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 12 Aug 2020 16:13:28 +0800

Hello Min,

Thank you for your comment and suggestion!
The problem to be addressed is ugent for us since lots of delay sensitive services are springing out in our networks. We can not guarentee the time delay for the services without knowing the delay of each member link of a LAG.

As for seperating the doc into two, I am fine with it. We should define the extensions for STAMP, TWAMP and OWAMP because they are all used in the field networks.

Best Regards,
Zhenqiang Li  

[email-masked]
 
From: Mach Chen
Date: 2020-08-11 15:17
To: [email-masked]; [email-masked]
CC: [email-masked]
Subject: RE: [ippm] Welcome comment on Performance Measurement on LAG
Hi Xiaomin,

 
Best regards,
Mach

Hi Zhenqiang,

Best Regards,
Xiao Min
原始邮件

 
 
Best Regards,
Zhenqiang Li

[email-masked]

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 14 Aug 2020 10:13:49 +0000

Hi Zhenqiang, all,

In my understanding, performance measurement of LAG member link is a useful feature, which can be used as the input for traffic steering to meet specific service requirement. Thus the mechanisms defined for STAMP, TWAMP and OWAMP in this document are needed.

Would like to see this document move forward.

Best regards,
Jie

From: ippm [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Friday, August 7, 2020 2:44 PM
To: ippm <[email-masked]<mailto:[email-masked]>>
Subject: [ippm] Welcome comment on Performance Measurement on LAG

Hello All,

Best Regards,
Zhenqiang Li

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 17 Aug 2020 09:06:30 +0800

Hello Jie,

Thank you for your comment. I believe the extension mechanism introduced in this doc is essential input to steer the traffic of time delay sensitive service.
We are updating this doc according to all the comments and suggestions received.

Best Regards,
Zhenqiang Li

[email-masked]
 
From: Dongjie (Jimmy)
Date: 2020-08-14 18:13
To: [email-masked]; [email-masked]
Subject: RE: [ippm] Welcome comment on Performance Measurement on LAG
Hi Zhenqiang, all, 

 
Best regards,
Jie

Hello All,

 
 
Best Regards,
Zhenqiang Li

[email-masked]